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Welcome to Ipswitch WhatsUp Gold v12 

Welcome to Ipswitch WhatsUp Gold v12, the powerful network monitoring solution designed 
to help you protect your changing business infrastructure. WhatsUp Gold provides standards-
based monitoring of any network device, service, or application on TCP/IP and Windows 
networks. 

WhatsUp Gold lets you discover devices on your network, initiate monitoring of those 
devices, and execute actions based on device state changes, so you can identify network 
failures before they become catastrophic. 

Discovery and Mapping 
The WhatsUp Gold wizard-based discovery process searches for devices on your network and 
lets you decide which devices to monitor. You can view monitored devices as a list of devices 
or as a graphical map. 

Polling/Listening 
WhatsUp Gold actively polls devices to determine their status. You can use active monitors to 
poll services on a device and to passively listen for messages sent across the network. 
Performance monitors track device performance by checking and reporting on device 
resources, such as disk, CPU, and interfaces. 

Actions/Alerts 
Depending on the responses received from polling, WhatsUp Gold fires actions to notify you 
of changes on your network. Actions aid in problem resolution through assorted options such 
as email and cell phone alerts, or service restarts. 
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Reporting and Workspaces 
Reports ensure 360-degree visibility into network status and performance, and historical data 
for devices and monitors. Workspaces let you focus on segments of the network and create 
your own views of report data. These views position crucial network data in one location, 
which allows for quick and easy access. WhatsUp Gold offers more than 100 summary reports, 
or workspace reports, that WhatsUp users can place into customized workspaces. 

 

WhatsUp Gold Interfaces 
WhatsUp Gold offers two user interfaces, the Windows console interface and the web 
interface, which offer similar functionality. We recommend that you do the initial set up—
discovery and mapping—on the console, then use the web interface for additional setup of 
monitors and workspaces, users and permissions, and for day-to-day monitoring. 

 Windows console interface. The console is a Windows application, through which you 
can configure and manage WhatsUp Gold and its database. 

 Web interface. The web interface provides access to WhatsUp Gold functionality (via 
HTTP or HTTPS) from a web browser. 

 

WhatsUp Gold editions 

WhatsUp Gold is available in four editions. Each edition tailors WhatsUp Gold's features to 
meet the diverse needs of WhatsUp users, from small networks to those spanning multiple 
geographic locations. 

 WhatsUp Gold Standard Edition provides core network management features. 

 WhatsUp Gold Premium Edition provides all of the network management capabilities of 
WhatsUp Gold Standard Edition, plus advanced management for Microsoft® Exchange™, 
Microsoft® SQL Server™, and SMTP email servers. Premium Edition also includes several 
features that let you monitor performance data in real time, as well as support for 
application monitoring using Microsoft's WMI™. 
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 WhatsUp Gold MSP Edition gives managed solution providers the ability to use all of 
the features of WhatsUp Gold Premium Edition to monitor their customers' remote 
networks from a central location in the managed solution provider's network operations 
center. Managing multiple companies' networks at once has never been easier. 

 WhatsUp Gold Distributed Edition extends the features of WhatsUp Gold Premium 
Edition to companies whose networks are segmented across multiple geographic 
locations. WhatsUp Gold Distributed Edition can detect issues at any of the company's 
sites and can then report the issue to the effected site and to a central location. 

Each edition includes a different set of features. The table below shows which features are 
available in each edition. If a feature is not shown in the table, it is available in all editions. 

 Standard 
Edition 

Premium 
Edition 

MSP 
Edition 

Distributed 
Edition 

Application Management     

Monitor Microsoft Exchange     

Monitor SQL Server     

Monitor applications via WMI     

Monitor Email servers     

Real-time Monitoring     

View real-time data about devices in reports     

Quickly access real-time data via InstantInfo 
popups 

    

Monitor performance data with the Web 
Performance Monitor 

    

View real-time information about tasks running on 
a device using the Web Task Manager 

    

Distributed Monitoring     

Monitor devices on networks segmented across 
multiple geographic locations 

    

View report data from multiple remote sites from 
one central location 
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WhatsUp Gold optional plug-ins are available for use with any of the WhatsUp Gold 
editions. These plug-ins broaden your monitoring and reporting capabilities to give you a 
more complete picture of your network and its many components. For more information, see 
the WhatsUp Gold web site (http://www.whatsupgold.com/wugplugins).  
 

New in v12.3 

New in all editions  
 Introduced WhatsUp Gold NetFlow Monitor plug-in. 

 Introduced WhatsUp Gold VoIP Monitor plug-in. 

 Added support for plug-in architecture. 

For information on available plug-ins and to see release notes for each plug-in, see WhatsUp 
Gold plug-ins documentation (http://www.whatsupgold.com/wugplugins). 

New in all editions in v12 
 Added support for high capacity SNMP interface counters through the Interface 

Performance Monitor. 

 Added support for NetSNMP agents for UNIX CPU utilization. 

 Added configurable interface name for SNMP interfaces. 

 Included select Cisco MIBs for use in WhatsUp Gold. 

 Added the SNMP MIB Walker network tool which allows you to browse for SNMP objects 
on a device. 

 Added the SNMP MIB File Explorer network tool which allows you to browse for SNMP 
objects in defined MIB files. 

 Added the MIB Manager for the import and validation of MIB files. 

 Improved SNMP API to support enhanced scripting capabilities with the Script Action and 
Active Script Monitor. 

 Added encryption and SMTP authentication to the Email Active Monitor. 

 Added support for SMTP authentication for email actions. 

 Extended Short Message Service (SMS) support for SMS Direct. 

 Implemented drag-and-drop device, group, and map management on the web interface. 

 Changed from MSDE 2000 database to the Microsoft SQL Server 2005 Express database. 

 Added support for Passive Monitors to use device credentials in the Credentials Library. 

 Added support for Windows Vista. 

 Updated the Web User Interface. 

 Added new licensing technology. 

New in v12 in WhatsUp Gold Premium, Distributed, and MSP 
Editions 
 Added quick access to real-time data via InstantInfo popups. 
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 Added Split Second Graphs that provide real-time graphical data in performance 
workspace and full reports, the Web Task Manager, and the Web Performance Monitor. 

 Added the Web Performance Monitor network tool. 

 Added the Web Task Manager network tool. 

 Added the Dashboard Screen Manager application. 
 

Finding more information and updates 

Following are information resources for WhatsUp Gold. This information may be periodically 
updated and available on the WhatsUp Gold Web site 
(http://www.whatsupgold.com/support/index.asp). 

 Release Notes. The release notes provide an overview of changes, known issues, and bug 
fixes for the current release. The notes also contain instructions for installing, upgrading, 
and configuring WhatsUp Gold. The release notes are available at Start > Programs > 
Ipswitch WhatsUp Gold > Release Notes or on the WhatsUp Gold web site 
(http://www.whatsupgold.com/wug123relnotes). 

 Application Help for the console and web interface. The console and web help contain 
dialog assistance, general configuration information, and how-to's that explain how to 
use the features. The Table of Contents is organized by functional area, and can be 
accessed from the main menu or by clicking Help in the console, or the ? icon in the web 
interface. 

 Getting Started Guide. This guide provides an overview of WhatsUp Gold, information 
to help you get started using the application, the system requirements, and information 
about installing and upgrading. The Getting Started Guide is available on the WhatsUp 
Gold web site (http://www.whatsupgold.com/wug123gsg). 

 Additional WhatsUp Gold guides. For a listing of current and previous guides and help 
files available for WhatsUp Gold's multiple versions, see the WhatsUp Gold web site 
(http://www.whatsupgold.com/support/guides.aspx). 

 WhatsUp Gold optional plug-ins. You can extend the core features of WhatsUp Gold by 
installing plug-ins. For information on available plug-ins and to see release notes for each 
plug-in, see WhatsUp Gold plug-ins documentation 
(http://www.whatsupgold.com/wugplugins). 

 Licensing Information. Licensing and support information is available on the MyIpswitch 
licensing portal (http://www.myipswitch.com/). The web portal provides enhanced web-
based capabilities to view and manage Ipswitch product licenses. 

 Knowledge Base. Search the Ipswitch Knowledge Base of technical support and 
customer service information. The knowledge base is available on the WhatsUp Gold web 
site (http://www.whatsupgold.com/wugTechSupport). 

 User Forum. Use the online user group forums to interact with other WhatsUp Gold users 
to share helpful information about the application. The User Forums are available on the 
WhatsUp Gold web site (http://forums.ipswitch.com/). 
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Sending feedback 

We value your opinions on our products and welcome your feedback. 

To provide feedback on existing features, suggest new features or enhancements, or suggest 
ways to make our products easier to use, please fill out our product feedback form 
(http://www.ipswitch.com/company/prodfeedback.asp). 
 

http://www.ipswitch.com/company/prodfeedback.asp
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Gathering network data 

There are a few things you need to do before WhatsUp Gold can gather the data you need 
about the devices on your network.  

1. Install the software 
First, you need to install your edition of WhatsUp Gold. The User Guide gives step-by-step 
instructions on how to install each of the four editions of WhatsUp Gold: 

 WhatsUp Gold Standard Edition (on page 10) 

 WhatsUp Gold Premium Edition (on page 10) 

 WhatsUp Gold MSP Edition (on page Error! Bookmark not defined.) 

 WhatsUp Gold Distributed Edition (on page Error! Bookmark not defined.) 

2. Discover devices 
After you have installed WhatsUp Gold, you need to discover devices on your network for the 
application to monitor. The Device Discovery Wizard allows to choose which devices to add 
to the database for monitoring. 

3. Configure your network 
In WhatsUp Gold, devices are organized through device groups. By default, all of the devices 
on your network are placed into a Dynamic Group named All devices. Additionally, each time 
you discover devices a new device group is created containing the devices found in the scan 
that you choose to monitor. You can create as many Dynamic and non-Dynamic groups as 
you want to organize your network in a way that is meaningful to you and your monitoring 
needs. 
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4. Configure monitors 
WhatsUp Gold comes with several default monitors, but you will need to configure new 
monitors to gather the specific types of information you seek about your network. There are 
three types of monitors in WhatsUp Gold: 

 Active monitors (on page 153) 

 Passive monitors (on page 201) 

 Performance monitors (on page 209) 

Each of the monitor types gathers a different type of information, so you may use each type 
of monitor. Before creating monitors, you should figure out what type of network information 
you need, and configure monitors to gather that specific data. 
 

Viewing network data 

After you have configured your network and the appropriate monitors, you can begin 
viewing the information WhatsUp Gold is gathering for you. There are several ways to view 
network data with WhatsUp Gold. 

1. Device and Map Views  
While Device and Map Views are good for viewing device information or the location of a 
device, they are also useful for viewing the current status of network devices. Devices on both 
are displayed with device state icons that show the status for devices at the time of the last 
poll. The Device and Map Views are viewable on both the WhatsUp Gold console and web 
interface. 

2. Workspace views and reports 
WhatsUp Gold's workspace views let you organize various workspace reports by the type of 
information they display or by devices and device groups. Workspace views and reports are 
viewable from the WhatsUp Gold web interface. 

3. Full reports 
In WhatsUp Gold, reports are used to troubleshoot and monitor performance and historical 
data that has been collected during the operation of the application. Reports are viewed from 
the WhatsUp Gold Reports tab and can be sent on a regular basis to an email address you 
identify through the Recurring Report feature.  
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System requirements 

Minimum software requirements 
 Windows XP Professional SP2 (or later), Windows Server 2003 SP2 (or later), Windows 

Vista Ultimate (Windows Vista SP1 recommended), Windows Vista Business (Windows 
Vista SP1 recommended), or Windows Server 2008 

 Microsoft Internet Explorer 6.0 SP1 (or later) or Firefox 2.0 (or later) 

 Microsoft Windows Scripting Host v5.7 (or later) 

 Note: Windows Scripting Host is installed with the Windows operating system. To verify your 
version, run cscript.exe at a command prompt. If you need to update Windows Scripting 
Host, refer to the Microsoft Windows Scripting Host site (http://www.ipswitch.com/wsh56). 

 Microsoft SAPI 5.1 (required for Text to Speech actions) 

http://www.ipswitch.com/wsh56


Using WhatsUp Gold v12.3 

Minimum hardware requirements 
 Recommended Required 

Number of Processors Two  One 

Processor  2 GHz 2 GHz 

RAM 2 GB 1 GB 

Hard disk space for 
application files 

3 GB 2 GB 

Hard disk space for 
database 

5 GB or more 

*This requirement is larger if you are 
using WhatsUp Gold NetFlow 
Monitor. For more information, see 
the NetFlow Monitor Release Notes. 

At least 1 GB 

*This requirement is larger if you are 
using WhatsUp Gold NetFlow 
Monitor. For more information, see 
the NetFlow Monitor Release Notes. 

Network interface card 1 Gbps 100 Mbps 

CD-ROM or DVD-ROM Required if installing from CD-ROM. 
Not required for download 
installations. 

Required if installing from CD-ROM. 
Not required for download 
installations. 

Video display resolution 1280 x 1024 or higher 1024 x 768 

Sound card SAPI-capable sound card required for 
Text-to-Speech actions 

Not required 

Modem and phone line Required for pager, SMS, and beeper 
actions; modem pooling is not 
supported 

Not required 

GSM modem Required for SMS Direct actions Not required 

 
 

Installation notes 

Read the Release Notes for information about potential installation issues, such as the 
following: 

 Windows XP (SP2) Errors. This Service Pack enables firewall settings that can interfere 
with Microsoft SQL Server’s ability to listen on the network. 

 

Installing WhatsUp Gold 

Before installing WhatsUp Gold, you must decide where you want to store the network 
management data WhatsUp Gold generates.  

By default, WhatsUp Gold installs Microsoft® SQL Server® 2005 Express Edition on the same 
computer where WhatsUp Gold is installed. This configuration works well for most networks. 
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However, Microsoft® SQL Server® 2005 Express Edition has a database size limit of 4 GB which 
may be too small to contain the data collected on larger networks. 

Alternatively, you can configure WhatsUp Gold to use an existing Microsoft® SQL Server® 
database. Microsoft® SQL Server® is not limited in size like Microsoft® SQL Server® 2005 
Express Edition, but it does require a knowledgable database administrator to configure and 
maintain it. 

 Note: The installation instructions in this document apply only to WhatsUp Gold Standard 
Edition and WhatsUp Gold Premium Edition. For installation instructions for WhatsUp Gold 
Distributed Edition or WhatsUp Gold MSP Edition, see  WhatsUp Gold Distributed Edition 
Deployment Guide (http://www.ipswitch.com/WUG123dsdg) or WhatsUp Gold MSP Edition 
Deployment Guide (http://www.ipswitch.com/WUG123mspdg). 

 

Installing WhatsUp Gold using Microsoft® SQL Server® 2005 Express 
Edition 

To install WhatsUp Gold using the default Microsoft® SQL Server® 2005 Express Edition 
instance: 
1 Log in directly to Microsoft Windows using the Administrator account (if you do not 

have an account called Administrator, use an account that has full administrative 
privileges to the computer).  

 Caution: We do not recommend using Terminal Services or Remote Desktop to install 
WhatsUp Gold. 

 Note: When installing on Windows Vista, additional steps are necessary for the Task Tray 
application to work properly. For more information, see Task Tray Application fails on 
Windows Vista (on page 329) in the Help or User Guide 
(http://www.whatsupgold.com/wug123ug). 

2 Start the installation program: 

 If you downloaded an electronic version of WhatsUp Gold, double-click on the 
downloaded file. 

 If you purchased a WhatsUp Gold CD-ROM, insert the CD-ROM into the appropriate 
drive. If it does not run automatically, click Start, select Run, then enter the CD path 
followed by AutoRun.exe (for example, D:\AutoRun.exe). 

3 Read the Welcome screen.  

Click a button next to an additional resource to view that resource.  

Click Next. The License Agreement dialog appears. 
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4 Read the license agreement. If you accept the terms of the license agreement, select I 
accept the terms of the license agreement.  

 To print a copy of the license agreement, click Print. The license agreement is sent to 
the default printer. 

 If you do not accept the terms of the license agreement, click Cancel to exit the 
installation program. 

Click Next to continue. 

5 Select the install directories for Microsoft® SQL Server® 2005 Express Edition. The 
application and data files are installed in default directories. To change the locations, 
click Browse to find and select a different directory for the application files or the data 
files. 

 Important: Make sure that you have a large capacity drive selected for data storage. The 
data files for WhatsUp Gold can reach a maximum size of 22 GB. 

 Important: During the initial installation, databases are created for WhatsUp Gold NetFlow 
Monitor. These initial databases are limited in size, but are increased the first time the 
NetFlow Monitor collector initializes. If at least 16 GB of disk space are available when the 
collector initializes, the maximum size of the NetFlow Monitor databases is increased to 4 GB 
each (16 GB total including transaction logs). If less than 16 GB is available, the maximum 
size of the NetFlow Monitor databases is limited proportionately to the amount of free disk 
space. If your license includes WhatsUp Gold NetFlow Monitor, we strongly recommend that 
you verify that you have at least 16 GB of free disk space before installing. 

6 Click Next. The Choose Destination Location dialog appears. 
7 Select the installation directory for the WhatsUp Gold application files. 

The default path is C:\Program Files\Ipswitch\WhatsUp. We recommend that you 
use the default path.  

 Tip: You can install WhatsUp Gold to a different location. To select a different location, click 
Change.  

After you select the installation directory, click Next.  

 Note: If the installation program detects data from a previous installation of WhatsUp Gold, 
the Back up Web and Report Files dialog appears. We recommend that you select Back up 
the existing Web and report files, then click Next.  

The Enable Web Server dialog appears. 
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8 Determine if you want to enable the WhatsUp web server.  

 To enable the WhatsUp web server, select Yes and enter a port. The default port is 80.  

 Note: You must select a port that is not already in use. If the port you enter is in use, you 
must enter a different port or stop the service using the entered port before you can 
continue installing WhatsUp Gold. If you choose to stop the service running on the port you 
want to use, you must disable it permanently. If you only disable it temporarily, a port 
conflict will occur the next time the disabled service is started. 

 To use Microsoft Internet Information Services, select No, then see Configuring the web 
server (on page 21) in the Help.  

After making a selection, click Next.  

 Note:  If the firewall is enabled when WhatsUp Gold is installed, the port you specify is 
opened in the Windows Firewall. This allows other computers on the network to log on to 
the WhatsUp Gold Web interface.  

9 Click Install to install WhatsUp Gold. The setup program installs and configures 
WhatsUp Gold. 

10 When the installation completes, the InstallShield Wizard Complete dialog appears.  

To see the release notes after the installation program closes, select View WhatsUp Gold 
release notes and documentation. 

Click Finish. The setup program closes. 
 

Installing WhatsUp Gold using an existing Microsoft SQL Server 
You can use an existing Microsoft® SQL Server® 2005 server to store the data collected by 
WhatsUp Gold. To do this, these requirements must be met: 

 Microsoft® SQL Server® 2005 English must be installed on the WhatsUp Gold host 
computer or another computer.  

 Important: WhatsUp Gold does not support non-English versions of Microsoft® SQL Server® 
2005. 

 Microsoft® SQL Server® 2005 must be configured to allow WhatsUp Gold to authenticate.  

 If Microsoft® SQL Server® 2005 is installed on a remote computer, remote connections 
must be allowed. For more information, see How to configure Microsoft® SQL Server® 
2005 to allow remote connections (http://support.microsoft.com/kb/914277). 

 We recommend using a Microsoft® SQL Server® user account to connect to the 
database. However, if the Microsoft® SQL Server® database exists on the same 
computer or both computers are members of the same domain, you may use 
Windows authentication. For more information about enabling mixed mode 
authentication in Microsoft® SQL Server® 2005, see the Microsoft article about 
Authentication Mode (http://msdn2.microsoft.com/en-us/library/ms144284.aspx).  
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 Note: When using Windows Authentication, the WhatsUp Gold services and applications 
must run as the database user. 

 Microsoft® SQL Server® 2005 must be configured to have a user account that meets the 
following requirements: 

 Full administrator privileges to Microsoft® SQL Server® 2005, not just the WhatsUp 
Gold databases. WhatsUp Gold only supports accessing the database via an account 
with full administrator rights. WhatsUp Gold does not support using a limited access 
database user account. 

 User's language is set to (United States) English. This can be set in the 
properties for the login used by WhatsUp Gold. 

If you need assistance configuring or verifying these prerequisites, contact your database 
administrator or refer to the Microsoft® SQL Server® 2005 documentation 
(http://support.microsoft.com/ph/2855). 

To install WhatsUp Gold using an existing Microsoft® SQL Server®: 
1 Log in directly to Microsoft Windows using the Administrator account (if you do not 

have an account called Administrator, use an account that has full administrative 
privileges to the computer).  

 Caution: We do not recommend using Terminal Services or Remote Desktop to install 
WhatsUp Gold. 

 Note: When installing on Windows Vista, additional steps are necessary for the Task Tray 
application to work properly. For more information, see Task Tray Application fails on 
Windows Vista (on page 329) in the Help or User Guide 
(http://www.whatsupgold.com/wug123ug). 

2 Start the installation program: 

 If you downloaded an electronic version of WhatsUp Gold, double-click on the 
downloaded file. 

 If you purchased a WhatsUp Gold CD-ROM, insert the CD-ROM into the appropriate 
drive. If it does not run automatically, click Start, select Run, then enter the CD path 
followed by AutoRun.exe (for example, D:\AutoRun.exe). 

3 Read the Welcome screen.  

Click a button next to an additional resource to view that resource.  

Clear Hide advanced installation options. This checkbox must be cleared in order for 
you to use Microsoft® SQL Server® as the WhatsUp Gold database. 

Click Next. The License Agreement dialog appears. 
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4 Read the license agreement. If you accept the terms of the license agreement, select I 
accept the terms of the license agreement.  

 To print a copy of the license agreement, click Print. The license agreement is sent to 
the default printer. 

 If you do not accept the terms of the license agreement, click Cancel to exit the 
installation program. 

Click Next to continue. The Microsoft SQL Server Installation Options dialog appears. 

5 Select Use an existing installation of Microsoft SQL Server, then click Next. The 
Database Server Login dialog appears. 

a) In Database server that you are installing to, enter the hostname of your database 
server. 

 Note: If you are using a database instance other than the default instance, you must include 
the instance name using the format <Server_Name>\<Instance_Name>. 

 Tip: If you cannot remember your database server's hostname, click Browse to see a list of 
all database servers detected on the domain. Database servers to which you can connect but 
which are not configured on the same domain as the computer where you are installing 
WhatsUp Gold are not shown. The Browse dialog scans your entire domain , so it may take 
some time before showing you a list of database servers. 

b) Select the appropriate authentication method for your database server.  

 If your database server is a member of a domain and is configured to accept 
Windows user names, select Windows authentication. The user whose 
credentials you use to run WhatsUp Gold must be a member of the same domain 
as the database server. 

 If your database server requires SQL Server authentication, or if the Windows user 
account under which WhatsUp Gold runs does not have access to the database 
server via Windows authentication, select SQL Server authentication using 
Login ID and password below, then enter the correct Login ID and Password. 

c) Click Next. The installation program attempts to validate the credentials you entered 
and checks for the existence of WhatsUp Gold databases on the database server. If 
WhatsUp Gold databases are found on the database server, the setup program alerts 
you and asks if you want to continue.  

 Select Yes to upgrade the databases and continue the installation. 

 Select No to select another Microsoft® SQL Server®.  

After the credentials are validated, the Enter Microsoft® SQL Server® 2005 Express 
Edition Paths dialog appears. 

6 This dialog lists the third-party resources that the installation program installs, including 
Microsoft® SQL Server® 2005 Express Edition client tools (required for installations of 
WhatsUp Gold that use Microsoft® SQL Server® databases) and Microsoft .Net 
Framework 2.0.  

Click Next. The Choose Destination Location dialog appears. 
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7 Select the installation directory for the WhatsUp Gold application files. 

The default path is C:\Program Files\Ipswitch\WhatsUp. We recommend that you 
use the default path.  

 Tip: You can install WhatsUp Gold to a different location. To select a different location, click 
Change.  

After you select the installation directory, click Next.  

 Note: If the installation program detects data from a previous installation of WhatsUp Gold, 
the Back up Web and Report Files dialog appears. We recommend that you select Back up 
the existing Web and report files, then click Next.  

The Enable Web Server dialog appears. 

8 Determine if you want to enable the WhatsUp web server.  

 To enable the WhatsUp web server, select Yes and enter a port. The default port is 80.  

 Note: You must select a port that is not already in use. If the port you enter is in use, you 
must enter a different port or stop the service using the entered port before you can 
continue installing WhatsUp Gold. If you choose to stop the service running on the port you 
want to use, you must disable it permanently. If you only disable it temporarily, a port 
conflict will occur the next time the disabled service is started. 

 To use Microsoft Internet Information Services, select No, then see Configuring the web 
server (on page 21) in the Help.  

After making a selection, click Next.  

 Note:  If the firewall is enabled when WhatsUp Gold is installed, the port you specify is 
opened in the Windows Firewall. This allows other computers on the network to log on to 
the WhatsUp Gold Web interface.  

9 Click Install to install WhatsUp Gold. The setup program installs and configures 
WhatsUp Gold. 

10 When the installation completes, the InstallShield Wizard Complete dialog appears.  

To see the release notes after the installation program closes, select View WhatsUp Gold 
release notes and documentation. 

Click Finish. The setup program closes. 
 

Upgrading 

The installation program can automatically upgrade WhatsUp Gold v11 and later. The 
installation program delivers new application files and upgrades the database. The 
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installation program automatically upgrades databases on Microsoft® SQL Server® Desktop 
Edition, Microsoft® SQL Server® 2005 Express Edition, and Microsoft® SQL Server® 2005. 

 Note: WhatsUp Gold v12.3 introduces automatic database upgrades. It is no longer 
necessary to manually execute SQL scripts to upgrade a non-standard database. 

 Note: If you are using Microsoft® SQL Server® 2000, you must upgrade to Microsoft® SQL 
Server® 2005 prior to upgrading WhatsUp Gold. Microsoft® SQL Server® 2000 is no longer 
supported by WhatsUp Gold. 

 Tip: To upgrade from an older version than WhatsUp Gold v11, you must first upgrade to 
WhatsUp Gold v11, then upgrade to WhatsUp Gold v12.3. For more information, see the 
WhatsUp Gold Answers repository (http://whatsup.custhelp.com). 

If the database is currently hosted on Microsoft® SQL Server® Desktop Edition or Microsoft® 
SQL Server® 2005 Express Edition but you want to migrate your database to Microsoft® SQL 
Server® 2005, complete the upgrade on the existing database, then follow the steps outlined 
in the WhatsUp Gold Database Migration Guide (http://www.whatsupgold.com/wugdbmg). 

To upgrade from a previous version of WhatsUp Gold: 
1 Log in directly to Microsoft Windows using the Administrator account (if you do not 

have an account called Administrator, use an account that has full administrative 
privileges to the computer).  

 Caution: We do not recommend using Terminal Services or Remote Desktop to install 
WhatsUp Gold. 

 Note: When installing on Windows Vista, additional steps are necessary for the Task Tray 
application to work properly. For more information, see Task Tray Application fails on 
Windows Vista (on page 329) in the Help or User Guide 
(http://www.whatsupgold.com/wug123ug). 

2 Start the installation program: 

 If you downloaded an electronic version of WhatsUp Gold, double-click on the 
downloaded file. 

 If you purchased a WhatsUp Gold CD-ROM, insert the CD-ROM into the appropriate 
drive. If it does not run automatically, click Start, select Run, then enter the CD path 
followed by AutoRun.exe (for example, D:\AutoRun.exe). 

3 Read the notice about device limit enforcement.  

 Select Yes to continue the upgrade. 

 Select No to abort the upgrade. 
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 Note: If you upgrade and you are currently managing more devices than your license allows, 
WhatsUp Gold will not poll your devices after the upgrade until you take additional action. 
To find out more about how device limits work and to determine if you are affected, see Are 
you managing more devices than your license allows? 
(http://www.whatsupgold.com/devicecount.htm). 

4 Read the Welcome screen.  

Click a button next to an additional resource to view that resource.  

 Important: During the upgrade process, WhatsUp Gold services and monitoring are 
stopped.  

Click Next. The License Agreement dialog appears. 

5 Read the license agreement. If you accept the terms of the license agreement, select I 
accept the terms of the license agreement.  

 To print a copy of the license agreement, click Print. The license agreement is sent to 
the default printer. 

 If you do not accept the terms of the license agreement, click Cancel to exit the 
installation program. 

Click Next. The Back Up Existing Database dialog appears. 

6 Since the installation program makes changes to the WhatsUp Gold database, we 
strongly recommend that you select Yes, back up the existing database.  

 Note: If you are upgrading from an installation of WhatsUp Gold 11.x that uses Microsoft® 
SQL Server® Desktop Edition as its database, you can select the location where you want to 
store the backup. For all other upgrades, the backup is made in the default backup location 
for the database server. 

Click Next.The Back Up Web and Report Files dialog appears. 

7 If you have modified any of the Web or Report files, select Back up the existing Web 
and report files. If this option is selected, the existing Web and report files are copied to 
a backup folder before the upgrade begins. We recommend that you select this option. 

Click Next. The Ready to Install the Program dialog appears. 

8 Click Install. The installation program begins upgrading WhatsUp Gold. 
9 When the installation completes, the InstallShield Wizard Complete dialog appears.  

To see the release notes after the installation program closes, select View WhatsUp Gold 
release notes and documentation. 

Click Finish. The setup program closes. 
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Activating WhatsUp Gold for new or upgraded 
licenses 

If WhatsUp Gold is installed using the installation application downloaded from the Web link 
provided in the purchase confirmation email, the program is fully functional immediately 
after installation.  

If the WhatsUp Gold v12 license is not automatically activated during the installation or if you 
are upgrading from a previous WhatsUp Gold version, you can manually activate WhatsUp 
Gold. 

 Important: Make sure that you activate WhatsUp Gold before starting the application. If the 
application is not activated before the polling engine is started, the engine will not start and 
a message telling you that the license has expired is written to the log. The application is not 
functional until after it has been activated. 

To activate WhatsUp Gold manually: 

 Note: Before you start the manual activation process, make sure that you have your product 
serial number available to use in the activation program. 

1 Click Start > Programs > Ipswitch WhatsUp Gold > Manage WhatsUp Gold License. 
The activation program appears. 
- or - 
If you run the WhatsUp Gold console at the end of the installation, it displays an Invalid 
License dialog. Click the Purchase/Unlock to start the license activation process. 

2 Follow the on-screen instructions to complete the product activation. 

 Note: When the activation is complete, a confirmation page indicates the license has been 
activated. If the activation does not complete successfully, you may be behind a proxy or 
firewall that is blocking the activation request. In this case, click the Offline button, then 
follow the onscreen instructions. 

For more help and information about licensing, go to the MyIpswitch licensing portal 
(http://www.myipswitch.com/). 

 Tip: You can view information about your installation via the About WhatsUp Gold dialog, 
located on both the console and web interface from Help > About WhatsUp. The About 
WhatsUp Gold dialog displays your license type, serial number, product edition, registered 
user, maximum devices. From the About WhatsUp Gold dialog, you can click Plugins to view 
the plugin licensing information. 
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About the Task Tray and Desktop Actions icon 

WhatsUp Gold installs two task bar icons on your computer.  

 The Task Tray icon  alerts you to the status of the application as a whole. 

 The Desktop Actions icon  displays to indicate that support is enabled for Sound, Text-
to-Speech, and WinPopup actions for Windows Server 2008 and Vista Enterprise. 

WhatsUp Gold Icons 
During normal operation, the WhatsUp Gold icon displays the worst state of all devices on 
your map. In addition, you can enable tooltips to have the icon display any state change that 
occurs on the system. To do this, right-click on the icon and select or clear Enable Tooltips. 

 

When the WhatsUp Gold polling engine is not running (the service is stopped) this icon 
appears: 

 

If this is the case, you need to restart the Ipswitch WhatsUp Gold Engine service. If the polling 
engine is not running, then WhatsUp Gold is not connected to the database, and nothing in 
the application will function properly. 

 To turn off the Task Tray Application and icon , right-click on the icon, then click Close 
Task Tray Application. 

 To turn off the Action Alert icon , right-click the icon, then click select Close. 
 

Configuring the database 

WhatsUp Gold requires a database to store information about the devices it monitors. 
WhatsUp Gold supports the following databases: 

 Microsoft® SQL Server® 2005 Express Edition (installed by WhatsUp Gold) 

 Microsoft® SQL Server® 2005 (not installed by WhatsUp Gold) 

You can select and install to either database during installation. Upgrades from previous 
versions of WhatsUp Gold automatically use the existing database. 

To learn how to migrate from Microsoft® SQL Server® 2005 Express Edition to Microsoft® SQL 
Server® 2005, see WhatsUp Gold Database Migration Guide 
(http://www.whatsupgold.com/wugdbmg). 
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Configuring the web server 

By default, WhatsUp Gold delivers and configures a lightweight web server to serve the web 
interface over regular HTTP or SSL-encrypted HTTPS. 

Alternatively, you can configure Microsoft Internet Information Services as the web server for 
the WhatsUp Gold web interface. 
 

Stopping and starting the internal web server 
To start or stop the WhatsUp Gold web server: 
1 On the WhatsUp Gold console, select Configure > Program Options. 
2 On the Program Options dialog, select Web Server. 

 
3 Select Enable web server on port to start the server, or clear the option to stop the 

server. 
4 Click OK to save your changes. 

You can change the port that the server runs on by changing the port number next to the 
Enable web server on port option. 

 Tip: To restart the web server, clear Enable web server on port and click OK to close the 
dialog. Then, open Program Options dialog again and select Enable web server on port 
again. 
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 Tip: You can also restart the web server using the NmServiceRestart.exe command line 
utility. For more information, see Restarting the WhatsUp Gold services from the command line 
(on page 332). 

 

About the default SSL certificates 
WhatsUp Gold install the SSL certificates and keys needed to immediately begin connecting 
to the SSL web server using 128 bit encryption. 

The SSL files included with WhatsUp Gold (root.pem and server.pem) are installed with 
every copy of WhatsUp Gold as a demonstration of how SSL can be used to encrypt web 
traffic. If you choose to use these default files, your encrypted session can be intercepted and 
decrypted by anyone who has access to these files. 

You should replaced the default certificates with new SSL certificates that you generate and 
sign. These sample files reside in the <WhatsUp Gold Install Directory>\data\SSL 
directory. 

Also, since the sample certificate is issued with Ipswitch as the Common Name, it will 
generate a Domain Name Mismatch Security Error every time a new browser session is 
established. 
 

Using IIS on Windows XP or Windows 2003 
Follow these steps to run the WhatsUp Gold web interface through an IIS (Internet 
Information Services) Web server on Windows XP or Windows 2003. This procedure assumes 
that you are using the default instance of SQL Server 2005 Express that is delivered with 
WhatsUp Gold and that WhatsUp Gold, SQL Server 2005 Express, and Internet Information 
Server are all installed on the same server. 

 Important: This procedure is for use with Windows XP and Windows 2003 only. For 
instructions on how to configure IIS as the web server for the WhatsUp Gold web interface on 
Windows Vista, see Using IIS on Windows Vista (on page 26). 

To use IIS  as the web server for the WhatsUp Gold web interface on Windows XP or 
Windows 2003: 
1 Stop the following services and applications: 

 Ipswitch WhatsUp Engine service 

 Ipswitch Web service 

 Task Tray application 

 WhatsUp Gold console 
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2 Specify a username and password for WhatsUp Gold to use when connecting to the 
database. 

a) From the Windows Start menu, select Control Panel > Administrative Tools > Data 
Sources and select the System DSN tab. 

b) Select the WhatsUp DSN and click Configure. The Configuration wizard appears. 

c) Verify that the fields in the first dialog are correct for your SQL Server authentication 
preferences, then click Next. 

d) On the second dialog, verify that the With SQL Server authentication using login ID 
and password entered by the user option is selected. In the Login field, enter the 
SQL username. In the Password field, enter the SQL user's password. Click Next. 

e) On the third dialog, verify that Change the default database to is selected and that 
the WhatsUp database appears in the drop-down menu. Click Next. 

f) Continue to click Next until you come to the final dialog, then click Finish. The ODBC 
Microsoft SQL Server Setup dialog opens. You can click Test Data Source to test the 
configuration or click OK. 

g) Repeat steps b-f for the NetFlow DSN. 

3 Configure WhatsUp Gold and its plug-ins to use the updated username and password 
for the database. 

a) Browse to the WhatsUp Gold install directory and run NmConfig.exe.  

b) Select Use SQL Server Authentication. 

c) Enter the Username and Password that you entered in the DSN, then click Connect. 
The utility verifies the connection information. If the information is correct, the 
Update Registry dialog appears. 

d) Verify that Restart the WhatsUp service after the update is selected.  

 Note: NmConfig.exe can only restart services that are already running when the utility is 
launched. If the services are not started when NmConfig.exe is run, you must manually start 
them after NmConfig.exe closes. 

e) Click Save. The utility updates the database connection settings and restarts effected 
services. The Finished dialog appears. 

f) Click Finish. The NmConfig.exe utility closes. 

 Note: For the default instance of Microsoft® SQL Server® 2005 Express Edition installed with 
WhatsUp Gold, the default username is sa and the password is WhatsUp_Gold. 

4 Stop the Web site under which you want to run the WhatsUp Gold web interface. 

a) From the Windows Start menu, select Control Panel > Administrative Tools > 
Internet Information Services. The Internet Information Services (IIS) Manager 
appears. 

b) Right-click on the Web site under which you want to run the WhatsUp Gold web 
interface and select Stop. 
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5 Create a virtual directory for the WhatsUp Gold web interface.  

a) Right-click on the Web site on which you want to run the WhatsUp Gold web interface 
and select New > Virtual Directory. The Virtual Directory Creation Wizard appears. 

b) Click Next. The Virtual Directory Alias dialog appears. 

c) In Alias, enter NmConsole. Click Next. The Web Site Content Directory dialog appears. 

d) In Path, enter or browse to select <WhatsUp Gold install 
path>\HTML\NmConsole\. Click Next. The Virtual Directory Access Permissions 
dialog appears. 

e) Enable Read and Run scripts (such as ASP), then click Next. 

f) Click Finish to close the wizard. 

6 Enable the parent paths feature for the NmConsole virtual directory.  

a) In the Internet Information Services (IIS) Manager, right-click on the newly created 
NmConsole virtual directory and select Properties. 

b) Select the Virtual Directory tab, then click Configuration. 

c) On the Options tab, select Enable parent paths. Click OK. 

7 Configure authentication methods for the NmConsole virtual directory. 

a) In the NmConsole Properties dialog, select the Directory Security tab.  

b) Under Anonymous access and authentication control (in Windows XP) or 
Authentication and access control (in Windows 2003), click Edit. Verify that Enable 
anonymous access is enabled.  

c) By default, IIS uses a restricted account named IUSR_<machine_name> for 
anonymous access. Under Account used for anonymous access, change the user 
listed in the User name field to a local administrator.  

 Note: In Windows XP, if you wish to use a domain user with local administrator rights, you 
must disable the Allow IIS to control password option and enter the password for the 
domain user.  

- or - 

Specify permissions for the IUSR_<machine_name> on the Windows Registry and the 
appropriate folders. 

 In the Windows Registry, grant IUSR_<machine_name> user the Full Control 
permission to the 
HKEY_LOCAL_MACHINE\SOFTWARE\Ipswitch\WebServer\WhatsUp key. 

 In Windows Explorer, grant IUSR_<machine_name> user the Full Control 
permission to the <WhatsUp Gold install path> folder. 

 In Windows Explorer, grant IUSR_<machine_name> user the Full Control 
permission to the <WhatsUp Gold install path>\HTML\ folder and all of the 
files and folders located beneath it. 

 In Windows Explorer, grant IUSR_<machine_name> user the Full Control 
permission to the <WhatsUp Gold install path>\Data\Mibs folder. 
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 Note: If you specify a user that does not have administrative privileges, the web interface 
cannot interact with Windows services. This means that you cannot view the status of 
services or start, stop, or restart services from the web interface. In this case, you must log in 
to Windows to manage services through the Control Panel. 

d) Click OK to close the Authentication Methods dialog, then OK to close the NmConsole 
Properties dialog.  

8 On Windows 2003 (IIS 6) only, you must enable and configure Active Server Pages. 

a) In the Internet Information Services (IIS) Manager, select the Web Services 
Extensions folder. The Web Services Extensions pane appears. 

b) Select Active Server Pages, then click Allow. 

c) Enable ASP response buffering and increase the buffer limit as follows: 

 From the Windows desktop, select Start > Run. The Run dialog appears. 

 Enter cmd.exe, then click OK. 

 Enter the following commands:  
cd /d %systemdrive%\inetpub\adminscripts 
cscript.exe adsutil.vbs SET w3svc/AspBufferingLimit 8000000 
cscript.exe adsutil.vbs SET w3svc/AspMaxRequestEntityAllowed 
8000000 

9 Restart IIS. To do this, in the Internet Information Services (IIS) Manager, right-click on 
the Web site on which you want to run the WhatsUp Gold web interface and select 
Start. 

10 Disable the Ipswitch web server. This can be done on the WhatsUp Gold console at 
Configure > Program Options > Web Server. After disabling the Ipswitch Web server, 
verify that reports still load correctly by right-clicking a device in the console and 
selecting Device Reports. If the reports do not load properly, verify that the Web server 
port in the Web report access from Windows console section of the contains the port 
number used by IIS. 

11 Restart the services and applications you stopped in Step 1. 
12 Connect to the WhatsUp web interface by opening a browser and entering the 

following address in the Address box: 

http://<ip_address - or - hostname>/NmConsole/ 

Examples 
http://192.168.1.200/NmConsole/ 

http://demo.whatsupgold.com/NmConsole/ 

 Important: When adding a device through IIS, an issue with IIS may cause you to receive an 
error that says, "Error scanning device." For information on how to resolve this issue, see 
“Error scanning device XXXXX. Probable cause is it does not exist" when using IIS as the Web Server 
(http://support.ipswitch.com/kb/WP-20061130-es01.htm). 
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Using IIS on Windows Vista 
Follow these steps to run the WhatsUp Gold web interface through an IIS (Internet 
Information Services) Web server on Windows Vista. This procedure assumes that you are 
using the default instance of SQL Server 2005 Express that is delivered with WhatsUp Gold 
and that WhatsUp Gold, SQL Server 2005 Express, and Internet Information Server are all 
installed on the same server. 

 Important: Throughout the procedure below, Windows Vista may periodically ask you to 
confirm that you want to perform certain tasks that require administrative privileges. If this 
occurs, select OK. 

 Important: This procedure applies to Windows Vista with Service Pack 1 only. For 
instructions on how to configure IIS as the web server for the WhatsUp Gold web interface on 
Windows XP or Windows 2003, see Using IIS on Windows XP or Windows 2003 (on page 22). 

1 Stop or close the following services and applications: 

 Ipswitch WhatsUp Engine service 

 Ipswitch Web service 

 WhatsUp Gold Task Tray application 

 WhatsUp Gold console application 

 Internet Information Services (which appears as the World Wide Web Publishing 
Service in the Services applet of the Control Panel) 

2 Specify a username and password for WhatsUp Gold to use when connecting to the 
database. 

a) From the Windows Start menu, select Control Panel > Administrative Tools > Data 
Sources and select the System DSN tab. 

b) Select the WhatsUp DSN and click Configure. The Configuration wizard appears. 

c) Verify that the fields in the first dialog are correct for your SQL Server authentication 
preferences, then click Next. 

d) On the second dialog, verify that the With SQL Server authentication using login ID 
and password entered by the user option is selected. In the Login field, enter the 
SQL username. In the Password field, enter the SQL user's password. Click Next. 

e) On the third dialog, verify that Change the default database to is selected and that 
the WhatsUp database appears in the drop-down menu. Click Next. 

f) Continue to click Next until you come to the final dialog, then click Finish. The ODBC 
Microsoft SQL Server Setup dialog opens. You can click Test Data Source to test the 
configuration or click OK. 

g) Repeat steps b-f for the NetFlow DSN. 

3 Configure WhatsUp Gold and its plug-ins to use the updated username and password 
for the database. 

a) Browse to the WhatsUp Gold install directory and run NmConfig.exe.  

b) Select Use SQL Server Authentication. 
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c) Enter the Username and Password that you entered in the DSN, then click Connect. 
The utility verifies the connection information. If the information is correct, the 
Update Registry dialog appears. 

d) Verify that Restart the WhatsUp service after the update is selected.  

 Note: NmConfig.exe can only restart services that are already running when the utility is 
launched. If the services are not started when NmConfig.exe is run, you must manually start 
them after NmConfig.exe closes. 

e) Click Save. The utility updates the database connection settings and restarts effected 
services. The Finished dialog appears. 

f) Click Finish. The NmConfig.exe utility closes. 

 Note: For the default instance of Microsoft® SQL Server® 2005 Express Edition installed with 
WhatsUp Gold, the default username is sa and the password is WhatsUp_Gold. 

4 Create a Windows user to serve as the user context under which the WhatsUp Gold web 
interface runs.  

a) Open Control Panel > Administrative Tools > Computer Management. The 
Computer Management application appears. 

b) Select Local User and Groups, then select the Users folder. 

c) From the menu, select Action > New User. The New User dialog appears. 

d) Enter the information for the new user. We recommend using a name that is easily 
identifiable as the WhatsUp Gold user, such as WhatsUpUser or WUGUser.  

e) Clear User must change password at next logon. 

f) Click Create. The new user is created. 

g) Click Close to close the New User dialog. 

h) Double-click the new user. The Properties dialog for the user appears. 

i) Select the Member Of tab. A list of groups to which this user belongs appears. 

j) Verify that the user is a member of the Users group. 

k) Click OK, and then close the Computer Management window. The user is now ready 
to be used by the WhatsUp Gold web interface.  

 Note: If you specify a user that does not have administrative privileges, the web interface 
cannot interact with Windows services. This means that you cannot view the status of 
services or start, stop, or restart services from the web interface. In this case, you must log in 
to Windows to manage services through the Control Panel. 

5 Verify that IIS is installed and properly configured. 

a) Open Control Panel > Programs and Features. 

b) From the Tasks pane on the left side of the window, select Turn Windows Features 
on or off. The Windows Features dialog appears. 
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c) Verify that Internet Information Services is selected. 

d) Expand Internet Information Services > World Wide Web Services > Application 
Development Features. 

e) Select ASP, then click OK. 

6 Create an IIS application pool for WhatsUp Gold to use. 

a) Open Control Panel > Administrative Tools. The Administration Tools window 
appears. 

b) Double-click Internet Information Services (IIS) Manager. The Internet Information 
Services (IIS) Manager appears. 

c) In the Connections pane on the left side of the window, expand the item that 
corresponds to the name of the server on which you are working. 

d) Right-click on Application Pools and select Add Application Pool. The Add 
Application Pool dialog appears. 

e) In Name, enter NmConsole. 

f) Under .NET Framework version, select the highest version available. 

g) Under Managed pipeline mode, select Classic. 

h) Click OK. The new application pool is created. 

7 Configure advanced settings on the NmConsole application pool. 

a) Right-click the NmConsole application pool from the list, then select Advanced 
Settings from the right-click menu. The Advanced Settings dialog appears. 

b) Expand Process Model, then select the Identity row. Click the browse (...) button that 
appears in the second column. The Application Pool Identity dialog appears. 

c) Select Custom account, then click Set. The Set Credentials dialog appears. 

d) Enter the name and password of the user you created for the WhatsUp Gold web 
interface to run as, then click OK. 

e) Make sure the Maximum Worker Processes are set to 1. 

f) Click OK to exit the Advanced Settings dialog. 

8 Create an IIS application for the WhatsUp Gold web interface. 

a) In the Connections pane on the left side of the screen, under Sites, locate the Web 
site under which you want WhatsUp Gold to run. Right-click it and select Add 
Application. The Add Application dialog appears. 

b) In Alias, enter NmConsole.  

c) Click the Select button next to Application pool. The Select Application Pool dialog 
appears. 

d) Select the NmConsole application pool, then click OK. 

e) In Physical path, enter (or use the browse button to select) the path to the WhatsUp 
Gold web interface. This should be located at <WhatsUp Gold install 
path>\HTML\NmConsole\.  

f) Click Connect As. The Connect As dialog appears. 
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g) Select Specific user, then click Set. The Set Credentials dialog appears. 

h) Enter the name and password of the user you created for the WhatsUp Gold web 
interface to run as, then click OK.  

i) Click OK to close the Connect As dialog. 

 Tip: After configuring the settings for the application, click Test Settings to verify that 
everything is configured correctly. 

j) Click OK. The new application is created. 

9 Modify the ASP settings for the NmConsole application. 

a) In the Connections pane on the left side of the window, select the NmConsole 
application.  

b) In the center section of the screen, under the IIS heading, double-click ASP. 

c) Under Enable Parent Paths, select True. This option is required to support use of the 
relative paths used to navigate in the WhatsUp Gold web interface. 

d) Expand Limit Properties. 

e) Change the value of Maximum Requesting Entity Body Limit to 8000000. 

f) Change the value of Response Buffering Limit to 8000000. 

g) In the Actions pane on the right side of the window, click Apply. 

10 On the Windows Registry and the appropriate folders, specify permissions for the user 
you created for the WhatsUp Gold web interface to run as. 

 In the Windows Registry, grant the user the Full Control permission to the 
HKEY_LOCAL_MACHINE\SOFTWARE\Ipswitch\WebServer\WhatsUp key. 

 In Windows Explorer, grant the user the Full Control permission to the <WhatsUp 
Gold install path>\HTML\ folder and all of the files and folders located beneath 
it. 

 In Windows Explorer, grant the user the Full Control permission to the <WhatsUp 
Gold install path>\Data\Mibs folder. 

11 To prevent a port conflict, the internal web server must be set to use another port, such 
as 8080, or must be disabled. This can be done on the WhatsUp Gold console at 
Configure > Program Options > Web Server.  

 Note: If you configure the Web Server to run on a port other than the port you specified 
during the installation of WhatsUp Gold, you must configure the Windows Firewall to allow 
traffic on that port. 

If you disable the WhatsUp web interface, verify that reports still load correctly by right-
clicking a device in the WhatsUp Gold console and selecting Device Reports. If not, 
double-check the settings on the Program Options > Web Server panel and verify the 
Web server port in the Web report access from Windows console section contains the 
port number used by IIS. 

12 Restart the services and applications you stopped in Step 1. 
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13 Connect to the WhatsUp web interface by opening a browser and entering the 
following address in the Address box: 

http://<ip_address - or - hostname>:port/NmConsole/ 

Examples 
http://192.168.1.200/NmConsole/ 

http://192.168.1.200:8080/NmConsole/ 

http://www.ipswitch.com:8080/NmConsole/ 
 

Using IIS on Windows Server 2008 
Follow these steps to run the WhatsUp Gold web interface through an IIS (Internet 
Information Services) Web server on Windows Server 2008. This procedure assumes that you 
are using the default instance of Microsoft® SQL Server® 2005 Express Edition that is delivered 
with WhatsUp Gold and that WhatsUp Gold, SQL Server 2005 Express, and Internet 
Information Server are all installed on the same server. 

 Important: Throughout the procedure below, Windows Server 2008 may periodically ask 
you to confirm that you want to perform certain tasks that require administrative privileges. 
If this occurs, select OK. 

1 Stop or close the following services and applications: 

 Ipswitch WhatsUp Engine service 

 Ipswitch Web service 

 WhatsUp Gold Task Tray application 

 WhatsUp Gold console application 

 Internet Information Services (which appears as the World Wide Web Publishing 
Service in the Services applet of the Control Panel) 

2 Specify a username and password to use when connecting to the database. 

a) From the Windows Start menu, select Control Panel > Administrative Tools > Data 
Sources and select the System DSN tab. 

b) Select the WhatsUp DSN and click Configure. The Configuration wizard appears. 

c) Verify that the fields in the first dialog are correct for your SQL Server authentication 
preferences, then click Next. 

d) On the second dialog, verify that the With SQL Server authentication using login ID 
and password entered by the user option is selected. In the Login field, enter the 
SQL username. In the Password field, enter the SQL user's password. Click Next. 

e) On the third dialog, verify that Change the default database to is selected and that 
the WhatsUp database appears in the drop-down menu. Click Next. 

f) Continue to click Next until you come to the final dialog, then click Finish. The ODBC 
Microsoft SQL Server Setup dialog opens. You can click Test Data Source to test the 
configuration or click OK. 

g) Repeat steps b-f for the NetFlow DSN. 

  30 



Using WhatsUp Gold v12.3 

3 Configure WhatsUp Gold and its plug-ins to use the updated username and password 
for the database. 

a) Browse to the WhatsUp Gold install directory and run NmConfig.exe.  

b) Select Use SQL Server Authentication. 

c) Enter the Username and Password that you entered in the DSN, then click Connect. 
The utility verifies the connection information. If the information is correct, the 
Update Registry dialog appears. 

d) Verify that Restart the WhatsUp service after the update is selected.  

 Note: NmConfig.exe can only restart services that are already running when the utility is 
launched. If the services are not started when NmConfig.exe is run, you must manually start 
them after NmConfig.exe closes. 

e) Click Save. The utility updates the database connection settings and restarts effected 
services. The Finished dialog appears. 

f) Click Finish. The NmConfig.exe utility closes. 

 Note: For the default instance of Microsoft® SQL Server® 2005 Express Edition installed with 
WhatsUp Gold, the default username is sa and the password is WhatsUp_Gold. 

4 Create a Windows user to serve as the user context under which the WhatsUp Gold web 
interface runs.  

a) Open Control Panel > Administrative Tools > Computer Management. The 
Computer Management application appears. 

b) Select Local User and Groups, then select the Users folder. 

c) From the menu, select Action > New User. The New User dialog appears. 

d) Enter the information for the new user. We recommend using a name that is easily 
identifiable as the WhatsUp Gold user, such as WhatsUpUser or WUGUser.  

e) Clear User must change password at next logon. 

f) Click Create. The new user is created. 

g) Click Close to close the New User dialog. 

h) Double-click the new user. The Properties dialog for the user appears. 

i) Select the Member Of tab. A list of groups to which this user belongs appears. 

j) Verify that the user is a member of the Users group. 

k) Click OK, and then close the Computer Management window. 

l) The user is now ready to be used by the WhatsUp Gold web interface. 
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 Note: If you specify a user that does not have administrative privileges, the web interface 
cannot interact with Windows services. This means that you cannot view the status of 
services or start, stop, or restart services from the web interface. In this case, you must log in 
to Windows to manage services through the Control Panel. 

5 Verify that IIS is installed and properly configured. 

a) Open Control Panel > Programs and Features. 

b) From the Tasks pane on the left side of the window, select Turn Windows Features 
on or off. The Windows Features dialog appears. 

c) On the left pane of the Server Manager dialog, select Roles.  

d) On the right pane of the Server Manager dialog, select Web Server (IIS) > Role 
Services. 

e) Verify that Web Server and ASP appear with a status of Installed under the Role 
Service column. 

6 Create an IIS application pool for WhatsUp Gold to use. 

a) Open Control Panel > Administrative Tools. The Administration Tools window 
appears. 

b) Double-click Internet Information Services (IIS) Manager. The Internet Information 
Services (IIS) Manager appears. 

c) In the Connections pane on the left side of the window, expand the item that 
corresponds to the name of the server on which you are working. 

d) Right-click on Application Pools and select Add Application Pool. The Add 
Application Pool dialog appears. 

e) In Name, enter NmConsole. 

f) Under .NET Framework version, select the highest version available. 

g) Under Managed pipeline mode, select Classic. 

h) Click OK. The new application pool is created. 

7 Configure advanced settings on the NmConsole application pool. 

a) Right-click the NmConsole application pool from the list, then select Advanced 
Settings from the right-click menu. The Advanced Settings dialog appears. 

b) Expand Process Model, then select the Identity row. Click the browse (...) button that 
appears in the second column. The Application Pool Identity dialog appears. 

c) Select Custom account, then click Set. The Set Credentials dialog appears. 

d) Enter the name and password of the user you created for the WhatsUp Gold web 
interface to run as, then click OK. 

e) Make sure the Maximum Worker Processes are set to 1. 

f) Click OK to exit the Advanced Settings dialog. 

8 Create an IIS application for the WhatsUp Gold web interface. 
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a) In the Connections pane on the left side of the screen, under Sites, locate the Web 
site under which you want WhatsUp Gold to run. Right-click it and select Add 
Application. The Add Application dialog appears. 

b) In Alias, enter NmConsole.  

c) Click the Select button next to Application pool. The Select Application Pool dialog 
appears. 

d) Select the NmConsole application pool, then click OK. 

e) In Physical path, enter (or use the browse button to select) the path to the WhatsUp 
Gold web interface. This should be located at <WhatsUp Gold install 
path>\HTML\NmConsole\.  

f) Click Connect As. The Connect As dialog appears. 

g) Select Specific user, then click Set. The Set Credentials dialog appears. 

h) Enter the name and password of the user you created for the WhatsUp Gold web 
interface to run as, then click OK.  

i) Click OK to close the Connect As dialog. 

 Tip: After configuring the settings for the application, click Test Settings to verify that 
everything is configured correctly. 

j) Click OK. The new application is created. 

9 Modify the ASP settings for the NmConsole application. 

a) In the Connections pane on the left side of the window, select the NmConsole 
application.  

b) In the center section of the screen, under the IIS heading, double-click ASP. 

c) Under Enable Parent Paths, select True. This option is required to support use of the 
relative paths used to navigate in the WhatsUp Gold web interface. 

d) Expand Limit Properties. 

e) Change the value of Maximum Requesting Entity Body Limit to 8000000. 

f) Change the value of Response Buffering Limit to 8000000. 

g) In the Actions pane on the right side of the window, click Apply. 

10 On the Windows Registry and the appropriate folders, specify permissions for the user 
you created for the WhatsUp Gold web interface to run as. 

 In the Windows Registry, grant the user the Full Control permission to the 
HKEY_LOCAL_MACHINE\SOFTWARE\Ipswitch\WebServer\WhatsUp key. 

 In Windows Explorer, grant the user the Full Control permission to the <WhatsUp 
Gold install path>\HTML\ folder and all of the files and folders located beneath 
it. 

 In Windows Explorer, grant the user the Full Control permission to the <WhatsUp 
Gold install path>\Data\Mibs folder. 
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11 To prevent a port conflict, the internal web server must be set to use another port, such 
as 8080, or must be disabled. This can be done on the WhatsUp Gold console at 
Configure > Program Options > Web Server.  

 Note: If you configure the Web Server to run on a port other than the port you specified 
during the installation of WhatsUp Gold, you must configure the Windows Firewall to allow 
traffic on that port. 

If you disable the WhatsUp web interface, verify that reports still load correctly by right-
clicking a device in the WhatsUp Gold console and selecting Device Reports. If not, 
double-check the settings on the Program Options > Web Server panel and verify the 
Web server port in the Web report access from Windows console section contains the 
port number used by IIS. 

12 Restart the services and applications you stopped in Step 1. 
13 Connect to the WhatsUp web interface by opening a browser and entering the 

following address in the Address box: 

http://<ip_address - or - hostname>:port/NmConsole/ 

Examples 
http://192.168.1.200/NmConsole/ 

http://192.168.1.200:8080/NmConsole/ 

http://www.ipswitch.com:8080/NmConsole/ 
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About device count limits 

WhatsUp Gold is licensed by the number of monitored devices. After the number of 
monitored devices has been reached, you cannot add new devices to WhatsUp Gold. 

To view how many devices your license allows and how many devices you have 
currently configured: 
1 From the console, select Help > About. The About dialog appears. 

- or - 

From the web interface, select GO > Help > About. The About dialog appears. 

2 Maximum Devices indicates the number of devices your license allows you to monitor. 
The total number of devices currently configured in WhatsUp Gold is indicated in the 
first paragraph. 

 Tip: You can upgrade your license to include more devices through the Ipswitch customer 
portal (http://www.myipswitch.com). 

 

About Device Discovery 

WhatsUp Gold provides you the capability called Device Discovery that allows you to discover 
devices connected to your network. 

http://www.myipswitch.com/
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There are three ways to use Device Discovery: 

1 Through the Device Discovery Wizard (on page 36) in the WhatsUp Gold console 
2 Through single Device Discovery (on page 40)  
3 Through Active Discovery (on page 45) 
 

Using the Device Discovery wizard 

The Device Discovery wizard scans your network for devices, using the protocol(s) and 
settings you choose. After devices and monitors are found, you select the ones you want to 
monitor and WhatsUp Gold creates devices in the database for each item you choose. 

The wizard begins by default after installation. After this initial Discovery, you can run another 
Discovery at any time from the console by clicking File > Discover Devices. 

 Note: The Device Discovery Wizard is only available in the console application. 

Device groups are created based on subnetworks found during the scan. You may notice that 
some group folders may be empty. This is because a subnet was found, but the devices in 
that subnet were not scannable or you chose not to monitor them. 
 

About Device Discovery scan types 

There are four options for device discovery. They are: 

 SNMP SmartScan: SmartScan discovers devices by reading SNMP information on your 
network. This scan type uses an SNMP enabled router to identify both network devices 
and subnetworks. We recommend using SmartScan as your primary Discovery method. 

 IP Range Scan: WhatsUp Gold scans a range of IP addresses and finds the devices that 
respond to one or more of the chosen services. The Discover Devices wizard prompts you 
to enter a range of the IP addresses in your network. You should use IP Range Scan if 
SNMP is either unavailable or does not meet your needs. 

 Network Neighborhood: Scanning a Network Neighborhood creates a list of devices by 
scanning the Windows network to which your computer is connected, and finding the 
other systems on the network. Use this type of scan if you only want to discover Windows 
devices. 

 Hosts File Import: WhatsUp Gold imports devices from the system’s Hosts file, which is a 
text file that lists host names and their IP addresses on a network. For small networks, the 
Hosts file is an alternative to DNS. The Hosts file may also be called a host table by some 
TCP/IP vendors. 

For more information, see Example: discovering devices (on page 37). 
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Using SNMP SmartScan 

This section describes how to use the Device Discovery wizard with the SNMP SmartScan 
option to discover devices. In this example, you want to discover all of the devices attached 
to a specific SNMP-enabled router on your network. To accomplish this, you need to: 

 Know the IP address of the SNMP-enabled router whose network you want to discover. 

 Know the Read Community name assigned to the devices on the network. 
 

Example: discovering devices 
To discover devices: 
1 Select File > Discover Devices. The New Device Discovery Wizard appears. 

 
2 Select SNMP SmartScan as the method for scanning your network, then click Next. The 

SNMP SmartScan settings dialog appears. 
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3 In the SNMP enabled router box, enter the IP address of the SNMP enabled router you 
want to use for this scan. 

4 In the SNMP read communities box, enter the proper read community string for that 
router. If an incorrect string is entered, WhatsUp Gold will be unable to scan the 
network. Additional community strings may be entered, separated by commas, if there 
are multiple SNMP enabled devices on your network that use different strings. 

Optionally, select the Windows credential that you want to use during discovery. These 
credentials are configured in the Credentials Library, and store Windows authentication 
information (username and password) for those devices that require a logon for 
discovery or monitoring. Click the browse (...) button next to this box to access the 
Credentials Library. You can select a specific credential, select All to try all credentials that 
are configured or select None to ignore those devices that require you to log on. The 
credential that is successful is associated with each device. 

5 Click the Advanced button if you want to change the scan’s default timeouts in 
milliseconds, retry counts, and scan depth.  

 

 Click to select the Limit scan to IP class of root device option if you want to limit the 
scan to the network class (A, B, or C) defined by the IP address of the root device. If the 
IP address is within the network class of the root device, the scan proceeds. Otherwise, 
the scan skips to the next IP address.  

 Click to select the Resolve host names option if you want to populate the list of 
discovered devices with host names in addition to IP addresses.  

 Click OK to save changes and return to the SNMP SmartScan settings dialog. 
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6 Click Next. The Active/Performance Monitors to Scan dialog appears. Select the type of 
Active Monitor(s) and Performance Monitor(s) you want to use in this scan process. In 
this example, select DNS, HTTP, and Interface as our Active Monitors (Ping is selected by 
default) and CPU, Disk, and Interface Utilization as our Performance Monitors to be used 
in the scan process. 

 

 The Ping monitor polls the device on a regular basis to establish whether it is Up or 
Down. By default, WhatsUp Gold sends a ping command to each viable IP address in 
the range configured during the first section of this wizard. If the device responds, 
WhatsUp Gold scans for the monitors listed on this dialog. If the device does not 
respond, discovery moves on to the next IP address. You can select Use 
comprehensive discovery to have device discovery scan each IP address for all of the 
selected monitors without first sending the ping command to the device. Discovery 
takes longer if this option is selected. 

 Note: If you want a Ping monitor created for the devices found in discovery, you must select 
Ping as an active monitor to scan even if you have cleared the Use comprehensive 
discovery option. 

 Note: If a device only has one interface, WhatsUp Gold intentionally does not add the 
Interface Active Monitor during discovery. Doing so with the Ping Active Monitor would be 
redundant.  

 The HTTP monitor polls a web server (if one is discovered) on the device on a regular 
basis to establish if it is Up or Down. 

 Tip: To see how a monitor is configured, you can go to the Active Monitor Library 
(Configure > Active Monitors), select a monitor, then click Edit. 

 The Disk Utilization monitor monitors and reports on the available disk space for the 
selected device. Data collected is displayed in the Disk Utilization Report. 

7 Click Next. The Device Discovery displays the estimated remaining scan time and the 
scan’s progress. You can cancel the Device Discovery by clicking Stop.  
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8 When the Discovery is completed, the Devices to Monitor window appears, listing all of 
the devices just discovered and the active and passive monitors that were applied. Note 
that if any of the devices have already been entered into the database, a shortcut to the 
device will be created in the device list. To add all of the devices to the database, click 
Next. To remove specific devices to be monitored from this list, clear the checkbox next 
to the device you want to remove. 

 Note: Additional Active Monitors and Performance Monitors that are already in the database 
will not be added to devices. 

9 Click Next. The Action Policy Selection dialog appears. For more information about 
Action Policies, see About Action Policies (on page 146). 

10 Complete the remaining screens in the wizard. 

The Results summary shows the number of selected new devices, number of active and 
performance monitors, whether or not an Action Policy is applied, and the number of 
selected device shortcuts. 

11 Click Finish to begin monitoring the devices. A progress bar appears while devices are 
added to the database, then the Device View appears with a list of new devices found in 
the device discovery process. For more information about Device Views, see About the 
Device View (on page 57). 

 Note: If some device group folders are empty, it is due to the fact that although a subnet was 
found, the devices in the subnet were either not scannable, or you chose not to monitor 
them. 

 

Adding a single device manually 

There are three ways to add devices, individually, to the monitoring database: 

 In the Map View or Device View, in the console or the web interface, right-click and select 
New > New Device. 

 From the console, you can display the Device Types (list of device icons) in the left pane, 
then click and drag one to the Device or Map view. 

 From the console, click File > New > New Device. 

- or - 

 From the web interface, click GO. The GO menu appears. 

 If the WhatsUp section is not visible, click WhatsUp.  The WhatsUp section of the GO 
menu appears. 

 Select Devices > New Device. 

Adding a device without scanning 
You can add a "bare bones" device to the database immediately without scanning. The new 
device is generically categorized as a workstation.  
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This option is sometimes useful for testing purposes, as it allows you to add the same device 
to a database multiple times. At this time there no limit for the number of times you can add 
the same device to your database. 

  

Examples 
 Example: manually adding a device to a device group (on page 41) 

 Example: clicking and dragging a device to a device group (on page 42) 
 

Example: manually adding a device to a device group 
When you manually add a device, you are prompted to enter the IP address or host name. 
WhatsUp Gold attempts to resolve the IP address or hostname, then scans the device for 
Active Monitors. When the scan is complete, you can further configure the device as needed. 
To demonstrate, we'll add a workstation to a device group. 

To manually add a device to a device group: 
1 Select the Device Group from the left hand pane to which you want to add a new 

device. Click the Map View tab (at the bottom of the console) to display the map for the 
group. 

2 Right-click in the Map View, then click New > New Device. The Add New Device dialog 
opens. 

   
3 Enter the IP address or host name for the device into the box. 

Optionally, select Add device immediately without scanning to add a device without 
scanning for the device.  

 Note: Any monitors for which the Use comprehensive discovery option is selected will be 
checked when the device is added. 
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4 Click OK to add the device. If the device already exists in another group, you will get a 
message to that effect. If you want to add a short cut for the device in this new group, 
click Yes. The Device Properties dialog opens. 

 
5 You can either accept the default Properties populated when you added the device, or 

modify them. If you accept them, click OK. The new device icon appears in the Map 
View. 

  

For more information about the Device Properties dialog, see Learning about the Device 
Properties (on page 80). 
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Example: clicking and dragging a device to a device group 
To click and drag a device to a device group: 
1 In the left pane of the console, select Device Types (Basic) or Device Types 

(Advanced), depending on which device type you desire. 
2 Drag the device icon to the Map View. 

 

The Add New Device dialog appears. 

  
3 Enter the IP address or host name for the device into the box. 

Optionally, select Add device immediately without scanning to add a device without 
scanning for the device.  

 Note: Any monitors for which the Use comprehensive discovery option is selected will be 
checked when the device is added. 
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4 Click OK to add the device. If the device already exists in another group, you will get a 
message to that effect. If you want to add a short cut for the device in this new group, 
click Yes. The Device Properties dialog opens. 

 
5 You can either accept the default Properties populated when you added the device, or 

modify them. If you accept them, click OK. The new device icon appears in the Map 
View. 

  
6 For more information about the Device Properties dialog, see Learning about the Device 

Properties (on page 80). 
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About Active Discovery 

You can use Active Discovery to schedule WhatsUp Gold to scan your network for new 
monitors (active monitors and performance monitors) and devices on a regular basis. Newly 
discovered items are added to the Active Discovery Results report, and WhatsUp Gold notifies 
you that a new device was found, or a new monitor was found on an existing device. You can 
then review the report and select the items you want to add to your device list.  

For more information, see Using Active Discovery (on page 229). 
 





 
 

CHAPTER 5 

Using the WhatsUp Gold Console 
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About the console 

The console is a Windows application used for the configuration and management of 
WhatsUp Gold and its database. The console has seven main components, which are 
indicated on the image below. 

  

1 The WhatsUp Gold Toolbar. The icons on this toolbar change according to the view 
you are currently using. Additional toolbar icons can be enabled for the Map view by 
selecting View > Toolbars. 

2 Device Group Tree. This is a list of all device groups created through WhatsUp Gold. 
When you perform a discovery scan, WhatsUp Gold creates a top level folder for that 
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scan. All discovered subnetworks are created in subgroups, but can be organized, 
deleted, or renamed to fit your needs. 

3 View pane. This pane displays the selected device group based on the view from the 
tabs below (Device View or Map View). 

4 Device Types Groups. Click the Basic or Advanced tab to view the device types 
contained in the group selection. These types can be dragged into the view pane to 
create a new device based on the selected device type. 

5 View selectors. Choose the way you want to view your device groups. Each of these 
views are explained in detail later in this chapter. 

 Device View. This view provides an overview of each device and subgroup in a 
selected device group. 

 Map View. This view shows a graphical representation of the devices and subgroups 
in a selected device group. 

6 Polling Indicator Icons. These icons indicate the current state of the poll engine. 

    

Poll engine is connected Poll engine is not connected Polling is enabled Polling is disabled 

7 Database Size Indicator Icon. This icon shows the current size of your database. The 
color and shape changes according the database size thresholds: 

 Green - 49% and below. 

 Yellow - 50% to 74% 

 Red - 75% and above. 
 

Using the WhatsUp Gold console menus 

Additional menu commands, including  the Arrange menu, are available in Map View. 

The File menu (on page 49) 

The Edit menu (on page 49) 

The View menu (on page 50) 

The Arrange Menu (on page 52) (Map View only) 

The Configure Menu (on page 53) 

The Tools Menu (on page 53) 

The Reports Menu (on page 54) 

The Window Menu (on page 55)  

The Help Menu (on page 55) 
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The File menu 
Use this menu to discover devices, add new devices, create device groups and dynamic 
groups, open and close device groups, print, and exit the application. 

 New. Use the submenu that appears to select a command.  

 New Device. Select this command to add a device.  

 New Group. Select this command to create a new device group. 

 New Dynamic Group. Select this command to create a new dynamic group. 

 New Group Shortcut. Select this command to create a new group shortcut. 

 Discover Devices. Select this command to perform a device discovery scan using the 
New Device Discovery Wizard.  

 Open. Select this command to open a device group.  

 Close. Select this command to close the device group. 

 Print Set Up. Select this command to configure printing options. 

 Print. Select this command to print the current page. 

 Exit. Select this command to exit WhatsUp Gold. 
 

The Edit menu 
Use this menu to copy and paste, rename devices and groups, delete devices and groups, 
perform a Bulk Field Change, and to access a device's or group's properties. 

 Copy. Select this command to perform a copy-and-paste operation with a device. 

 Paste. Select this command to perform a copy-and-paste operation with a device. 

 Note: This command is unavailable until you have copied an item to paste.  

 Rename. Select this command to rename a device or group. 

 Delete. Select this command to delete a device or group from the Device List or from a 
map.  

 Bulk Field Change. Use the submenu that appears to select a Bulk Field Change 
command.  

 Note: This command is available only when you have multiple devices selected in either 
Device View or Map View.  

 Credentials. Select this command to perform a Bulk Field Change operation that 
modifies device credentials. 

 Polling Interval. Select this command to perform a Bulk Field Change operation that 
modifies device polling intervals. 

 Maintenance Mode. Select this command to perform a Bulk Field Change operation 
that modifies device maintenance modes. 
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 Device Type. Select this command to perform a Bulk Field Change operation that 
modifies device types. 

 Action Policy. Select this command to perform a Bulk Field Change operation that 
modifies and applies Action Policies. 

 Up Dependency. Select this command to perform a Bulk Field Change operation that 
modifies and applies up dependencies. 

 Down Dependency. Select this command to perform a Bulk Field Change operation 
that modifies and applies down dependencies. 

 Notes. Select this command to perform a Bulk Field Change operation that configures 
device notes. 

 Attribute. Select this command to perform a Bulk Field Change operation that 
modifies and applies device attributes. 

 Performance Monitors. Select this command to perform a Bulk Field Change 
operation that modifies and applies device performance monitors. 

 Active Monitor. Select this command to perform a Bulk Field Change operation that 
modifies and applies device active monitors. 

 Active Monitor Properties. Select this command to perform a Bulk Field Change 
operation that modifies device active monitor properties. 

 Properties. Select this command to view a device's or group's properties. 
 

The View menu 
Use this menu to select Device and Map View. 

 Device View. Select this command to select Device View. 

 Map View. Select this command to select Map View. 

 Navigate Up. Select this command to navigate to a device group higher in the device 
tree.  

 Refresh. Select this command to refresh the application.  

 Zoom. Use the submenu that appears to select a Zoom command. 

 Note: The Zoom commands are only available only in Map View. 

 Percentages. Select one of the available percentage value commands to view the 
map at the selected percentage value. Choose either 400%, 200%, 100%, 50%, or 25%.  

 All. Select this command to enlarge the entire map to fit the window. 

 In. Select this command to enlarge the size of the map by 25%. 

 Out. Select this command to decrease the size of the map by 25%. 

 Window. Select this command to magnify a specific area of the map to fit the 
window.  

 Display. Use the submenu that appears to select a Display command. 
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  Note: The Display commands are only available in Map View. 

 Device Icons. Select this command to disable or enable device icons in Map View. 
Device Icons are enabled by default. 

 Polling Dependency Arrows. Select this command to enable or disable polling 
dependency arrows in Map View.  

 Unconnected Links. Select this command to enable or disable unconnected links in 
Map View. 

 Snap to Grid. Select this command to enable or disable grid lines in Map View. 

 Clip Device Names. Select the command to clip or un-clip device names in Map View. 

 Wrap Device Names. Select this command to wrap or un-wrap device names in Map 
View. 

 Remove Link Comments. Select this command to disable or enable Remove Link 
Comments in Map View. Remove Link Comments are enabled by default.  

 Toolbars. Use the submenu that appears to select a Toolbar command.  

 Note: The Standard toolbar is the only toolbar available in Device View. 

 Standard. Select this command to remove or add the Standard toolbar to the 
console. The Standard toolbar is enabled by default. 

 Zoom. Select this command to remove or add the Zoom toolbar to the Map View. The 
Zoom toolbar is enabled by default. 

 Draw. Select this command to remove or add the Draw toolbar to the Map View. The 
Draw toolbar is enabled by default. 

 Edit. Select this command to remove or add the Edit toolbar to the Map View. The 
Edit toolbar is enabled by default. 

 Grid. Select this command to add or remove the Grid toolbar from the Map View.  

 Align. Select this command to add or remove the Align toolbar from the Map View. 

 Distribute. Select this command to add or remove the Distribute toolbar from the 
Map View. 

 Order. Select this command to add or remove the Order toolbar from the Map View. 

 Grouping. Select this command to add or remove the Grouping toolbar from the Map 
View. 

 Dependency. Select this command to add or remove the Dependency toolbar from 
the Map View. 

 Flip. Select this command to add or remove the Flip toolbar from the Map View. 

 Status Bar. Select this command to remove or add the Status Bar from the console. 
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 Note: Any changes made to the console Device and Map View are user-specific and only 
effect the user account under which a change is made.  

 

The Arrange menu 
Use this menu in Map View to order, align, distribute, group, and flip the devices in your 
device maps.  

 Note: This menu is only available in Map View. 

 Order. Use the submenu that appears to select an Order command. 

 Note: The Order commands are only available for use with map annotations. 

 Bring to front. Select this command to move a map annotation to the very front of 
the map image. 

 Bring to back. Select this command to move a map annotation to the very back of 
the map image. 

 Bring forward. Select this command to move a map annotation forward a level. 

 Send backward. Select this command to move a map annotation backward a level. 

 Align. Use the submenu that appears to select an Align command. 

 Left. Select this command to align selected devices to the left side of the selected 
area. 

 Horizontal center. Select this command to align selected devices in the horizontal 
center of the selected area. 

 Right. Select this command to align selected devices to the right side of the selected 
area. 

 Top. Select this command to align selected devices to the top of the selected area. 

 Vertical bar. Select this command to align selected devices in a vertical bar. 

 Bottom. Select this command to align selected devices to the bottom of the map. 

 Distribute. Use the submenu that appears to select a Distribute command. 

 Spacing horizontally. Select this command to space selected devices equidistant 
from one another horizontally. 

 Spacing vertically. Select this command to space selected devices equidistant from 
one another vertically. 

 Center horizontally. Select this command to arrange selected devices around a 
horizontal axis. 

 Center vertically. Select this command to arrange selected devices around a vertical 
axis. 
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 Device icons radially. Select this command to arrange selected devices into a circle. 

 Device icons in rows. Select this command to arrange selected devices in rows. 

 Device icons by links. Select this command to arrange selected devices by their links. 

 Grouping. Use the submenu that appears to select a Grouping command. 

 Note: The Group commands are only available for use with map annotations. 

 Group. Select this command to group two or more selected map annotations 
together. 

 Ungroup. Select this command to ungroup map annotations.  

 Flip. Use the submenu that appears to select a Flip command. 

 Note: The Flip commands are only available for use with map annotations. 

 Horizontally. Select this command to flip a selected map annotation horizontally. 

 Vertically. Select this command to flip a selected map annotation vertically. 
 

The Configure menu 
Use this menu to access the program options, all of the WhatsUp Gold libraries, recurring 
actions and reports, device types, and active discovery. 

 Note: The monitors and actions you configure via the Configure menu can be applied to a 
device from its Properties dialog (Edit > Properties). 

 Program Options. Select this command to configure the WhatsUp Gold program 
options. 

 Performance Monitor Library. Select this command to configure performance monitors. 

 Active Monitor Library. Select this command to configure active monitors. 

 Passive Monitor Library. Select this command to configure passive monitors. 

 Action Library. Select this command to configure actions. 

 Action Policies. Select this command to configure action policies. 

 Device Types. Select this command to configure WhatsUp Gold device types. 

 Recurring Actions. Select this command to configure recurring actions. 

 Recurring Reports. Select this command to configure recurring reports. 

 Active Discovery. Select this command to configure active discovery tasks. 

 Credentials. Select this command to configure device credentials. 
 

The Tools menu 
Use this menu to discover devices, access a desktop remotely, view running actions, perform 
database utilities, import trap definitions, and to acknowledge devices. 
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 Discover Devices. Select this command to perform a device discovery scan using the 
New Device Discovery Wizard. 

 VoIP Configuration Utility. Select this command to run the WhatsUp Gold VoIP 
Configuration Utility. This command is only available if you have an active VoIP Monitor 
license. 

 WhatsConnected. Select this command to open WhatsConnected. This command is only 
available if you have an active WhatsConnected license. 

 Remote Desktop. Select this command to connect to a remote desktop. 

 Running Actions. Select this command to view any actions that are currently running.  

 Tip: You can use the Running Actions dialog to cancel running actions.  

 Database Utilities. Use the submenu that appears to select a Database Utilities 
command. 

 Back Up WhatsUp SQL Database. Select this command to make a copy of your 
WhatsUp Gold SQL database. 

 Restore WhatsUp SQL Database. Select this command to restore your WhatsUp Gold 
SQL database with a previous version. 

 Back Up NetFlow SQL Database. Select this command to make a copy of your 
NetFlow SQL database. 

 Restore NetFlow SQL Database. Select this command to restore your NetFlow SQL 
database with a previous version. 

 Services. Use the submenu that appears to select a Services command. 

 Restart the polling engine. Select this command to restart the WhatsUp Gold polling 
engine. 

 Restart the web server. Select this command to restart the WhatsUp Gold web 
server. 

 Restart the NetFlow collector. Select this command to restart the WhatsUp Gold 
NetFlow  Collector Service. 

 Note: This option is only available if you have an activated copy of the WhatsUp Gold 
NetFlow Monitor. 

 Import Trap Definitions. Select this command to import trap definitions to the Passive 
Monitor Library using the Trap Definition Import tool. 

 Acknowledge. Select this command to acknowledge device state changes. 
 

The Reports menu 
Use this menu to view WhatsUp Gold reports. 

 All. Select this command to view a list of all WhatsUp Gold reports. 

 System. Select this command to a view a list of WhatsUp Gold System reports, such as the 
Performance Error Log, and Active Discovery Log. 

  54 



Using WhatsUp Gold v12.3 

 Group. Select this command to view a list of WhatsUp Gold Group reports, such as group 
performance reports. 

 Device. Select this command to view a list of WhatsUp Gold Device reports, such as 
device performance reports and the Device Status report. 

 

The Window menu 
Use this menu manage the open windows on your computer desktop, and to enable the 
WhatsUp Gold Network Explorer. 

 Close. Select this command to close the current window.  

 Note: If you only one WhatsUp Gold window is open, you are unable to close the window 
with this command. To exit the application, select File > Exit. 

 New Window. Select this command to open a new window containing WhatsUp Gold. 

 Cascade. Select this command to cascade the open WhatsUp Gold windows on your 
desktop. 

 Tile Horizontally. Select this command to tile the open WhatsUp Gold windows on your 
desktop horizontally. 

 Tile Vertically. Select this command to tile the open WhatsUp Gold windows on your 
desktop vertically. 

 Network Explorer. Select this command to enable or disable the WhatsUp Gold Network 
Explorer. 

 

The Help menu 
Use this menu to view the WhatsUp Gold help system, User Guide, and information about 
your licensed version of the product.  

 Help Topics. Select this command to view the WhatsUp Gold help system. 

 User Guide. Select this command to view the WhatsUp Gold User Guide. 

 About WhatsUp. Select this command to view the About WhatsUp Gold dialog that 
displays your license type, serial number, product edition, the registered user, the number 
of currently monitored devices, the maximum number of monitored devices your license 
type allows, and any installed plug-ins. 
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Organizing Devices, Device Groups, and Maps with 
drag-and-drop 

In the Device and Map views, you can quickly and easily organize your devices and device 
groups by dragging the device you want in a particular group to the device group folder.  

 

After you drop the icon or icons, a menu appears, asking if you want to move or copy the 
devices. If you move the devices, they are deleted from the previous device group. If you 
copy the devices, the devices appear in both device groups. 

 Note: When you copy a device using drag-and-drop, a shortcut is created in the new 
location. Even though a device exists in multiple locations, it only exists once in the database. 
Therefore, to modify a device, you can change the settings by opening the device properties 
from any group in which the device appears, and the change is reflected in all other 
instances of the device. This also means that each device is only polled once, no matter how 
many times it appears in your device group tree. 
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About the Device View 

With a similar look and feel to Windows Explorer, the Device View gives you another option 
to help you keep your complex network organized and performing properly. In this view, 
devices are organized by device group, and appear in the list in alphabetical order based on 
the name of the folder or the display name of the device. 

 

Each device's icon provides information about its device state and the state of the monitors 
associated to that device. In addition, the Status column indicates which specific monitor is 
down and the duration of the interruption. 

When the entry in the Device list is a group folder, the Status column shows the number of 
devices in the group with a breakdown of how many devices are in each device state. 
 

About device icons 
The following icons appear in the Device View when viewing the contents of a device group. 

Icon Description 

 
(Green) All monitors on the device are considered up. 

 
(Red) Device is considered down, because one or more monitors are down. The 
green square shows that at least one monitor is responding. 

 
Device entry appears in another device group. At least one monitor on the device 
is unresponsive, but at least one is considered up. 

 
(Orange) The device is currently in maintenance mode. 

 
A bold device name shows that the device has undergone a state change, and that 
state change has not been acknowledged. For more information about 
Acknowledgements, see Device overview (on page 79). 

 
 

About the Map View 

Through the Map View of WhatsUp Gold, you can create graphical representations of your 
network, organized by any means that suits your needs. Devices can be placed on as many 
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maps as needed, without the devices being polled multiple times. In short, there is an 
enormous amount of flexibility in the way you can use the Map View feature. 

 

The map above was created after an SNMP Device Discovery Scan. It shows the relationship 
between the different sub-networks that were discovered during the scan. 
 

Organizing device layout and views 
The Map View has a number of options you can use to organize your view of devices.  

Arrange options are available from the console Arrange menu located on the main menu bar. 
Display options are available from the View menu on the main menu bar and the toolbar 
right-click menu. 

Try the different Arrange menu features until you are satisfied with the device layout. Be 
aware that there is no undo option for the arrange tool. 
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To clean up a map after completing Discovery: 
1 Select a device group, then click the Map View tab. 
2 Right-click in the Map View, then select Display > Clip Device Names. This removes the 

domain part of the device name and shows only the host name. 
3 Select all devices in the view by clicking and dragging a selection box around all 

devices. Then, from the Arrange menu, select Distribute > Device Icons in Rows. 

If you have a large set of devices or want to represent a topology specific to your network, 
you can also use the graphics annotations (such as lines, text, circles) and attached lines to 
create custom map views. 

You can select object(s) in the map, right-click and select Lock Position from the menu. Lock 
Position keeps an object from moving as you move other items around, or when adding 
devices to the map. If you want an object to be able to change positions on the map, remove 
the Lock Position selection. It is very useful to lock images you may place in the background, 
or text you want to protect. 

 Note: Locking an object on the console prevents you from moving that same object on the 
web interface. 

 

Adding annotations to a map 
Annotations are graphical objects that let you customize a map view. You can add text, 
shapes, lines, and graphics to visually organize a set of devices. 

 

To use the Annotation (Draw) tools: 
1 In the Map View toolbar, click an Annotation (Draw) icon to make it the active tool.  
2 Drag the cursor onto a map to create a line, rectangle, circle, polygon, text, file image, or 

network cloud. 

To change Annotation (Draw) tool properties, such as border width and color, select the 
annotation, then click Properties from the right-click menu. 
 

About link lines 
You can use Link lines to get a graphical view of the network link (the Interface service) 
between two devices. Link lines can also show the status of any service which has an Active 
Monitor on the device. 
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The following example shows a map with link lines displayed. 

 

 Router 1 shows a connecting link to device RRA and this link is currently up. Also shown 
are eight unconnected links, all of which represent interfaces on the router. One of the 
unconnected links is disabled. 

 JMA is a workstation that shows two unconnected links that are currently up. These are 
Ping and FTP monitors, found under Device Properties > Active Monitors.  

 RRA is an FTP Server that is currently down and shows five unconnected links, two of 
which are down. 

By default, links are rendered in one of four colors: 

 Green indicates an Active Monitor that is up (for example, but not limited to, Interface). 
This includes services that have not yet been polled. 

 Red indicates a down Active Monitor. 

 Gray indicates a service listed in the device's Active Monitors list, but not currently 
monitored. 

 Orange indicates that the device is currently in maintenance mode. 

 Note: These colors are subject to change if a user changes the colors of the default device 
states. 

For more information, see Using link lines (on page 239). 
 

Using attached lines 
Attached lines show an arbitrary connection between devices. When you move two devices 
that are connected by attach lines, the attach lines also move. Attach lines are visual 
representations assigned by the user, and not a reflection of a true connection between the 
two devices. The true connection between the two devices is done with Link lines. 

  60 



Using WhatsUp Gold v12.3 

To draw an attached line: 
1 In the Map View, right-click a device. The right-click menu appears. 
2 Click Attach > Attach to. A line displays next to the cursor. 
3 Click the device icon you want to attach to. WhatsUp Gold draws an attached line 

between the two devices. 

 Note: Each device can attach to up to five other devices. 
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Accessing the web interface 

You can connect to the WhatsUp Gold web interface from any supported browser by 
entering its web address. This web address consists of the hostname of the WhatsUp Gold 
host and the web server port number. The default port number is 80. 

For example, if your WhatsUp Gold host is named monitor1.ipswitch.com, then the web 
address will be: http://monitor1.ipswitch.com:80.  

 Note: When you use the default port number (80), you do not have to include the port 
number in the address. 

There are two default users on the Web server: 

Account type Username Password 

Administrator admin admin 

Guest guest <password left blank> 

By default, the web server is disabled in the console. You have the option to enable the web 
server during installation, or on the console by going to Configure > Program Options > 
Web Server. Select Enable web server on port.  

 Note: You can also use Microsoft Internet Information Services (IIS) as the web server for 
WhatsUp Gold. For more information, see Using IIS on Windows XP or Windows 2003 (on page 
22) or Using IIS on Windows Vista (on page 26). 
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About the WhatsUp Gold web interface 

The web interface allows you to view and modify almost all aspects of WhatsUp Gold using a 
web browser. From the web interface, you can add devices, view or modify device groups, 
view device maps, and access reports about your devices. 

The web interface includes two features that are not available through the console: 

 In WhatsUp Gold Premium, Distributed, and MSP Editions, Split Second Graphs display 
up-to-the-second information on SNMP and WMI performance counters for the devices 
on your network. Split Second Graphs can be viewed on the WhatsUp Gold Web 
Performance Monitor, the Web Task Manager, device and group performance reports, 
and several workspace reports.  

 Full and workspace reports are only available through the web interface. From the 
console, you can launch a web browser to view reports in the web interface, but you 
cannot view the reports directly in the console. 

There are also some features that are available in the console but are not available through 
the web interface: 

 Advanced mapping features, such as annotations, link lines, and automatic arrangement 
of device icons are not available in the web interface. 

 Device discovery is not available in the web interface, but you can add specific devices by 
IP address. 

The web interface is organized into four main sections: the GO menu, the Home tab, the 
Devices tab, and the Reports tab. 
 

About the GO menu 
The main menu for the web interface is accessed using the GO button. The GO menu is 
similar to the Microsoft Windows Start menu. The GO menu allows navigation to other areas 
of the web interface with only a few clicks. It is always present in the top-left corner of the 
browser window, except when viewing dialogs.  
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With the GO menu, you can navigate to the areas you will use most in WhatsUp Gold, 
including your customized Home workspace views; your monitored devices list; Network 
Tools; the configuration of the Passive, Active, and Performance Monitor libraries; and the 
WhatsUp Gold Help. 

In some cases, plug-in products for WhatsUp Gold, such as WhatsUp Gold NetFlow Monitor, 
add additional sections to the GO menu. In these cases, select the name of the plug-in from 
the list on the left to see the menu options for that plug-in. 
 

About the Home tab 
The Home Workspace is the first screen you see after logging in to the web interface. The 
Home Workspace is your customizable home page. It displays important information about 
the health of monitored servers and network devices in a way that can be tailored to your 
specific needs.  

For more information on your Home Workspace, see Customizing workspace views (on page 
264). 

The Workspace Toolbar 
 Add Content. Use this button to add workspace reports to your workspace views. 

 Workspace View. Use this drop-down menu to edit your workspace views and to switch 
between workspace views. 

 Help. Use this button to view the WhatsUp Gold Help for the window you are currently 
viewing. 

 
 

About the Devices tab 
The Devices tab is used to view and manage the lists of devices you have added to WhatsUp 
Gold. The Devices tab has two modes:  

 Device View shows a list of devices and groups formatted like a table. 

 Map View shows the map that you configured for the current device group in the 
console. 

You can add devices in either mode by using the Devices Menu or the Devices Toolbar 
located along the top edge of your browser. 

The Devices Menu bar  
 File. Use this section of the menu to add new devices, device groups, and dynamic 

groups. 

 Edit. Use this section of the menu to copy, move, edit, and delete devices and device 
groups. You can also access Device Status and Device Properties from this section. 
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 View. Use this section to switch between Device and Map views, to navigate to device 
groups, and to refresh the screen. 

 

The Devices Toolbar 
 New Device. Use this button to add a new device to your list of monitored devices. 

 New Group. Use this button to add a new device group to your list of monitored devices. 

 New Dynamic Group. Use this button to add a new dynamic group to your list of 
monitored devices. 

 

The Right-Click Menu 
You can also manage groups using the right-click menu, which includes quick links to many 
common tasks, tools, and reports. 

 

Drag and Drop 
Just like in the console and most Windows applications, you can use your mouse to organize 
devices and groups using drag and drop in the web interface. You can drag devices from the 
device view or map view into device groups in the device groups list, in the list of devices and 
groups contained in the current group, or on a map. 
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About the Reports tab 
The Reports tab is the starting point for launching Full Reports. When you select the Reports 
tab, the Reports Overview screen appears.  

 

This screen divides the reports into several categories. 

 System reports show logs and diagnostic data for all devices. 

 Group reports allow you to compare availability and performance data for devices within 
a group. 

 Device reports give a view into availability and performance data for a single device. 

 Performance reports allow you to view historical performance data for a device or group. 

 Problem Area reports provide an indication of typical problems that may be occurring 
on your network. 

 General reports give you access to your workspaces and show you data logged by 
WhatsUp Gold during its operation (such as logs from active discovery). 

 All Reports opens a page with links to every available report. 

 Favorite reports is a customizable list of reports that you find useful. 
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Report Category menu 
The Report Category drop-down menu allows you to jump to report category screens from 
where to choose reports for viewing. 
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About user accounts 

User accounts in WhatsUp Gold define a person's role and determine what actions the person 
can perform. 

Default user accounts 
There are two default user accounts: 

1 Administrator account. The Administrator account is given all user rights, including 
Manage Users, which grants the the right to create and edit user accounts. The 
Administrator is also given all group access rights, so that when enabled, this account 
will be able to view and edit devices in all device groups. 

2 Guest account. The Guest account allows people to see the application without giving 
them the ability to modify any settings. By default, all user rights and all group access 
rights are disabled for this account. This limits the account to only seeing a limited 
number of things in the application. The Administrator (or anyone else with Manage 
User rights) can modify the Guest account rights using the Manage Users dialog. 

Additional user accounts 
The Administrator can create additional user accounts as needed. There is no limit to the 
number of user accounts allowed on the system, though each additional account does 
increase the maintenance overhead for WhatsUp Gold. Each time permissions and rights are 
modified, the Administrator should verify that each user has only the intended rights. 

 Note: We recommend limiting the number of users to whom you grant the Manage Users 
right. If multiple user accounts are given permission to create and delete user accounts, 
confusion could surface as a result. Open communication between all user accounts with the 
Manage Users right is crucial to a smooth network management operation. 
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Creating and modifying user accounts 
User accounts that are granted the Manage User right can create and edit user accounts.  

 

To create a new or edit a WhatsUp Gold user account: 
1 From the WhatsUp Gold web interface, select GO. The GO menu appears. 
2 If the WhatsUp section of the GO menu is not visible, click WhatsUp. The WhatsUp 

section of the GO menu appears. 
3 Select Configure > Manage Users. The Manage Users dialog appears. 
4 Click New. The Add User dialog appears. 

- or - 

Select a user account and then click Edit. The Edit User dialog appears. 
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5 Enter the appropriate information. 

 User Name. Enter the name of the user. 

 Authentication Type. Select the method of authenticating the user. 

 Internal. Use the internal user database built in to WhatsUp Gold. 

 LDAP. Use an external LDAP database. 

 Language. Select the language to display for the user. 

 Internal Password. Enter a password for the user. This option is disabled if 
Authentication Type is set to LDAP. 

 Confirm Password. Confirm the user's password. This option is disabled if 
Authentication Type is set to LDAP. 

 Home Group. Select the device group that the user will see when they log into the 
WhatsUp Gold web interface. If they have the correct group access rights, they will be 
able to navigate out of this group. 

 User Rights. Select the rights that correspond to the actions you want to allow the 
user to complete. 

 Check all rights. Select this option grant the user rights to perform all of the actions 
listed. 

6 Click OK to save changes.  
7 If you have enabled Group Access Rights, you will be prompted if you would like to 

specify Group Access Rights for the new user account. 

 

Select Yes to open the Device Group Properties dialog for the user's home group. 

- or - 

Select No to close the dialog and return to the Manage Users dialog. 
 

About user rights 

User rights govern what actions users in WhatsUp Gold can perform. Any user who has been 
granted the Manager Users right can manage user rights on the Add/Edit User dialog in the 
web interface.  

 Caution: When creating an account for a novice user, do not grant all user rights. An 
inexperienced user with too many user rights may make inappropriate selections that 
accidentally interrupt network monitoring. In the case of a new user, we recommend that 
you restrict the account to only those rights that they will need to gain familiarity with the 
application. Grant additional rights as the user gains confidence and application knowledge. 
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The table below lists and describes each of the user rights. 

General   

Change Your Password Enables users to change their own password. 

Configure Workspaces Enables users to add workspace views as well as configure, move, and 
delete workspace reports within workspace views. 

Manage IP Security Enables users to control access to the web interface based on specific IP 
addresses. 

Manage Web Server Enables users to change the configuration of the web server. 

Translations Enables users to view the translation system as well as import and 
export languages. 

Manage Workspace Views Enables users to add, delete, and copy workspace views, as well as edit 
the properties of a specific workspace view. 

Manage Users Enables users to create and edit users for the web interface. This option 
also allows users to specify Group Access Rights. 

Configure LDAP Credentials Enables users to configure LDAP credentials for connecting to an LDAP 
server for user authentication in the web interface. 

Manage SNMP MIBs Enables users to download and delete SNMP MIBs through the SNMP 
MIB Manager. 

Monitors/Actions   

Configure Active Monitors Enables users to create, edit, and remove active monitors on devices in 
the groups to which the user has access. 

Configure Performance 
Monitors 

Enables users to create, edit, and remove performance monitors on 
devices in the groups to which the user has access. 

Configure Actions Enables users to create, edit, and remove actions on devices in the 
groups to which the user has access. 

Configure Passive Monitors Enables users to create, edit, and remove passive monitors on devices 
in the groups to which the user has access. 

Configure Action Policies Enables users to create, edit, and remove action policies on devices in 
the groups to which the user has access. 

Manage Recurring Actions Enables users to create, edit, and remove recurring actions on devices 
in the groups to which the user has access. 

Devices   

Manage Groups Enables users to create, edit, or remove device groups on the network. 

Access Active Discovery 
Results 

Enables users to access the Active Discovery Results dialog. Granting 
users access to this dialog also enables users to add devices to the 
network and to add Active Monitors, and Performance Monitors to a 
device. 

Configure Credentials Enables users to configure SNMP and Windows credentials. 

Manage Devices Enables users to add new devices and edit existing devices in the 
groups in which the user has access. 
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Reports  

Access Group and Device 
Reports 

Enables users to view group and device reports for the groups the user 
has access. 

Access System Reports Enables users to view system reports. 

Access Split Second Graph 
Reports 

Enables users to view Split Second Graph reports in workspace and full 
reports. 

Remote  

Access Remote Reports Enables users to view reports on WhatsUp Gold remote sites. 

Configure Remote Sites Enables users to create, edit, and delete remote sites for use with 
WhatsUp Gold Central and Remote Site Editions. 

About Remote User Rights 
When using WhatsUp Gold Distributed or MSP editions, make sure that Access Remote 
Reports is selected on the Central Site for each user that you want to provide access to the 
Remote Site reports. Also, make sure that you select Configure Remote Sites if you want a 
user to be able to access and change options in the Configure Remote Sites dialog. This 
dialog provides a list of all of the Remote Sites that have connected to the Central Site. You 
can view and edit two important settings in this dialog:  

 Accept remote site connection. Allows authorized users to enable or disable accepting 
connections from Remote Sites. This option is checked by default. The primary reason to 
clear the option is if you need to disable the Central Site from accepting any connections 
from this Remote Site. For example, this option could be helpful if one of the Remote Sites 
connected to the Central Site has an unusual amount of activity and is using too much 
bandwidth between sites. This option lets you temporarily disable a single Central Site 
from accepting remote site connections until you determine what the problem is. 

 Local device. Allows authorized users to select a local device to associate with the 
Remote Site. Click the browse (...) button to select a device. This device is often the 
computer that is running the WhatsUp software on a Remote Site. Associating a local 
device allows you to view the device status from the Remote Site, keeping you informed 
about the connection status with the Remote Site. It also provides easy access to the 
Network Tools for the local device you selected. 

 

About group access rights 

Group access rights enable WhatsUp Gold users to see or make changes to specific groups 
and devices. These rights can be enabled or disabled by the administrator and are disabled 
by default. 

Group access rights are useful when users need to view and edit only those groups that 
matter to them, as would be the case with a large network with multiple network 
administrators. Group access rights allow an administrator to grant each user rights to only 
the devices on the network for which that user is responsible. 
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Types of group access rights 
There are four types of group access rights: 

1 Group Read. This right allows users to view items within the selected group and 
pertaining to that group, including the group's reports, map, and device list. 

2 Group Write. This right allows users to edit group properties and add, edit, and delete 
devices and subgroups within the selected group. 

3 Device Read. This right allows users to view the device properties and device reports of 
all devices within the selected group. 

4 Device Write. This right allows users to edit the device properties of any device within 
the selected group and to delete the device from the group. 

 Note: To add a device to a group, a user must have Group Write rights to the group. Device 
Write rights allow users to modify and delete existing rights, but do not allow them to add 
new devices to the group. 

 Tip: When enabled, group access rights are applied throughout WhatsUp Gold. Device and 
group pickers, reports, and group views all respect what a user account is granted permission 
to view and edit. 

The following is a list of operations and the group access rights that must be assigned for the 
user to perform that task: 

 List, Map, and Group reports in the Group Views menu require Group Read access. 

 Create Group and Group Properties in the Group Operations menu require Group Read 
and Group Write access. 

 Copy Group requires Group Read in the source group, and Group Read and Group 
Write in the destination group. (Permissions to groups and sub-groups are copied, not 
inherited from the new parent). 

 Move Group requires Group Read and Group Write in both the source and the 
destination groups. (Permissions of the group and sub-groups remain the same.) 

 Delete Group requires Group Read, Group Write, Device Read, and Device Write 
recursively. (Device Read Write may not be required if the group is empty). 

 Create Device requires Group Read, Group Write, Device Read, and Device Write. If the 
device already exists in other group(s), you must also have Group Read, Group Write, 
Device Read, and Device Write in one or more of those groups. 

 Copy Device requires Group Read in the source group and Group Read and Group 
Write in the destination group. The level of device permissions must be the same in both 
groups. Downgrade from Device Read and Device Write to Device Read is also 
permitted. 

 Move Device requires Group Read and Group Write in both the source and the 
destination groups. The level of device permissions must be the same in both groups. 
Downgrade from Device Read and Device Write to Device Read is also permitted. 

 Viewing Device Properties and Device Reports requires Device Read. 

Modifying Device Properties, Bulk Field Change, and Acknowledgement require Device Read 
and Device Write. 
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Enabling group access rights 
Group access rights may be enabled and disabled from the Manage Users dialog. 

 

To enable group access rights: 
1 From the WhatsUp Gold web interface, select GO. The GO menu appears. 
2 If the WhatsUp section of the GO menu is not visible, click WhatsUp. The WhatsUp 

section of the GO menu appears. 
3 Select Configure > Manage Users. The Manage Users dialog appears. 
4 Select Enable Group Access Rights at the bottom of the dialog. The setting is 

immediately saved. 

Simply enabling group access rights does not ensure that the rights are set up the way that 
you want. You also need to assign group access rights to each group on your network. 
 

Assigning group access rights 
From the web interface, select a device group and go to Properties for that group. There are 
several ways to do this: 

 Select a device group from the Devices tab in either Map View or Device View, and right-
click. From the right-click menu, select Properties. 

 Select a device group from the Devices tab in either Map View or Device View. From the 
Devices Menu bar, go to Edit > Properties. 
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From the Group Properties dialog, you can add and edit the access rights for the selected 
group.  

 

 Important: You must enable group access rights for a user account before a user can add or 
edit access rights for a device group. To do this, the WhatsUp Gold Administrator will have to 
enable group access rights in the Manage Users dialog (From the WhatsUp section of the GO 
menu, select Configure > Manage Users). 

 Note: Group access rights cannot be assigned directly to Dynamic Groups. Instead, devices 
are governed by the group access rights assigned to the other group or groups where the 
device is located. For more information, please see About group access rights (on page 73). 

 
 

Propagating group access rights to subgroups 
Group access rights are passed from parent group to subgroup: when a new a group is 
created, all of the group access rights that exist in the parent group are copied to the new 
group. If the rights on a parent group are modified after subgroups have been created, you 
can propagate the changes to the subgroup by selecting Apply changes to all sub Device 
Groups recursively on the Device Group Properties dialog. 
 

Determining the highest right 
Devices can belong to more than one device group, and each group can specify a different 
set of group access rights. When a device exists in multiple groups, the group access rights 
from all of the groups are added together to determine the rights granted to a user when 
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accessing the device. This means that if a device is granted a right (Device Read, for example) 
in one group, it has that right from every group to which the device belongs.  

The table below demonstrates the effective rights granted to a user accessing a device that 
exists in three groups that each have different group access rights. 

 Device Read right Device Write right 

Rights granted in Group A X  

Rights granted in Group B 
 X 

Rights granted in Group C 
  

Effective rights when accessing device from any group X X 

In this example, the device is granted Device Read by its membership in Group A and Device 
Write by its membership in Group B. The result is that the user can access the device with full 
rights from any device group to which the device belongs, even Group C where no explicit 
rights are set. 
 

Understanding group access rights and user access right 
When group access rights are enabled, WhatsUp Gold determines effective rights by first 
negotiating user rights, then group access rights. This means that, while group access rights 
govern access to device groups, a user must first have user access rights to a device or group 
before group access rights are considered. If a user does not have the Manage Devices user 
access right, for example, then Device Write group access rights are not honored. 

 Tip: By disabling the Manage Groups and Manage Devices user access rights, you can 
prevent a user from modifying any groups or devices in WhatsUp Gold. 

 

About group access rights and users' home groups 
Users are given Group Read rights for their Home group by default. If Group Read rights are 
removed from a user's home group, the user cannot access the Device List until the Group 
Read right is restored or the user's Home group is changed to a group for which the user has 
Group Read rights. 

 Note: Changing a user's Home group does not change the user's Group Access rights for 
original Home group. Be careful to prevent unintentionally granting access to a device group 
to which you do not want a user to have access. 

For example, an administrator creates a new user account and leaves the Home group as the 
default My Network. The new user account automatically receives Group Read rights to My 
Network. At a later date, the administrator changes the user account to use a subgroup as the 
user's Home group. Unless the administrator deliberately removes the Group Read right from 
My Network, the user continues to have Group Read rights to My Network, potentially 
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granting the user more visibility into WhatsUp Gold than the administrator intended. 
Changing the user's Home group is not enough to restrict what he or she can see in WhatsUp 
Gold. 
 

About group access rights and dynamic device groups 
Group access rights cannot be assigned to dynamic device groups. However, every device 
within a dynamic device group belongs to at least one other group. Therefore, when a user 
accesses a device accessed through a dynamic device group, the rights he or she is granted 
to the device are equal to the sum of the rights granted in each of the groups to which the 
device belongs.  

For more information, see Determining the highest right (on page 76). 
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Device overview 

In WhatsUp Gold, devices are virtual representations of resources (computers/workstations, 
servers, routers, switches, etc.) that are connected to your computer through a LAN (Local 
Area Network), a wireless network, or even over the Internet. WhatsUp Gold watches these 
devices through a network connection. When those network resources are cannot be 
reached by WhatsUp Gold, the device is considered down and an action can be configured to 
fire. 

Device Services 
WhatsUp Gold associates Active Monitors with devices on your network. Active monitors 
query the network services installed on a device and then wait for a response. These monitors 
query the services running on a network resource, checking to make sure that the FTP server, 
web server, email server, etc., is up and responding. Active Monitors include DNS, SNMP, 
Telnet, Ping, TCPIP, and NT Service. If a response is either not received or is not what is 
expected, the service is considered down. If the query is returned as expected, the service is 
considered up. 

For a more information about service monitors, see Active monitors overview (on page 153). 
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About the Device View 

This view provides an overview of each device in a selected group. Each device's icon 
provides information about its status. In addition, the Status column indicates which specific 
active monitor is down and the duration of the interruption. When the entry in the Device list 
is a group folder, the Status column shows the number of devices in the group with a 
breakdown of how many devices are in each device state. 

 Note: Dynamic groups will not show information about the number of devices in a group or 
a breakdown of how many devices are in each device state in the Status column. For more 
information, see Using Dynamic Groups. 

Following is an example of a device list. 

 

The indicators in the Display Name column show the current state of the items in this group. 

 Routers is a dynamic group. 

 Device NorthPoint is a server that is currently up. The icon shows that this device is also in 
another device group. 

 Device HRA is a workstation that is currently up. 

 Device ASA is an HP Device that is up, but one of the interfaces (E3) is not responding. 

 Device JMA is a wireless access point that is currently in maintenance mode. 

 Device RRA is a workstation that is currently up. Its icon shows that this device is also in 
another device group. 

 Device JTA is a workstation that is currently responding to polls, but it has a monitor (FTP) 
that is down. 

 Device Hub 1 is in an unknown status because the device has not been polled. In this 
case, it is due to a down dependency set on the Router. 

 

Learning about the Device Properties 

You can modify individual device properties by right-clicking a device icon in either the 
Device View or Map View, then selecting Properties. Following is an overview of the device 
properties available to use in WhatsUp Gold. 
 
 

  80 



Using WhatsUp Gold v12.3 

About General Device Properties 
The General section of the Device Properties dialog box provides, and lets you modify, basic 
information for the selected device. 

 

 Display name. An identifying name for the current device. This name is populated 
during discovery, but can be changed by the user at any time. Changing the name will 
not change how the device is polled, only how it is displayed in WhatsUp Gold. 

 Polling type. Select the type of polling you want  WhatsUp Gold to use for this device. 

 ICMP (TCP/UDP) 

 IPX 

 NetBIOS 

 Note: If NetBIOS is selected, the Host Name box must contain a valid NetBIOS name. If IPX is 
selected, the Address box must contain a valid IPX address. If NetBIOS or IPX is selected, you 
cannot monitor TCP/IP services on this device. 

 Poll using. Select if you want WhatsUp Gold to use the IP address or the Host name 
(DNS) of the device for polling. 

 Host name (DNS). This should be the official network name of the device if the 
polling method is ICMP. The network name must be a name that can be resolved to 
an IP address. If the polling method is NetBIOS or IPX, this must be the NetBIOS or IPX 
name. 

 Address. Enter an IP or IPX address. 

 Additional Network Interfaces. Click this button to configure an additional Network 
Interface for the current device. 

 Device Type. Select the appropriate device type from the pull-down menu. The icon 
displayed will represent the device in all views. 
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About Device Property Performance Monitors 
Use Performance Monitors dialog to configure and manage performance monitors for the 
selected device. 

 Note: For some performance monitors, the SNMP credential on the device must be 
configured. For WMI performance monitors, the Windows credential is required. 

 

For more information, see Performance monitor overview (on page 209). 
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About Active Monitor Device Properties 
Use the Active Monitors dialog to display and manage Active Monitors for this device. There 
are several ways an Active Monitor can be added to this list: You can manually add the 
monitor by clicking the Add button on this dialog, click the Discover button to have 
WhatsUp Gold scan the device for all Active Monitors. Monitors may have been added during 
initial discovery, when WhatsUp Gold first added the device to the database. 

 

 Click Add to configure a new Active Monitor. 

 Select an Active Monitor and click Edit to change the configuration.  

- or - 

Double-click an Active Monitor to edit the configuration. 

 Select an Active Monitor and click Remove to remove the monitor from the device. 

 On the WhatsUp Gold console, you can click Discover to have WhatsUp Gold scan the 
device for Active Monitors on the device. 

For more information, see Active monitors overview (on page 153). 
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About Passive Monitor Device Properties 
Some elements on a network may not provide a clear up or down status when queried. For 
example, a message may get logged to the system's Event log by another application (such 
as an antivirus application alerting when a virus is found). Because these messages/events 
can occur at any time, a Passive Monitor Listener listens for them, and notifies WhatsUp Gold 
when they occur. 

 

This dialog displays all Passive Monitors configured for this device. 

 Click Add to configure a new Passive Monitor. 

 Select a Passive Monitor, then click Edit to change the configuration 

- or - 

Double-click a Passive Monitor to edit the configuration. 

 Select a Passive Monitor, then click Remove to remove the monitor from the device. 

For more information, see Passive monitor overview (on page 201). 
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About Device Property Actions 
You can select an Action Policy to use on this device or configure alerts specifically for this 
device. 

 

Select a policy from the Apply this Action policy pull-down menu. You can also create a 
new, or edit an existing action policy by clicking the Browse button next to the pull-down 
menu box. 

Configured alerts appear in the Apply individual actions list, displaying the action type that 
is to be fired and the state change that will trigger the action. You may have multiple actions 
on a single device. 

This dialog displays all Actions configured for this device. 

 Click Add to configure a new Action. 

 Select an Action, then click Edit to change the configuration 

- or - 

Double-click an Action to edit the configuration. 

 Select an Action, then click Remove to remove the action from the device. Removing the 
action from the list also deletes all records for this action (on this device) from the Action 
Log. 

For more information, see About actions (on page 121). 
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About Device Property Credentials 
The Credentials dialog displays Windows and SNMP credentials information for the current 
device. 

 

Devices that are SNMP manageable devices appear on the map view with an icon with a 
white star in the top right corner. 

 

 Windows credentials. Select the Windows credential to connect to this device. Click the 
browse (...) button to browse the Credentials Library. 

 SNMP v1/v2/v3 credentials. Select the SNMP credentials to connect to this device. If the 
Identify devices via SNMP option was selected during discovery (or if an SNMP 
discovery was performed) the correct SNMP credential was used during the discovery 
process, and if the device is an SNMP manageable device, then the correct credential is 
selected automatically. If any of these conditions are not met, None is selected. Click the 
browse (...) button to browse the Credentials Library. 

 Device Object ID (OID). The SNMP object identifier for the device. This identifier is used 
to access a device and read other SNMP data. 

For more information, see Credentials overview (on page 100). 
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About Device Property Polling 
Polling is the term used for monitoring discovered devices in WhatsUp Gold. The Polling 
dialog lets you configure polling options and/or schedule maintenance times for the selected 
device. 

 

Polling 
 Poll interval. This number determines how often WhatsUp Gold will poll the selected 

device. Enter the number of seconds you want to pass between polls.  

 Up dependency. Click to configure additional options, based on when another 
device is operational, that determine when the selected device is polled. 

 Down dependency. Click to configure additional options, based on when the 
selected device is operational, that determine when other devices are polled. 

Maintenance 
Use this section of the dialog to manually set the device Maintenance state, or schedule the 
maintenance state for a certain time period. Any device placed in Maintenance mode will not 
be polled, but it remains in the device list with an identifying icon. By default, the 
maintenance state is represented by an orange background color. 

 Force this device into maintenance mode now. Select this option to put the selected 
device in maintenance mode. Clear the option to resume polling the device. 

 Recurring maintenance times. This box displays all scheduled maintenance times for 
the device. 

 Click Add to schedule a new maintenance time for the device. 

 Select an entry, then click Edit to change a scheduled time. 

- or - 

Double-click a Schedule to edit its configuration. 

 Select an entry, then click Remove to delete a scheduled time. 
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For more information, see Polling overview (on page 111) and Dependencies overview (on page 
113). 
 

About Device Property Notes 
The Notes dialog provides an option to enter free-form messages to the device database. 

 
 

About Device Property Menus 
In the WhatsUp Gold console, you can use the Menu dialog to create a custom context menu 
for a device. After a new option has been configured, it appears on the context menu when 
you right-click the device in the device list.  

When you select the new menu item, the associated command is launched with the 
arguments that were included in the device's custom menu configuration. 
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 Customize the menu on this device (don't use device type menu). Select this option to 
create and/or modify a context menu for this device. This will override any separate 
context menu that has already been created for the device type of the device. 

 Menu list. This box displays the commands that are currently configured for the device. 
After an item has been configured, it appears on the context (right-click) menu. When you 
click the menu item, the menu item is executed. 

 Click Add to add a new menu item. 

 Select a Menu Name, then click Edit to change the settings. 

- or - 

Double-click a Menu Name to edit its configuration. 

 Select an Menu Name, then click Remove to delete it from the list. 

 Important: Menu items can only be configured on the WhatsUp Gold console. 

 

About Device Property Custom Links 
In the WhatsUp Gold web interface, you can use this dialog to create a custom link for a 
device.  
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To view custom links created for a device, you need to add the Device Custom Links 
workspace report to its Device Status workspace view. For more information, see Adding 
workspace reports to a Device Status workspace (on page 268). 

 

 Click Add to add a new custom link. 

 Select a custom link in the list, then click Edit to change the settings. 

- or -  

Double-click a custom link to edit its configuration. 

 Select a custom link in the list, then click Remove to remove it from the list. 

 Important: Custom links are only configurable and viewable in the web interface.  
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About Device Property Attributes 
The Attributes dialog lists attributes that are associated with a device, such as contact person, 
location, serial number, etc. The first three attributes in the list (Contact, Description, and 
Location) are added by WhatsUp Gold when the device is added to the database, either by 
the Device Discovery wizard, or through another means. 

 

 Click Add to add a new attribute. 

 Select an attribute on the list, then click Edit to change the settings. 

- or -  

Double-click an attribute to edit its configuration. 

 Select an attribute in the list, then click Remove to remove it from the list. 
 

Adding a new device 

There are two ways to add devices to the monitoring database: 

 Discover devices automatically. For more information, see Using the Device Discovery 
wizard (on page 36). 

 Manually add devices.  
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To manually add a new device: 
1 In the Device view, right-click, then select New Device. The Add New Device dialog 

appears. 

 
2 Enter the IP address or hostname for the device you want to add.  
3 Click Advanced to select a number of additional options for which to scan the device. 
4 If you want to add a device without scanning, select Add device immediately without 

scanning. This immediately adds a "bare-bones" device, generically categorized as a 
workstation.  

5 Click OK to save changes. The WhatsUp Gold attempts to resolve the IP address or 
hostname, then scans that device for Active Monitors. When the scan is complete, 
Device Properties dialog appears, allowing you to further configure the device as 
needed. 

 Note: If WhatsUp Gold already contains the number of devices that your license allows, a 
message appears telling you that you must upgrade your license or remove existing devices 
to add a new device. 

 

Adding additional network interfaces to a device 
To configure a network interface: 
1 Right-click a device, then click Properties. The Device Properties dialog appears. 
2 Click General. The General dialog appears. 

 
3 Click Additional Network Interfaces. The Add Network Interfaces dialog appears. 
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4 Click Add. The Add Network Interfaces dialog appears. 

 
5 Enter the network information for the new interface. 
6 Click OK to return to the General section. 

To change the default network interface on a device: 
1 In the General section of Device Properties, click Additional Network Interfaces. 
2 On the Network Interfaces dialog, select the interface you want to make the default. 
3 Click Set Default. 
4 Click OK to return to the General section. 
 

Adding attributes to a device 
To add attributes to a device: 
1 Right-click a device, then click Properties. The Device Properties dialog appears. 
2 Click Attributes. The Attributes dialog appears. 

 
3 Use the following options: 

 Click Add to add a new device attribute. The Add Attribute dialog appears. 

 Select a device attribute in the list, then click Edit to change the settings. 
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 Select a device attribute in the list, then click Remove to remove it from the list. 

4 Enter information in the Attribute name and Attribute value boxes. 
5 Click OK to save changes. 
 

Adding notes to a device 
To add a note to a device: 
1 Right-click a device, then click Properties. The Device Properties dialog appears. 
2 Click Notes. The Notes dialog opens. 

 
3 Enter the note in the Notes box. 

Notes. The first line of the notes box displays information about when the device was 
added to the database.  

You can customize the notes with any information you want to include about the 
device. For example, you may want to record historical information about a device, 
physical location information, or perhaps notes relating to the actions configured for 
the device. 

 Note: There is no automatic word wrap. Add a return to display information in the dialog 
without requiring you to scroll to view it. 

4 Click OK to save changes. 
 

Changing a device IP address 
To change a device IP address: 
1 In Device view, right-click a device. In the context menu, select Properties > General. 
2 Enter the new IP address in the Address box. 
3 Click OK to save changes. 
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Changing a device name 
Changing the name of a device changes how it appears in the list views. 

To change a device name: 
1 In Device view, right-click a device. In the context menu, click Properties > General. 
2 In the General section of Device Properties, enter the new name in the Display Name 

box. 
3 Click OK to save changes. 
 

Selecting Device Types 

In the left-hand pane of the WhatsUp Gold console interface, the Device Types (icons 
representing the types of devices you may have on your network) appear. 

  

Click the tab at the bottom of the pane to switch from Device Types (Basic) to Device Types 
(Advanced).  

You can select a device type in the Device Properties General dialog on the console or web 
interface. For more information about selecting a specific device types for existing devices, 
see About General Device Properties (on page 81). 
 

  95 



Using WhatsUp Gold v12.3 

Configuring Device Types 
To create a device type: 

If you want Device Discovery to use a special icon when it finds this device, make sure you 
have run the MIB extractor. 

1 From the console, click Configure > Device Types > New. 
2 Enter a Device Type Name for the new device. 
3 In the Icon filename box, browse to a graphic file to represent the device. 
4 In the Overlay text box, you can enter a word or two which will overlay the device icon 

to help differentiate this device. For example, HP Laser to help differentiate this device 
from other printers which use the same icon. 

5 Select the device Polling type. 
6 (Optional) In the SNMP Object ID text box, enter an SNMP identifier (or use the browse 

button ... to find one) that corresponds to a vendor device type; this is usually found in 
the private > enterprises section of the MIB tree, under the vendor name. 

Device discovery finds and maps devices using the SNMP identifiers to locate the 
specified devices. To scan for devices, you must also enter the proper Community name. 

You can use multiple identifiers. For example, suppose a manufacturer named Acme 
makes three devices: the Acme 4500, the Acme 4501, and the Acme 4502. You could 
define one device type to represent any Acme device in the 4500 series; in the SNMP 
Object box, you would enter the three SNMP identifiers for the Acme 4500, 4501, and 
4502. The Scan tool will use the icon for any of the three devices. 

You need to separate multiple SNMP object identifiers by using semi-colons. The last 
number in the identifier can be an asterisk, a range using hyphens, or contain multiples 
separated by commas. For example:  

1.3.6.1.4.1.311.1.1.3.1.3  

1.3.6.1.4.1.311.1.1.3.1.3;1.3.6.1.4.1.311.1.1.3.1.4  

1.3.6.1.4.1.311.1.1.3.1.3,4  

1.3.6.1.4.1.311.1.1.3.1.1,3-4  

1.3.6.1.4.1.311.1.1.3.1.* 

7 Click Next to save the new device type, and access the Active Monitor dialog for device 
types. 

8 Click Add to add an active monitor for the device type. 
9 Click Next to access the Passive Monitor dialog for device types. 
10 Click Add to add a passive monitor for the device type. 
11 Click Next to access the Context Menu dialog for device types. 
12 Click Add to add a context menu for the device type. 
13 Click Next to access the Action Policy dialog for device types. 
14 Associate an action policy, or click the browse button to create or edit an action policy. 
15 Click Finish to save the new device type. 
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Changing Device Types 
Device Types act like templates for new devices, containing device properties (such as active 
and passive monitors, menu items, etc.) and represented by different icons in Device 
Properties and on the Map view. 

When you change a device type on an existing device, you are only changing the icon that 
represents the device, and not adding additional information and settings to the device. All 
other changes will have to be done manually. 

To change a device type icon on an existing device: 
1 In Device view, right-click on a device, then select Properties > General from the 

context menu. 
2 In the Device type list, select a new device type. 
3 Click OK to save changes. 
 

Using Acknowledgements 

When a device state changes, regardless of any action that has been placed on the device, 
WhatsUp Gold uses the Acknowledgement feature to make you aware that a state change 
occurred. The name of the device name appears in bold in the Device List and on a black 
background in the Map View. 

 

After the device is in Acknowledgement mode, it will remain so until you actively 
acknowledge it. 

 Note: Acknowledging a device state change does not keep that device from firing actions. To 
stop a device from firing actions, you must put the device into maintenance mode. 

 

To acknowledge a state change: 

 Select the device or devices you want to acknowledge, right-click, then click 
Acknowledge. 
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- or - 

 Access the State Change Acknowledgement report and select the devices you want to 
acknowledge. After the devices are selected, click Clear to remove the devices from the 
report, thereby acknowledging the state change. 

 

Editing multiple devices with Bulk Field Change 

The Bulk Field Change feature gives you the ability to make changes to multiple devices and 
device groups. You must have administrative privileges to the devices or device groups that 
you want to make changes to.  

To edit multiple devices: 
1 Select the devices or device groups you want to change, right-click and select Bulk 

Field Change. The Bulk Field Change context menu appears. 

 Note: When you select a device group, every device in the group, and any subgroup of the 
group, will reflect the bulk field change. 
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2 Select the field you want to change. The following items can be modified through Bulk 

Field Change. 

 Credentials 

 Polling Interval 

 Maintenance Mode 

 Maintenance Schedule (web interface only) 

 Device Type 

 Action Policy 

 Up Dependency 

 Down Dependency 

 Notes 

 Attribute 

 Performance Monitors 

 Active Monitor 

 Active Monitor Properties 

 Passive Monitor (web interface only) 

 Passive Monitor Properties (web interface only) 

3 Enter the configuration information that you want set. 
4 Click OK to save changes. 
 

  99 



Using WhatsUp Gold v12.3 

Using Credentials 

The Credentials system stores login or community string information for Windows (WMI 
Active Monitors, WMI Performance Monitors, and the Web Task Manager) and SNMP devices 
in the WhatsUp Gold database. The system supports SNMP v 1, 2, and 3.  

Credentials are configured in the Credentials Library (found on the web interface menu in the 
WhatsUp section of the GO menu at Configure > Credentials Library) and used in several 
places throughout the application. They can be associated to devices in Device Properties > 
Credentials, or through the Credentials Bulk Field Change option. 

A device needs SNMP credentials applied to it before SNMP-based Active Monitors will work. 
Similarly, NT Service Checks must have Windows credentials applied. 
 

Creating Custom Context menus 

You can create custom context menus for WhatsUp Gold in the console. When you create a 
custom context menu, it is available in the right-click menu for devices. When the menu item 
is selected, the associated command is executed with the arguments that were entered in the 
menu configuration options. 

To create a custom menu: 
1 Double-click the device you want to edit, the Device Properties appear. 
2 Click Menu. The Device Properties Menu dialog appears. 

 
3 Click to select the Customize the menu on this device (don't use device type menu) 

option. 
4 Click Add. The Add Menu Item dialog appears. 
5 Enter information in the Display name, Command, and Arguments boxes. 
6 Click OK to save changes. The custom menu is added to the device's context menu. 
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About device groups 

In WhatsUp Gold, devices are organized in groups to allow you to quickly find and diagnose 
problems. You can create as many device groups as you wish to organize your network in a 
way that is meaningful to you and your monitoring needs. 

Device group types 
Two types of device groups exist in WhatsUp Gold: 

 Non-dynamic groups 

 Dynamic groups 

Non-dynamic groups are simply referred to as "device groups." Each time you discover 
devices on your network, a new device group is created containing the devices found in the 
scan that you choose to monitor. The group is named using the type of scan you used during 
discovery, and the date and time the scan took place. For example, "SNMPScan (2007-08-03 
10:24:37)." Devices that are already in the database are added to the new group as a shortcut 
to the original device reference. This is only to relay that there are more than one reference in 
the My Network tree, as you configure devices by clicking either the original reference icon or 
the shortcut. Functionally, they serve the same purpose and display the same device status. 

Dynamic groups are created by using SQL queries that search for devices based on user-
specified criteria. By default, all devices discovered on your network are placed into a 
dynamic group named All devices. Similarly, each time a router is discovered it is placed into 
a similar dynamic group named All routers.  

Device group icons 
Just as devices in WhatsUp Gold, device groups use icons to display the current state of the 
group, or to indicate the type of device group. 

 All of the monitors on all devices in the group are up. 

  The device group contains at least one device that is considered down. 
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The device group is empty, or devices have not been polled due to a dependency on 
another device. 

 Indicates a dynamic group. 

Device group maps 
The Map View is based on device group folders, meaning that each device group will have a 
separate map. If a device group folder contains a subfolder, or subgroup, you can double-
click on the folder in Map View to display the subfolder's map. 

Device group reports  
Device groups are particularly important when you are viewing full and workspace reports 
pertaining to a specific group, or group reports (on page 249). When viewing Group Reports, 
you choose one specific device group in which to view network data. It's a good idea to think 
of ways to easily distinguish device groups from one another for this reason. An easy way to 
distinguish groups is using group names that are meaningful, such as "Atlanta Developers" 
and "Atlanta Tech Support." As a result, you can easily tell what each device group is when 
choosing a group on which to view Group Report information. 

Device Group Access Rights 
Similar to user rights are the WhatsUp Gold group access rights which link permissions to 
device groups. For more information, see About group access rights (on page 73). 
 

Creating device groups 
To create a new device group: 

 Important: You cannot create a new device group within a dynamic group. 

 Note: There is a separate procedure for creating new dynamic groups. 

On the WhatsUp Gold console 
1 Select File > New Group. A new device group appears in the My Network Tree named 

"New Device Group." You will need to rename this group. 
2 To rename the group, select the new group and right-click. The right-click menu 

appears. Select Rename and enter a new name for the group. 

On the WhatsUp Gold web interface 
1 From the Devices tab, click the New Group  button.  

- or - 

From the Devices tab, select File > New Group. 

The Create Group dialog appears. 

2 Enter a title and short description for the group in the Group Name and Description 
fields. 

3 Click OK to add the group to the My Network tree. 
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About Dynamic Groups 

This feature provides the ability to create device groups based on whatever criteria users 
choose, without having to create device shortcuts. Dynamic groups can be created for 
specific device types, device attributes, active monitors, or anything else that is stored for 
individual devices in the database. Dynamic groups act as SQL queries that run on the 
WhatsUp Gold database, and can display real-time data if viewed through a report that is set 
to automatically refresh. 

WhatsUp Gold is pre-configured with dynamic group examples, which you can see in the 
Devices view, under Device Groups.  

 

All of the Dynamic Group examples are active, so if you have devices that meet the criteria, 
you will see the device displayed within the group. In the web interface, the dynamic group 
display is refreshed every 2 minutes. A group is also refreshed when you select it. 

To view or edit the criteria for a dynamic group, right-click the group name, then select 
properties. 

 Note: Dynamic groups on the web interface do not follow group access rights. Anyone with 
the ability to view the device group that a dynamic group is in can access that dynamic 
group. However, only devices that the user has the permission to view appear in the group. 

To configure Dynamic Groups: 
1 In the WhatsUp Gold web interface, right-click on the device view, then select New 

Dynamic Group. The SQL Dynamic Group dialog appears.  
2 From here, you must select a method for configuring the new Dynamic Group. You can 

either use the WhatsUp Gold Dynamic Group Builder, or the SQL dialog. If you are an 
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advanced SQL user, you should choose the second option. Otherwise, we recommend 

appropriate information into the following fields: 

sUp 

ional.) Enter a short description for the new Dynamic Group. 

2 or 
ic Group.  

ey are added to the Dynamic 

wn within your filter code by selecting a rule and then 
s.  

 

so that you may edit it at a later time, click OK. 
p from the Device List and right-click, then select 
e. 

r 
og. If you aren't 

t you make a copy of the Dynamic Group so that 

s you want to appear in that group. 

In addition to the pre-configured dynamic groups, we have provided several sample filters for 
you to create some very interesting dynamic groups. 

selecting the Dynamic Group Builder. 

To use the Dynamic Group Builder: 
1 In the first part of the dialog, enter the 

 Group Name. Enter a name for the Dynamic Group as it will appear in the What
Gold Device List. 

 Description. (Opt

In the second part of the dialog, you will create and edit rules to form an SQL filter f
the Dynam

To begin writing the rules for your SQL filter, click Add. The Dynamic Group Editor 
appears.  

3 In the Dynamic Group Editor, enter the appropriate information (for more information, 
see the help topic for this dialog). As you create rules, th
Group Builder dialog where you can add more rules, edit, or delete existing rules by 
clicking the Add, Edit, or Delete buttons.  

Parentheses (single, double, triple, and quadruple) are available for use in your filter code - 
add them by selecting them from the lists before and after your rules.  

You can move existing rules up or do
clicking on the Up and Down button

Validating your filter code 
Keep in mind that as you configure your rules, the SQL filter is displayed at the bottom of the 
Builder dialog. When you are satisfied with the filter code that is displayed, click the Validate
button to test the filter. If it runs as you expect, click OK to save the configured SQL filter and 
to add the new Dynamic Group to your Device List. If the code does not run as you expect, 
but you would still like to save the filter code 
You can then select the Dynamic Grou
Properties to edit the group filter cod

Converting your filter code 
You can convert a Dynamic Group created with the Dynamic Group Builder to the SQL dialog 
by clicking the Convert button. It is important to note that once you convert the Dynamic 
Group to the SQL dialog, you will not be able to edit the group in the Dynamic Group Builde
again - you will only be able to make changes to the group from the SQL dial
an advanced SQL user, we recommend tha

uyo  can keep a copy available for edit in the Dynamic Group Builder.  

To use the SQL Dynamic Group dialog: 
1 Enter a Display name for the group, enter the group Description, and enter an SQL 

query in the Filter box that identifies the device
2 Click OK to add the group to the device list. SQL validation occurs as soon as you click 

OK. If the filter fails, an error message appears. 
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 Tip: You can learn more about the database structure by downloading the database schema 
file on the WhatsUp Gold support page (http://www.whatsupgold.com/support/index.asp). 

 

Dynamic Group Examples 
WhatsUp Gold is pre-configured with dynamic group examples, which you can see in the 
Devices view, under Device Groups. For more information on these groups, see Using 
Dynamic Groups. 

The following examples show several dynamic group filters that you can use to create some 
interesting dynamic groups for your devices. To use these examples, select the text of the 
filter, and then copy and paste the text into the Filter box of the Dynamic Group dialog. 

 Note: You may have to remove the copyright information from the cut and paste if it appears 
when you copy from this help file. 

To show all devices that have had a state change in the last three hours: 

SELECT DISTINCT Device.nDeviceID 

FROM   Device 

       JOIN PivotActiveMonitorTypeToDevice 

         ON Device.nDeviceID = PivotActiveMonitorTypeToDevice.nDeviceID 

       JOIN ActiveMonitorStateChangeLog 

         ON PivotActiveMonitorTypeToDevice.nPivotActiveMonitorTypeToDeviceID= 

              ActiveMonitorStateChangeLog.nPivotActiveMonitorTypeToDeviceID 

WHERE  Device.bRemoved = 0 

       AND DATEDIFF(Hh,ActiveMonitorStateChangeLog.dStartTime,GETDATE()) <= 3 

To show all devices with multiple interfaces: 

SELECT DISTINCT NetworkInterface.nDeviceID 

FROM Device 

         JOIN NetworkInterface 

           ON Device.nDeviceID = NetworkInterface.nDeviceID 

WHERE    Device.bRemoved = 0 

GROUP BY NetworkInterface.nDeviceID 

HAVING   COUNT(NetworkInterface.nDeviceID) > 1 

To show all devices that have gone down in the last two hours and are still down: 

SELECT DISTINCT Device.nDeviceID 

FROM  Device 

 JOIN PivotActiveMonitorTypeToDevice 

   ON Device.nDeviceID = PivotActiveMonitorTypeToDevice.nDeviceID 

 JOIN ActiveMonitorStateChangeLog 

        ON PivotActiveMonitorTypeToDevice.nPivotActiveMonitorTypeToDeviceID = 

             ActiveMonitorStateChangeLog.nPivotActiveMonitorTypeToDeviceID 

      JOIN MonitorState 

        ON Device.nWorstStateID = MonitorState.nMonitorStateID 

WHERE Device.bRemoved = 0 
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 PivotActiveMonitorTypeToDevice.bDisabled = 0 

 AND DATEDIFF(hh, ActiveMonitorStateChangeLog.dStartTime, GETDATE()) <= 2 

 AND MonitorState.nInternalMonitorState = 1 

To show all the devices (in one specific group) that have had an action fire in the last 
two days: 

SELECT DISTINCT Device.nDeviceID 

FROM   Device 

       JOIN ActionActivityLog 

         ON Device.nDeviceID = ActionActivityLog.nDeviceID 

       JOIN PivotDeviceToGroup 

         ON Device.nDeviceID = PivotDeviceToGroup.nDeviceID 

       JOIN DeviceGroup 

         ON PivotDeviceToGroup.nDeviceGroupID = DeviceGroup.nDeviceGroupID 

WHERE  Device.bRemoved = 0 

       AND DATEDIFF(Dd,ActionActivityLog.dDateTime,GETDATE()) <= 2 

       AND DeviceGroup.sGroupName = 'My Key Resources Group' 

To show all devices that need acknowledgement: 

SELECT DISTINCT Device.nDeviceID 

FROM   Device 

       JOIN PivotActiveMonitorTypeToDevice 

         ON Device.nDeviceID = PivotActiveMonitorTypeToDevice.nDeviceID 

       JOIN ActiveMonitorStateChangeLog 

         ON PivotActiveMonitorTypeToDevice.nPivotActiveMonitorTypeToDeviceID = 

              ActiveMonitorStateChangeLog.nPivotActiveMonitorTypeToDeviceID 

WHERE  Device.bRemoved = 0 

       AND ActiveMonitorStateChangeLog.bAcknowledged = 0 

       AND PivotActiveMonitorTypeToDevice.bRemoved = 0 

To show all devices with disks that are 90% full or fuller: 

SELECT DISTINCT Device.nDeviceID 

FROM   Device 

       JOIN PivotStatisticalMonitorTypeToDevice 

         ON Device.nDeviceID = PivotStatisticalMonitorTypeToDevice.nDeviceID 

       JOIN StatisticalDiskIdentification 

         ON PivotStatisticalMonitorTypeToDevice.nPivotStatisticalMonitorTypeToDeviceID = 

              StatisticalDiskIdentification.nPivotStatisticalMonitorTypeToDeviceID 

       JOIN StatisticalDiskCache 

         ON StatisticalDiskIdentification.nStatisticalDiskIdentificationID = 

              StatisticalDiskCache.nStatisticalDiskIdentificationID 

WHERE  Device.bRemoved = 0 

       AND PivotStatisticalMonitorTypeToDevice.bEnabled = 1 

       AND StatisticalDiskCache.nDataType = 1 

       AND (((nUsed_Avg / nSize) > 0.90) 

            AND (NOT nSize = 0 

                  OR nSize IS 

                     NULL)) 
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To show all devices in maintenance or with at least one down Active Monitor and match 
the specified device types: 

SELECT DISTINCT Device.nDeviceID 

FROM   Device 

       JOIN MonitorState 

         ON Device.nWorstStateID = MonitorState.nMonitorStateID 

WHERE  Device.bRemoved = 0 

       AND MonitorState.nInternalMonitorState IN (1,2) 

       AND Device.nDeviceTypeID IN (3,4,38,63,64,65,66,67,68,71,72) 

To show only devices on which all active monitors are down: 

SELECT DISTINCT Device.nDeviceID 

FROM   Device 

       JOIN MonitorState 

         ON Device.nWorstStateID = MonitorState.nMonitorStateID 

WHERE  Device.bRemoved = 0 

       AND MonitorState.nInternalMonitorState = 1 

       AND Device.nWorstStateID = Device.nBestStateID 

To show only those devices on which all active monitors have been down for 20 
minutes or more: 

SELECT DISTINCT Device.nDeviceID 

FROM   Device 

       JOIN PivotActiveMonitorTypeToDevice 

         ON Device.nDeviceID = PivotActiveMonitorTypeToDevice.nDeviceID 

       JOIN ActiveMonitorStateChangeLog 

         ON PivotActiveMonitorTypeToDevice.nPivotActiveMonitorTypeToDeviceID = 

              ActiveMonitorStateChangeLog.nPivotActiveMonitorTypeToDeviceID 

       JOIN MonitorState 

         ON PivotActiveMonitorTypeToDevice.nMonitorStateID =  

              MonitorState.nMonitorStateID 

WHERE  Device.bRemoved = 0 

       AND PivotActiveMonitorTypetoDevice.bRemoved = 0 

       AND PivotActiveMonitorTypeToDevice.bDisabled = 0 

       AND MonitorState.nInternalMonitorState = 1 

       AND DATEDIFF(Mi,ActiveMonitorStateChangeLog.dStartTime,GETDATE()) >= 20 

       AND Device.nWorstStateId = Device.nBestStateId 

To show devices whose Actions (or whose Active Monitors' Actions) have a specific 
word in their name: 

 Note: To search for a different Action, change the Action name after LIKE. Be sure to leave 
both % symbols. 

SELECT DISTINCT Device.nDeviceID 

FROM   Device 

       JOIN ActionPolicy 

         ON Device.nActionPolicyID = ActionPolicy.nActionPolicyID 

       JOIN PivotActionTypeToActionPolicy 

         ON ActionPolicy.nActionPolicyID =  
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              PivotActionTypeToActionPolicy.nActionPolicyID 

       JOIN ActionType 

         ON PivotActionTypeToActionPolicy.nActionTypeID =  

              ActionType.nActionTypeID 

WHERE  Device.bRemoved = 0 

       AND ActionType.sActionTypeName LIKE '%Critical%' 

 

UNION 

 

SELECT DISTINCT Device.nDeviceID 

FROM   Device 

       JOIN PivotActiveMonitorTypeToDevice 

         ON Device.nDeviceID = PivotActiveMonitorTypeToDevice.nDeviceID 

       JOIN ActionPolicy 

         ON PivotActiveMonitorTypeToDevice.nActionPolicyID =  

              ActionPolicy.nActionPolicyID 

       JOIN PivotActionTypeToActionPolicy 

         ON ActionPolicy.nActionPolicyID =  

              PivotActionTypeToActionPolicy.nActionPolicyID 

       JOIN ActionType 

         ON PivotActionTypeToActionPolicy.nActionTypeID =  

              ActionType.nActionTypeID 

WHERE  Device.bRemoved = 0 

       AND PivotActiveMonitorTypeToDevice.bRemoved = 0 

       AND ActionType.sActionTypeName LIKE '%Critical%' 

To show devices to which a particular Performance Monitor is assigned: 

SELECT DISTINCT Device.nDeviceID 

FROM   Device 

       JOIN PivotStatisticalMonitorTypeToDevice 

         ON Device.nDeviceID = PivotStatisticalMonitorTypeToDevice.nDeviceID 

       JOIN StatisticalMonitorType 

         ON StatisticalMonitorType.nStatisticalMonitorTypeID = 

              PivotStatisticalMonitorTypeToDevice.nStatisticalMonitorTypeID 

WHERE  Device.bRemoved = 0 

       AND PivotStatisticalMonitorTypeToDevice.bEnabled = 1 

       AND StatisticalMonitorType.sStatisticalMonitorTypeName  

           LIKE '%Interface Utilization%' 

To show devices to which a particular Passive Monitor is assigned: 

SELECT DISTINCT Device.nDeviceID 

FROM   Device 

       JOIN PivotPassiveMonitorTypeToDevice 

         ON Device.nDeviceID = PivotPassiveMonitorTypeToDevice.nDeviceID 

       JOIN PassiveMonitorType 

         ON PassiveMonitorType.nPassiveMonitorTypeID =  

              PivotPassiveMonitorTypeToDevice.nPassiveMonitorTypeID 

WHERE  Device.bRemoved = 0 

       AND PivotPassiveMonitorTypeToDevice.bRemoved = 0 

       AND PassiveMonitorType.sMonitorTypeName LIKE '%Cold Start%' 
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To show devices to which a particular Active Monitor is assigned: 

SELECT DISTINCT Device.nDeviceID 

FROM   Device 

       JOIN PivotActiveMonitorTypeToDevice 

         ON Device.nDeviceID = PivotActiveMonitorTypeToDevice.nDeviceID 

       JOIN ActiveMonitorType 

         ON ActiveMonitorType.nActiveMonitorTypeID = 

              PivotActiveMonitorTypeToDevice.nActiveMonitorTypeID 

WHERE  Device.bRemoved = 0 

       AND PivotActiveMonitorTypeToDevice.bRemoved = 0 

       AND ActiveMonitorType.sMonitorTypeName LIKE '%Ping%' 

To find a device by its display name, host name, or IP address: 

SELECT DISTINCT Device.nDeviceID 

FROM   Device 

       JOIN NetworkInterface 

         ON Device.nDeviceID = NetworkInterface.nDeviceID 

            AND Device.nDefaultNetworkInterfaceID = 

                  NetworkInterface.nNetworkInterfaceID 

       JOIN DeviceType 

         ON Device.nDeviceTypeID = DeviceType.nDeviceTypeID 

WHERE  (Device.sDisplayName LIKE '%Mail Server%' 

         OR NetworkInterface.sNetworkName LIKE '%server1.ipswitch.com%' 

         OR NetworkInterface.sNetworkAddress LIKE '%1.2.3.4%') 

       AND Device.bRemoved = 0 
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Building Dynamic Groups 
1 In the first part of the dialog, enter the appropriate information into the following fields: 

 Group Name. Enter a name for the Dynamic Group as it will appear in the WhatsUp 
Gold Device List. 

 Description. (Optional.) Enter a short description for the new Dynamic Group. 

2 In the second part of the dialog, you will create and edit rules to form an SQL filter for 
the Dynamic Group.  

To begin writing the rules for your SQL filter, click Add. The Dynamic Group Editor 
appears.  

3 In the Dynamic Group Editor, enter the appropriate information (for more information, 
see the help topic for this dialog). As you create rules, they are added to the Dynamic 
Group Builder dialog where you can add more rules, edit, or delete existing rules by 
clicking the Add, Edit, or Delete buttons.  

Parentheses (single, double, triple, and quadruple) are available for use in your filter code - 
add them by selecting them from the lists before and after your rules.  

You can move existing rules up or down within your filter code by selecting a rule and then 
clicking on the Up and Down buttons.  

Validating your filter code 
Keep in mind that as you configure your rules, the SQL filter is displayed at the bottom of the 
Builder dialog. When you are satisfied with the filter code that is displayed, click the Validate 
button to test the filter. If it runs as you expect, click OK to save the configured SQL filter and 
to add the new Dynamic Group to your Device List. If the code does not run as you expect, 
but you would still like to save the filter code so that you may edit it at a later time, click OK. 
You can then select the Dynamic Group from the Device List and right-click, then select 
Properties to edit the group filter code. 

Converting your filter code 
You can convert a Dynamic Group created with the Dynamic Group Builder to the SQL dialog 
by clicking the Convert button. It is important to note that once you convert the Dynamic 
Group to the SQL dialog, you will not be able to edit the group in the Dynamic Group Builder 
again - you will only be able to make changes to the group from the SQL dialog. If you aren't 
an advanced SQL user, we recommend that you make a copy of the Dynamic Group so that 
you can keep a copy available for edit in the Dynamic Group Builder.  
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Polling overview 

Polling is the active watching, or monitoring, of your network by WhatsUp Gold. This is done 
in a variety of ways, depending on the service monitors you have configured on your devices. 
The default polling method is done through Internet Control Message Protocol (ICMP). The 
default polling interval for WhatsUp Gold is 60 seconds. 

A small amount of data is sent from the WhatsUp Gold computer across the network to the 
device it is watching. If the device is up, it echoes the data back to the WhatsUp Gold 
computer. A device is considered down by WhatsUp Gold when it does not send the data 
back. 
 

Changing how you poll devices 
After a device is added to the database, WhatsUp Gold begins watching that device using 
ICMP (Internet Control Message Protocol). WhatsUp Gold 'bounces' a message off of the 
device, then waits for the echo reply. If the reply is not returned, WhatsUp Gold considers it 
unresponsive device and changes the status color of the device. 

By default, WhatsUp Gold uses the IP address of the device to send this message. You can 
change this to use the Host name or the Windows name of the computer, and you can 
change the means it uses to poll the devices. 

To change how you poll a device: 
1 Double-click on the device you want to edit to view Device Properties. 
2 Click the General icon. 
3 Select the type of poll you want to check the device with in the Polling type list box. 
4 Select IP address or Host name from the Poll using list box. 
5 If you select Host name in the Poll using box, you must complete the Host name box. 
6 Click OK to save changes. 
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This is useful if you want to monitor a device that has a dynamic IP address instead of an 
address assigned to that device. You will need to choose Poll using Host name so the DNS 
will be able to find the device on the network. 
 

Using Maintenance mode 
This feature lets you place devices in Maintenance mode, where they will not be polled by the 
engine.  

Any device placed in maintenance mode is not polled, and actions are not fired for it, but it 
remains in the device list and historical data is preserved. By default, the maintenance state is 
represented by an orange color in both the device list view and the map view. 

 
Device view 

 

Map view 

The mode can be set in two ways: 

 Force this device into maintenance mode now. Set this device options manually by 
selecting Device Properties > Polling. 

 Scheduled maintenance times. Schedule maintenance times for the device. 

 Click Add to schedule a new maintenance time for the device. 

 Select an existing entry, then click Edit to change a scheduled time. 

 Select an existing entry, then click Remove to delete a scheduled time from the list. 
 

Setting how often your devices are polled 
The default polling interval is 60 second. You can change this on a per-device basis. 

1 Double-click on the device you want to edit to view Device Properties. 
2 Click the Polling icon to view the Polling section of Device Properties. 
3 Change the interval in the Poll Frequency box. 
4 Click OK to save changes. 
 

Stopping and starting polling 
To stop or start the polling on all devices by turning the polling engine off or on: 
1 From the main menu, click Configure > Program Options. 
2 Click the General icon. 
3 Select the Enable polling engine to turn on polling. Clear the selection to turn polling 

off. 
4 Click OK to save changes. 

In the bottom right corner of the WhatsUp Gold console, the Polling icon shows if the engine 
is active. 
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Stopping and starting polling on a monitor 
To stop and start polling on a per-monitor basis: 
1 Double-click on the device you want to edit to view Device Properties. 
2 Click the Active Monitor icon. 
3 Select the Active Monitor you want to change the polling on. 
4 Click Edit to view the Monitor Properties for that monitor. 
5 Click the Polling icon. 
6 Select Enable polling for this Active Monitor to turn polling on, clear the option to 

turn it off. 
7 Click OK to save changes. 
 

Dependencies overview 

By default, WhatsUp Gold polls all devices and active monitors in your device list, unless you 
manually turn off polling for the system as a whole, or at the device and monitor level. The 
dependency feature gives you the ability to avoid turning off polling to devices, and instead 
makes polling dependent on the status of another device's active monitor(s). 

Setting dependencies on one device's active monitors will place another device up or down 
depending on the type of dependency you configure. 

There are two types of dependencies: 

 Up Dependency can be thought of as something is “behind” something else. The 
dependant device will only be polled if the device "in front" of it is up. 

 Down Dependency can be thought of as something is “in front of” something else. The 
dependant devices in front will not be polled unless the device further down the line is 
down. 

Example 

If you make devices behind a router, up dependant on the router's ping active monitor, those 
devices will not be polled unless the dependent router's ping attempts are successful. If the 
router's ping active monitor fails, the devices behind the router are placed in the unknown 
state. Without the dependency, the devices behind the router would fire off actions when 
they became unavailable due to the router's failed ping attempts. With the dependency, only 
actions on the router will fire. 

Reading dependencies 
There are several ways to "read" dependencies to ensure they are applied as you want them 
to be. 
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1 Review the description of the dependency in the Device Properties dialog. 

 
2 Read the dependency arrows in the Map View. 

 

The map above displays several Up and Down dependencies. The green arrows indicate an 
Up dependency, and the red arrows indicate a Down dependency.  

Using the "behind" and "in front" terminology you can follow the graphical arrow in the map 
above to read a dependency. For example, the server dependencies are read as, "only poll the 
servers if the switch is up." The servers are behind the switch, and will only be polled if the 
switch is also responding to polls. If the switch goes down, the server is assumed unavailable 
and is no longer be polled. Since the server is unavailable, the server's state then changes to 
Unknown.  
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For another example, the router dependency on the firewall is read as, "only poll the firewall if 
the switch is down." If a break in communication takes place between the router and the 
firewall, the switch changes to the Down state because it is Down dependent on the firewall. 
If the switch goes down, the state of the servers changes to Unknown, because they are Up 
dependent on the switch. Then, since the switch is down, the firewall is polled and changes 
to the Down state. After the firewall is considered down, the router is polled. 

 

Down dependencies are useful in showing the break position in a chain of machines. If the 
chain is not broken at any point, the machines in the chain are not polled and are assumed 
up. 
 

Setting Dependencies 
There are two ways to set dependencies in WhatsUp Gold: 

 Using Device Properties 

 Using the Map View 

To set dependencies in the Device Properties: 

1 Double-click a device in My Network view (View > Device View). The Device View 
appears. 

2 Double-click a device.  

In the console, the Device Properties dialog appears. 

- or - 

In the web interface, the Device Status page appears. Click Device Properties. The 
Device Properties dialog appears. 
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3 Click Polling. The Polling, Maintenance, and Dependencies dialog appears. 

4 Click either the Up Dependency... or the Down Dependency... button to bring up 
the Device Dependencies dialog and configure the up or down dependency.  

To set dependencies in the Map View: 

1 In the console, double-click a device in My Network view (View > Map View). The 
Map View appears. 
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2 Right-click a device, select Set Dependencies, then select either Set Up 
Dependency on or Set Down Dependency on. The cursor changes to the Set 
Dependency arrow. 

 

3 Click on any device in the current group to set the dependency. For information 
about using the Device Dependencies dialog, see the Using the Device Dependencies 
dialog topic below. 

 Note: You cannot set a dependency across groups. However, you can make shortcuts to the 
devices you want to set a dependency on in a group, then set the dependency to the 
shortcut. 

To view the dependency between the two devices, click Display > Polling 
Dependency Arrows In the Map View,  
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Using the Device Dependencies dialog 
The Device Dependencies dialog is the same for both up and down dependencies with the 
exception that one sets up dependencies and the other sets down dependencies. Up 
dependencies are indicated with an upward green arrow icon, while down dependencies are 
indicated with a downward red arrow. 

 
 Click to select the Poll only if check box to either poll only if Any one or Every one of the 

active monitors selected below are up or down on device, depending on the type of 
dependency you want to set. 

 Click the browse (...) button to select a device for the dependency. 

 Select either All active monitors or Specific active monitors and check the active 
monitors you want to associate with the dependency. 

The statement at the bottom of the dialog is generated to help you understand the type of 
dependency you have created. 

An example statement would read: 

The polling of Workstation Simulator depends on every one of Intel Switch's active monitors being 
'Up'. (Workstation Simulator is 'behind' Intel Switch). 
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Viewing Dependencies 
After you have set up your dependencies, you can view dependency lines in the Map view, as 
long as the devices appear in the same group. If the devices are not in the same group, you 
can refer to the Polling section of Device Properties to view the dependencies. 

 

In the example above, the devices have an up dependency on the router, and the router has a 
down dependency on the hub. If the router's active monitors fail, the hub would be polled, 
and the devices behind the router would not be polled. When the router's active monitors are 
successful, the hub is not polled, but the devices behind the router are. 
 

IPX support 

To poll IPX devices, Microsoft's NWLink IPX/SPX Compatible Transfer Protocol must be 
installed and running on the computer on which you installed WhatsUp Gold. 

To add the IPX protocol: 
1 Open the Network applet in the Windows Control Panel. 
2 In the Select Network Component dialog box, select Microsoft, then select the 

IPX/SPX-compatible Component and follow the online instructions. 
 

  119 





 
 

  121 

 

CHAPTER 11 

Using Actions 

In This Chapter 

About actions.....................................................................................................121 

About action strategies ..................................................................................122 

About the Action Library ...............................................................................123 

About Web Alarms...........................................................................................124 

Configuring an action .....................................................................................126 

Testing an action ..............................................................................................142 

Deleting an action............................................................................................142 

Assigning an action to a device...................................................................143 

Creating a Blackout Period............................................................................143 

Percent Variables ..............................................................................................144 

About action policies ......................................................................................146
 
 

About actions 

Actions are designed to perform a task as a device or monitor state change occurs.  

As you configure an action, you choose the task it is to perform. Actions can try to correct the 
problem, notify someone of the state change, or launch an external application. Also, when 
you configure an action, you choose whether to assign it to a device, or to an active monitor. 

When assigned to an active monitor, actions fire according to the state changes it issues. For 
example, you can configure an email action to send you an email alert when the active 
monitor for the Web server issues a down state change.  

You can configure actions on a single device or monitor, or define an Action Policy to use 
across multiple devices or monitors. 

WhatsUp Gold provides the following action types: 

 Beeper Action. Activates a beeper. 

 Pager Action. Sends a message to a pager. 

 Program Action. Runs another program (executable) to take some action. 

 Email Action. Sends an SMTP mail message. 

 Winpop Action. Displays a message in a pop-up window on a Windows NT system. 
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 SMS Action. Sends a Short Message Service (SMS) notification to a pager or cell phone 
using an email or dialup gateway 

 SMS Direct Action. Sends an SMS message to pager or cell phone directly using an SMS 
modem. 

 Service Restart Action. Stops or restarts a Windows NT system. 

 Syslog Action. Sends a message to a host that is running a Syslog server. 

 Text to Speech Action. Sends a text-to-speech notification to a speaker. 

 Sound Action. Sounds an alarm by playing a sound file on the WhatsUp Gold console. 

 Active Script Action. Allows you to write either VBScript or JScript code to perform a 
check on a device. If the script returns an error code, the monitor is considered down.  

 Note: Ipswitch does not support the scripts that you create, only the ability to use them in 
the Active Script Action. 

 Web Alarm. Sounds an alarm by playing a sound file on the WhatsUp Gold web interface. 
 

About action strategies 

When configuring actions for your devices and monitors, you should take a few things into 
consideration. 

 Large lists of devices have the potential of sending out very large amounts of external 
notifications (email, SMS, beeper, etc). 

Imagine the number of messages sent if external notifications are placed on a router and 
every device and monitor that uses that router for their connection to the Internet. If the 
router goes down, it will appear as if all of the devices are down, and messages will be 
sent for each of them. Consider using dependencies and limiting the external 
notifications to the router and the most important of the devices in the group. 

 Do not rely on sound actions when there is not someone around to hear the notification. 

Sound notifications are safe to use in almost any situation, but is not the best choice for 
items that are monitored overnight.  

 If the device states do not fit what you need, change them, or add new ones. 

You may want to add device states for longer periods of downtime. Perhaps creating a 
Down at least 60 mins state, and sending an escalated message to show that the device 
is still down after an hour.  

 Action policies are easier to manage than lists of actions built on a device. 

Whenever possible, it is a good idea to use action policies over actions configured for a 
single device. That way, you can reuse the work you put into the list, and can keep better 
watch over the actions that are being fired. 

 Visual notifications are usually enough for most of the devices on your network. 
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Unless the device is vital to the daily-operation of the business or office, the state change 
color and shape should be enough to let you know what is going on with your monitored 
devices. 

 An action can be assigned to a device or to a specific monitor. If you want to be notified if 
any or all of the monitors on a device goes down, assign the action to the device. If you 
are concerned with specific monitors on a device, assign the action to the monitor itself. 
Remember that if you assign the action to both the monitor and the device, both actions 
will fire if the monitor goes down. 

 You can check on the status of firing alerts via Running Actions. Here, you can cancel 
single alerts, or all currently firing alerts. 

 

About the Action Library 

The Action Library shows all of the actions configured for your network. These actions can be 
assigned to any device or monitor, or included in an action policy. When you assign the 
action to a device or monitor, you specify the state change that will trigger the action. 

To open the Action Library, from the main menu of the WhatsUp Gold console, select 
Configure > Action Library. 

 

From this dialog, you can: 

 Create a new action. Click New. After the action has been created, it can be assigned to 
one or multiple devices or monitors. You can create the following types of actions to send 
a message or take an action when the status of a device or monitor changes. 

 Beeper 

 Sound 

 Pager 

 Program 
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 Service Restart 

 SMS 

 SMS Direct 

 SMTPMail 

 Syslog 

 Text to Speech 

 WinPopup 

 Web Alarms 

 Active Script Action 

 Make changes to an action. Select the action you want to modify and click Edit. 
Changes made here effect each instance of the action. 

 Copy an action. To create a copy of an action so you can base a new action on the setup 
information of an existing one, select the action and click Copy. You can then edit the 
new copy as needed. 

 Remove an action from the Action Library, devices, and monitors. To remove an 
action from both the Action Library and any device or monitor to which it is assigned, 
select the action, then click Delete. This is a global delete of the selected action; the 
action is removed from any action policy, device, or active monitor to which the action is 
associated. 

If you need to remove an action from a specific action policy, device, or monitor, open the 
properties for the policy, device, or monitor and delete it there. This removes only the 
specified instance of that action; the action remains in the Action Library and on other 
devices to which it is assigned. 

 Note: Be aware that when you remove an action from the Action Library, you are removing 
that action from all action policies, as well as all devices and monitors on which the action is 
assigned. In addition, all statistics relating to that action are also deleted from the database. 
When you first open the Action Library, if you have not yet defined an Action, you will see 
the default Web Alarm, which you can assign to any device or monitor. 

 

About Web Alarms 

A Web Alarm is a type of Action that can be applied to a device, or through an Action Policy. 
On the WhatsUp Gold web interface, when Web Alarms are enabled and a device goes down, 
or a state changes, a window pops up and an audible alarm sounds. In the Web Alarm popup 
window, the current Web Alarms are listed. You can mute or dismiss these alarms.  

 Note: In previous versions of WhatsUp Gold, the Web Alarm Action was included in the 
Implicit Action Policy. This is no longer true in Ipswitch WhatsUp Gold v12. 
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Configuring a Web Alarm Action 
A Web Alarm can be configured to apply to a device as an individual Action on a specific 
device, or to multiple devices using an Action Policy. Before you can assign an Action to a 
device or group of devices, you must first configure it in the Action Library. 

For more information, see Creating a Web Alarm Action (on page 140). 

The Web Alarm popup window 
When a Web Alarm Action is fired, and you are logged in to the WhatsUp Gold web interface, 
the Web Alarm popup box appears in your browser. From here, you dismiss one or all of the 
alarms listed. You can also mute them. Muting an alarm leaves the alarm listed, but stops the 
alarm from sounding.  

 Note: You cannot disable Web Alarms from the popup window. 

If you'd like more information on one of the devices listed in the popup window, you can 
double-click the device to bring up its Device Status Workspace. 

Enabling and Disabling Web Alarms 
While you can mute and dismiss Web Alarms from the Web Alarms popup window, you 
cannot disable, or turn them off, from here. Instead, you enable and disable Web Alarms on 
the web interface on the User Preferences dialog (Select GO. From the WhatsUp section, 
select Configure > Preferences). Also from the User Preferences dialog, you can adjust the 
Web Alarms refresh interval. The refresh interval indicates the number of seconds WhatsUp 
Gold waits until checking for new Web Alarms. 

By default, Web Alarms are enabled on the web interface with a refresh interval of 120 
seconds. 

Accessing Web Alarms on the web interface 
There are two places users can access Web Alarms from the WhatsUp Gold web interface: 

1 The Web Alarm window. This appears when Web Alarms are enabled and a Web Alarm 
Action is fired. You can also access this window by selecting GO, then from the 
WhatsUp section, selecting Devices > Web Alarms. 

2 The Web Alarm workspace report. This is a default workspace report located on the 
Problem Areas 1 workspace view of the Home Workspace. 

Another way of listing and accessing your network's Web Alarms is creating a Dynamic Group 
which lists all of the current Web Alarms. For more information on Dynamic Groups in 
WhatsUp Gold, please see Using Dynamic Groups. 
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Configuring an action 

There are two aspects of fully configuring an action. The first is to create the action itself in 
the Action Library dialog or through the Action Builder wizard. The setup consists of: 

 Defining the target of the action (for example, a pager or email address) 

 Entering the notification variables or program arguments (that specify what information 
to report in the action message, or to pass to another program). 

After the action is created, the second step is to assign the action or action policy to a device 
or active monitor and to link it to a state change (action policies are already linked to a state 
change during the policy definition). For more information see: 

 Assigning an action to a device (on page 143) 

 Assigning an action to a monitor (on page 158) 

 Creating a custom action policy (on page 147) 

After the actions have been completely configured, WhatsUp Gold launches the action as 
soon as the proper state change is reached. 
 

Creating a Beeper Action 
To create a Beeper Action: 
1 Go to the Action Library: 

 From the web interface, click GO. The GO menu appears. 

 If the WhatsUp section is not visible, click WhatsUp.  The WhatsUp section of the GO 
menu appears. 

 Select Configure > Action Library. The Action Library appears. 

- or - 

 From the main menu bar of the console, select Configure > Action Library. The 
Action Library appears. 

2 In the Action Library, do one of the following: 

 Click New, then select Beeper Action. 

- or - 

 Select an existing Beeper Action, then click Edit. 

The action properties page appears. 
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3 Set the appropriate options. 

 Name. The name of the action as it appears in the Action Library. 

 Description. Enter a short description of the action. This is displayed in the Action 
Library dialog along with the entry in Name. 

 Beeper number. Enter the phone number to dial. You can use parentheses to delimit 
the area code and a dash to separate the exchange from the extension numbers, for 
example: (617) 555-5555. 

 Pause after answer. Enter a number of seconds the modem should pause before 
sending the signal codes once a connection has been made. 

 End transmission. By default, # is the correct symbol for the end transmission 
command. Some international systems require other or additional symbols. 

 Modem setup. Select either Primary, or one of the Alternate setups. Click Port 
Settings to further define your selection. Modem Setup is used specifically to support 
different service providers in case you use more than one provider for sending your 
beeper notifications. There could also be times you want to change your settings to 
meet a specific service provider’s requirements for a specific notification (for example: 
a lower baud rate). To do this, you can set up an alternate Modem Setup and associate 
this to the notification instead of using your Primary setting.   

 Note: Changing the Port Settings for the desired Modem Setup will affect ALL uses of that 
setting. 

 Up code. Specifies the characters sent to the beeper to indicate that the device has 
come back up after being down (the default value is 0*). 

 Down Code. Specifies the code sent to indicate the device is down (the default value 
is 1*). 
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 On passive monitor code. Specifies the code sent to indicate that an active monitor 
has been received for the device. (Default value is 2*) You can use the asterisk (*) 
character to separate codes from a subsequent message. 

 Recurring action code. The percent variables for the action. The default action codes 
are: 

 %System.NumberofUpDevices 

 %System.NumberofDownDevices 

4 Click OK to save this action. The action now appears in the Action Library. 
5 Assign the action to a device or a monitor. For more information, see Assigning an action 

to a device (on page 143) or Assigning an action to a monitor (on page 158). 
 

Creating a Pager Action 
To create a Pager Action: 
1 Go to the Action Library: 

 From the web interface, click GO. The GO menu appears. 

 If the WhatsUp section is not visible, click WhatsUp.  The WhatsUp section of the GO 
menu appears. 

 Select Configure > Action Library. The Action Library appears. 

- or - 

 From the main menu bar of the console, select Configure > Action Library. The 
Action Library appears. 

2 In the Action Library, do one of the following: 

 Click New, then select Pager Action. 

- or - 

 Select an existing Pager Action, then click Edit. 

The action properties page appears. 
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3 Set the appropriate options. 

 Name. Enter an identifying name for this pager action. 

 Description. Enter a short description of the action. This is displayed along with the 
Names in the Action Library. 

 Terminal number. Enter the pager number to dial. Your service provider can provide 
you with this number. 

 Terminal password. If required, enter the pager password here. This is a password 
that is required to log in to some paging services. 

 Modem Setup. Select either Primary, or one of the Alternate setups. 

 Click Port Settings to further define your selection. Modem Setup is used 
specifically to support different service providers in case you use more than one 
provider for sending your pager notifications. There could also be times you want 
to change your settings to meet a specific service provider’s requirements for a 
specific notification (for example: a lower baud rate). To do this, you can set up an 
alternate Modem Setup and associate this to the notification instead of using your 
Primary setting.  

 Note: Changing the Port Settings for the desired Modem Setup will affect ALL uses of that 
setting. 

 Protocol. Select the type of protocol used by your pager service. 

 Pager ID. Enter the pager identification number. 

 Message. Enter a text message plus any of the percent variable codes used to deliver 
WhatsUp Gold information with the page. 

4 Click OK to save this action. The action now appears in the Action Library. 
5 Assign the action to a device or a monitor. For more information, see Assigning an action 

to a device (on page 143) or Assigning an action to a monitor (on page 158). 
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Creating an Email Action 
To create an Email Action: 
1 Go to the Action Library: 

 From the web interface, click GO. The GO menu appears. 

 If the WhatsUp section is not visible, click WhatsUp.  The WhatsUp section of the GO 
menu appears. 

 Select Configure > Action Library. The Action Library appears. 

- or - 

 From the main menu bar of the console, select Configure > Action Library. The 
Action Library appears. 

2 In the Action Library, do one of the following: 

 Click New, then select Email Action. 

- or - 

 Select an existing Email Action, then click Edit. 

The action properties page appears. 

 
3 Enter the email destination information. 

 Name. Enter a unique name for this action. 

 Description. Enter a short description of the action. This is displayed in the Action 
Library along with the entry in Name. 

 SMTP Mail Server. Enter the IP address or Host (DNS) name of your email server 
(SMTP mail host). 

 Port. Enter the port number that the SMTP server is installed on. 
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 Timeout. Enter the amount of time (in seconds) to wait for user authentication on the 
SMTP server. The authentication fails if this time limit is exceeded. 

 Mail To. Enter the email addresses you want to send the alert to. Email addresses 
must be fully qualified. You can enter two addresses, separated by commas (but no 
spaces). The address should not contain brackets, braces, quotes, or parentheses. 

 SMTP server requires authentication. Check this option if your SMTP server uses 
authentication. This enables the Username and Password fields. 

The Email action supports three authentication types: 

 CRAM-MD5 

 login 

 plain 

The authentication type is not configurable. It is negotiated with the SMTP server 
automatically. 

 Username. Enter the username to be used with SMTP authentication. 

 Password. Enter the password of the username to be used with authentication. 

 Use an encrypted connection (SSL/TLS). Check this option if your SMTP server 
requires the data to be encrypted over a TLS connection (formerly known as SSL). 

4 Click Mail Content. Enter the content of the email alert. 

 From. Enter the email address that will appear in the From field of the email that is 
sent by the Email action. 

 Subject. Enter a text message or edit the default message. You can use percent 
variable codes to display specific information in the subject. 

 Message body. Enter a text message or edit the default message. You can use 
percent variable codes to display specific information in the message body. 

5 Click OK to save this action. The action now appears in the Action Library. 
6 Assign the action to a device or a monitor. For more information, see Assigning an action 

to a device (on page 143) or Assigning an action to a monitor (on page 158). 
 

Creating an SMS Action 
To create an SMS Action: 
1 Go to the Action Library: 

 From the web interface, click GO. The GO menu appears. 

 If the WhatsUp section is not visible, click WhatsUp.  The WhatsUp section of the GO 
menu appears. 

 Select Configure > Action Library. The Action Library appears. 

- or - 

 From the main menu bar of the console, select Configure > Action Library. The 
Action Library appears. 
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2 In the Action Library, do one of the following: 

 Click New, then select SMS Action. 

- or - 

 Select an existing SMS Action, then click Edit. 

The action properties page appears. 

 
3 Set the appropriate options. 

 Name. Enter a unique display name to identify the SMS notification. 

 Description. Enter a short description of the action. This is displayed in the Action 
Library along with the entry in Name. 

 Country. Using the list box, select the country for the SMS provider. 

 Provider. Using the list box, select the desired provider. 

 Note: If the provider list is incomplete and/or incorrect, you can click the Providers button 
to add, edit, or delete providers in this list. 

 Connection Settings. Mode is either Email or Dialup, depending on how the Provider 
was created in the system. 

 Email to. If the connection setting is Email, enter the email address of the SMS device. 

 Phone Number. If the connection setting is Dialup, enter the phone number to call 
with the message. You can enter multiple phone numbers, separated by a comma. 
There is a 2,000 character limit in this field, so you can enter many numbers.  

 Note: Non-numeric characters such as "-" and "." will be ignored. 
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 Message. Enter a text message plus any desired percent variable codes. Keep in mind 
that if you use percent variables, this will greatly increase the character count. 

 Note: If the message exceeds 140 characters, the message will be broken into up to 3 
parts and will be sent as separate messages ("1 of 3", "1 of 2", etc.). 

4 Click OK to save this action. The action now appears in the Action Library. 
5 Assign the action to a device or a monitor. For more information, see Assigning an action 

to a device (on page 143) or Assigning an action to a monitor (on page 158). 
 

Creating an SMS Direct Action 
SMS Direct Actions send SMS messages directly through an SMS modem, unlike SMS actions, 
which use email gateways or dial-up modems. If you want to send an SMS message and do 
not have an SMS modem, see Creating an SMS Action (on page 131). 

To create an SMS Direct Action: 
1 Go to the Action Library: 

 From the web interface, click GO. The GO menu appears. 

 If the WhatsUp section is not visible, click WhatsUp.  The WhatsUp section of the GO 
menu appears. 

 Select Configure > Action Library. The Action Library appears. 

- or - 

 From the main menu bar of the console, select Configure > Action Library. The 
Action Library appears. 

2 In the Action Library, do one of the following: 

 Click New, then select SMS Direct. 

- or - 

 Select an existing SMS Direct Action, then click Edit. 

The action properties page appears. 
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3 Set the appropriate options. 

 Name. Enter a name for this notification. This name is for your reference only and will 
never be displayed to the notification recipient. 

 Description. Enter or modify the description. This description appears in the Action 
Library and is for your reference only. 

 Phone number. Enter the cell phone number(s) of the intended SMS message 
recipients. You can enter multiple phone numbers, separated by a comma. For 
example: 555-555-5555, 55 555 55 55 55, (555) 555 5555 

 Note: All non-numeric characters other than the comma, such as "-" and ".", will be ignored. 

There is a 2,000 character limit in this field, so you can enter many numbers. 

 COM Port. Select the COM port you want to use with this notification. 

 Note: The list displays all ports associated with the GSM modem, including virtual and hard-
wired, serial ports. You must select the port that is assigned to the modem in the Windows 
Device Manager.  

 Message. Enter the text message you want to send with this notification plus any 
desired percent variable codes. Keep in mind that if you use percent variables, this will 
greatly increase the character count. 

 Note: If the message exceeds 140 characters, the message may be broken into up to 3 parts 
and will be sent as separate messages ("1 of 3", "1 of 2", etc.), each message containing up to 
140 characters, for a total of up to 420 characters. Spaces are counted in the total number of 
characters.  

4 Click OK to save this action. The action now appears in the Action Library. 
5 Assign the action to a device or a monitor. For more information, see Assigning an action 

to a device (on page 143) or Assigning an action to a monitor (on page 158). 
 

Creating a WinPopup Action 
To create a WinPopup Action: 
1 Go to the Action Library: 

 From the web interface, click GO. The GO menu appears. 

 If the WhatsUp section is not visible, click WhatsUp.  The WhatsUp section of the GO 
menu appears. 

 Select Configure > Action Library. The Action Library appears. 

- or - 

 From the main menu bar of the console, select Configure > Action Library. The 
Action Library appears. 
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2 In the Action Library, do one of the following: 

 Click New, then select WinPopup Action. 

- or - 

 Select an existing WinPopup Action, then click Edit.  

The Action Properties page appears. 

 
3 Set the appropriate options. 

 Name. Enter an identifying name for this winpop action. 

 Description. Enter a short description of the action. This is displayed in the Action 
Library along with the entry in Name. 

 Destination. Specify the Windows NT host or domain that you want to receive this 
notification. 

 Message. Enter a text message using percent variables if needed. 

 Refresh. Click this button to refresh the Destination list. This populates the list with 
all of the targets you can choose in which to send a winpop action. 

4 Click OK to save this action. The action now appears in the Action Library. 
5 Assign the action to a device or a monitor. For more information, see Assigning an action 

to a device (on page 143) or Assigning an action to a monitor (on page 158). 
 

Creating a Syslog Action 
To create a Syslog Action: 
1 Go to the Action Library: 

 From the web interface, click GO. The GO menu appears. 

 If the WhatsUp section is not visible, click WhatsUp.  The WhatsUp section of the GO 
menu appears. 

 Select Configure > Action Library. The Action Library appears. 

- or - 

 From the main menu bar of the console, select Configure > Action Library. The 
Action Library appears. 
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2 In the Action Library, do one of the following: 

 Click New, then select Syslog Action. 

- or - 

 Select an existing Syslog Action, then click Edit. 

The action properties page appears. 

 
3 Set the appropriate options. 

 Name. Enter a name for the action. This will appear in the Action Library. 

 Description. Enter a short description of the action. This is displayed in the Action 
Library along with the entry in Name. 

 Syslog Server. Enter the IP address of the machine that is running the Syslog server. 

 Port. Enter the UDP port that the Syslog listener is listening on. The default port is 514. 

 Message. Enter a text message to be sent to the Syslog server. This message may 
include notification variables. The Syslog message box limits input to 511 characters. 
If notification variables are used, then the message that actually gets sent will be 
limited to 1023 bytes, in order to comply with the Syslog protocol. Non-visible ASCII 
characters such as tabs and linefeeds will be replaced by space characters. 

4 Click OK to save this action. The action now appears in the Action Library. 
5 Assign the action to a device or a monitor. For more information, see Assigning an action 

to a device (on page 143) or Assigning an action to a monitor (on page 158). 
 

Creating a Text-to-Speech Action 
To create a Text-to-Speech Action: 
1 Go to the Action Library: 

 From the web interface, click GO. The GO menu appears. 

 If the WhatsUp section is not visible, click WhatsUp.  The WhatsUp section of the GO 
menu appears. 

 Select Configure > Action Library. The Action Library appears. 

- or - 

 From the main menu bar of the console, select Configure > Action Library. The 
Action Library appears. 
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2 In the Action Library, do one of the following: 

 Click New, then select Text-to-Speech Action. 

- or - 

 Select an existing Text-to-Speech Action, then click Edit. 

The action properties page appears. 

 
3 Set the appropriate options. 

 Name. Enter a unique name for this action. 

 Description. Enter a short description of the action. This is displayed in the Action 
Library along with the entry in Name. 

 Speak Rate. Select how fast the voice speaks the message. 

 Volume. Select the volume of the message. 

 Message. Enter any text message you want audibly repeated. Your own text can be 
used in addition to percent variables. 

4 Click OK to save this action. The action now appears in the Action Library. 
5 Assign the action to a device or a monitor. For more information, see Assigning an action 

to a device (on page 143) or Assigning an action to a monitor (on page 158). 
 

Creating a Program Action 
To create a Program Action: 
1 Go to the Action Library: 

 From the web interface, click GO. The GO menu appears. 

 If the WhatsUp section is not visible, click WhatsUp.  The WhatsUp section of the GO 
menu appears. 

 Select Configure > Action Library. The Action Library appears. 

- or - 

 From the main menu bar of the console, select Configure > Action Library. The 
Action Library appears. 
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2 In the Action Library, do one of the following: 

 Click New, then select Program Action. 

- or - 

 Select an existing Program Action, then click Edit. 

The action properties page appears. 

 
3 Set the appropriate options. 

 Name. Enter a name for the action you are creating. This is the name that appears in 
the Action Library. 

 Description. Enter a short description of the action. This is displayed in the Action 
Library along with the entry in Name. 

 Program filename. Enter or browse to the executable of the application you want to 
launch. 

 Working path. Enter or browse to the directory where the working files for the 
application are stored. The working path is located on the server where WhatsUp Gold 
is running. 

 Program arguments. Enter any percent variables you want to pass to the specified 
program. 

4 Click OK to save this action. The action now appears in the Action Library. 
5 Assign the action to a device or a monitor. For more information, see Assigning an action 

to a device (on page 143) or Assigning an action to a monitor (on page 158). 
 

Creating an Active Script Action 
To create an Active Script Action: 
1 Go to the Action Library: 

 From the web interface, click GO. The GO menu appears. 

 If the WhatsUp section is not visible, click WhatsUp.  The WhatsUp section of the GO 
menu appears. 

 Select Configure > Action Library. The Action Library appears. 

- or - 

 From the main menu bar of the console, select Configure > Action Library. The 
Action Library appears. 
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2 In the Action Library, do one of the following: 

 Click New, then select Active Script Action. 

- or - 

 Select an existing Active Script Action, then click Edit. 

The action properties page appears. 

 
3 Set the appropriate options. 

 Name. The name of the action as it appears in the Action Library. 

 Description. The description of the action as it appears in the Action Library. 

 Timeout. The amount of time (in seconds) WhatsUp Gold should wait for the action 
script to run. 

 Note: Though the maximum timeout is 60 seconds, you are highly discouraged from using a 
timeout longer than the default of 10 seconds. You are encouraged to use the shortest 
timeout possible. 

 Script type. Select the scripting language that you want to use to write this active 
script (either VBScript or JScript). 

 Script text. Write or insert your action code here. 

 Note: We do not recommend using the % variable in a script text because they may resolve 
in text that could contain special characters that may break your script, such as ' ' (quotes), " " 
(double-quotes), and % (percent), new line characters, etc. 

4 Click OK to save this action. The action now appears in the Action Library. 
5 Assign the action to a device or a monitor. For more information, see Assigning an action 

to a device (on page 143) or Assigning an action to a monitor (on page 158). 
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Creating a Web Alarm Action 
To create a Web Alarm Action: 
1 Go to the Action Library: 

 From the web interface, click GO. The GO menu appears. 

 If the WhatsUp section is not visible, click WhatsUp.  The WhatsUp section of the GO 
menu appears. 

 Select Configure > Action Library. The Action Library appears. 

- or - 

 From the main menu bar of the console, select Configure > Action Library. The 
Action Library appears. 

2 In the Action Library, do one of the following: 

 Click New, then select Web Alarms Action. 

- or - 

Select an existing Web Alarms Action, then click Edit. The Action Properties page 
appears. 

 
3 Set the appropriate options. 

 Name. The name identifies the Web Alarm action in the Action Library list. 

 Description. A short description of the action. The description appears in the Action 
Library list. 

 Message. Enter a short message to send to the visual cue part of the Web Alarm in the 
web interface. 

 Play Sound. Select this option to play the sound file whenever a web alarm action is 
fired. Clear this option to only have the visual cue appear in the Web Interface. 

 Sound file name. Select a sound file that has been installed in your \Program 
Files\Ipswitch\WhatsUp\HTML\1033\NMconsole\WebSounds directory. Custom 
sounds added to this directory appear in the drop-down list. 

 Note: For Web Alarms to work properly, your browser must support embedded sound files. 

4 Click OK to save this action. The action now appears in the Action Library. 
5 Assign the action to a device or a monitor. For more information, see Assigning an action 

to a device (on page 143) or Assigning an action to a monitor (on page 158). 
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Creating a Service Restart Action 
To create a Service Restart Action: 
1 Go to the Action Library: 

 From the web interface, click GO. The GO menu appears. 

 If the WhatsUp section is not visible, click WhatsUp.  The WhatsUp section of the GO 
menu appears. 

 Select Configure > Action Library. The Action Library appears. 

- or - 

 From the main menu bar of the console, select Configure > Action Library. The 
Action Library appears. 

2 In the Action Library, do one of the following: 

 Click New, then select Service Restart Action. 

- or - 

 Select an existing Service Restart Action, then click Edit. 

The action properties page appears. 

 
3 Set the appropriate options. 

 Name. Enter the name of the action as you would like it to appear in the Action 
Library. 

 Description. Enter a short description of the action. This is displayed in the Action 
Library along with the entry Name. 

 Host. Click the browse button to select the desired host from your Network 
Neighborhood. 

 User name (domain\username). Enter a user login to use with this monitor. In order 
to monitor the service on another machine, the WinEvent monitor has to be 
configured with the correct user name and password and a user account that belongs 
to the administrators group on the remote machine. If a domain account is used, then 
the expected user name is domain\user. If the device is on a workgroup, there are two 
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possible user names: workgroup name\user or machine name\user. No user name and 
password is needed for local services (services on the machine where WhatsUp Gold is 
running). 

 Password. Enter the password for the login used above.  

To monitor NT services on a XP machine with an account that has empty password, 
the XP's Local Security Settings might have to be modified:  

From Administrative tools > Local Security Settings, select Security Settings > 
Local Policies > Security Options. Next, right click on Account: Limit local account 
use of blank passwords to console logon only, then click Properties, and select 
Disable. 

 Service. Click the browse (...) button to select the desired service associated with your 
host. 

 Command. Use the list box to select either Start or Stop, depending on whether you 
want the associated alert to Start or Stop the service you have selected. 

4 Click OK to save this action. The action now appears in the Action Library. 
5 Assign the action to a device or a monitor. For more information, see Assigning an action 

to a device (on page 143) or Assigning an action to a monitor (on page 158). 
 

Testing an action 

After an action has been created, you can test that action to make sure it works properly. 

To test an action: 
1 Select Configure > Action Library. The Action Library appears. 
2 In the Action Library, select the action you want to test. 
3 Click Test. 
4 Review the action in the Action Progress dialog. 
 

Deleting an action 

Actions that were added at the device or monitor level can be removed by selecting the 
action in the Actions dialog of the Device or Monitor Properties, and clicking Remove. This 
does not effect any other item in the database. 

If you have assigned action policies to your devices, you can remove the action from the 
policy itself. 

To remove an action from the database completely, you must access the Action Library, 
select the action and click Delete. When an action is removed from the Library, it is also 
removed from all items configured to use that action. 
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Assigning an action to a device 

You can assign one or more individual actions to a device, or assign an action policy that may 
contain multiple actions used across your device list. 

To assign actions to a device: 
1 Right-click a device, then click Properties. The Device Properties dialog appears. 
2 Click Actions. The Actions dialog appears. 
3 Select the Apply individual actions option. 
4 Click Add to access the Action Builder wizard. 
5 Follow the directions in the Action Builder wizard. 
6 At the end of the wizard, click Finish to add the action to the device. 
7 If you need to add more actions to the device, click Add and repeat these directions. 
8 When you have completed adding actions, click OK. 

To assign an action policy to a device: 
1 Right-click a device, then click Properties. The Device Properties dialog appears. 
2 Click Actions. The Actions dialog appears. 
3 Select the Apply this Action Policy option. 
4 Select the action policy you want to use for this device. If you need to create a new 

action policy first, click Add to access the Action Builder dialog. 
5 Click OK to save the changes. 

After an action has been added to the device, the action fires when that device reaches the 
specified state. 
 

Creating a Blackout Period 

You can create a Blackout period to have WhatsUp Gold suspend specific actions during the 
scheduled period of time. Use this feature to keep from sending a notification to someone 
who is on vacation, or to keep from sending email when there is no one to receive it. 

To create a Blackout period: 
1 Access the Action Builder Wizard. 

 Select Device Properties > Actions, then click Add. 

 Select Device Properties > Active Monitors > Monitor Properties > Actions, then 
click Add. 

 On the Actions Policies dialog, then click Add. 

2 Within this wizard, click the Blackout period button. 
3 On the Weekly Blackout Schedule dialog, set the times you want the blackout to occur. 

The schedule that is set is repeated weekly. 
4 Click OK. 
5 Complete the wizard. 
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Percent Variables 

Active Monitor Variables Description 

%ActiveMonitor.Argument SNMP instance number. This is only used when an 
action is associated directly with an active monitor, 
and not the device as a whole. 

%ActiveMonitor.Comment The human readable name that coincides with the 
network switch. This is only used when an action is 
associated directly with an active monitor, and not 
the device as a whole. 

%ActiveMonitor.Name 

 

The name of the active monitor that fired an action. 
This is only used when an action is associated 
directly with an active monitor, and not the device as 
a whole. 

%ActiveMonitor.NetworkInterfaceAddress IP address for the network interface. This is only used 
when an action is associated directly with an active 
monitor, and not the device as a whole. 

%ActiveMonitor.Payload The payload returned by a WMI, Exchange, SQL, 
SNMP or Active Script active monitor. This is only 
used when an action is associated directly with an 
active monitor and not the devices as a whole. 

For Active Script Active Monitors, the payload is the 
text that is passed to the SetResult() method in 
the script. 

%ActiveMonitor.State 

 

The Current status of the monitor, such as "Down at 
least 5 min." This is only used when an action is 
associated directly with an active monitor, and not 
the device as a whole. 

 

Device Variables Description 

%Device.ActiveMonitorDownNames List of down services using the abbreviated name if 
available. 

%Device.ActiveMonitorUpNames Full service names of all UP monitored services on a 
device. 

%Device.Address IP address (from device properties). 
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%Device.Attribute.[Attribute 
Name] 

Returns an attribute from the SNMP information available 
for the device, such as the Contact name. To specify the 
attribute, append the category name (listed below) to the 
end of the variable. For example: 
%Device.Attribute.Contact, returns the contact 
name. 

Default categories: 

· *. Returns all attributes 

· Info1. Upgrade path from v8 

· Info2. Upgrade path from v8 

· Contact. Contact information from SNMP 

· Location. Location information from SNMP 

· Description. Description information from SNMP 

· Custom. If you have created a custom attribute you can 
use  the name of that custom attribute in the percent 
variable. 

Example:  

%Device.Attribute.Phone  
%Device.Attribute.RackPosition 

To avoid an error, when placing %Device.Attribute in 
quotation marks, place a space between the last letter and 
the closing quotation mark.   
 
Example: 
 
"%Device.Attribute.Contact ";   correct 
 
"%Device.Attribute.Contact";    incorrect 

%Device.DatabaseID Returns the database ID of a device. 

%Device.DisplayName Display Name (from General of device properties) 

%Device.HostName Host Name (from General of device properties) 

%Device.Notes Notes. (Notes are from the device properties Notes) 

%Device.SNMPOid SNMP Object identifier. 

%Device.State The state's description (such as "Down at least 2 min" or 
"Up at least 5 min") 

%Device.Status This shows the name of the active monitor, preceded by 
the device state id : 10|DNS 

%Device.Type Device Type (from General of device properties) 

 

Passive Monitor Variables Description 

%PassiveMonitor.DisplayName The name of the monitor as it appears in the Passive 
Monitor Library. 
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%PassiveMonitor.LoggedText Detailed Event description. (SNMP traps - Returns the full 
SNMP trap text.) (Windows Log Entries - Returns 
information contained in the Windows Event Log entries.) 
(Syslog Entries - Returns the text contained in the Syslog 
message.) 

%PassiveMonitor.Payload.* Payload generated by a passive monitor. 

%PassiveMonitor.Payload.EventType The type of passive monitor (Syslog, Windows Event, or 
SNMP Trap) 

 

System Variables Description 

%System.Date The current system date. Configure the date format in 
Regional Options (from Program Options) 

%System.DisplayNamesDownDevices Display names of devices with down monitors 

%System.DisplayNamesDownMonitors 

 

Shows the name of a device and each monitor that is 
down on that device. The format of the response is 'device 
name':'monitor 1','monitor 2','...' 

Example: ARNOR: FTP, HTTPS, Ping 

%System.DisplayNamesUpDevices Display names of up devices 

%System.DisplayNamesUpMonitors Shows the name of a device and each monitor that is up 
on that device. The format of the response is 'device 
name':'monitor 1','monitor 2','...' 

Example: ARNOR: FTP, HTTPS, Ping 

%System.InstallDir Displays the directory on which WhatsUp Gold is installed 

%System.NumberofDownDevices Number of down devices on your network 

%System.NumberOfDownMonitors Shows the number of down monitors on your network 

%System.NumberofUpDevices Number of up devices on your network 

%System.NumberOfUpMonitors Shows the number of up monitors on your network 

%System.Time The current system  time. The format is hh:mm:ss 
 

About action policies 

You can use action policies to stack multiple actions together in a single policy. You can then 
assign the action policy to any device or monitor. If you later need to edit an action, you can 
edit the action policy and the changes will be applied to all of the devices that use that 
particular action.  

For more information, see: 

 Creating an action policy (on page 147) 

 Editing action policies (on page 147) 

 Implicit Action Policy (on page 148) 
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Creating an action policy 
This feature gives you the ability to stack multiple actions together in a single policy. You can 
then assign those actions to any device or monitor in your device list. Once assigned, you can 
edit the policies in the Action Policies dialog without having to make changes to all of the 
devices that use that particular action. 

To create an action policy: 
1 Open the Action Policies dialog. 

 From the web interface, click GO. The GO menu appears. 

 If the WhatsUp section is not visible, click WhatsUp.  The WhatsUp section of the GO 
menu appears. 

 Select Configure > Action Policies. 

- or - 

 From the main menu bar on the console, select Configure > Action Policies. The 
Action Policies dialog appears. 

2 On the Action Policies dialog, click New. 
3 In the New Action Policy dialog, enter a name in Policy name. This name is used to 

identify the policy later, so you should make sure the name is something that will help 
you remember what is contained in that policy. 

4 Click Add. The Action Builder wizard appears. 
5 Follow the directions in the wizard. 
6 Click Finish at the end of the wizard to add the action to the policy. 
7 Add as many actions as you need to complete the policy. You can move actions up and 

down in the list by clicking the Up and Down buttons above the action list. 

If you select Only execute first action, WhatsUp Gold executes the actions in the list, 
starting at the top, and stops as soon as an action successfully fires. 

8 Once all of the actions have been added, click OK to create the policy and add it to the 
active list. 

9 Assign the action policy to a device or monitor. For more information, see: 

 Assigning an action to a device (on page 143) 

 Assigning an action to a monitor (on page 158) 

 Note: During Device Discovery, you can assign an existing action policy (if one has been 
created previously), create a simple action policy through a wizard, or access the Action 
Policy Editor to create an action policy yourself. 

 

Editing Action Policies 
When you make changes to an action policy, you change the operation of all items that are 
currently assigned to use the policy. 
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To edit an action policy: 
1 Open the Action Policies dialog. 

 From the web interface, click GO. The GO menu appears. 

 If the WhatsUp section is not visible, click WhatsUp.  The WhatsUp section of the GO 
menu appears. 

 Select Configure > Action Policies. 

- or - 

From the main menu of the console, Configure > Action Policies. The Action Policies 
dialog appears. 

2 On the Action Policies dialog, select the policy you want to edit. 
3 Click Edit. 
4 Make changes to the policy as necessary. 
5 Click OK. 
 

Implicit Action Policy 
With the Implicit Action policy, WhatsUp Gold automatically assigns actions to all devices in 
your database. There is no way to opt out of the Implicit Action policy, so any action in that 
policy will be used by all devices. The Implicit Action Policy is not used for active monitors, 
just devices. 

The Implicit Action policy is configured through the Action Policies dialog. If at any time 
during the normal operation of WhatsUp Gold you notice that actions are firing and you 
cannot find the action associated to the down device or monitor, remember to check the 
Implicit Action Policy too. 

 Note: In Previous versions of WhatsUp Gold, the Web Alarm Action was included in the 
Implicit Action Policy. This is no longer true in Ipswitch WhatsUp Gold v12. For more 
information on the Web Alarm Action, see About Web Alarms (on page 124). 

 

Example: getting an Email alert when the Web server fails 
This example shows how to set up monitoring for your Web server so that an email alert is 
sent when the Web server fails, or when Web content is not available.  

First, you need to set up the monitors for your Web server. Then, create an Email Action and 
assign it to the monitors. 

Setting up monitors for a Web server and creating an Email Action that is assigned to 
monitors: 
1 Open device properties for your Web server device (right-click a web server device, then 

click Properties). The Device Properties dialog appears. 
2 Click Active Monitors. The Active Monitors dialog appears. 
3 Click Add. The Select Active Monitor Type dialog appears.  
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4 Use the following dialogs to add the HTTP active monitor to your Web server device. 
This monitor checks that HTTP (port 80) is active. 

a) On the Select Active Monitor Type screen, select HTTP, then click Next. The Set 
Polling Properties dialog appears. 

b) Leave the default settings selected (Enable polling for this Active Monitor and Use 
default network interface, then click Next. The Setup Actions for Monitor State 
Changes dialog appears. 

c) Select Apply individual actions, then click Add. The Select or Create Action dialog 
appears. 

d) Select Create a new action, then click Next. The Select Action Type dialog appears. 

e) In the Select the actions type to create list, select E-Mail Action, then click Next. The 
Select State Change dialog appears. 

f) Select the Down option in the Execute the action on the following state change 
list, then click Finish. The New Email Action dialog appears. 

g) Enter the information as shown: 
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h) Click Mail Content. The following information is included in the Edit Mail Content 
dialog and can be customized as required: 

 

i) Click OK to save changes and return to the previous screen. Click OK again to return 
to the Setup Actions for Monitor State Changes screen, then click Finish.  

Setting up an HTTP Content Active Monitor with an email alert: 
1 Open device properties for your Web server device (right-click the same Web server 

device you used for the email alert, then click Properties). The Device Properties dialog 
appears. 

2 Click Active Monitors. The Active Monitors dialog appears. 
3 Click Add. The Select Active Monitor Type dialog appears.  
4 Use the same process to add the HTTP Content active monitor. This monitor checks that 

the Web server returns valid content in response to an HTTP request. 

a) On the Select Active Monitor Type screen, select HTTP Content, then click Next. The 
Set Polling Properties dialog appears. 

b) Leave the default settings selected (Enable polling for this Active Monitor and Use 
default network interface, then click Next. The Setup Actions for Monitor State 
Changes dialog appears. 

c) Select Apply individual actions, then click Add. The Select or Create Action dialog 
appears. 

d) Select Select an action from the Action Library, then click Next. The Select Action 
and State dialog appears. 

e) In the Select an action from th Action Library list, select MailtoWebmaster. In the 
Execute the actions on the following state change list, select Down, then click 
Finish to save the changes and return to the Setup Actions for Monitor State Changes 
screen. 

f) On the Select Action and State screen, select MailtoWebmaster, then click Finish to 
save the changes and return to the Setup Actions for Monitor State Changes dialog. 

g) Click Finish. 
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The two active monitors and resulting email actions are now enabled. When the Web 
server is down, HTTP Active Monitor will fail, triggering the Email Action, which sends an 
email message similar to the following: 

Web1 is down on server: web1.YourDomain.com (192.168.5.5) 

Details: 

Monitors that are down include: 

 

Monitors that are up include: 

HTTP Content 

Notes on this device (from device property page): 

Lamar Bldg; 2nd floor 

----------------------- 

This mail was sent on 11/28/2007 at 15:34:01 

Ipswitch WhatsUp Gold 

If the Web server could not return web content, the Email Action would report: 

HTTP Content is down on server: web1.YourDomain.com (192.168.5.5) 

Any details or notes specified in the action will also be reported. 
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Active monitors overview 

Active monitors query network services installed on a device, then wait on the response. If a 
response is not received or if the response does not match what is expected, the service is 
considered down, and a state change occurs on the device.  

If the query is returned with the expected response, the service is considered up. The 
following Active Monitor types are available in WhatsUp Gold:  

 Active Script Monitor 

 DNS Monitor 

 Email Monitor  (WhatsUp Gold Premium) 

 NT Service Monitor 

 Ping Monitor 

 SNMP Monitor 

 TCPIP Monitor 

 Telnet Monitor 

 WMI Monitor (WhatsUp Gold Premium) 

 Microsoft® Exchange™ and Microsoft SQL Server Monitor (WhatsUp Gold Premium) 

 VoIP Monitor (available as a WhatsUp Gold plug-in) 
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 Note: There are several types of TCPIP Monitors that are configured using the same dialog. 

For more information about the Active Monitor types, see Supported active monitors (on page 
155). 
 

About the Active Monitor Library 

The Active Monitor Library is the central storehouse of all active monitors that have been 
configured for your network.  

The Active Monitor Library dialog is used to configure active monitor types. It includes a list of 
Active Monitors that are available by default, on an out of the box installation. As you 
configure new active monitor types, they are listed here.  

It's important to note that when you make changes to the active monitors listed in this dialog, 
the changes affect each instance of that particular monitor across your device groups. 

To access the Active Monitor Library: 

 On the console, click Configure > Active Monitor Library. 

 From the web interface, click GO. If the WhatsUp menu is not visible, click WhatsUp. 
Then, from the WhatsUp menu, click Configure > Active Monitor Library. 
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Use this dialog to configure new or existing active monitor types: 

 Click New to configure a new type. 

 Select an existing type, then click Edit to change its configuration. 

 Select an active monitor type, then click Copy to make a copy of that type. 

 Select an active monitor type, then click Delete to remove it from the list. 

 In the WhatsUp Gold console, you can select an active monitor, then click Test to test the 
selected Active Monitor on a device. 

 

Supported active monitors 
The following is a list of all of the active monitor types that are supported by WhatsUp Gold. 

Active Script Monitor. The Active Script Monitors let you write either VBScript or JScript 
code to perform a check on a device. If the script returns an error code, the monitor is 
considered down. 

 Note: Please be aware that Ipswitch does not support the scripts that you create, only the 
ability to use them in the Active Script Monitor. 

 DNS Monitor. The DNS monitor is a simple service Monitor that checks for the DNS 
(Domain Name Server) on port 53. If no DNS service responds on this port, then the 
service is considered down. 

 Email Monitor. This monitor checks a mail server by first sending the server an email via 
SMTP. The monitor then attempts to delete previously sent emails using either POP3 or 
IMAP. If no emails from the monitor are present in the inbox to delete, the mail server is 
considered down. 

The email active monitor supports encryption with SSL/TLS and SMTP Authentication 
which ensures that the monitor sends emails to a secure email account. 

 SNMP Monitor. The Simple Network Management Protocol is the protocol governing 
network management and monitoring of network devices and their functions. This 
monitor queries the SNMP device and tries to match the expected returned value. 

 Telnet Monitor. Telnet is a simple service monitor that checks for a Telnet server on port 
23. If no telnet service responds on this port, then the service is considered down. 

 Ping Monitor. The Ping monitor sends an ICMP (ping) command to a device. If the device 
does not respond, the monitor is considered down. 

 TCP/IP Monitor. The TCPIP monitor is used to monitor a TCPIP service that either does 
not appear in the list of standard services, or uses a non-standard port number. 

 NT Service Monitor. The NT Service Monitor checks the status of a service on a Windows 
machine and attempts a restart of the service (if the appropriate Administrator 
permissions exist). 
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 Note: A running Windows Management Instrumentation (WMI) service on the targeted 
machine is required for this NT Service Monitor to work properly. Windows 2000 Service Pack 
2 or higher, XP, and 2003 are installed with the WMI service. WMI is not installed with 
Windows NT, but can be downloaded from Microsoft and installed on Windows NT.  

WhatsUp Gold Premium supports additional Active Monitor types: 

 Microsoft® Exchange™ and Microsoft SQL Server Monitor manages the availability of 
key application services, rather than just the network visibility of the host server. 

 General application monitoring using Microsoft's WMI monitors any performance 
counter value you specify, and triggers an alarm if the value changes, goes out of range, 
or undergoes an unexpected rate of change. 

For more information, see Using WhatsUp Gold Premium Edition (on page 183). 

WhatsUp Gold active monitor plug-ins: 

 VoIP Monitor. The VoIP active monitor lets you set the acceptable Mean Opinion Score 
(MOS) threshold for an IP SLA device; so if the MOS threshold is exceeded, an alert can be 
sent to notify the appropriate network manager about the issue. 

 

Assigning active monitors 

There are two steps in assigning an active monitor to a device. The first is to configure the 
active monitor in the Active Monitor Library, and the second is to add that Monitor to a 
device. For most users, the default configuration is sufficient and there is no need to make 
any changes to the active monitors in the library. 

To configure (add/edit) an active monitor: 
1 Open the Active Monitor Library. 

 From the web interface, click GO. The GO menu appears. 

 If the WhatsUp section is not visible, click WhatsUp.  The WhatsUp section of the GO 
menu appears. 

 Select Configure > Active Monitor Library. 

2 Click New to configure a new Active Monitor, 

- or - 

Select a monitor from the list and click Edit to make changes to an existing configuration.  

The configuration dialog for the selected monitor type appears. 

3 After you make the necessary changes, click OK to add the monitor to the list, or to save 
the changes you made to one already on the list. 
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To assign an active monitor to a device: 

 Note: If you are assigning an active monitor to a device that uses WMI or SNMP credentials, 
make sure that the device has credentials assigned before creating an active monitor for it. 
For more information, see Using Credentials (on page 100). 

There are a number of ways to assign Active Monitors to devices: 

 Select the Active Monitors you want to scan for during Device Discovery. When you select 
the discovered devices and add them to your database, WhatsUp Gold creates a monitor 
for each network service found. 

 In the Device Properties Active Monitor dialog, click Discover. WhatsUp Gold scans the 
device and creates a monitor for each network service found. 

 

 Manually assign an active monitor to the device: 

1 In the Device Properties Active Monitor dialog, click Add. The Active Monitor 
Properties dialog appears. 

2 Select the active monitor type you want to assign to the device, then click Next. 

3 Set the polling properties for the monitor, then click Next. 

4 Setup actions for the monitor state changes. 

5 Click Finish to add the monitor to the device. 
 

 Add when you create a new device: 

1 In the console click File > New > New Device. The Add New Device dialog appears. 

- or - 

In the web interface,from the WhatsUp section of the GO menu, click Devices > New 
Device. The Add New Device dialog appears. 

2 Click Advance. The Device Discovery Properties dialog appears. 

3 In the Select Active Monitors to be used in the scan process section, select the 
Active Monitors type you want to assign to the device. 

4  Click OK. 
 

 Use Bulk Field Change to add an active monitor to multiple devices: 

1 Select the devices in the device list, then right-click on one of the selected items. 

2 From the right-click menu, select Bulk Field Change > Active Monitor. 

3 Select the active monitor type you want to add. 

4 Click OK. 
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Assigning an action to a monitor 

You can assign one or more individual actions to a monitor, or assign an action policy that 
may contain multiple actions. 

To assign an action to an active monitor: 

 Note: During the configuration of a new monitor, you are presented with the Action Builder 
as part of the wizard. The following set of directions is for existing monitors. 

1 Right-click the device the active monitor is configured on, then click Properties. The 
Device Properties dialog appears. 

2 Click Active Monitors. The Active Monitors dialog appears. 
3 Double-click the monitor on which you want to add actions.  
4 Go to the actions properties: 

 From the web interface, in the Active Monitor Properties wizard, click Next. 

- or - 

From the console, in the Active Monitor Properties dialog, select Actions. 

5 Select the Apply individual actions option. 
6 Click Add to access the Action Builder wizard. 
7 Follow the directions in the Action Builder wizard. 
8 At the end of the wizard, click Finish to add the action to the monitor. 
9 If you need to add more actions to the monitor, click Add and repeat these directions. 
10 Click OK after all actions have been added. 

To assign an action policy to an active monitor: 

 Note: During the configuration of a new device, you are presented with the Action Builder as 
part of the wizard. The following instructions are for existing devices. 

1 Right-click the device on which the active monitor is configured, then click Properties. 
The Device Properties dialog appears. 

2 Click Active Monitors. The Active Monitors dialog appears. 
3 Double-click the monitor on which you want to add actions.  
4 Go to the actions properties: 

 From the web interface, in the Active Monitor Properties wizard, click Next. 

- or - 

From the console, in the Active Monitor Properties dialog, select Actions. 

5 Select the Apply this Action Policy option. 
6 Select the action policy you want to use for this device. If you need to create a new 

action policy first, click the browse button to access the Action Policies dialog. 
7 Click OK to save the changes. 
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To assign an action to a passive monitor: 
1 Right-click the device the on which the passive monitor is configured, then click 

Properties. The Device Properties dialog appears. 
2 Click Passive Monitors.  
3 Double-click the monitor on which you want to add actions. The Passive Monitor 

Properties appear. 
4 Go to the actions properties: 

 From the web interface, in the Passive Monitor Properties wizard, click Next. 

- or - 

From the console, the Passive Monitor dialog appears. 

5 Click Add to access the Action Builder wizard. 
6 Follow the directions in the Action Builder wizard. 
7 At the end of the wizard, click Finish to add the action to the monitor. 
8 If you need to add more actions to the monitor, click Add and repeat these directions. 
9 Click OK after all actions have been added. 

 Note: You cannot assign an action policy to a passive monitor. 

After an action has been added to the monitor, the action fires when that state reaches the 
assigned down state. 
 

Deleting active monitors 

Unless you are absolutely sure you need to remove an active monitor Type from the Active 
Monitor Library, you should never have to delete an item from this list. If you do, and you find 
you need it later, you will have to configure it completely again. This includes the default 
types that were added during initial installation of WhatsUp Gold. We recommend that you 
only delete the custom monitors that you create. 

 Caution: When you remove an active monitor type from the library, all active monitors of 
that type are deleted from the devices you are monitoring, and all related report data is lost. 

The best course of action is to remove the monitors at the device level or to disable the 
monitor by clearing the selection on the Device Properties. 

To remove a monitor from a device: 
1 Right-click the device you want to remove the monitor from, then click Properties. The 

Device Properties dialog opens. 
2 Click Active Monitors. The Active Monitors attached to the selected device displays in 

the list. 
3 Select the monitor you want to remove. 
4 Click Remove. A warning dialog opens, stating that all data for that monitor will be 

deleted if the monitor is removed. 
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5 Click Yes to remove the monitor. 

 Note: If you want to stop monitoring an Active Monitor on a device, but want to keep the 
historical data, then you must disable the monitor instead of deleting it from a device. 

Using the Bulk Field Change feature 
To remove an active monitor from multiple devices: 
1 Select the devices in the Device View or Map View, then right-click on one of the 

selected items. The context menu appears. 
2 Select Bulk Field Change > Active Monitor. The Bulk Field Change: Active Monitor 

dialog box appears. 
3 In the Operation list, click Remove.  
4 In the Active Monitor type list, select the active monitor that you want to remove. 
5 Click OK to remove the monitor from the selected devices. 
 

Group and Device active monitor reports 

The following reports display information for devices or device groups that have active 
monitors configured and enabled. Access these reports from the Reports tab on the web 
interface. For more information, see Using Full Reports (on page 247). 

 State Change Acknowledgement 

 Active Monitor Availability 

 Active Monitor Outage 

 Health 

 State Change Timeline 

 State Summary 

 Device Status 
 

Example: monitoring network printer toner levels 

To avoid running out of printer ink in the middle of print jobs, or wasting toner by switching 
toner cartridges before they are empty, through WhatsUp Gold you can create a custom 
SNMP active Monitor that will notify you when toner levels are low. 

To configure the printer monitor: 
1 From the WhatsUp Gold web interface, click GO. The GO menu appears. 
2 If the WhatsUp section is not visible, click WhatsUp. The WhatsUp section of the GO 

menu appears. 
3 Select Configure > Active Monitor Library. The Active Monitor Library dialog appears.  
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You need to create an active monitor for each printer type in use. It may be that the office 
uses the same printer type in each office. In this example, we are using a Hewlett Packard 
LaserJet 4050N. Check your network printers for their specific maximum capacity toner 
levels. 

4 Click New, select SNMP Monitor, then click OK. The Add SNMP Monitor dialog appears. 
5 Enter a Name and Description for the monitor. For example, TonerMonitor and Toner 

monitor for the Hewlett Packard LaserJet 4050N.  

For the Object ID and Instance, click the browse (...) button; then locate and find the 
prtMarkerSuppliesLevel (OID 1.3.6.1.2.1.43.11.1.1.9) SNMP object in the MIB 
object tree. This SNMP object is found in the MIB tree at: 

mgmt >  mib 2 > printmib > prtMarkerSupplies > prtMarkerSuppliesEntry 
> prtMarkerSuppliesLevel 

6 Select Range of Values from the type drop down menu and enter 4600 (the maximum 
capacity toner level) as the High value and 100 as the Low Value, then click OK. The 
action will fail when the printer toner level reaches 99. 

7 Test the newly created active monitor and make appropriate changes if needed. 
8 Assign the active monitor to the printer device, click Device Properties > Active 

Monitors. 
9 In the active monitor dialog, click Add. 
10 During the configuration wizard, create or select an action to notify you when the 

printer’s toner levels are low. 

Repeat steps 6-8 for each network printer that requires monitoring. 
 

Expression Editor 

WhatsUp Gold knows the proper connecting commands for checking the standard services 
listed on the Services dialog box, but to monitor a custom service, you may want to specify 
what commands to send to the service and what responses to expect from the service in 
order for WhatsUp Gold to consider the service up. It is up to you to determine the proper 
command strings to expect and send for a custom service. 

You can use a rule expression to test a string of text for particular patterns. 
 

Script Syntax 
You create a script using keywords. In general the Script Syntax is Command=String. 
Command is either Send, Expect, SimpleExpect, or Flow Control. 

 Note: A script can have as many send and receive lines as needed. However, the more you 
have, the slower the service checking. 

Keywords 
 To send a string to a port, use the Send= keyword. 
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 To expect a string from a port, use the SimpleExpect= or the Expect= keyword. 

 To comment out a line, use the # symbol as the first character of the line. 

 To receive conditional responses for errors and successes, use Flow Control Keywords (on 
page 163). 

Examples 

If you have a TCP service to check where you needed to do the following: 

  expect something on connection 

  send a command 

  check for a response 

  send something to disconnect 
 

Script Syntax: Expect=Keyword 
This provides you a great amount of flexibility to accept variable responses and pick out only 
the information you need. This is accomplished using special control characters and regular 
expressions. If you do not need all this flexibility or are new to writing your own custom 
TCP/UDP scripts then you may want to start off using the SimpleExpect keyword first. 

There are 4 variations of the Expect Keyword: 
 Expect. Returns true when the expected value is matched. 

 Expect(MatchCase). Only returns true when the case matches the expected value. 

 DontExpect. Returns true when the value is not found. 

 DontExpect(MatchCase). Returns true when the value is not found. 

The Expect syntax has the form Expect=Response where the Response is either specified as 
an exact text string or a mixture of regular expression rules and text. The Add/Edit Expect 
Rule button will help you construct and test a regular expression response string. It will 
automatically choose the variation of Expect for you based on options you select in that 
dialog. The Add/Edit Expect Rule button does not aid in the generation of SimpleExpect 
keywords. 

WhatsUp Gold v7 or v8 users: The ~, ,̂ ! and = = codes have been replaced with variations 
on the Expect keyword itself. Migrated definitions will be converted automatically. 

Example 1: 

# 

# Note: script comments start with a # character 

# 

# Send a simple text command 

# 

Send = Hello There 

# 

# Expect a nice response that begins with, "Hi, How are you" 

# 

Expect=^Hi, How are you 
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Example 2: 

# 

# Send a command followed by CR/LF 

# 

Send=Select * from Accounts\r\n 

# 

# Expect a large response, but we only care to check that somewhere 

# in the response John Doe is mentioned 

# 

Expect=John Doe 

Example 3: 

# 

# Send a binary escape (27) and an x y and z and then a nak (21) 

# 

Send=\x1Bxyz\x15 

# 

# Expect something that does *not* contain 123 escape (27) 

# 

DontExpect=123\x1B 

Script Syntax: Flow Control Keywords 
The script language has been expanded to have conditional responses on "error" or "success" 
of a step within the scripts. This is done by using the following keywords. 

 IfState. This checks for the current state (ok or error) and jumps to a label if true. 
Valid syntax: IfState {ERR|OK} label 
Example: 
IfState ERR End 
IfState OK Bye 

 Goto. This immediately jumps to a label. 
Valid syntax: Goto End 
Example:  
Goto End 

 Exit. This immediately ends the script with an optional state (ok or error). The optional 
state overrides the current state. 
Valid syntax: Exit {ERR|OK} 
Example: 
Exit ERR 
Exit OK 

 :Label. This defines a label that can be the target of a jump. A label is defined by a single 
word beginning with the ":" character. 
Valid syntax: :(with a name following) 
Example: 
Bye 
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 OnError. This allows for a global handling of an error situation 
Valid Syntax: OnError {EXIT|CONTINUE|GOTO} label 
Example: 
OnError EXIT (Default behavior) 
OnError CONTINUE 
OnError GOTO Logoff 

 

Script Syntax: Send=Keyword 
To Send command on a connection, use a Send=keyword. The form is Send=Command. The 
Command is exactly the message you want to send. You may use a combination of literal 
characters and binary representations. 

WhatsUp Gold understands the C0 set of ANSI 7-bit control characters. A Binary can be 
represented  as \x##, where the ## is a hexadecimal value. Those familiar with the table may 
also choose to use shorthand such as \A (\x01) or \W (\x17) 

You can also use \r and \n as the conventions for sending the carriage return and line feed 
control characters to terminate a line. 

The following table shows the keywords you can use. 

Keyword Description 

\x## Binary value in Hexadecimal. For example, \x1B is escape 

\\ The "\" character 

\t The tab character (\x09) 

\r The return character (\x0D) 

\n The new line character \x0A) 

WhatsUp Gold versions 7 and 8 users: The %### decimal syntax for specifying binary octets 
has been replaced with the \x## hexidecimal syntax.  

Example 1: 
# 
# Note: script comments start with a # character 
# 
# Send a simple text command 
# 
Send=Hello There 

Example 2: 
# 
# Send a command followed by CR/LF 
# 
Send=Select * from Accounts\r\n 

Example 3: 
# 
# Send a binary escape (27) an x y and z and then a nak (21) 
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# 
Send=\x1Bxyz\x15 

Script Syntax: SimpleExpect Keyword 
The SimpleExpect Keyword lets you specify expected responses from your server. Responses 
can even be binary (i.e. non-printable ASCII character) responses. If you know exactly (or even 
approximately) what to expect you can construct a simple expect response string to match 
against. 

This keyword allows you some flexibility in accepting variable responses and picking out only 
the information you need. If you need additional flexibility you may want to consider using 
the regular expression syntax available in the Expect Keyword. 

The SimpleExpect form is SimpleExpect=Response. Where the response is just a series of 
characters you expect back from the service. The following table displays keywords that 
match logic and wildcards to compare responses byte-by-byte expanding escape codes as 
you go. 

Command Options: 
Keyword Description 

\x## Binary value (in Hexidecimal) for example \x00 is null 

. Matches any character 

\% The "%" character 

\. The "." character 

\\ The "\" character 

 Note: Only the number of characters specified in the expect string are used to match the 
response. The response is expected to start with these characters. Any extra trailing 
characters received are just ignored. 

Example 1: 
#  
# Note: script comments start with a # character 
# 
# Send=Hello There 
# 
# Expect a nice response 
# 
SimpleExpect=Hi, how are you? 

Example 2: 
#  
# Send a command followed by CR/LF 
#  
Send=Select * from Accounts\r\n 
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# 
# Expect a large response, be we only care to check that first word 
# received is "Customer" 
# 
SimpleExpect=Customer 

Example 3: 
#  
# Send a binary escape (27) an x y and z and then a nak (21) 
# 
Send=\x1B\x15 
# 
# Expect any byte (we don't care) then an abc and an ack (6) 
# 
SimpleExpect=.abc\x06 

Send to disconnect examples 
For a service like FTP, this would be QUIT/r/n. If a command string is not specified, the 
connection is closed by sending a FIN packet and then an RST packet. 

The /r (carriage return) and /n (line feed) are the conventions for sending these control 
characters to terminate a string. You can use: 

 /r = 0x0a 

 /n = 0x0d 

 /t = 0x09 or /xnn where nn is any hexadecimal value from 00 to FF 

The disconnect string is: 

Send=QUIT/r/n 
 

Regular Expression syntax 
This table lists the meta-characters understood by the WhatsUp Gold Regex Engine. 

Matching a Single Character 
Meta-character Matches 

 . dot Matches any one character 

 [...] character class Matches any character inside the brackets. 
Example, [abc] matches "a", "b", and "c" 

 [^...] negated character class Matches any character except those inside the brackets.
Example, [^abc] matches all characters except "a", "b", 
and "c". 
See below for alternate use - the way ^ is used controls 
its meaning. 
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 - dash Used within a character class. Indicates a range of 
characters. 
Example: [2-7] matches any of the digits "2" through "7".
Example: [0-3a-d] is equivalent to [0123abcd] 

 \ escaped character Interpret the next character literally.   
Example: 3\.14 matches only "3.14". whereas 3.14 
matches "3214", "3.14", "3z14", etc. 

 \xnn binary character Match a single binary character. nn is a hexadecimal 
value between 00 and FF. 
Example: \x41 matches "A" 
Example: \x0B matches Vertical Tab 

Quantifiers 
Meta-character Matches 

 ? question One optional. The preceding expression once or not at 
all. 
Example: colou?r matches "colour" or "color" 
Example: [0-3][0-5]? matches "2" and "25" 

 * star Any number allowed, but are optional. 
Example:  .*  Zero or more occurrences of any character 

 + plus One required, additional are optional. 
Example, [0-9]+ matches "1", "15", "220", and so on 

??, +?, *?  "Non-greedy" versions of ?, +, and *. Match as little as 
possible, whereas the "greedy" versions match as much 
as possible 
Example: For input string <html>content</html> 
<.*?> matches <html> 
<.*> matches <html>content</html>  

Matching Position 
Meta-character Matches 

 ^ caret Matches the position at the start of the input. 
Example: ^2 will only match input that begins with "2".  
Example: ^[45] will only match input that begins with "4" 
or "5" 

 $ dollar At the end of a regular expression, this character matches 
the end of the input. 
Example: >$ matches a ">" at the end of the input. 

Other 
Meta-character Matches 

 | alternation Matches either expression it separates.  
Example:  H|Cat matches either "Hat" or "Cat" 
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 (...) parentheses Provides grouping for quantifiers, limits scope of 
alternation via precedence. 
Example: (abc)*  matches 0 or more occurrences of the 
the string abc 
Example: WhatsUp (Gold)|(Professional) matches 
"WhatsUp Gold" or "WhatsUp Professional" 

 \0, \1, ... backreference Matches text previously matched within first, second, 
etc, match group (starting at 0). 
Example: <{head}>.*?</\0> matches 
"<head>xxx</head>". 

! negation The expression following ! does not match the input 
Example: a!b matches "a" not followed by "b". 

Abbreviations 
Abbreviations are shorthand Meta-characters. 

Abbreviation Matches 

\a Any alphanumeric character: ([a-zA-Z0-9]) 

\b White space (blank): ([ \\t]) 

\c Any alphabetic character: ([a-zA-Z]) 

\d Any decimal digit: [0-9] 

\D Any non decimal digit [^0-9] 

\h Any hexadecimal digit: ([0-9a-fA-F]) 

\n Newline: (\r|(\r?\n)) 

\p Any punctuation character:  ,./\';:"!?@#$%^&*()[]{}- _=+|<>!~ 

\P Any non-punctuation character 

\q A quoted string: (\"[^\"]*\")|(\'[^\']*\') 

\s WhatsUp Gold style white space character [ \\t\\n\\r\\f\\v] 

\S WhatsUp Gold style non-white space character [^ \\t\\n\\r\\f\\v] 

\w Part-of-word character ([a-zA-Z0-9_]) 

\W Non-word character ([^a-zA-Z0-9_]) 

\z An integer: ([0-9]+) 
 

Text string example 
Example 1 

To check an IRC (Internet Relay Chat) service, you can send the command Version/r/n and 
the expected response from the IRC service is: irc. 

Name: IRC; Port: 6667; TCP. 

Send=Version/r/n 

Expect=irc 
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Send=QUIT/r/n 

 Note: You can use Telnet to find the proper value for SimpleExpect, or an Expect string for a 
particular service. Packet Capture tools can also be very useful. 

 

Using Telnet to determine "Expect on Connect" string 
Telnet to the desired port on the host when you are certain it is working properly, and see 
what comes back. You can enter just an identifying portion of a SimpleExpect or Expect 
keyword.  

For example, if you expect to get "220 hostname.domain.com Imail v1.3" back from the host, 
you could use "220 host" as a response string (i.e. SimpleExpect=220 host, or 
Expect=^220 host).  

 Note: Some services are based on binary protocols (such as DNS) and will not provide you 
with a simple response string to use. You can use a packet capture tool to view these types of 
responses. 

 

Using the Active Script Monitor 

The Active Script Monitors let you write either VBScript or JScript code to perform a check on 
a device. If the script returns an error code, the monitor is considered down. 

 Note: Please be aware that Ipswitch does not support the scripts that you create, only the 
ability to use them in the Active Script Monitor. 

 Name. The name of the monitor as it appears in the Active Monitor Library. 

 Description. The description of the monitor as it appears in the Active Monitor Library. 

 Timeout. The amount of time (in seconds) WhatsUp Gold should wait for a response to 
the poll. 

 Note: Though the maximum timeout is 60 seconds, you are highly discouraged from using a 
timeout longer than the default of 10 seconds. You are encouraged to use the shortest 
timeout possible. 

 Script type. Select the scripting language you want to use to write this script (either 
VBScript or JScript). 

 Script text. Write or insert your monitor code here. 

 Use in discovery. Select this option to have the monitor appear in the Active Monitor list 
during discovery. From there, you can select the monitor to have WhatsUp Gold discover 
that monitor type in your devices. 
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This script monitor has a context object that you can use to poll for specific information about 
the device in context. For more information, see Using the Active Script Monitor context object 
(on page 170). 

We have provided several code samples for you to create useful active script monitors for 
your devices. For more information, see Examples: Active Script Monitor context code (on page 
174) 

All script features in WhatsUp Gold utilize the SNMP API. For more information, see Using the 
SNMP API (on page 341). 
 

Using the Active Script Monitor context object 
The context object is available to the script programmer when scripts are executing. It 
delivers context aspects of the device that it is operating upon. All methods and properties 
are retrieved using the Context namespace. 

We have provided several code samples for you to create useful Active Script Monitors for 
your devices. 

Methods  Method description 

LogMessage(sText) This method allows for a message to be written to the WhatsUp 
Gold debug log. 

Example: 

JScript: 

Context.LogMessage( "Checking Monitor name using 

Context.GetProperty()"); 

VBScript: 

Context.LogMessage "Checking Address using 

Context.GetProperty()" 

PutProperty(sPropertyName) This method allows you to store a value in the INMSerialize object. 
This value is retained across polls. 

Example: 

JScript: 

var nCount = parselnt(nNum) +1; 

Context.PutProperty("MyNumeric",nCount); 
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SetResult(nCode, sText) This method allows for a result code and result message to be set. 
This is how you can tell  the WhatsUp Gold system if the monitor 
succeeded or not. 

Important: Every script should have a result, otherwise it will report 
back positively. 

Example: 

JScript: 

Context.SetResult(0, "    Everything is OK"); //Success 

Context.SetResult(1, "    Really big big error"); //Failure

VBScript: 

Context.SetResult 1, "    Really big big error" 
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Properties 
Property Description 

GetProperty(sPropertyName) This property offers access to many device specific 
aspects. You obtain access to these items using the names 
listed. These names are case sensitive. 

Property Description 

"ActiveMonitorTypeName" The active monitor 
display name 

"Address" The IP address of the 
device 

"DeviceID" The device ID 

"Mode" 1 =  doing discovery 
2 =  polling 
3 =  test 

"ActiveMonitorTypeID" The active monitor's 
type ID 

"CredSnmpV1:ReadCommunity" SNMP V1 Read 
community 

"CredSnmpV1:WriteCommunity" SNMP V1 Write 
community 

"CredSnmpV2:ReadCommunity" SNMP V2 Read 
community 

"CredSnmpV2:WriteCommunity" SNMP V2 Write 
community 

"CredSnmpV3:Username" SNMP V3 Username 

"CredSnmpV3:Context" SNMP V3 Context 

"CredSnmpV3:AuthPassword" SNMP V3 
Authentication 
password 

"CredSnmpV3:AuthProtocol" SNMP V3 
Authentication 
protocol 

"CredSnmpV3:EncryptPassword" SNMP V3 Encrypt 
password 

"CredSnmpV3:EncryptProtocol" SNMP V3 Encrypt 
protocol 

"CredWindows:DomainAndUserid" Windows NT Domain 
and User ID 

"CredWindows:Password" Windows NT Password 

GetDB This property returns an open connection to the WhatsUp 
Gold database. 
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GetProperty Examples 
JScript: 

var sAddress = Context.GetProperty("Address");  

var sReadCommunity = Context.GetProperty("CredSnmpV1:ReadCommunity"); 

var nDeviceID = Context.GetProperty("DeviceID"); 

JScript: 

//Sending log message to the WhatsUp Event Viewer 

Context.LogMessage ( "Checking Mode flag"); 

 

var nFlag = Context.GetProperty("Mode"); 

 

if (nFlag == 1) 

{ 

   Context.LogMessage ("Doing a discovery"); 

} 

else if (nFlag == 2) 

{ 

   Context.LogMessage ("Doing a poll"); 

} 

else if (nFlag == 3) 

{ 

   Context.LogMessage ("Must be just a test."); 

} 

else 

{ 

   Context.LogMessage ("Do not know the mode."); 

} 

 

//Set the result code of the check (0=Success, 1=Error) 

Context.SetResult (0, "No error"); 

GetDB Examples 

This example gets the Open connection and reads some values out of the WhatsUp Gold 
"Device" table using the deviceID context. Refer to the WhatsUp Gold Database Schema for 
more information about the WhatsUp Gold schema. 

var oDb = Context.GetDB; 

if (null == oDb) 

{ 

   Context.SetResult( 1, "  Problem creating the PRO DB object"); 

} 

else 

{ 

   var oRs = new ActiveXObject("ADODB.Recordset"); 

   // Get the device ID 

   var nDeviceID = Context.GetProperty("DeviceID"); 

   var sSql = "SELECT * from Device WHERE nDeviceID = " + nDeviceID; 

   oRs = oDb.Execute(sSql); 

   if ( !oRs.EOF ) 

   { 
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      var sDisplay; 

      sDisplay = "" + oRs("sDisplayName"); 

      Context.LogMessage("Display Name=" + sDisplay);  

      sDisplay = "" + oRs("nWorstStateID"); 

      Context.LogMessage("WorstStateID=" + sDisplay);   

      sDisplay = "" + oRs("sNote"); 

      Context.LogMessage("Note=" + sDisplay);    

      sDisplay = "" + oRs("sStatus"); 

      Context.LogMessage("Status=" + sDisplay); 

   }    

   Context.SetResult( 0, "  Ok"); 

} 

 

Examples: Active Script Monitor context code 
The following table lists several active script monitor context code examples that you can use 
to create useful active monitors for your devices. To use these examples, select the text of the 
context and then copy and paste the code into the Script text box of the Active Script 
Monitor dialog. 

 Note: You may have to remove the copyright information from the cut and paste if it appears 
when you copy from this help file. 

Sample Monitor 1 
To return the results of the script to WhatsUp Gold. 

 Note: This affects the state of the device. 

JScript: 

Context.SetResult(0, "Everything is OK"); //Success 

Context.SetResult(1, "Really big big error"); //Failure 

VBScript: 

Context.SetResult 1, "Really big big error" 

Sample Monitor 2 
To log a message to the WhatsUp Gold event viewer. 

 Note: In order to view Context.LogMessage entries, the Debug On option in the event 
viewer must be selected. 

JScript: 

Context.LogMessage("This is the message"); 

  174 



Using WhatsUp Gold v12.3 

Sample Monitor 3 
To access the Device ID. 

JScript: 

var nDeviceID = Context.GetProperty("DeviceID"); 

Sample Monitor 4 
Accessing the IP address of the device. 

JScript: 

var sAddress = Context.GetProperty("Address"); 

Sample Monitor 5 
To access the device credentials. 

 Note: All passwords are decrypted. 

JScript: 

var sV1ReadCommunity = Context.GetProperty("CredSnmpV1:ReadCommunity"); 

var sV1WriteCommunity = Context.GetProperty("CredSnmpV1:WriteCommunity"); 

var sV2ReadCommunity = Context.GetProperty("CredSnmpV2:ReadCommunity"); 

var sV2WriteCommunity = Context.GetProperty("CredSnmpV2:WriteCommunity"); 

var sV3UserName = Context.GetProperty("CredSnmpV3:Username"); 

var sV3Context = Context.GetProperty("CredSnmpV3:Context"); 

var sV3AuthPassword = Context.GetProperty("CredSnmpV3:AuthPassword"); 

var nV3Authprotocol = Context.GetProperty("CredSnmpV3:AuthProtocol"); 

var sV3EncryptPassword = Context.GetProperty("CredSnmpV3:EncryptPassword"); 

var nV3EncryptProtocol = Context.GetProperty("CredSnmpV3:EncryptProtocol"); 

var sNTUsername = Context.GetProperty("CredWindows:DomainAndUserid"); 

var sNTPassword =  Context.GetProperty("CredWindows:Password"); 

Sample Monitor 6 
To access the WhatsUp Gold database. 

This sample uses the device ID in context and accesses the 'Device' table. 

JScript: 

// Get the Open DB connection from the Context NameSpace 

var oDb = Context.GetDB; 

if (null == oDb) 

{ 

Context.SetResult( 1, "  Problem creating the PRO DB object"); 

}  

else 
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{ 

// Get the device ID 

var nDeviceID = Context.GetProperty("DeviceID"); 

// Retrieve all columns for this device. 

var sSql = "SELECT * from Device WHERE nDeviceID = " + nDeviceID; 

var oRs = oDb.Execute(sSql); 

if ( !oRs.EOF ) 

{ 

  // Display various columns in the debug log (Event Viewer). 

  var sDisplay; 

  sDisplay = "" + oRs("sDisplayName"); 

  Context.LogMessage("Display Name=" + sDisplay);  

  sDisplay = "" + oRs("nWorstStateID"); 

  Context.LogMessage("WorstStateID=" + sDisplay);   

  sDisplay = "" + oRs("sNote"); 

  Context.LogMessage("Note=" + sDisplay);    

  sDisplay = "" + oRs("sStatus"); 

  Context.LogMessage("Status=" + sDisplay); 

}     

Context.SetResult( 0, "   Ok"); 

} 

Sample Monitor 7 
Using WMI, see who is currently logged on to a device. 

You can set the monitor to be down if the logged on user is not the expected user. In this 
case, if no one is logged on, then the monitor is assumed up. 

VBScript: 

sComputer = Context.GetProperty("Address") 

nDeviceID = Context.GetProperty("DeviceID") 

 

'Assuming ICMP is not blocked and there's a ping monitor on the device, we want to  

'perform the actual check only if the Ping monitor is up. ConnectServer method of  

'the SWbemLocator has a long time out so it would be good to avoid unnecessary tries. 

'Please note: there's no particular polling order of active monitors on a device.  

'During each polling cycle, it's possible that this monitor could be polled before  

'Ping is polled. If the network connection just goes down but Ping is not polled yet,  

'and therefore still has an up state, this active monitor will still do an actual   

'check and experience a real down. But for the subsequent polls, it won't be doing a 

'real check (ConnectServer won't be called) as Ping monitor has a down state, and this 

'monitor will be assumed down.   

 

If IsPingUp(nDeviceID) = false Then 

Context.SetResult 1,"Actual check was not performed due to ping being down. Automatically 

set to down." 

Else 

sAdminName = Context.GetProperty("CredWindows:DomainAndUserid") 

sAdminPasswd = Context.GetProperty("CredWindows:Password")    

 

    sLoginUser = GetCurrentLoginUser(sComputer, sAdminName, sAdminPasswd) 

sExpectedUser = "administrator" 
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If Not IsNull(sLoginUser) Then 

If instr(1,sLoginUser, sExpectedUser,1) > 0  Then 

Context.SetResult 0,"Current login user is " & sLoginUser 

ElseIf sLoginUser = " " Then 

  Context.SetResult 0,"No one is currently logged in."  

Else 

  Context.SetResult 1,"an unexpected user " & sLoginUser & " has logged in " & sComputer  

End If 

End If 

End If 

'Check if Ping monitor on the device specified by nDeviceID is up. 

'If nDeviceID is not available as it's in the case during discovery, then assume 

'ping is up. 

'If ping monitor is not on the device, then assume it's up so the real check will be 

'performed.  

Function IsPingUp(nDeviceID) 

If nDeviceID > -1 Then  

'get the Ping monitor up state. 

sSqlGetUpState = "SELECT sStateName from PivotActiveMonitorTypeToDevice as P join " & _ 

"ActiveMonitorType as A on P.nActiveMonitorTypeID=A.nActiveMonitorTypeID " & _ 

"join MonitorState as M on P.nMonitorStateID = M.nMonitorStateID " & _ 

"where nDeviceID=" & nDeviceID & " and A.sMonitorTypeName='Ping' and " & _ 

                      " P.bRemoved=0" 

Set oDBconn = Context.GetDB 

Set oStateRS = CreateObject("ADODB.Recordset") 

' oStateRS.ActiveConnection = oDBconn 

' oStateRS.CursorType =3  'adOpenStatic cursorType  

 

       oStateRS.Open sSqlGetUpState,oDBconn,3 

'if recordset is empty then  

If oStateRS.RecordCount = 1 Then 

If instr(1,oStateRS("sStateName"),"up",1) > 0 Then 

IsPingUp = true 

  Else 

     IsPingUP = false 

  End If 

Else 

  'if there's no ping on the device, then just assume up, so regular check will happen. 

  IsPingUp= true 

 

End If 

oStateRS.Close 

oDBconn.Close 

Set oStateRS = Nothing 

Set oDBconn = Nothing 

Else 

'assume up, since there's no device yet. It's for scanning during discovery. 

 IsPingUP = true 

End If 

End Function 

 

'Try to get the current login user name. 

Function GetCurrentLoginUser(sComputer, sAdminName, sAdminPasswd)  

GetCurrentLoginUser=Null 
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Set oSWbemLocator = CreateObject("WbemScripting.SWbemLocator") 

On Error Resume Next 

Set oSWbemServices = oSWbemLocator.ConnectServer _ 

  (sComputer, "root\cimv2",sAdminName,sAdminPasswd) 

If Err.Number <> 0 Then 

 Context.LogMessage("The 1st try to connect to " & sComputer & " failed. Err:" & 

Err.Description) 

 Err.Clear       

      'If the specified user name and password for WMI connection failed, then 

 'try to connect without user name and password. Can't specify user name 

 'and password when connecting to local machine. 

On Error Resume Next 

 Set oSWbemServices = oSWbemLocator.ConnectServer(sComputer, "root\cimv2") 

 If Err.Number <> 0 Then 

    Err.Clear 

    On Error Resume Next 

    Context.SetResult 1,"Failed to access " & sComputer & " " & _ 

"using username:" & sAdminName & " password."  & " Err:  " &  Err.Description 

    Exit Function 

 End If 

End If 

 

Set colSWbemObjectSet = oSWbemServices.InstancesOf("Win32_ComputerSystem") 

 

For Each oSWbemObject In colSWbemObjectSet 

On Error Resume Next 

 'Context.SetResult 0,"User Name: " & oSWbemObject.UserName & " at " & sComputer 

  sCurrentLoginUser = oSWbemObject.UserName 

  Err.Clear 

 

Next 

 

If Cstr(sCurrentLoginUser) ="" Then 

  GetCurrentLoginUser = " " 

Else 

GetCurrentLoginUser = sCurrentLoginUser 

End If 

Set oSWbemServices = Nothing 

Set oSWbemLocator = Nothing 

End Function 

Sample Monitor 8 
Use SNMP to monitor the total bandwidth utilization on an interface (in and out octets) by 
polling values of the interface MIB. 

JScript: 

// Settings for this monitor: 

 

// the interface index ifIndex: 

var nInterfaceIndex = 65540; 

// this monitor will fail if the interface utilization goes above this current ratio: 

// current bandwidth / maxBandwidth > nMaxInterfaceUtilizationRatio  
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var nMaxInterfaceUtilizationRatio =  0.7; // Set to 70% 

// Create an SNMP object, that will poll the device. 

var oSnmpRqst =  new ActiveXObject("CoreAsp.SnmpRqst"); 

// Get the device ID 

var nDeviceID = Context.GetProperty("DeviceID"); 

// This function polls the device returns the ifSpeed of the inteface indexed by 

nIfIndex. 

// ifSpeed is in bits per second. 

function getIfSpeed(nIfIndex) 

{  

var oResult = oSnmpRqst.Initialize(nDeviceID); 

if(oResult.Failed) 

{ 

    return null; 

} 

return parseInt(SnmpGet("1.3.6.1.2.1.2.2.1.5." + nIfIndex)); // ifSpeed 

} 

// Function to get SNMP ifInOctets for the interface indexed by nIfIndex (in bytes). 

// Returns the value polled upon success, null in case of failure. 

function getInOctets(nIfIndex) 

{  

var oResult = oSnmpRqst.Initialize(nDeviceID); 

if(oResult.Failed) 

{ 

    return null; 

} 

return parseInt(SnmpGet("1.3.6.1.2.1.2.2.1.10." + nIfIndex)); // inOctets 

} 

// Function to get SNMP ifOutOctets for the interface indexed by nIfIndex (in bytes). 

// Returns the value polled upon success, null in case of failure. 

function getOutOctets(nIfIndex) 

{  

var oResult = oSnmpRqst.Initialize(nDeviceID); 

if(oResult.Failed) 

{ 

   return null; 

} 

return parseInt(SnmpGet("1.3.6.1.2.1.2.2.1.16." + nIfIndex)); //  outOctets 

} 

// Helper function to get a specific SNMP object (OID in sOid). 

// Returns the value polled upon success, null in case of failure. 

function SnmpGet(sOid) 

{ 

var oResult = oSnmpRqst.Get(sOid); 

if(oResult.Failed) 

{ 

   return null; 

} 

else 

{ 

return oResult.GetPayload; 

} 

} 

// Get the current date. It will be used as a reference date for the SNMP polls. 
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var oDate = new Date(); 

var nPollDate = parseInt(oDate.getTime()); // get the date in millisec in an integer. 

// Do the actual polling: 

var nInOctets = getInOctets(nInterfaceIndex); 

var nOutOctets = getOutOctets(nInterfaceIndex); 

var nIfSpeed = getIfSpeed(nInterfaceIndex); 

if (nInOctets == null || nOutOctets == null ||  nIfSpeed == null) 

{ 

Context.SetResult(1, "Failure to poll this device."); 

} 

else 

{ 

var nTotalOctets = nInOctets + nOutOctets; 

// Retrieve the octets value and date of the last poll saved in a context variable: 

var nInOutOctetsMonitorPreviousPolledValue =        

Context.GetProperty("nInOutOctetsMonitorPreviousPolledValue"); 

var nInOutOctetsMonitorPreviousPollDate =          

Context.GetProperty("nInOutOctetsMonitorPreviousPollDate"); 

if (nInOutOctetsMonitorPreviousPolledValue == null || nInOutOctetsMonitorPreviousPollDate 

          

== null) 

{ 

    // the context variable has never been set, this is the first time we are polling. 

    Context.LogMessage("This monitor requires two polls."); 

    Context.SetResult(0, "success"); 

} 

else 

{ 

// compute the bandwidth that was used between this poll and the previous poll 

var nIntervalSec =  (nPollDate - nInOutOctetsMonitorPreviousPollDate)/1000; // time since 

     

 

    last poll in seconds 

var nCurrentBps = (nTotalOctets - nInOutOctetsMonitorPreviousPolledValue) * 8 /      

nIntervalSec; 

Context.LogMessage( "total octets for interface " + nInterfaceIndex + " = " + 

nTotalOctets)    

; 

Context.LogMessage( "previous value = " + nInOutOctetsMonitorPreviousPolledValue); 

Context.LogMessage("difference: " + (nTotalOctets - 

nInOutOctetsMonitorPreviousPolledValue)    

+ " bytes"); 

Context.LogMessage("Interface Speed: " + nIfSpeed + "bps"); 

Context.LogMessage("time elapsed since last poll: " + nIntervalSec  + "s"); 

Context.LogMessage("Current Bandwidth utilization: "+ nCurrentBps + "bps"); 

if (nCurrentBps/nIfSpeed > nMaxInterfaceUtilizationRatio) 

{ 

   Context.SetResult(1, "Failure: bandwidth used on this interface " + nCurrentBps + "bps 

  

   / total available: " + nIfSpeed + "bps is above the specified ratio: " +       

   nMaxInterfaceUtilizationRatio); 

   } 

       else 

   { 
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   Context.SetResult(0, "Success"); 

} 

} 

// Save this poll information in the context variables: 

Context.PutProperty("nInOutOctetsMonitorPreviousPolledValue", nTotalOctets) 

Context.PutProperty("nInOutOctetsMonitorPreviousPollDate", nPollDate); 

} 

Sample Monitor 9  
To monitor an SNMP agent running on a non standard port (the standard SNMP port is 161). 

JScript: 

var nSNMPPort = 1234; // change this value to the port your agent is running on 

var oSnmpRqst =  new ActiveXObject("CoreAsp.SnmpRqst"); 

 

// Get the device ID 

 

var nDeviceID = Context.GetProperty("DeviceID"); 

// Initialize the SNMP request object 

var oResult = oSnmpRqst.Initialize(nDeviceID); 

if(oResult.Failed) 

{ 

Context.SetResult(1, oResult.GetPayload); 

} 

else 

{ 

 

    // Set the request destination port.  

var oResult = oSnmpRqst.SetPort(nSNMPPort); 

// Get sysDescr. 

var oResult = oSnmpRqst.Get("1.3.6.1.2.1.1.1.0"); 

if (oResult.Failed) 

{ 

    Context.SetResult(1, "Failed to poll device using port " + nSNMPPort + ". Error=" + 

    oResult.GetPayload); 

} 

else 

{ 

    Context.SetResult(0, "SUCCESS. Detected an SNMP agent running on port " + nSNMPPort 

); 

    } 

} 

Sample Monitor 10 
To access SNMP using WhatsUp PRO CoreAsp.dll Interface DLL. 

This code sample uses WhatsUp PRO CoreAsp.dll and uses the SnmpRqst interface. 

JScript: 

var oSnmpRqst =  new ActiveXObject("CoreAsp.SnmpRqst");  

  181 



Using WhatsUp Gold v12.3 

// Get the device ID 

var nDeviceID = Context.GetProperty("DeviceID"); 

// 

// Function to get SNMP details 

// 

function getSnmpDetails() 

{  

var oResult = oSnmpRqst.Initialize(nDeviceID); 

if(oResult.Failed) 

{ 

   return null; 

} 

var oReturnArray = new Array(); 

oReturnArray["sysDescr"] = SnmpGet("1.3.6.1.2.1.1.1.0"); // sysDescr 

if(oReturnArray["sysDescr"] == null) 

{ 

   return null; 

} 

oReturnArray["objectID"] = SnmpGet("1.3.6.1.2.1.1.2.0"); // objectID 

oReturnArray["sysUpTime"] = SnmpGet("1.3.6.1.2.1.1.3.0"); // sysUpTime 

oReturnArray["sysContact"] = SnmpGet("1.3.6.1.2.1.1.4.0"); // sysContact 

oReturnArray["sysName"] = SnmpGet("1.3.6.1.2.1.1.5.0"); // sysName 

oReturnArray["sysLocation"] = SnmpGet("1.3.6.1.2.1.1.6.0"); // sysLocation 

return oReturnArray; 

} 

// 

// Helper function to get specific OID 

// 

function SnmpGet(sOid) 

{ 

var oResult = oSnmpRqst.Get(sOid); 

if(oResult.Failed) 

{ 

   return null; 

} 

else 

{ 

   return oResult.GetPayload; 

} 

} 

// 

// Get the SNMP details for the device that we passed in via the Context. 

// 

var oSNMPDetails = getSnmpDetails(); 

if(oSNMPDetails != null) 

{ 

Context.LogMessage( "SNMP Details"); 

Context.LogMessage( " sysDescr=" + oSNMPDetails["sysDescr"]); 

Context.LogMessage( " objectID=" + oSNMPDetails["objectID"]); 

Context.LogMessage( " sysUpTime=" + oSNMPDetails["sysUpTime"]); 

Context.LogMessage( " sysContact=" + oSNMPDetails["sysContact"]); 

Context.LogMessage( " sysName=" + oSNMPDetails["sysName"]); 

Context.LogMessage( " sysLocation=" + oSNMPDetails["sysLocation"]); 

// Set success 
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Context.SetResult(0, "Device is SNMP enabled." ); 

} 

else 

{  

// Set an error 

Context.SetResult(1, "Device is not SNMP enabled."); 

} 

 

Using premium monitors 

WhatsUp Gold Premium Edition provides all of the network monitoring capabilities of 
WhatsUp Gold and extends the product to allow additional monitoring capabilities, 
including: 

 Microsoft® Exchange™ and Microsoft SQL Server monitors let you manage the availability 
of key application services, rather than just the network visibility of the host server. 

 General application monitoring using Microsoft's WMI lets you monitor any performance 
counter value and trigger an alarm if the value changes, goes out of range, or experiences 
an unexpected rate of change. 

 Email monitor lets you periodically verify that mail servers are not only up, but are 
receiving and delivering messages properly. 

 

Monitoring a Microsoft Exchange Server 
The Exchange Monitor t lets you monitor the Microsoft®  Exchange™ Server application. The 
Exchange Monitor provides real-time information about the state and health of Microsoft 
Exchange servers on your network. 

The Exchange Monitor supports monitoring of Microsoft Exchange Server 2000 or later 
versions (excluding Microsoft Exchange Server 2007), which can be on any machine in your 
network. 

To create custom parameters to monitor, the Exchange Server host must be WMI-enabled. 

Why use it? 
WhatsUp Gold can monitor and report the status of the standard services associated with any 
mail server, such as SMTP, POP3, and IMAP. If any of these services fail, your users will be 
unable to get mail. It is a good idea to set up monitoring on these services so that you are the 
first to know if they fail. The Exchange Monitor extends monitoring to parameters reported 
by Microsoft Exchange, allowing you to get an early warning of a degradation in 
performance. For example, you can monitor the SMTP queues to see if performance is within 
an expected range, and if not, you can intervene before the SMTP service fails. In other words, 
you can detect a looming problem before it causes an application or service failure.  
 

How to get started using the Exchange Monitor 
This topic describes the overall process of configuring an Exchange Monitor, assigning it to a 
device, and getting feedback from the monitor. 
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A basic approach to using the Exchange Monitor: 

1 Determine which Exchange parameters to monitor. 
2 Determine which Exchange services to monitor. 
3 Decide whether to create a single monitor with multiple parameters and services, sev-

eral monitors with one parameter or service, or some combination. 

To start, it may be simpler to create one monitor for each parameter or service that you 
want to monitor. Whether you set up one monitor or many has a bearing on how the 
information is reported in WhatsUp Gold logs and by actions. For example, a single 
monitor to check disk space, named ExchangeDisk, is reported in logs with this name. If 
ExchangeDisk is reported down, you know it's a disk space problem. 

4 Configure an Exchange Monitor with your selected parameters and/or services. 
5 Add the Exchange Monitor to the device that represents your Microsoft Exchange 

server. 
6 Set up an Action to tell you when the monitor goes down or comes back up. 

 Note: The monitor will be reported down if any of the parameters or services in that monitor 
are down. 

 

Configuring an Exchange Monitor 
To configure an instance of the Exchange Monitor: 
1 Go to the Active Monitor Library: 

 From the web interface, click GO. The GO menu appears. 

 If the WhatsUp section is not visible, click WhatsUp.  The WhatsUp section of the GO 
menu appears. 

 Select Configure > Active Monitor Library. 

- or - 

 From the main menu bar of the console, select Configure > Active Monitor Library. 
The Active Monitor Library appears.  

 Tip: The Active Monitor Library is the starting point for creating any Active Monitor in 
WhatsUp Gold. This dialog shows all of the Active Monitors in your database. 

2 Add an Exchange monitor: 

a) Click New. The Select Active Monitor Type dialog appears. 

b) Select Exchange Monitor from the list. The New Exchange Monitor Server dialog 
appears. 

c) In the Name box, enter the name you want to use to identify this instance of the 
Exchange monitor. For example, if you are configuring a monitor to check disk space, 
you might enter ExchangeDisk. 

d) In the Description box, enter any text information to further describe the monitor. 

e) Select the thresholds to add to the monitor. For more information about specific 
thresholds, see Exchange parameters (on page 185). 
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f) Select the services to monitor. For more information about specific services, see 
Exchange services (on page 185). 

g) Click OK to save the monitor in the Active Monitor Library. 

3 Add the monitor to your Exchange Server device. 

a) In your device list, find the device that represents the Exchange server. Right-click the 
device, then select Properties. Select Active Monitors. 

b) Click Add. The Active Monitor wizard appears. 

Select the monitor, and continue with the wizard to configure any actions for the 
monitor. 

For more information on setting up an action, see Configuring an action (on page 126). 

If you select Use in discovery, WhatsUp Gold adds the monitor to the Active Monitors 
list. From that list, you can select to scan for that service on all applications found during 
discovery. 

 

Exchange parameters 

You can set thresholds on the following parameters: 

Select this parameter: If you want to: 

CPU Monitor CPU state on the Exchange host. 

Memory Monitor free memory on the Exchange host. 

Disk Monitor available disk space on the Exchange host. 

System Monitor operating system performance on the Exchange host, 
including context switches, CPU queue length, and system calls. 

Links Monitor message-handling links between mail servers. A link can 
contain zero or more ExchangeQueue objects, depending on the 
current message traffic along the link. In the Exchange System 
Manager, these links are called queues. 

Queues Monitor the dynamic queues created to transfer individual messages 
between mail servers. An ExchangeQueue is part of an ExchangeLink. 
ExchangeQueue objects are not the same as the queues listed in the 
Exchange System Manager. 

Cluster 

 

Monitor the state of the clustered resources on the Exchange server. 
This parameter will return a value of Unknown - 0; OK - 1; Warning - 2; 
Error - 3. 

Custom Thresholds Browse and select from the large number of additional parameters 
that Microsoft Exchange reports. 

 

Exchange services 

You can monitor the following critical Exchange services to determine whether the service is 
available (Up) or is disabled (Down). 
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Select this process: If you want to: 

Information Store Monitor the MAPI message store service. The information store can contain 
messages, forms, documents, and other information created by users and 
applications. It provides each user with a server-based mailbox and stores 
public folder contents. 

Site Replication 
Service 

Monitor the Site Replication service. 

Management Monitor the Management service. 

MTA Stacks Monitor the Mail Transport Agent (MTA) service. The MTA service provides the 
engine for sending messages and distributing information between Microsoft 
Exchange Server systems or between Microsoft Exchange Server and a foreign 
system. Each MTA is associated with one information store. It is accessed using 
MAPI calls only and has no direct programmer interface with Microsoft 
Exchange Server. The MTA conforms to the 1988 X.400 specification. 

System Attendant Monitor the System Attendant service. 

Routing Engine Monitor the Routing Engine, which determines the routes for delivering 
messages to remote addresses. It forwards the message to remote Exchange 
addresses using SMTP. If some addresses are on a foreign messaging system, 
the routing engine assigns the message to a gateway that handles the address 
type of the recipient and passes the message to the message transfer agent 
(MTA). 

Event Monitor the Event service, which reports warnings and errors. 

POP3 Monitor the POP3 service, which lets a mail client access mail on the server. 

IMAP4 Monitor the IMAP4 service, which lets a mail client access mail on the server. 
 

Example: Exchange Server monitor 
To monitor what is happening with the operating system on the Exchange server, you can 
create a monitor called ExchangeSystemCheck and add several parameters. The purpose of 
this monitor is to give an indication of the general state of the system on which your 
Exchange server is running. To this end, you can configure the monitor to check thresholds 
for the CPU, Memory, and System parameters. The monitor will also check the state of the 
System Attendant service. 

1 Open the Active Monitor Library. 

 From the web interface, click GO. The GO menu appears. 

 If the WhatsUp section is not visible, click WhatsUp.  The WhatsUp section of the GO 
menu appears. 

 Select Configure > Active Monitor Library. The Active Monitor Library appears. 

2 Click New. The Select Active Monitor Type dialog appears. 
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3 Select Exchange Monitor and click OK. The New Exchange Server Monitor dialog 
appears. 

a) In the Name box, enter ExchangeSystemCheck to identify that this monitor will do a 
check on system parameters. 

b) Under Thresholds to monitor, select the CPU, Memory, and System parameters; then 
under Services to monitor, select the System Attendant service. Make sure these 
items have a check in the box to the left. You need to clear the selections for the other 
parameters and also for the other processes. 

c) Select the CPU parameter, then click Configure. The CPU Threshold dialog opens. 
Enter an appropriate threshold and click OK. 

d) Select the Memory parameter, then click Configure. The Memory Threshold dialog 
appears. Enter an appropriate threshold for the amount of free memory and click OK. 

e) Select the System parameter, then click Configure. The System Threshold dialog 
appears. Enter an appropriate threshold and click OK. 

f) Click OK to add the ExchangeSystemCheck monitor to the Active Monitor library. 

4 Add the ExchangeSystemCheck monitor to your Exchange server device. 

a) In your device list, find the device that represents the Exchange server. Right-click the 
device, then select Properties. Select Active Monitors. 

b) Click Add. The Active Monitor wizard appears. 

Select the ExchangeSystemCheck monitor, and continue with the wizard to configure 
any actions for the monitor. 

For more information on setting up an action, see Configuring an action (on page 126). 

After you complete the wizard, the monitor immediately begins to monitor the Exchange 
server. 

 Note: WhatsUp Gold does not support Microsoft Exchange Server 2007. 

 

Monitoring Microsoft SQL Server 
The SQL Server Monitor lets you monitor Microsoft® SQL Server. The SQL Server Monitor 
provides real-time information about the state and health of Microsoft SQL Server 
applications on your network. 

 Note: Microsoft SQL Monitor is available as part of WhatsUp Gold Premium Edition.  

The SQL Server Monitor supports monitoring of Microsoft SQL Server 2000 or later versions, 
and MSDE 2000 or later versions, which can be on any machine in your network. 

To create custom parameters to monitor, the SQL Server host must be WMI-enabled. 
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Why use it? 
WhatsUp Gold can monitor and report the status of the standard services associated with 
TCP/IP servers, such as SMTP, POP3, and IMAP, FTP, HTTP. If any of these services fail, your 
users will be unable to get mail, transfer files, or use the web.  It is a good idea to set up 
monitoring on these services so that you are the first to know if they fail. The SQL Server 
Monitor extends monitoring to parameters reported by Microsoft SQL Server (and Microsoft 
MSDE), allowing you to get an early warning of a degradation in performance. For example, 
you can monitor system parameters on your SQL Server database server to see if 
performance is within an expected range, and if not, you can intervene before the SQL Server 
fails. In other words, you can detect a looming problem before it causes an application or 
service failure.  
 

How to get started using SQL Server Monitor 
1 Determine which SQL parameters to monitor. 

 Note: To use some parameters, configure your System Data Source (ODBC) name for the SQL 
Server. This is done in the Windows Data Sources (ODBC) administrator. 

2 Determine which SQL services to monitor. 
3 Decide whether to create a single monitor with multiple parameters and services, sev-

eral monitors with one parameter or service, or some combination. Whether you set up 
one monitor or many has a bearing on how the information is reported in WhatsUp Gold 
logs and by actions. For example, if you create a single monitor to check disk usage, you 
can name it SQLDisk and it will be reported in logs with this name. 

4 Configure an SQL Server Monitor with your selected parameters and/or services. 
5 Add the SQL Monitor to the device that represents your SQL server. 
6 Set up an action to tell you when the monitor goes down or comes back up. 

 Note: The monitor is reported down if any of its parameters or services is down. 

 

Configuring an SQL Server Monitor 
To configure an instance of the SQL Server Monitor: 
1 Open to the Active Monitor Library: 

 From the web interface, click GO. The GO menu appears. 

 If the WhatsUp section is not visible, click WhatsUp.  The WhatsUp section of the GO 
menu appears. 

 Select Configure > Active Monitor Library. 

- or - 

 From the main menu bar of the console, select Configure > Active Monitor Library. 
The Active Monitor Library appears.  
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 Tip: The Active Monitor Library is the starting point for creating any Active Monitor in 
WhatsUp Gold. This dialog shows all of the Active Monitors in your database. 

2 Add an SQL monitor: 

a) Click New. The Select Active Monitor Type dialog appears. 

b) Select SQL Service Monitor and click OK. 

c) The New SQL Service Monitor dialog appears. 

 

d) In the Name box, enter the name you want to use to identify this instance of the SQL 
Server monitor. For example, if you are configuring a monitor to check disk space, you 
might enter SQLServerDisk. 

e) In the Description box, enter any text information to further describe the monitor. 

f) In the SQL Server Instance Name box, enter the name of the database you want to 
monitor.  

g) Select the thresholds to add to the monitor. For more information about specific 
thresholds, see SQL Server Parameters (on page 190).  

h) Select the services to add to the monitor. For more information about specific 
services, see SQL Server Services (on page 190). 

i) Click OK to save the monitor in the Active Monitor Library. 

3 Add the monitor to your SQL Server device. 

a) In your device list, find the device that represents the SQL Server. Right-click the 
device, then select Properties. Select Active Monitors. 

b) Click Add. The Active Monitor wizard appears. 
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Select the monitor, and continue with the wizard to configure any actions for the 
monitor. 

For more information on setting up an action, see Configuring an action (on page 126). 

If you select Use in discovery, WhatsUp Gold adds the monitor to the Active Monitors 
list. From that list, you can select to scan for that service on all applications found during 
discovery. 

 

SQL Server Parameters 

You can set thresholds on the following parameters: 

Select this parameter: If you want to: 

CPU Monitor CPU state on the SQL host. 

Memory Monitor free memory on the SQL host. 

Disk Monitor disk usage on the SQL host by the SQL server. 

Disk space Monitor free disk space on the SQL host. 

System Monitor system processes on the SQL host. 

Buffers Monitors SQL page buffers. 

Cache Monitors cache usage on the SQL server. 

Locks Monitors wait locks on the SQL server. 

Transactions Monitors the transactions on the SQL server. 

Users Monitors the users on the SQL server. 

Alerts Monitors SQL alerts and severity of alerts. 

Custom Thresholds Browse and select from the large number of additional 
parameters that SQL reports.  

 

SQL Server Services 

You can monitor the following critical SQL services to determine whether the service is 
available (Up) or is disabled (Down). 

Select this process: If you want to: 

MSSQLSERVER This is the database engine. It controls processes all SQL 
functions and manages all files that comprise the databases on 
the server. 

SQLSERVERAGENT This service works with the SQL Server service to create and 
manage local server jobs, alerts and operators, or items from 
multiple servers. 

Microsoft Search A full-text indexing and search engine. 

Distributed Transaction Coordinator The MS DTC service allows for several sources of data to be 
processed in one transaction. It also coordinates the proper 
completion of all transactions to make sure all updates and 
errors are processed and ended correctly. 

SQL Server Analysis Services Implements a highly scalable service for data storage, 
processing, and security. 
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SQL Server Reporting Services Used to create/manage tabular, matrix, graphical, and free-form 
reports. 

SQL Server Integration Services A platform for building high performance data integration 
solutions. 

SQL Server FullText Search Issues full-text queries against plain character-based data in SQL 
Server tables. 

SQL Server Browser Listens for incoming requests for SQL Server resources and 
provides information about SQL Server instances installed on 
the computer. 

SQL Server Active Directory Helper View replication objects, such as a publication, and, if allowed, 
subscribe to that publication. 

SQL Server VSS Writer Added functionality for backup and restore of SQL Server 2005. 
 

Example: SQL Server Monitor 
To monitor user activity on an SQL Server, you can create a monitor called SQLUser, then 
select Users as the only parameter to monitor. 

1 Open the Active Monitor Library. 

 From the web interface, click GO. The GO menu appears. 

 If the WhatsUp section is not visible, click WhatsUp.  The WhatsUp section of the GO 
menu appears. 

 Select Configure > Active Monitor Library. The Active Monitor Library appears. 

2 Click New. The Select Active Monitor Type dialog appears. 
3 Select SQL Server Monitor and click OK. The New SQL Server Monitor dialog appears. 

a) In the Name box, enter SQLUser. 

b) In the SQL Server Instance Name box, enter the name of your database.  

c) Make sure that Users is the only parameter that has a check in the box to the left of it. 
You will need to clear the selections for the other parameters and also for the 
processes. 

d) Click the Users parameter to select it, then click Configure. The Users Threshold 
dialog appears. You should have in mind how many users or connections you want to 
consider as a threshold, and enter those values in the appropriate boxes on the 
dialog. 

e) When finished, click OK to add the SQLUser monitor to the Active Monitor Library. 

4 Add the SQLUser monitor to your SQL server device. 

a) In the device list, select the device that represents the SQL server. Right-click the 
device, then select Properties. Select Active Monitors. 

b) Click Add. The Active Monitor wizard appears. 

Select the SQLUser monitor and continue with the wizard to add to configure actions 
for the monitor. 

For more information on setting up an action, see Configuring an action (on page 126). 
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After you complete the wizard, the monitor immediately begins to monitor the SQL 
Server application. 

 

Monitoring WMI-enabled applications 
The WMI Monitor lets you monitor any WMI-enabled application. The WMI Monitor lets you 
create custom monitors to get real-time information about the state and health of 
applications and servers on your network. Most Windows applications and servers support 
WMI and provide their own set of real-time WMI data. 

 Note: WMI Monitor is part of the WhatsUp Gold Premium Edition, which extends monitoring 
capabilities.  

To create custom monitors, the host on which the application or server is installed must be 
WMI-enabled. You can connect to a host and view the WMI parameters reported by the 
Windows applications and servers on that host. 

Why use it? 
WhatsUp Gold can monitor and report the status of the standard services associated with 
TCP/IP servers, such as SMTP, POP3, IMAP, FTP, HTTP. If any of these services fail, network 
users cannot send mail, transfer files, or use the web. It is a good idea to set up monitoring on 
these services so that you are the first to know if they fail. The WMI Monitor extends 
monitoring to parameters reported by Windows-based applications and servers, allowing you 
to get an early warning of a degradation in performance. For example, you can monitor 
system parameters on your Oracle® database server to see if performance is within an 
expected range, and if not, you can intervene before the Oracle server fails. In other words, 
you can detect a looming problem before it causes an application or service failure. 
 

How to use WMI Monitors 
This topic describes the overall process of configuring a WMI monitor, assigning it to a device, 
and getting feedback from the monitor. 

1 Determine which WMI object you want to monitor. 
2 Decide whether to create a single monitor with multiple WMI objects, several monitors 

with one object, or some combination. 

To start, it may be simpler to create one monitor for each WMI object that you want to 
monitor. Whether you set up one monitor or many has a bearing on how the information 
is reported in WhatsUp Gold logs and by actions. For example, a single monitor to check 
errors on logon, named LogonErrors, is reported in logs with this name. If LogonErrors is 
reported down, you know it's a specific problem. 

3 Configure a WMI Monitor with your objects. 
4 Add the WMI Monitor to the device that represents your application host or server. 
5 Set up an action to tell you when the monitor goes down or comes back up. 

 Note: The monitor will be reported down if any of the objects that you selected to monitor 
are down. 
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Configuring a WMI Monitor 
To configure an instance of the WMI Monitor: 
1 Open the Active Monitor Library. 

 From the web interface, click GO. The GO menu appears. 

 If the WhatsUp section is not visible, click WhatsUp.  The WhatsUp section of the GO 
menu appears. 

 Select Active Monitor Library. 

The Active Monitor Library is the starting point for creating any Active Monitor in 
WhatsUp Gold. This dialog shows all of the Active Monitors in your database. 

2 Add a WMI Monitor: 

a) Click New. The Select Active Monitor Type dialog appears. 

b) Select WMI Monitor and click OK. The New WMI Monitor dialog appears. 

3 Enter or select the appropriate information in the following fields. 

 Name. The name of the monitor as it appears in the Active Monitor Library. 

 Description. The description of the monitor as it appears in the Active Monitor 
Library. 

 Performance counter/Instance. Click the browse button next to this box to select a 
performance counter and instance for the monitor. 

 Check type. Select the type of check you want the WhatsUp Gold WMI monitor to 
make on the performance counter selected above. 

 Constant Value. Monitors the performance counter/instance for a specific value. 
If that value changes, the monitor triggers a device state change. 

 Range of Values. Monitors the performance counter/instance to make sure the 
returned value falls within a range of values. If the value falls outside of the range, 
the monitor triggers a device state change. 

 Rate of Change. Monitors the performance counter/instance to make sure the 
change in value matches the rate you enter in the check values section. If that rate 
changes, the monitor triggers a device state change. 

 Check values. Enter the values for the check type selected above. For Constant 
Value and Rate of Change, select the state of the device when the check value is met. 

 Note: You can also click Advanced to access Advanced Monitor Properties. 

 

Example: WMI Monitor 
Imagine that a device on your network has been illegally logged into through a brute force 
attack (an attack where an intruder runs a script to try random usernames and passwords on 
a range of IP addresses on your network). These types of attacks are extremely dangerous if 
the device in peril is on your domain or is storing sensitive information.  
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You can use a custom WMI Active Monitor to check the appropriate performance counters on 
a Windows device and notify you when this type of attack occurs, so you can do something 
about it before a potential intruder gains access to your network. 

To configure this type of active monitor: 
1 Using the WhatsUp Gold web interface, create the WMI monitor. 

a) Open the Active Monitor Library. 

 From the web interface, click GO. The GO menu appears. 

 If the WhatsUp section is not visible, click WhatsUp.  The WhatsUp section of the GO 
menu appears. 

a) Select Configure > Active Monitor Library. The Active Monitor Library appears. 

b) Click New. The Select Active Monitor Type dialog appears.  

c) Select WMI Monitor and click OK. The Add WMI Monitor dialog appears. 

d) In the Name box, enter "ErrorsLogon" to identify that this monitor checks for logon 
errors. 

e) Click the Browse (…) button next to Instance to access the Performance Counters 
dialog. 

f) Enter the computer name or IP address of the computer in which you want to 
connect. 

g) Select a credential from a list of Windows credentials (pulled from the Credentials 
Library), then click OK to connect to the computer. 

h) In the Performance object box, select Server. 

i) In the Server folder, select the ErrorsLogon performance counter. 

Take note of the Current value entry at the bottom of the dialog. This is the number of 
logon errors currently reported through WMI. 

Click OK to add the Performance counter to the New WMI Monitor dialog. 

j) In the Check type box, select Rate of Change. 

k) In the Rate of Change box, enter the number of logon errors you feel is acceptable. 
This is the number of failed logon attempts between polls. 

l) In the If the value is above the rate, then the monitor is box, select Down. 

m) Click OK to add the active monitor to the library. 

2 Enter the credentials for logging on to the device to which you will add this monitor. 

a) In the Device Properties for the device, select the Credentials section. 

b) In the Credentials Section, click the browse (…) button next to Windows credentials 
to access the Credentials Library. 

c) Create a Windows credential using the administration login and password for the 
device you want to create the passive monitor for. When you have configured the 
credential, click Close.  

d) On the Credentials page, select the new Windows credential, then click OK. 
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3 Add the ErrorsLogon monitor to the problem device. 

a) In your device list, find the device. Double-click the device to display its properties, 
then select Active Monitors. 

b) Click Add. The Active Monitor wizard appears. 

Select the ErrorsLogon monitor, and continue with the wizard to configure any 
actions for the monitor. 

c) For more information on setting up an action, see Configuring an Action (on page 126). 

You may want to consider creating several levels of the active monitor, each with a higher 
threshold than the other, and with more severe actions associated with it. 

For example, create a monitor with 30 as the threshold that simply sends you an email, letting 
you know that at least 31 attempts have been made. Next, create another monitor that uses 
60 as the threshold. This monitor may have an SMS action associated with it that sends a text 
message to you when at least 61 attempts are made. For the most severe level you could 
create a 100 threshold and have the action send messages to several people who may be 
able to block the IP or take the device off the network while the attack is addressed. 
 

Monitoring Mail Servers 
The Email Monitor lets you monitor that a mail server is available and functioning correctly. 
This monitor checks a mail server by first sending the server an email via SMTP. The monitor 
then attempts to delete previously sent emails using either POP3 or IMAP. If no emails from 
the monitor are present in the inbox to delete, the mail server is considered down. 

The email active monitor supports encryption with SSL/TLS and SMTP Authentication which 
ensures that the monitor sends emails to a secure email account. 

The Email Monitor's email delivery check is done across two polls. Therefore, it is important 
that you pick a meaningful polling interval. For example, if you want to be notified when your 
mail server is taking more than two minutes to send and receive email, use a two-minute 
polling interval.  

 Note: WhatsUp Gold can monitor any POP3 server that supports these commands: USER, 
PASS, LIST, TOP, QUIT, RETR, and DELE. WhatsUp Gold can monitor any IMAP server that 
supports these commands: LOGIN, SELECT, SEARCH, STORE, CLOSE, and LOGOUT. 

 

Configuring an Email Active Monitor 
To configure an Email monitor: 
1 Go to the Active Monitor Library: 

 From the web interface, click GO. The GO menu appears. 

 If the WhatsUp section is not visible, click WhatsUp.  The WhatsUp section of the GO 
menu appears. 

 Select Configure > Active Monitor Library. The Active Monitor Library appears. 

- or - 
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 From the main menu of the console, select Configure > Active Monitor Library. The 
Active Monitor Library appears. 

2 Add an Email Monitor: 

a) Click New. The Select Active Monitor Type dialog appears.  

b) Select Email Monitor from the list, then click OK. The Add Email Monitor dialog 
appears. 

c) In Name, enter a title to identify this instance of the monitor.  

d) In Description, enter any additional information to further describe the monitor. 

e) In the Outgoing mail section of the dialog, in SMTP server, enter the address of the 
server on which SMTP is running. Use the default, %Device.Address, to use the 
device IP address on which the monitor is attached. 

f) In Port, enter the port on which the SMTP service is listening. The standard SMTP port 
is 25. 

g) In Mail to, enter the address to which the Email Monitor will send email. 

h) In Mail from, enter the address from which the Email Monitor was sent from. 

i) In the Incoming mail section of the dialog, in Server, enter the address of the server 
on which the POP3 or IMAP service is running. 

j) In Account type, select the protocol (POP3 or IMAP) you want the monitor to use to 
check for correct email delivery. 

k) In Username, enter the username of the email account in which the monitor will use 
to log in. 

l) In Password, enter the password for the email account in which the monitor will use 
to log in. 

m) Click OK to add the monitor to the Active Monitor Library. 

If you want to configure advanced settings for this instance of the Email Monitor, click 
Advanced. From here, you can choose to use SMTP Authentication; set the port on which 
POP3 or IMAP is running; use encrypted connections for SMTP, IMAP, and POP3; and set 
timeouts for SMTP, IMAP, and POP3. 

3 Add the monitor to your mail server. 

a) On the device list, find the device that represents the mail server. Right-click the 
device, then select Properties. Select Active Monitors. 

b) Click Add. The Active Monitor Wizard appears. 

Select the monitor, and continue with the wizard to configure any actions for the 
monitor. 

For more information on setting up an action, see Configuring an action (on page 126). 
 

Example: Email Monitor 
This example creates an Email Monitor that checks to see if an account on Google's Gmail 
service is working properly. To test and use the Email Monitor created in this example 
properly, you need a working Gmail account configured to allow POP3 and SMTP access. 
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To create an Email Monitor for a Gmail account: 
1 Open the Active Monitor Library. 

 From the web interface, click GO. The GO menu appears. 

 If the WhatsUp section is not visible, click WhatsUp.  The WhatsUp section of the GO 
menu appears. 

 Select Configure > Active Monitor Library. The Active Monitor Library appears. 
2 Click New. The Select Active Monitor Type dialog appears.  
3 Select the Email Monitor, then click OK. The Add Email Monitor dialog appears. 

 
4 Enter or select the appropriate information in the dialog fields: 

a) Enter Gmail Status in Name. 

b) In Description, enter Checks Gmail status. 

In the Outgoing mail section of the dialog: 

c) Enter smtp.gmail.com in SMTP server. 

d) Enter 587 for the Port. 

e) If you have a Gmail account, enter it in Mail to, in the following format: 
youraccount@gmail.com. If you do not have a Gmail account, create one on the Gmail 
site.  

f) Enter the same Gmail account in Mail from. 

In the Incoming mail section of the dialog: 

g) Enter pop.gmail.com in Mail server. 

h) Choose POP3 from the Account type list. 

i) Enter 995 for the Port. 

j) Again, enter your Gmail account in Username. 

k) Enter the password for your Gmail account in Password. 

5 Click Advanced. The Advance Monitor Properties dialog appears. 
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6 Enter or select the appropriate information in the dialog fields: 

In the Outgoing server advanced properties section of the dialog: 

a) Select SMTP server requires authentication. 

b) Enter your Gmail account in Username. 

c) Enter the password for your Gmail account in Password. 

d) Select Use an encrypted connection (SSL/TLS). 

e) Use the default Timeout of 5 seconds. 

In the Incoming server advanced properties section of the dialog: 

f) Select Use an encrypted connection (SSL/TLS). 

g) Ensure that Use STARTTLS command is not selected. 

h) Use the default Timeout of 5 seconds. 

i) Click OK to save changes and return to the Add Email Monitor dialog.  

j) Click OK on the Add Email Monitor dialog to add the Gmail Monitor to the Active 
Monitor Library. 

7 Test the Gmail Status monitor.  

a) From the WhatsUp Gold console, go to Configure > Active Monitor Library. The 
Active Monitor Library dialog appears. 

b) Select the Gmail Status monitor, then click Test. 

 

The Test dialog will list the test as either SUCCESS or FAILED. 
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You can log in to the Gmail account used for the Gmail Status monitor and actually see the 
email sent by WhatsUp Gold via the Email Monitor. 
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About Passive Monitors 

Unlike active monitors or performance monitors, which actively poll a device to check its 
status or to gather statistical data, passive monitors passively listen for events on devices. 

Because it does not repeatedly poll devices and wait for a device to signal a problem, a 
passive monitor uses less resources than an active monitor both on the machine running 
WhatsUp Gold and on the network. 

Passive monitors are also useful because some devices on a network may not provide a clear 
up or down status when queried. For example, a message may get logged to the system's 
Event log by another application (such as an antivirus application alerting when a virus is 
found). Since these messages/events can occur at any time, a Passive Monitor Listener 
"listens" for them, and notifies WhatsUp Gold when they occur. 

However, the information that can be reported in a passive monitor event is not as 
customizable as it is with active monitors. In the case of a severe device failure, a device may 
enter a state where it is not able to successfully send a passive monitor event. A connectivity 
loss may prevent the WhatsUp system from receiving an event sent to it as well. 

Passive monitors should be used to complement active monitors, but you should not rely 
solely on Passive Monitors to monitor a device or service. 
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Passive Monitors Icon 

 

When a passive monitor is configured on a device, the device icon displays a 
diamond shape on the upper left side.  

 

This shape changes color when an unacknowledged state change occurs on 
the monitor. After the device has been acknowledged, the icon returns to 
the above appearance. 

 

Assigning passive monitors 

There are two steps in assigning a passive monitor to a device. The first is to configure the 
active monitor in the Passive Monitor Library, and the second is to add that Monitor to a 
device. 

To configure (add/edit) a passive monitor manually: 
1 Open the Passive Monitor Library. 

 From the web interface, click GO. The GO menu appears. 

 If the WhatsUp section is not visible, click WhatsUp.  The WhatsUp section of the GO 
menu appears. 

 Select Configure > Passive Monitor Library. 
2 Click New to configure a new Passive Monitor. The configuration dialog for the selected 

monitor type appears. 

- or - 

Select a monitor from the list, then click Edit to make changes to an existing 
configuration. The Edit dialog for the selected monitor appears. 

3 After you make the necessary changes, click OK to add the monitor to the list or to save 
the changes you made to a monitor already on the list. 

To assign a passive monitor to a device: 

 Note: If you are assigning a Windows Event Log passive monitor type to a device, make sure 
that the device has credentials assigned before creating a passive monitor for it. For more 
information, see Using Credentials (on page 100). 
If want to use multiple Windows Event Log passive monitors, you must assign a unique 
Windows Event Log passive monitor for each device. 

 Note: The upgrade process to WhatsUp Gold v12 from previous versions, automatically 
migrates Windows Event Log passive monitor credentials into the Credentials Library. If you 
experience upgrade problems with Windows Event Log passive monitors, look in the 
credentials library for the Windows (WMI) credentials that will work for the device. If the 
device credentials do not exist, create new credentials for the device. For more information, 
see Using Credentials (on page 100). 
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1 Right-click the device to which you want to assign a passive monitor, then click 
Properties. The Device Properties dialog appears. 

2 Click Passive Monitors. The Device Properties Passive Monitor dialog appears. 
3 Click Add. The Passive Monitor Properties dialog appears. 

 
4 Select the passive monitor type and passive monitor you want to assign, then click 

Next. The Setup Actions for Passive Monitors dialog appears. 
5 Click Add to setup a new action for the passive monitor. The Select or Create Action 

dialog appears. Click: 

Select an action from the Action Library 

- or - 

Create a new action 

Follow the remaining Wizard dialog screens for the selection you made. 

6 Click Finish to add the passive monitor to the device. 
 

Configuring Passive Monitor Listeners 

A Passive Monitor Listeners listens for an event to occur and then notifies WhatsUp Gold. This 
lets you get notification of an event when it occurs, rather than polling for all event types. The 
Passive Monitor Listener is solely responsible for how it monitors its events. This means that 
the server could listen for network traffic or application specific events. 

WhatsUp Gold is installed with three Passive Monitor Listeners: 

 SNMP Passive Monitor (SNMP Trap). A trap is an unsolicited SNMP message (packet) 
sent from a device to indicate a change in status, such as a router indicating one of its 
interfaces went down or a printer indicating that it is out of paper. 
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 Syslog Passive Monitor. A Syslog monitor is used to examine Syslog messages 
forwarded from other devices for a specific record and/or specific text within a record. 
Usually Syslog messages are forwarded from the Syslog on a system that runs UNIX, but 
they can also come from non-UNIX devices as well.  
A Syslog message consists of a priority and a text payload. The text message can contain 
anything you want permanently logged, such as a device failure, or a failed attempt to log 
in to the system. The only way to identify different types of syslog messages is to 
configure a regular expression in the Passive Monitor definition. 

 Windows Event Log Monitor. This monitor can capture any Windows Event Log entry, 
such as a service start or stop, if there was a logon failure recorded, and other log entries. 

Before you can configure passive monitors, you must configure listeners. 

To configure a listener: 
1 From the console, select Configure > Program Options. The Program Options dialog 

appears. 

 Note: If the Windows SNMP Trap Service (located in Control Panel > Services) is running on 
the WhatsUp Gold console PC, you should stop the service. This is a precaution to prevent 
any conflict with the WhatsUp Passive Monitor Listener. 

2 Click Passive Monitor Listeners. The Passive Monitor Listeners display in a list. 

 
3 Select the listener you want to configure, then click Configure. The configuration dialog 

appears. 
4 Select the appropriate settings based on the listener you are configuring. For more 

information about the Passive Monitor Listener options, refer to the Help. 
5 Click OK to save changes. 
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About the Passive Monitor Library 

The Passive Monitor Library dialog displays the Passive Monitor types that have been created 
for WhatsUp Gold. These types are specific configurations of SNMP traps, Windows Log 
Events, and Syslog Events. After the monitor types have been configured, you can associate 
them to devices on the Passive Monitors section of Device Properties dialog. 

 Note: If you are assigning a Windows Event Log passive monitor type to a device, make sure 
that the device has credentials assigned before creating a passive monitor for it. For more 
information, see Using Credentials (on page 100). 
If want to use multiple Windows Event Log passive monitors, you must assign a unique 
Windows Event Log passive monitor for each device. 

 Note: The upgrade process to WhatsUp Gold v12 from previous versions, automatically 
migrates Windows Event Log passive monitor credentials into the Credentials Library. If you 
experience upgrade problems with Windows Event Log passive monitors, look in the 
credentials library for the Windows (WMI) credentials that will work for the device. If the 
device credentials do not exist, create new credentials for the device. For more information, 
see Using Credentials (on page 100). 

1 Go to the Passive Monitor Library. 

 From the web interface, click GO. The GO menu appears. 

 If the WhatsUp section is not visible, click WhatsUp.  The WhatsUp section of the GO 
menu appears. 

 Select Configure > Passive Monitor Library. 

 - or - 
From the main menu bar of the console, select Configure > Passive Monitor Library. 

 
2 Click New to create a new passive monitor type. 
3 Select a monitor type in the list, then click Edit to change the settings. 
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4 Select a monitor type in the list, then click Copy to create a new monitor type based on 
the selected type. 

5 Select a monitor type, then click Delete to remove it from the list. 
 

Group and device passive monitor reports 

The following reports display information for devices or device groups that have passive 
monitors configured and enabled. Access these reports from the web interface Reports tab. 
For more information, see Using Full Reports (on page 247). 

 SNMP Trap Log 

 Syslog Entries 

 Windows Event Log 

 Passive Monitor Error Log 

 Note: If you are missing traps or logs or receiving blank emails generated from an Action on a 
Passive Monitor, see the Passive Monitor payload limitation (on page 332). 

 

Receiving SNMP traps 

WhatsUp Gold has an internal SNMP trap handler, which when enabled, listens for and 
accepts SNMP traps. WhatsUp Gold records the trap in the device's SNMP Trap Log. 

You can also set up WhatsUp Gold to fire an Action when a trap is received for a device. For 
more information, see Using the Trap Definition Import Tool (on page 300). 

To configure WhatsUp Gold to receive traps: 
1 On the devices that will be monitored, set the SNMP agent to send traps to WhatsUp 

Gold. Trap manager addresses must be set on each physical device. This cannot be done 
from WhatsUp Gold. 

2 Set up the MIB entries for traps by placing the MIB text file in the C:\Program 
Files\Ipswitch\WhatsUp\Data\Mibs directory. 

3 Enable the SNMP Trap Handler.  

a) From the WhatsUp Gold console, select Configure > Program Options.  

b) Select Passive Monitor Listeners.  

c) Select SNMP Trap. 

d) Click the Configure button. 

e) Select the appropriate options. 

 Listen for messages on port. Select this option if you want WhatsUp Gold to 
listen for SNMP traps. The standard SNMP trap Port is 162, but you can change this 
port to a non-standard number. The changes are immediate, and you do not have 
to restart WhatsUp Gold for the changes to be in effect. 
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 Accept unsolicited SNMP traps. Select this option to receive and log all incoming 
SNMP traps, including those not assigned to devices as passive monitors. By 
default, only SNMP traps assigned to devices as passive monitors are logged and 
can trigger actions. Incoming traps received as unsolicited traps are logged to the 
System SNMP Trap Log.  

 Caution: When Accept unsolicited SNMP traps is enabled, every SNMP trap that is received 
by WhatsUp Gold is logged to the database. Since leaving this option enabled can result in a 
large database that impacts performance, we strongly advise you to leave this option 
disabled except when troubleshooting.  

 Note: To configure SNMP traps initially, we recommend enabling the Any SNMP trap on the 
source device; you can then see all incoming traps sent from that device in the Device SNMP 
Trap Log. After you configure the trap successfully, remember to disable the Any trap, as it 
may also log large amounts of data. 

 Forward traps. Select this option to forward traps to IP addresses added to the 
Forward traps to list. 

 Forward unsolicited traps. Select this option to forward all traps, including 
unsolicited traps. 

 Forward traps to. Click Add to add an IP address and port to forward traps to. 
You can forward traps to multiple IP addresses. 

f) Click OK to save changes. 

 Note: If the SNMP agent is installed on the WhatsUp Gold machine, this will also start an 
SNMP trap service. This can result in a port conflict, because both the SNMP trap service and 
the WhatsUp Gold SNMP trap handler listen on port 162. To fix this, turn off the SNMP trap 
service. 
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Performance Monitor overview 

Performance Monitors in WhatsUp Gold gather important information about the devices 
running on your network. The gathered data is then used to create reports, trending the 
utilization and availability of different device aspects. Through WhatsUp Gold, you can gather 
statistics on the following areas: 

 CPU utilization 

 Memory utilization 

 Interface utilization (bandwidth) 

 Ping availability 

 Disk utilization 

The system also lets you create custom Performance Monitors that you can use to monitor 
any performance counter made available through WMI or SNMP, as well as the use of JScript 
and VBScript.  

Performance Monitors are configured in the Performance Monitor Library (on page 210), and 
added to individual devices through Device Properties > Performance Monitors. You can 
create global WMI, SNMP, and Active Script Monitors in the library, or create device-specific 
monitors in Device Properties. 
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About the Performance Monitor Library 

The Performance Monitor Library dialog displays the Performance Monitors that have been 
created for WhatsUp Gold. Performance Monitors gather information about specific WMI and 
SNMP values from the network devices. 

 Note: Default monitors in the library cannot be edited or removed: CPU Utilization, Disk 
Utilization, Interface Utilization, and Ping Latency and Availability.  

Use the Performance Monitor Library to configure and manage Performance Monitors. When 
custom Performance Monitors are changed, the changes affect each instance of that 
particular monitor across the device groups.   

To access the Performance Monitor Library dialog: 

 From the console main menu, select Configure > Performance Monitor Library. 

- or - 

 From the web interface, select GO. If the WhatsUp section is not visible, click WhatsUp. 
Then, from the WhatsUp section of the menu, select Configure > Performance Monitor 
Library. 
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To configure Performance Monitors for the devices they are assigned to: 
1 Right-click a device you want to configure. The shortcut menu appears. 
2 Click Properties. The Device Properties dialog appears. 

 

 Click New to configure a new monitor. 

 Select an existing monitor, then click Edit to change the current monitor 
configuration or double-click an existing monitor to change the configuration. 

 Select a performance monitor type, then click Delete to remove it from the list. 

3 Click OK to save changes. 
 

Configuring and enabling Performance Monitors 

WhatsUp Gold is installed with five performance monitors that monitor specific types of data 
on your devices: CPU, Disk, Memory, and Interface Utilization; and Ping Latency and 
Availability. These monitors appear in the Performance Monitor Library. 

To configure these monitors for use on specific devices, you must use either the Device 
Properties > Performance Monitors to configure for a single device, or Bulk Field Change 
> Performance Monitors to configure for multiple devices. 

To enable a global performance monitor for a single device: 
1 In Device View, select a device from the device list.  
2 Right-click and choose Properties from the right-menu to view the device's Device 

Properties. 
3 Click Performance Monitors to view the Performance Monitors dialog. 

From the top section of the dialog, select the global performance monitor you would like 
to enable for the selected device. 

 Important: To enable a CPU, disk, interface, or memory global Performance Monitor, you 
must first select and SNMP credential for the device from the SNMP credential page. 
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4 Click OK to save the changes. 

To configure a global performance monitor: 
1 In Device View, select a device from the device list.  
2 Right-click and choose Properties from the right-menu to view the device's Device 

Properties. 
3 Click Performance Monitors to view the Performance Monitors dialog. 
4 In the top section of the dialog, you can select a global performance monitor, then click 

Configure. 

On the monitor configuration dialog, select the specific item you want to monitor by 
making a selection in the Collect data for drop-down list. Depending on the monitor, 
you can select to collect data for All, Active, Specific, or Default interfaces, memories, 
CPUs, or disks. 

 

If you select Specific, the list is enabled and you can select or clear the selection for any of 
the items in the list. This is particularly useful with the Interface Utilization monitor where 
a device may have many interfaces. 

5 Select the Data collection interval. This is the amount of time between performance 
polls. 

6 Click Advanced to change connection settings on the device. 

 
7 Click OK to save the changes. 

To enable a global performance monitor for multiple devices, use the Bulk Field Change 
feature for performance monitors. 

For information on the Active Script Performance Monitor, see Adding custom performance 
monitors to the Performance Monitor Library (on page 213). 
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Enabling SNMP on Windows devices 

Before you can collect performance data on a Windows computer using SNMP, you must first 
install and enable the Microsoft SNMP Agent on the device itself. For more information, see 
Using SNMP Features (on page 291). 

To install SNMP Monitoring: 
1 From the Windows Control Panel, click Add or Remove Programs. 
2 Click Add/Remove Windows Components. 
3 From the Components list, select Management and Monitoring Tools. 
4 Click Details to view the list of Subcomponents. 
5 Make sure Simple Network Management Protocol is selected. 
6 Click OK. 
7 Click Next to install the components. 
8 After the install wizard is complete, click Finish to close the window. 

To enable SNMP Monitoring: 
1 In the Control Panel, click Administrative Tools. 
2 Double-click Services. the Services console appears. 
3 In the Services (Local) list, double-click SNMP Service to view the Properties. 
4 On the Agent tab, enter the Contact name for the person responsible for the upkeep 

and administration of the computer, then enter the Location of the computer. These 
items are returned during some SNMP queries. 

5 On the Security tab, click Add to add a community string for the device. Community 
strings are pass codes that allow applications like WhatsUp to read information about 
the computer. This community string will be later used to create credentials for 
connecting to this device. 

6 On the General tab, click Start to start the service (if necessary). 
7 Click OK to close the dialog. 

You can test the device by connecting to it through SNMP View. 
 

Adding monitors to the Performance Monitor 
Library 

Performance Monitors gather specific types of data on the devices to which they are 
assigned. System wide monitors are configured using the Performance Monitor Library, but 
you can also create specific SNMP and WMI monitors to be used on a per-device basis. The 
default performance monitors (CPU, memory, disk, and interface utilization; and ping latency 
and availability) cannot be edited or changed from their default settings. By creating custom 
performance monitors, you can adjust the settings to fit your specific monitoring needs. 
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To create custom performance monitors (for system wide use): 
1 From the web interface, select GO. 
2 On the WhatsUp section, select Configure > Performance Monitor Library. The 

Performance Monitor Library dialog appears. 

 
3 Click New. 
4 Select the monitor type: SNMP Performance Monitor, WMI Performance Monitor, or 

Active Script Performance Monitor, then click OK. 
5 Follow the instructions below for the type of monitor you choose. 

To configure an SNMP monitor: 
1 In the Add SNMP Performance Counter dialog, enter a Name and Description for the 

monitor as it will appear in the Performance Monitor Library. Either enter the 
Performance counter OID and Instance or click the browse (...) button next to the 
Instance box to go to the SNMP MIB Walker dialog. 

2 In the MIB Browser dialog, enter the share name or IP address of the computer in which 
you want to connect. 

3 Enter the SNMP credential used to connect to the device (or click the browse (...) button 
to access the Credentials Library to create a new credential). 

4 If needed, adjust the Timeout and Retries count for the connection to the device. 
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5 Click OK. The SNMP MIB Walker appears. 

 
6 Use the navigation tree in the left panel to select the specific MIB you want to monitor 

for the selected computer or device. 
7 In the right pane, select the Property of that MIB you want to monitor. You can view 

more information about the property/value pair at the bottom of the dialog. 
8 Click OK to add the OID to the Performance counter and Instance box in the Add 

SNMP Performance counter dialog. 
9 Verify the configuration and click OK to add the monitor to the Performance Monitor 

Library. 

 Note: After the monitor has been added to the library, make sure that you enable that 
monitor through Device Properties > Performance Monitors for that device or other 
devices. 

To configure a WMI monitor: 
1 On the Add WMI Performance Counter dialog, enter a Name and Description for the 

monitor, as it will appear in the Performance Monitor Library. 
2 Click the browse (...) button next to Instance. The Performance Counters dialog 

appears. 
3 Enter the computer name or IP address of the computer in which you want to connect. 
4 Select a credential from a list of Windows credentials (pulled from the Credentials 

Library), then click OK to connect to the computer. 
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5 Use the Performance counter tree to navigate to the performance counter you want to 
monitor. 

 
6 After you select the performance counter, select the specific instance you want to 

monitor. 
7 Click OK to add the counter and instance to the Add Performance Counter dialog. 
8 Verify the configuration and click OK to add the monitor to the Performance Monitor 

Library. 

 Note: After the monitor has been added to the library, you can enable that monitor through 
Device Properties > Performance Monitors for that device or other devices. 

To configure an SNMP active script performance monitor: 
1 On the Add Active Script Performance Monitor dialog, enter a Name and Description 

for the monitor as it will appear in the Performance Monitor Library. 
2 Enter a number for the timeout (in seconds). 
3 Choose the type of script (JScript or VBScript) you will be using to write the monitor 

from the Script type list. 
4 Add a new variable to the Reference Variables list by clicking Add. 

 Important: You can add up to 10 reference variables to the monitor. 

5 On the Add reference variables dialog, enter a name and description for the variable. 
6 Select the type of object (SNMP or WMI) from the Object type list. 
7 If needed, adjust the Timeout and Retries count for connection to the device. 
8 Click the browse (...) button next to Instance. The SNMP MIB Browser appears. 
9 Enter the share name or IP address of the computer in which you are trying to connect. 
10  Enter the SNMP credential used to connect to the device (or click the browse (...) button 

to access the Credentials Library to create a new credential). 
11  If needed, adjust the Timeout and Retries count for the computer in which you are 

trying to connect. 
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12  Click OK. The SNMP MIB Walker appears. 
13  Use the navigation tree in the left panel to select the specific MIB you want to monitor. 

You can view more information about the property/value at the bottom of the dialog. 
14  Click OK to add the OID to the Performance counter and Instance box in the Add new 

reference variable dialog. 
15  Verify the configuration and click OK to add the variable to the Reference variable list 

on the Add active script performance monitor dialog. 
16 Write or paste your monitor code in the Script text box. 
17  Click OK to save changes and add the monitor to the Performance Monitor Library. 

To configure a WMI active script performance monitor: 
1 On the Add Active Script Performance Monitor dialog, enter a Name and Description 

for the monitor as it will appear in the Performance Monitor Library. 
2 Enter a number for the timeout (in seconds). 
3 Choose the type of script (JScript or VBScript) you will be using to write the monitor 

from the Script type list. 
4 Add a new variable to the Reference Variables list by clicking Add. 

 Important: You can add up to 10 reference variables to the monitor. 

5 On the Add reference variables dialog, enter a name and description for the variable. 
6 Select the type of object (SNMP or WMI) from the Object type list. 
7 Click the Browse (...) button next to the Instance box. 
8 In the dialog that appears, enter the share name or IP address of the computer in which 

you want to connect. 
9 Enter the domain and user login for the account on this computer. If a domain account 

is used, then the expected user name is <domain>\<user>. If the device is on a 
workgroup, there are two possible user names: workgroup <name>\<user> or machine 
<name>\<user>. 

10  Enter a password for the login used above and click OK to connect to the computer. 
11  Use the Performance counter tree to navigate to the performance counter you want to 

monitor. 
12  Once you select the performance counter, select the specific instance you want to 

monitor. 
13  Click OK to add the variable to the Reference variable list on the Add active script 

performance monitor dialog. 
14  Write or paste your monitor code in the Script text box. 
15  Click OK to save changes and to add the monitor to the Performance Monitor Library. 
 

About performance reporting 

After you have configured a performance monitor, you can generate a performance report to 
see the results of the performance polling attempts. These reports can be used to 
troubleshoot your network problems.  

  217 



Using WhatsUp Gold v12.3 

More than 40 reports are installed with WhatsUp Gold. These reports can be viewed from the 
WhatsUp Gold web interface on the Reports tab.  

The Reports tab contains all of the WhatsUp Gold Full reports. You can use the Reports 
Overview page and the Reports Category drop-down menu to navigate to reports according 
to their type and category. 

 

All reports can be printed and many can also be exported into Microsoft Excel. Reports can 
also be saved as an .html file for later review. For more information on reports, see Using Full 
Reports (on page 247). 
 

Performance Monitors gather specific types of data on the devices they are assigned to. 
System wide monitors are configured using the Performance Monitor Library, but you can 
also create specific SNMP and WMI monitors to be used on a per-device basis. 

To create custom performance monitors for system-wide use: 
1 From the web interface, select GO. On the WhatsUp section, select Configure > 

Performance Monitor Library. 
2 In the Performance Monitor Library, click New. 
3 Select the monitor type: SNMP or WMI. 
4 Configure the monitor as follows for the type of monitor you are creating: 

For WMI: 
1 On the Add Performance Counter dialog, enter a name and description for the monitor. 
2 Click the browse (...) button next to Instance to go to the Select Performance Counter 

dialog. 
3 Click the browse (...) button next to Select counters from computer. The Select 

Computer dialog appears. 
4 Enter the computer name or IP address of the computer in which you want to connect. 
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5 Select a credential from a list of Windows credentials (pulled from the Credentials 
Library), then click OK to connect to the computer. 

6 Use the Performance counter tree to navigate to the performance counter you want to 
monitor. 

 
7 After you select the performance counter, select the specific instance you want to 

monitor. 
8 Click OK to add the counter and instance to the Add Performance Counter  

dialog. 
9 Verify the configuration and click OK to add the monitor to the library. 

For SNMP: 
1 On the Add SNMP Performance counter dialog, enter a name and description for the 

monitor. 
2 Click the browse (...) button next to Instance to go to the Select Performance Counter 

dialog. You must enter a numerical value in the Instance field. 
3 Enter the share name or IP address of the computer to which you want to connect. 
4 Enter the SNMP credential used to connect to the device (or click the browse (...) button 

to access the Credentials Library to create a new credential). 
5 If needed, adjust the Timeout and Retries count for the connection to the device. 
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6 Click OK. The SNMP MIB Browser appears. 

 
7 Use the navigation tree in the left panel to select the specific MIB you want to monitor. 
8 In the right pane, select the Property of that MIB you want to monitor. You can view 

more information about the property/value pair at the bottom of the dialog. 
9 Click OK to add the OID to Performance counter and Instance in the Add SNMP 

Performance counter dialog. 
10 Verify the configuration and click OK to add the monitor to the library. 
11 After the monitor has been added to the library, you can enable the monitor through 

Device Properties > Performance Monitors. 
12 On the WhatsUp Gold web interface, select a device and right-click. Select Properties 

from the right-menu.  
13 On the Device Properties dialog, select Performance Monitors. 
14 Click New next to the Individual performance monitors list. 
15 Select the monitor type: SNMP or WMI. 
16 Follow the directions above for creating either an SNMP or WMI monitor. 
17 You can suspend or enable data collection on that monitor by selecting or clearing the 

checkbox next to the monitor name. 
18 On the WhatsUp Gold web interface, select a device and right-click. Select Properties 

from the right-menu.  
19 On the Device Properties dialog, select Performance Monitors. 
20 Click New next to the Individual performance monitors list. 
21 Select the monitor type: SNMP or WMI. 
22 Follow the directions above for creating either an SNMP or WMI monitor. 

You can suspend or enable data collection on that monitor by selecting or clearing the 
checkbox next to the monitor name. 
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Example: monitoring router bandwidth 
Through the Performance Monitoring system, you have the ability to configure WhatsUp 
Gold to gather bandwidth usage on your SNMP enabled devices (routers, switches, etc.) and 
then track that usage through performance reports. Several Performance Monitors are 
installed with the application, but for bandwidth monitoring, the Interface Utilization monitor 
is the most useful (this will illustrate percent utilization and throughput). 

The Interface Utilization monitor gathers statistics on the volume of bytes going through the 
active interfaces on the device. You can collect data on all interfaces, active interfaces, or just 
specific interfaces. This monitor is configured and enabled through Device Properties > 
Performance Monitors. 

 Note: Before you can configure the monitor, you must have SNMP enabled on the device, 
and the proper credentials configured in the Credentials Library for the device. The 
Performance Monitoring system uses these credentials to connect to the device during the 
configuration process, and during normal performance gathering. For more information, see 
Enabling SNMP on Windows devices (on page 213).  

Configuring the monitor 
The Interface Utilization Performance Monitor is one of the default performance monitors 
installed with WhatsUp Gold, and needs no global configuration to configure the monitor for 
a single device.  

To configure the Bandwidth Monitor: 
1 Select Properties from the right-menu. 
2 Select Performance Monitors on the Device Properties dialog.  
3 Select the Interface Utilization monitor from the list. 
4 Click Configure to set up the monitor for the device. WhatsUp Gold scans the device 

and discovers the interfaces on the device. 

When the scan completes, the Configure Interface Data Collection dialog appears. If the 
credentials for the device are not configured properly, the scan will fail (return to the 
Credentials Library to fix it). If the device is not SNMP-enabled, the scan will fail. 

5 Select the interfaces you want to collect data for. From the Collect data for pull-down, 
select All, Active, or Specific. If you select Specific, select just the interfaces you want to 
monitor in the list below. By default, active interfaces will be measured. 

6 (Optional) Click Advanced to change the retry and timeout settings for the SNMP 
connection to the device. Click OK to save the changes to the Advanced Settings. 

7 On the Configure Interface Data Collection dialog, enter a time interval (in minutes) for 
how long you want the application to wait between polls. The default is 10 minutes. See, 
“Program Options - Report Data for more information on data collection and roll-up.” 

8 Click OK to save the Interface Utilization configuration. 

Viewing the data 
WhatsUp Gold will take several polling cycles to produce meaningful graphs (with a 10 
minute poll interval, this may mean a few hours). After enough data is gathered, several 
reports display this data. 
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 By Device. For device-specific data, view the Interface Utilization report; or the Device 
Status report, which shows graphical statistics of all monitors configured on a device. 

 By Group. Access the Group Interface Statistics report to view summarized statistics for 
all devices in the selected group that have interface statistics enabled. 

 System Wide. Use the Top 10 report to view the top performers in terms of bandwidth 
utilization across your network. You can also view system-wide data by running the 
Group Interface Utilization report against the All Devices dynamic group. 

 

Example: troubleshooting a slow network connection 
The real-time reporting provided by performance monitors can provide both the raw data 
and the data trend analysis that can help you isolate network problems. For example, we 
recently experienced a problem with a network connection between two of our Ipswitch 
office sites. This example shows how we used Performance Monitors to troubleshoot the slow 
network connection. 

First, the scenario is described, then the steps taken by the network administrator to solve the 
problem are outlined. 

Scenario:  
A developer working in Augusta, GA on an Atlanta-based project complained of a slow 
network connection between the Augusta and Atlanta offices. He stated it took 40 minutes to 
check-in files to the source library over the T1 connection. 

The Atlanta office network administrator reacted by completing the following steps: 

1 On the WhatsUp Gold web interface, he goes to the Reports tab to select the Ping 
Response Time report.  

2 From here, he checks the connection from the Atlanta WhatsUp Gold application to the 
Augusta primary server. The report shows an increased response time beginning at 
11:45 a.m. 

 Note: This connection has been configured with the appropriate Performance Monitors and 
has been gathering data for weeks. To set up this type of monitor for a connection, configure 
the Ping Latency and Availability monitor on a device located on the other end of the 
connection. For more information, see Configuring performance monitors (on page 211). 
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CHAPTER 15 

Monitoring Performance Data in Real 
Time 
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About Real-Time Data features 

 Note: These features are only available in WhatsUp Gold Premium Edition, WhatsUp Gold 
MSP Edition, and WhatsUp Gold Distributed Edition. 

 

The historical performance data that WhatsUp Gold tracks helps you discover and analyze 
network usage trends that have already occurred; however, at times you need to view device 
usage data immediately, in real time. 

WhatsUp Gold includes several features that enable you to monitor performance data in real 
time. 

 InstantInfo popups. Throughout workspaces and full reports, you can hover over some 
links (such as hard drive names or network interfaces) to see real-time data. 

 Web Task Manager and Web Performance Monitor. These Web-based network tools 
extend the functionality of familiar Windows tools to every device you monitor in real 
time--even for devices that do not run Windows. 

 Split Second Graphs Workspace Reports. These reports allow you to add real-time data 
into any workspace view. 

 Real-time data in Full Reports. Many full reports now include a graph that updates with 
up-to-the-minute information. This real-time data is paired with historical data to give you 
a comprehensive report. 
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Using InstantInfo popups 

InstantInfo popups provide easy access into real-time data that corresponds to the historical 
data viewed in performance workspace and full reports. The historical report data shows you 
device trends over the recent past hours, whereas InstantInfo popups provide dynamic 
graphs that show the latest device trends over the past minutes and seconds. 

To determine if real-time data is available for a report, hover over each link in the report (in 
most cases, the InstantInfo popups are triggered by the link on the second column in the 
report). If more information is available for the link, a continuously updating graph of real-
time data appears. 

 

 Important: InstantInfo popups require a minimum screen resolution of 1024 x 768 pixels, but 
is optimized for screen resolutions of 1280 x 1024 pixels and higher. 

 

Disabling InstantInfo popups 
By default, InstantInfo popups are available in both workspace and full reports, but you can 
disable them if you prefer. 

To disable InstantInfo popups: 
1 In the WhatsUp Gold web interface, click GO.  
2 If the WhatsUp section is not visible, click WhatsUp. The WhatsUp section of the GO 

menu appears. 
3 Click Configure > Preferences. The User Preferences dialog appears.  
4 Under InstantInfo (popups), clear the checkboxes for the areas where you do not want 

popups to appear. 
5 Click OK to save changes. 
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Using Network Tools to view real-time data 

WhatsUp Gold includes two network tools you can use to view real-time data on network 
devices, the Web Task Manager and Web Performance Manager. These network tools provide 
the capability to view real-time device data directly from the WhatsUp Gold web interface. 
 

About the Web Task Manager 
The Web Task Manager extends the functionality of the Microsoft Windows Task Manager to 
provide network device overview information about processes occurring on a device, device 
performance, and device interface activity. The Web Task Manager graphs and displays real-
time information using SNMP or WMI device connections.  

You can use the Web Task Manager to identify device issues and take corrective action on a 
device. 

 

There are three tabs that provide device information: 

 Processes. Provides key indicator process information for a selected device that WhatsUp 
Gold is monitoring. For example, you can view a list of .exe files that are running and the 
amount of CPU and memory used by each program. 

 Performance. Provides dynamic performance information for a selected device that 
WhatsUp Gold is monitoring. For example, you can view details about the CPU and 
memory usage.  

 Interfaces. Provides information about a selected device's interfaces that WhatsUp Gold 
is monitoring. For example, you can view a list of interfaces that the device uses learn 
about how much data is transmitted and received via each interface.  

For more information on the Web Task Manager, see Using the Web Task Manager (on page 
316). 
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 Note: The Web Task Manager shows slightly different data on the Performance tab 
depending on the type of device being monitored. For Windows devices, the information 
matches the data that is available via the Windows Task Manager 

 

About the Web Performance Monitor 
The Web Performance Monitor extends the functionality of the Microsoft Windows 
Performance Monitor to the Web. It is a data collecting and graphing utility designed 
specifically for the WhatsUp Gold Web interface that graphs and displays real-time 
information on user-specified SNMP and WMI performance counters. It can be used for a 
quick inspection of a specific network device.  

 

The graphs can be saved to the database and displayed on workspace views using the Split 
Second Graph - Performance Monitor workspace report or on the Web Performance Monitor 
tool. Multiple SNMP and WMI counters can be displayed on a single graph, and the color and 
scale of each graphed item can be individually configured.  

Graphs created with the Web Performance Monitor are saved on a per-user account basis, 
meaning, graphs are only accessible by the user account that created and saved them. 
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The Web Performance Monitor has two purposes: 

 To provide a Web enabled WMI and SNMP performance counter poller and grapher. It 
supports WMI for Windows servers, and SNMP for network devices such as switches, 
routers, and UNIX devices. 

 To build and edit graphs for use by the Performance Monitor workspace report. You can 
use this workspace report to display any saved graph. 

For more information, see Using the Web Performance Monitor (on page 313). 
 

Using Split Second Graph Workspace Reports 

With Split Second Graph Workspace Reports, you can embed the real-time data that is 
available from InstantInfo popups, the Web Task Manager, and the Web Performance Monitor 
into any workspace view. 

For information on how to add a Workspace Report to a workspace view, see Adding 
workspace reports to a workspace view (on page 268). 
 

Using the Performance Monitor workspace report 
The Performance Monitor workspace report allows you to add a graph that you create in the 
Web Performance Monitor to a home workspace view. 

To use the Performance Monitor workspace report: 
1 In Web Performance Monitor, create and save the graph you want to use in the 

Performance Monitor workspace report. 

a) From the web interface, click GO. The GO menu appears. 

b) If the WhatsUp section is not visible, click WhatsUp. The WhatsUp section of the GO 
menu appears. 

c) Select Tools > Web Performance Monitor. The Web Performance Monitor appears. 

d) From the Graph menu, add the WMI and SMP counters that you want to graph. 

e) After the graph is configured to show the data you want to see in the Performance 
Monitor workspace report, select File > Save Graph as. The Save Graph dialog 
appears. 

f) Enter a name for the graph, then click OK. Your graph is saved and ready to use in the 
Performance Monitor workspace report. 

2 Add the Performance Monitor workspace report to a home workspace view. 

a) From any home workspace view, click Add Content. The Add Content to View dialog 
appears. 

b) Expand the Split Second Graphs section, select Performance Monitor, then click 
OK. The dialog closes and the home workspace view appears with the new 
Performance Monitor workspace report added. 
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c) On the new Performance Monitor workspace report, click Menu > Configure. The 
Configure Line Chart dialog appears. 

d) In Graph name list, select the graph you created. You can optionally configure any 
other options on this dialog to your preferences.  

e) Click OK. The dialog closes and the home workspace view appears with your custom 
Web Performance Monitor graph displayed in the Performance Monitor workspace 
report. 

 

Viewing Real-time Data in Full Reports 

For all full reports where real-time data is available, a second graph appears below the graph 
showing historical data. This second graph displays poll data for the report in real-time, 
updating every second. 
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About Active Discovery 

With Active Discovery, you can schedule WhatsUp Gold to scan your network for new 
monitors (active monitors and performance monitors) and devices on a regular basis. Newly 
discovered items are added to the Active Discovery Results report, and WhatsUp Gold notifies 
you that a new device was found, or a new monitor was found on an existing device. You can 
then review the report and select the items you want to add to your device list. 

Active Discovery works with two types of device discovery: 

 SNMP SmartScan. WhatsUp Gold discovers devices by reading SNMP information on 
your network. This scan type uses an SNMP enabled router to identify the devices in your 
network and also identifies subnetworks within your network. 

 IP Range Scan. WhatsUp Gold scans a range of IP addresses and finds the devices that 
respond to a message sent via the Internet Control Message Protocol (ICMP). 

If the scan finds results, an email is generated and sent to the address you provide during 
Active Discovery configuration. The email contains links to the reports that are populated by 
the scan:  

 Active Discovery Log shows the success or failure of the Active Discovery task, and any 
devices and/or Monitors found during that scan. 

 Active Discovery Results shows all new items found in the latest scan, or all unprocessed 
items from previous scans. Through this report, you can add devices to the device list and 
new monitors (Active Monitors and Performance Monitors) to the device monitors. 

If an email notification is not specified (in the wizard), these reports are also available in the 
System report list, on the Reports tab. 
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Configuring Active Discovery 

To configure an Active Discovery Task: 
1 From the console main menu, select Configure > Active Discovery. The Active 

Discovery dialog appears. 

 
2 Click New to add a new task, or select an existing task and click Edit. 
3 If you are adding a new task, follow the wizard to create the task. 

- or - 

If you are editing a task, you must click the sections you want to make changes to. 

4 After the wizard is complete or your change edits are complete, the task is processed 
according to the schedule you set for the task. 

For more information on how to test your new task, see Testing Active Discovery tasks (on 
page 232). 

Scanning for new services on existing devices 
If you want to scan the devices currently in your databases for new services, make sure that 
you select the Scan for new services on existing devices option.  

Clear the Scan for new services on existing devices option to keep your existing devices 
from being scanned. 
 

Example: configuring Active Discovery 
In this example, we set up an Active Discovery task to scan our Atlanta network every 
morning and send an email update to the network administrator. 

To configure an Active Discovery task: 
1 From the WhatsUp Gold console, select Configure > Active Discovery. The Active 

Discovery dialog appears. 
2 Click New to add a new Task.  
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We completed the Add Active Discovery Task wizard example as follows: 

Wizard screen Settings 

General Task Name: Atlanta Network Sweep 

Description: Daily scan of Atl net 

Scan for new services on existing devices (selected) 

Schedule Enable Schedule (selected) 

Schedule Time: 8:00 AM 

Days: All days selected 

Notification Enable Email Notification (selected) 

Email address: netadmin@ipswitch.com 

Outgoing mail (SMTP) server: 192.2.200.10 

Port: 25 

From: whatsup@ipswitch.com 

Scan Type SNMP SmartScan (selected) 

SNMP SmartScan 
Settings 

SNMP enabled router: 192.168.2.1 

SNMP read communities: public 

Windows credentials: none 

Active/Performance 
Monitors 

Select Active Monitors to be used in the scan process: FTP, HTTP SMTP, 
Ping 

Select Performance Monitors to be used in the scan process: CPU 
Utilization, Disk Utilization, Interface Utilization 

 Important: If you want to scan the devices currently in your databases for new services, 
make sure you select the Scan for new services on existing devices option. Clear the 
option to keep your existing devices from being scanned. 

3 Click OK to complete the wizard. The new task is displayed in the Active Discovery 
dialog. 
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e Discovery results (devices, services, or monitors found) you want to add to 
your device group, then click Add. 

 

Enabling and disabling an Active Discovery task 

To stop an Active Discovery task from being executed: 
1 From the WhatsUp Gold console main menu, select Configure > Active Discovery. The 

Active Discovery dialog appears. 
2 Select the task you want to stop, then click Edit. 
3 Select the Schedule section. 
4 Clear the Enable Schedule option to stop the task from being processed according to 

the schedule. 
5 Click OK to return to the Active Discovery dialog. 
 

To test an active discovery task: 
y. The 

2 Select the task you want to test and click Test. 
 for that Task. After the task is 

o return to the Active Discovery dialog. 

4 From the email, click the Active Discovery Results link to view the report.  
5 Select th

Testing Active Discovery tasks 

1 From the WhatsUp Gold console main menu, select Configure > Active Discover
Active Discovery dialog appears. 

3 WhatsUp Gold scans the network based on the settings
complete, the Active Discovery Results dialog appears. 

4 Review the dialog, then click OK t

 Note: The results of the Active Discovery test scan are not stored in the database and cannot 
be processed. 
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Using the Map View 

Map View shows a graphical representation of the devices in a group. Map View can be used 
to: 

 Organize devices into user-specified groups, for example, all HTTP servers. 

 Customize individual device icons such as workstations, containers, routers, and bridges. 

 Indicate relationships among devices by using annotation objects such as rectangles, 
ellipses, text, and "attached" or "free" lines to. Annotation objects let you organize your 
map to best represent your network. Attached lines show a connection between devices 
and move with the device. 

 Show status of network link lines. 

Map View is accessed on the Devices tab under View > Map View. 
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About the Map View 

Map View shows a graphical representation of your devices. As in Device View, each device's 
icon provides information about its device type and status. Map View can also show the 
status of network interfaces (by using link lines) and provide visual indications of polling 
dependencies. 

 

 

Current device state is shown by the color and shape of a device icon. 

 Device ASA is a workstation that is currently up. 

 Device HRA is a workstation that is currently in maintenance mode. 

 Device JMA is an FTP server that is currently down. 

 Device PDA has missed a poll, but has not yet missed enough polls to be considered 
down. 

 Devices ASA, HRA, RRA, JMA, and PDA are "Up" dependent on Router 1, as shown by the 
green arrows pointing to the Router 1 device. These devices get polled only if Router 1 is 
Up. 

 

In addition, device icons can show complex states. For example, the icon to the 
left shows a device that is accessible but has a  monitor that is reporting as 
down. 

You can also use Map View to: 

 Indicate relationships among devices by using annotation objects. 

 Change the layout of devices and annotations. 
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Passive Monitors Icon 
When a passive monitor is configured on a device, the device icon displays a diamond shape 
on the upper left side.  

 

urs on the monitor. 
 appearance. 

This shape changes color when an unacknowledged state change occ
Once the device has been acknowledge, the icon returns to the above

 

For more information, see Using Map View (on page 233). 

Map Limitations 
By default, WhatsUp Gold will not display a map with more than 256 devices. You can change 

l cause lengthy delays this default within the registry keys, with the understanding that it wil
by specifying larger device defaults. 

 Important: The more devices you allow on a map, the longer time you will wait for the map 
to load. 

To change map device limitations: 

1 Go to HKEY_LOCAL_MACHINE\Software\Ipswitch\Network Monitor\WhatsUp 

Change the MapView-MaxDevices registry key to a number greater than 256 
Gold\Settings. 

2 
(Decimal). 

 Note: If you want to change the text that displays when you reach the maximum device limit, 
you can change it in the MapView-MaxDevicesMessage registry value. The default text is: 
There are more devices on this Map than can be |drawn in a reasonable 
time. Use the Device List |to manage devices for this Group. | |To 
increase the maximum of (%ld) devices that |can be drawn per Map, look in 
the online help |system for Map Device Limits. 
The pipes (|) in the default text indicate line breaks in the text and the (%ld) is a variable for 
the MapView-MaxDevicesMessage value. 
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Using map display options 

elect 

. By default the map will show an icon for each device. If you only want to 
show a dot, or node, to represent each device, then clear this selection. 

 Polling Dependency Arrows. If you have set up a device so that it gets polled only if a 
second device is down or up (a dependency), then by default you will see an arrow that 
shows this dependency. For example, if polling of device A is dependent on the state of 
device B, the arrow will point from device A to device B. 

 Unconnected Links. Select this option to make the map display short lines for links that 
are not connected anywhere. If this is cleared, only connected links are displayed. This 
could be a network interface that is not connected to another device. It could also be any 
active monitor (such as HTTP, or SMTP), in which case, the short line will show green when 
up and red when down. 

 Snap to Grid. Select this option to display a grid and automatically align objects along 
your grid when they come within a certain distance of it. 

 Clip Device Names. Select this option if you want to shorten the device display names. 
The display names will be terminated at the first space or period in the name. If the 
display name is a dotted decimal IP address, Clip Device Names shows only the last digits 
of the IP address. 

 Wrap Device Names. Select this option to wrap long display names. The display names 

 

s, 

toolbar, click the Select (arrow) tool, then click in the Map view and drag the 
cursor to d

2 Then selec  
on the current map in equally spaced rows starting in the top left corner. 

Other ways to arrange map objects include: 

Order. You can arrange which annotations are moved to the foreground or background. 

n edge or centerline. 

s so they are spaced evenly along a line. 
You can arrange icons in a radial format, in rows, or by links. 

 Grouping. You can group selected annotations so that they can be arranged or moved as 
a unit. 

 Flip. You can transpose the location of two selected annotations. 
 

Display options let you change the visual representation of a map, and add annotations that 
help you monitor dependencies and active monitors. Right-click on the Map View, then s
from the following Display options. 

 Device Icons

will be wrapped at every space or period in the name. 

Using Arrange options 

Use the Arrange options to position device icons and annotations (such as lines, rectangle
text) on a map. 

For example, you can automatically arrange device icons: 

1 In the 
raw a box around the icons you want to select. 
t Arrange > Arrange All Device Icons. This feature arranges all device icons

 
 Align. You can arrange icons or annotations so they share a commo

 Distribute. You can arrange icons or annotation
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Orga

 View has a number of options you can use to organize your view of 
devices. Arrange options are available from the Arrange menu on the main menu bar and 
right-click menu. Display options are available from the View menu on the main menu bar 
and the right-click menu. 

Try the different functions on the Arrange menu until you are satisfied with the device layout. 

g 

1 Select the device group, then click the Map View tab. 
2 Right-click in the Map View, then select Display > Clip Device Names. This removes the 

domain part of the device name and shows only the host name. 
3 Select all devices in the view by clicking and dragging a selection box around all 

devices. Then, from the Arrange menu, select Distribute > Device Icons in Rows. 

pology specific to your network, 
hics annotations (such as lines, text, circles) and attached lines to 

s. 

Using device types 

The Device pool provides "Device Types" for ten standard device types; and some custom 
that have been created. When you click one of these 

 add the device to the map, select and drag it to the 

Using grid properties 

Set th

To vi

 S

 ts 
 a certain distance of it. 

 Increase the number of gridlines. This allows you to display more gridlines, letting 
you place items closer together when using Snap to the grid. 

 Decrease the number of gridlines. This lowers the number of gridlines on your map 
view, spacing them further apart when using Snap to the grid. 

 

nizing devices 

In the console, the Map

For example, to clean-up a map, after completing discovery, you can try the followin
display options: 

If you have a large set of devices or want to represent a to
you can also use the grap
create custom map view

Lock position can be useful in positioning objects on the map. 
 

host types. It also displays any galleries 
devices, it becomes the active tool. To
map. 
 

ese properties from the WhatsUp Gold console Map view toolbar.  

ew the toolbar:  

elect View > Toolbars > Grid. 

Snap to the grid. Select this option to display a grid and automatically align objec
along your grid when they come within
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Grouping objects 

The Group function lets you change the layout of multiple map annotations in the Map view. 

 Group. Allows multiple objects to be grouped together as a single object, which will make 
all of the objects react to drawing transformations as one. 

re 
bject was 

 Ungroup. Undoes the group effect so that all the objects that were originally grouped a
now separated objects once again. All transformations done when the o
grouped are kept when the object is ungrouped. 

 Note: You can also use these features together. For example: You could take 4 different 
objects and group them together to form 1 object. Then you could take the grouped object 
and flip it horizontally or vertically. 

 

Locking the position of map objects 

 the map. If you want to change an object position on the map, remove 

To change the font used in maps: 
t selection dialog box.  

n. 

Organizing devices 

To lock objects on the map:  

 Right-click and select Lock Position from the menu.  

Lock Position keeps an object from moving as you move other items around, or when 
adding devices to
the "lock position" selection. It is helpful to lock images or text you place in the 
background to protect them from changes. 

 

Mapping fonts 

You can specify the font used for device display names.  

1 Click Change Font to open the standard Windows fon
2 Select the font properties you want to use and click OK.  
3 The Sample Label (AaBbYyZz) shows the new font selectio
 

Map View has a number of options you can use to organize your view of devices. Arrange 
options are available from the Arrange menu on the main menu bar and right-click menu. 
Display options are available from the View menu on the main menu bar and the right-click 
menu. 

Try the different functions on the Arrange menu until you are satisfied with the topology. 
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If you have a large set of devic
you can also use the graphics

es or want to represent a topology specific to your network, 
 tools to create custom map views. 

View and select Display > Clip Device Names. This removes the 
domain part of the device name and shows only the host name. 

) 
ctive 

For example, to clean-up a map, after completing discovery, you can try the following 
display options: 
1 Select the device group, and click the Map View tab. 
2 Right-click in the Map 

3 Select all devices in the view by clicking and dragging a selection box around all 
devices. Then, from the Arrange menu, select Distribute > Device Icons in Rows. 

 

Using link lines 

You can use Link lines to get a graphical view of the network link (the Interface service
between two devices. Link lines can also show the status of any service which has an A
Monitor on the device. 

The following example shows a map with link lines displayed. 

 

 connecting link lines: 

Manually, in the Map View select a device, then right-click the Link > Link to option on 
etween devices) 

to display a link line, then click OK. The link line 
 

vice and click to create a link. 

There are three ways to set up the

1 
the context menu. (Click Link > Disconnect link to remove the link b

a) Select a monitor for which you want 
cursor appears.

b) Drag the cursor to another de

2 Automatically, during device discovery when using SNMP SmartScan (Click File > 
Discover Devices > SNMP SmartScan) 

 Note: The Interface service must be included in the scan. 

3 Automatically, when you right-click a device, then click Properties > Active 
Monitors > Discover. 
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 Note: When you use one of the automatic discover options, particularly when discovering 
interfaces on a router or switch, you need to enter the SNMP community string in the 
appropriate scan dialog. This lets the scan identify all the interfaces on the device. 
If scanning a specific device (from the Device Properties > Active Monitors dialog), with 
the device selected, right-click Properties, then select Credentials. In the SNMP v1/v2/v3 
credentials box, select the Public Read Community. Click Active Monitors, then click 
Discover. 

When creating links manually, you are always creating a connected link. If there was an 
unconnected link for the service, it will be replaced by the connected link. 
Bot   device h connect and disconnect skips the dialog if there is only one active monitor on the

se it assumes you meant that monitor. becau

 

, there are two link lines connected by a dot in the center of the line 
between the two devices. This shows that the devices are linked both directions. This is done 

back to the first. Now, when one of 
the links goes down, you can see on which side the problem occurs.  

en you move two devices 
attach lines also move. Attach lines are visual 

representations assigned by the user, and not a reflection of a true connection between the 
ion between the two devices is done with Link lines. 

To draw an attached line: 

een the two devices. 

In the graphic above

by repeating the process above from the second device, 

 

Using attached lines 
Attached lines show an arbitrary connection between devices. Wh
that are connected by attach lines, the 

two devices. The true connect

1 In the Map View, right-click a device. The right-click menu appears. 
2 Click Attach > Attach to. A line displays next to the cursor. 
3 Click the device icon you want to attach to. WhatsUp Gold draws an attached line 

betw

 Note: Each device can attach to up to five other devices. 
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necting links Con

 lines from one device to another. If two devices have mutual links, the 
t is up and the other is down). The 

to 

If the red part of the line touches "System A" and the green part of the line touches "System 
 some service on "System A" is the problem. 

About unc
 

 router. They are drawn as short lines extending out from the host. 
The first unconnected interface is drawn straight up ("12 noon") and the rest are evenly 

ose to display or not display 
the unconnected links. 

As these unconnected links show any service for which the device has an active monitor, you 
can use this feature to show a visual status of the services. For example, though the device is 
up (green), you may see that one of the unconnected links is down (red) and will know to 
check the services on the device. 
 

Showing unconnected links 
Unconnected links must be shown for all or none of the devices in a map.  

To show unconnected links for all devices: 
1 Right-click in Map View to display the pop-up menu. 
2 Then, select Display > Unconnected Links. 

teps to disable Unconnected Links. 

 not connected to another device. It could also be any active monitor 
(such as HTTP, or SMTP), in which case, the short line will show green when up and red when 

Connecting links represent a service, for example an interface, that connects two devices. 
They are drawn as
single line can consist of more than one color (if one objec
center-point of the line back to the up object is green, while the other half of the line going 
the down object is red. In essence, the color of the line represents the state of the service on 
the host that the color touches.  

Example 

B", then we know that
 

onnected links 
Unconnected links represent a service that is not connected to some other host, for instance
an unused interface on a

distributed around the host in a clockwise fashion. You can cho

Repeat these s

The Unconnected Links option makes the map display short lines for links that are not 
connected anywhere. If this is cleared, only connected links are displayed. This could be a 
network interface that is

down. 
 

  241 



Using WhatsUp Gold v12.3 

  242 

Creati
There

1 M n 
th  

a) onitor for which you want to display a link line, then click OK. The link line 
cursor appears. 

Click File > 

ng connected link lines 
 are three ways to set up the connecting link lines: 

anually, in the Map View select a device, then right-click the Link > Link to option o
e context menu. (Click Link > Disconnect link to remove the link between devices)

 Select a m

b) Drag the cursor to another device and click to create a link. 

2 Automatically, during device discovery when using SNMP SmartScan (
Discover Devices > SNMP SmartScan) 

 Note: The Interface service must be included in the scan. 

3 Automatically, when you right-click a device, then click Properties > Active Monitors 
> Discover. 

 Note: When you use one of the automatic discover options, particularly when discovering 
interfaces on a router or switch, you need to enter the SNMP community string in the 
appropriate scan dialog. This lets the scan identify all the interfaces on the device. 
If scanning a specific device (from the Device Properties > Active Monitors dialog), with 
the device selected, right-click Properties, then select Credentials. In the SNMP v1/v2/v3 
credentials box, select the Public Read Community. Click Active Monitors, then click 
Discover. 

 When creating links manually, you are always creating a connected link. If there was an 
unconnected link for the service, it will be replaced by the connected link. 
Both connect and disconnect skips the dialog if there is only one active monitor on the 
device because it assumes you meant that monitor. 
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Changing 

Changing how long report data is stored................................................244 

Changing the device state colors or icons ..............................................24

Changing clock/regional preferen
 
 

ging the date and time format 

To change the date and time format: 
From the WhatsUp Gold main menu, select Configure > Progra

2 Select the Regional section. 

 
3 For each of the three date formats, select the one that best suits your needs. 
4 Click OK. 

These formats can be seen in use on several of the reports available on the Reports view. 
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Changing how long report data is stored 

atabase to populate the Ping Active Monitor data is stored in the WhatsUp Gold d
Performance reports available in the application. 

1 From the main menu, select Configure > Program Options. 
2 In Program Options, select Report Data. 

 
n the Report Data section, you can change the settings for raw data, hourly data,
ily data. 

OK to save the changes. 

3 O  and 
da

4 Click 

You can see how many rows in the database that the data takes up by viewing the numbers 
under the time settings. 
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Changing the device state colors or icons 

1 From the main menu, select Configure > Program Options. 

To change the device state colors or icons: 

2 In Program Options, select Device States. 

 
3 To change an existing icon or state, select the entry from the list and click Edit. 
4 Adjust the shape and color of the icon using the settings in the Device State Editor. 
5 Click OK to save changes. 

If the default settings do not fit your needs, click Add to create a new device state, using the 
internal state and state time that you need. 
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Changing clock/regional preferences 
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nfigure > Program Options. 

To use a 24-hour clock instead of the default 12-hour clock: 
1 From the WhatsUp Gold main menu, select Co
2 Select the Regional section. 

 
Select the Use 24 hour clock option. 3 

4 Click OK. 
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ta that has 

In This Chapter 

Learning about full reports 

Full reports are used to troubleshoot and monitor performance and historical da
been collected during the operation of the application. 
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  From the WhatsUp Gold console, you can access full reports by clicking the Reports
button on the console toolbar.  

en down by the scope and the type of  information 
displayed within each report. 

There are three categories for full reports based on the scope of information displayed: 

 System. These reports display system-wide information. System reports do not focus on a 
particular device nor a specific device group. For example, the General Error Log and the 
Web User Activity Log are system reports. 

 Group. These reports display information relating to a specific device group. For 
example, the Group State Change Timeline and the Group Actions Applied reports are 
group reports. 

 Device. These reports display information relating to a specific device. For example, the 
Device Status Report is a device report. 

There are three categories for full reports based on the type of information displayed: 

 Performance. These reports display information gathered from WMI and SNMP 
Performance Monitors regarding your network devices' CPU, disk, interface, and memory 
utilization; and ping latency and availability. For example, the Device Custom 
Performance Monitors and the Group Memory Utilization reports are performance 
reports. 

Report categories 
Reports in WhatsUp Gold are brok

 Note: By default, performance data is not collected for the monitors assigned to the devices 
in your database. To begin collecting performance data for a device, right-click on a device 
on the Devices tab and select Properties from the context menu. In the Device Properties 
dialog, select Performance Monitors and choose the monitors you want to apply to the 
selected device. 

 Problem Areas. These are troubleshooting reports that allow you to investigate network 
issues. For example, the Group Active Monitor Outage and the Passive Monitor Error Log 
are problem area reports. 

 General. These reports display information on your WhatsUp Gold settings and 
diagnostics, as well as device-specific and user-configured details. For example, the 
Home, Top 10, and Device Status workspaces/full reports are general reports. 

Advantages of full Reports 
 Larger than workspace reports, full reports give you a larger data view, which can be 

useful in pin-pointing the time an event occurred or viewing multiple graphed items. 
Many workspace reports link to full reports, so that you can view this larger data view to 
troubleshoot. 

 The date range on full reports can be zoomed in or out so that you can get a smaller or 
larger picture of what's going on with an aspect of the network.  
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 A list in the upper-right corner of a full report screen allows you to navigate to other 
n the same category. When you use this list to navigate to another report, the 
ge selected in the report you are navigating away from is transferred to any 

 exported to Microsoft Excel or to a formatted text 

 

Ab ts 
ot focus on a particular 

device nor a specific device group, but rather all devices that fall under a certain category. For 
occurred on your 

reports i
date ran
report you view subsequently. 

 Much of the data in full reports can be
file. 

out System Repor
System reports display system-wide information. System reports do n

example, when choosing to view the General Error Log, all errors that 
network are listed, regardless to which group a device belongs. 

When viewing a system report, take note of the features made available to you to enhance 
your report viewing experience: 

 

iddle of the page allows you to easily change 
the time period for the report you are viewing. 

l full reports. 

To the right of the More System Reports drop-down are the report icons: 

 Export. Allows you to export a report into text or Microsoft Excel. 

 Favorites. Allows you to add a report to your list of Favorites. 

 Help. Brings up the WhatsUp Gold help system. 
 

Ab
ple, when 

se to which group the 

When viewing a group report, take note of the features made available to you to enhance 
your report viewing experience: 

 

The report Date/Time Picker located in the m

The More System Reports drop-down menu allows you to easily jump to other system 
reports, or to bring up the report picker to select from al

out Group Reports 
Group reports display information relating to a specific device group. For exam
choosing to view the Group Actions Applied report, you must choo
report applies and will view only Actions applied in that specific group. 
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Along with the Date/Time Picker and the report icons also available to you when view g 
system reports, there are two other features unique to group reports. 

in

 The More Group Reports drop-down menu allows you to easily jump to other group 
 the report picker to select from all full reports. 

e 
e 

 

 device, only CPU utilization information is 

you to enhance 

reports, or to bring up

 The All Devices button, located to the right of the Reports tab, brings up the Devic
Group Picker dialog. From this dialog you can choose a group for the report you ar
viewing. 

About Device Reports 
Device reports display information relating to a specific device. For example, when choosing 
to view the CPU Utilization report for a specific
listed for the specific device you choose for the report. 

When viewing a device report, take note of the features made available to 
your report viewing experience: 

 

Along with the Date/Time Picker and the report icons also available to you when viewin
system and group reports, there are a few other features unique to device reports. 

g 

 The More Device Reports drop-down menu allows you to easily jump to other device 

 T  
ch

 T rties button to the right of the Device Picker button brings up the 
Device Properties for the device-in-context. 

The following is a list of all reports that are available in Ipswitch WhatsUp Gold v12.  

Description 

reports, or to bring up the report picker to select from all full reports. 

he Device Picker button located directly to the right of the Reports tab allows you to
ange the device-in-context for the report you are viewing. 

he Device Prope

 The Chart Properties button allows you to change the graph properties. These property 
configurations are user-specific. 

 

List of full reports 

System reports Type 

Action Log Problem Area A record of all Actions that WhatsUp attempts to fire. 

Active Discovery Log General A record of all Active Discovery task results. 

Activity Log General A history of system-wide configuration and application 
r initialization messages generated by WhatsUp Gold fo

the selected time period.  

General Error Log  Problem Area A record of error messages generated by WhatsUp. 
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System reports Type Description 

Passive Monitor Error Log  Problem Area A record of Passive Monitor errors reported by WhatsUp. 

Performance Monitor Error Problem Area A record of Performance Monitor errors reported by 
Log  WhatsUp. 

Rec  Action Log  General Results of Recurring Action executions. urring

Recurring Report Log General Results of Recurring Report executions. 

Remote Site Log Problem Area A record of messages generated by Remote Server 
connection attempts.  Available in WhatsUp Gold MSP 
and WhatsUp Gold Distributed editions. 

Remote Site Status Problem Area View the Remote Location State of devices and Act
Monitors. Available only 

ive 
in the central installation of 

WhatsUp Gold MSP and WhatsUp Gold Distributed 
editions. 

SNMP Trap Log Problem Area A history of SNMP traps that have occurred during the 
selected time period. If the SNMP Trap Passive Monitor 
Listener is configured to listen for messages, any 
messages received are recorded in the SNMP Trap Log. 

State Change 
Acknowledgement 

Problem Area When a device state changes, regardless of any action 
that has been placed on the device, WhatsUp Gold uses 
the Acknowledgement feature to make you aware that 
the state change occurred. This report can be used to 
view the devices which require acknowledgement and 
then acknowledge them. 

Syslog Entries Problem Area Syslog events logged during the selected time period. If 
 

ges received are recorded 
in the Syslog Entries log. 

the Syslog Passive Monitor Listener is configured to
listen for messages, any messa

Web User Activity Log General Shows the history of user activity on the system. 

Windows Event Log Problem Area Shows Windows events logged for all devices during the 
 Windows Event Passive 
red to listen for messages, any 

ceived are recorded in the Windows Event 
Log. 

selected time period. If the
Monitor Listener is configu
messages re

 

Group reports Type Description 

Actions Applied  General The Group Actions Applied report shows how Actions 

Monitor and state that triggered it. 

are applied to devices and Monitors in the current 
group.  Each entry shows an action and the device, 

Active Monitor Availability  Problem Area Compare the amount of time the Active Monitors on 
your devices have been available. 

Active Monitor Outage  Problem Area Compare the amount of time the Active Monitors on 
your devices have been down. 
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Group reports Type Description 

CPU Utilization  Performance CPU utilization statistics for devices by group. 

Dis  Utilization  Performance Disk space utilization statistics for devices by group. k

Health Problem Area The current status of monitored devices in the select
group, along with each Monitor configured to those
devices. 

ed 
 

Interface Utilization  Performance Interface traffic and utilization for devices by group. 

Memory Utilization  Performance Memory utilization statistics for devices by group. 

Ping Availability  Performance Ping availability statistics for devices by group. 

Ping Response Time  Performance Ping response times for devices by group. 

Quarterly Availability 
Summary  

General Shows the availability summary for a group. 

State Change Timeline  Problem Area A timeline of when each Monitor on a device in the 
selected group changed from one state to another 
during the selected time period. 

State Summary  General A summary of device states organized by device group. 

 

Device reports Type Description 

Active Monitor Availability  Problem Area Find out when the Active Monitors on your device have 
been accessible. 

CPU Utilization  Performance CPU utilization statistics for a device. 

Cus  devices collected by tom Performance Performance View information on your
Monitors Performance Monitors. 

Dev led look at a specific device. ice Status  General A detai

Disk Utilization  Performance Disk space and utilization statistics for a device. 

Hea rea Displays the current status (a snapshot) of the selected 
device and all Monitors on that device. Each Monitor 
shows its own device state, the current status of each 
item, how long the device has been in that status, and 
the time that status was first reported. 

lth  Problem A

Interface Utilization  Performance Interface traffic and utilization statistics. 

Memory Utilization  Performance Memory statistics for a device. utilization 

Performanc
Log  

e Monitor Error l Problem Area A record of Performance Monitor errors for an individua
device. 

Ping Availability  Performance Availability statistics for a device. 

Ping Response Time  nce Performa Ping response times for an individual device. 
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Device reports Type Description 

SNMP Trap Log  Problem Area A history of SNMP traps that have occurred for the 
selected device during the selected time period. If the 
SNMP Trap Passive Monitor Listener is configured to 
listen for messages, any messages received are recorded 
in the SNMP Trap Log. 

State Change Timeline  Area h Monitor on 
the selected device changed from one state to another 

Problem This report shows a timeline of when eac

during the selected time period. 

Syslog Entries  Problem Area r the selected 
device during the selected time period. If the Syslog 

 

This report shows syslog events logged fo

Passive Monitor Listener is configured to listen for 
messages, any messages received are recorded in the
Syslog Entries Log. 

Windows Event Log Problem Area This report shows Windows events logged for the 

 
selected device during the selected time period. If the 
Windows Event Passive Monitor Listener is configured to
listen for messages, any messages received are recorded 
in the Windows Event Log. 

 

About 

Report es dialog called the report 

report refresh interv

s are refreshed at an interval specifi
al. The defaul h

als 

ed in the User Preferenc
refresh interv t report refres  interval is 120 seconds.  

 

 Note: The report refresh interval is user er account  specific and is only applied to the us
logged-in at the time the change is made. 
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To change the report refr terval: 
ser Preferen

e web inter . 

If the WhatsUp sect
menu appears. 

 Select Configure >Preferences. 

e chang
 

Print rting a

e print any c l. In some 
orted reports show more detailed data than that of the data displayed in the report 

mp ing 
data point with higher precision. For eithe de 
JavaScript must be enabled. Full reports c . 

To print a full report: 

to print: 

nywhere in he repor
 s

On the Print dialog, click Print, or select File > Print. 

dialog, click 

t a full report to text: 

 the full repo ish to 

ort Toolbar o
the Export Report d x

3 Clear or select the following options: I
either include or remove the report tit

4 Choose a Column delimeter from the
5 Choose a Text qualifier from the drop-down menu. 

ort the . 

To export a full report to Microsoft Excel: 

 viewing the full report you wish to e

rt Toolbar o
eport d x

3 Clear or select the following options: Include report title, Include column names to 
either include or remove the report title or column names from the exported file. 

4 Click OK to export the report to Excel. 

esh in
1 Open the U ces dialog. 

 From th face, click GO The GO menu appears. 

 ion is not visible, click WhatsUp.  The WhatsUp section of the GO 

2 Enter a new time (in seconds) for the report refresh interval in the Full report field. 
3 Click OK to sav es. 

ing, expo , and s ving full reports 

All full reports can b
cases, exp

ed and m an be exported into text or Microsoft Exce

in Report View. For exa le, an exported report my contain more data columns, or a float
r the print or export functions to work, client-si

an also be saved for later review

While viewing the full report you wish 

1 Right-click a side t t window.  
2 From the right-menu, elect Print. 

3 On the Print Print. 

To expor

 While viewing rt you w export: 

1 On the Rep , click the Exp rt button. 
2 On ialog, select E port to Text. 

nclude report title, Include column names to 
le or column names from the exported file. 
 drop-down menu. 

6 Click OK to exp report to text

While xport: 

1 On the Repo , click the Exp rt button. 
2 On the Export R ialog, select E port to Excel. 
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To save a full report: 

he full repo  s

1 Select File > Save As. 
2 In the Save Web Page dialog, browse 

Save in box. 
 in th o

4 Choose the type of file you wish to sa
5 Click Save. 

Report column sizing and 

ns can u dge 
of the report title box and moving it eithe

Wh column is resized, the new
viewed. 

Most full report columns can be sorted. You can sort by left-clicking a column heading. The 
 ascending or descending. The column's 
ward pointing arrow.  

While viewing t rt you wish to ave: 

to the location you wish to save your file from the 

3 Give the file a title e File name b x. 
ve the report as from the Save as type box. 

 

sorting 

All full report colum  be resized. Yo  can resize a report column by clicking on the e
r left or right. 

 size is saved and used again each time the report is en a report 

report column then automatically sorts itself either
sort direction is indicated with an upward, or down

 

As in column sizing, column sorting settings are saved and are used again each time the 
report is viewed. 

sorting are maintained on a per user basis, and only for the report in 

Changing the report date range 

Date/Time picker 
Most full reports have a date range selection tool (date/time picker) that you can use to 
change the range of data you are viewing in the report. This tool is useful in controlling the 
amount of information that you are viewing on a report. 

You can select both start and end times for the report. 

Both column sizing and 
which the column changes are made. 
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You can select from the following date ranges: 

 Last 8 hours 

 Last 7 days 

 

nt date range in or out by selecting the zoom 
trol moving the selected date range 

 Today 

 Yesterday 

 Last week 

 Last month 

 Week to date 

 Month to date 

 Last 4 hours 

 Last 3 days 

 Last 30 days 

 Custom 

The date and time format for full reports matches the format specified in Program Options >
Regional. 

Zoom tool 
The Zoom toolbar allows you to zoom the curre
in our zoom out icons. The arrows on the toolbar con

y. forward and backward one calendar da

 

Clicking outside the chart 
Another way to move the report date backward and forward is to click in the space outside of 

the chart will move the selected date 
ted date backward. 

Ad

isit certain reports more than 
ports to your list of favorites so that you can 

eports tab. 
 side of the report page. 

port(s) you wish to remove from your list of 
favorites. 

the chart report. Clicking the space to the right of 
forward, while clicking to the left will move the selec
 

ding a report to your list of favorites 

As you're viewing reports, you may find that you tend to v
others. WhatsUp Gold allows you to save these re
easily navigate to them. 

To add a report to your list of favorites: 
1 Select a report to view from the WhatsUp Gold R
2 Click the Favorites button located in the upper right

To remove a report from your list of favorites: 
1 Navigate to your list of favorites from the Report Overview page. 
2 Click the Remove button next to the re
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Usin

ail addresses at regularly scheduled intervals. This feature provides a way to 
eam members who need reports at specified 

ated or 
rchived Web Page (.mht) file.  

To create a new Recurring Report: 

g Recurring Reports 

Recurring reports let you send a "snapshot" of selected WhatsUp Gold Workspace Report or 
F ll Report to emu
easily receive reports or send them to other t
intervals. Recurring reports can be sent either in the body of the email message gener
as an attached A
 

Configuring Recurring Reports 

 Important: Recurring reports for workspace reports that include Split Second Graphs display 
a user rights error. Currently, Split Second Graphs are not supported in recurring reports. 

 Note: Recurring reports are sent in a fixed format that cannot be modified. They may not 
appear as expected, depending on your email client and your email preferences. If this is the 
case, you can send the reports as attachments. Recurring reports of workspace reports can 
only be sent as attachments. 

1 From the WhatsUp Gold console, select Configure > Recurring Reports. 
2 On the Recurring Reports dialog, click New to create a new report. 

RL path to the report. 

p computer in the report URL. 

5 Click Next. 
n which to send the report. 

8 On the E-mail dialog, enter the Email (SMTP) information for the Email address to which 
eport. 

 

ng the report. The default address is 
from WhatsUp Gold. 

 Subject. Enter a subject for the report email. 

 Send reports as attachments. Select this option to have reports sent as attachments, 
rather than inline text within the original email. Workspace reports can only be sent as 
attachments. 

9 Click Finish to add the report. 

3 On the General dialog, enter a title for the report in the Report name box. 
4 Enter the full U

You can find this path by selecting a report in the web interface. The URL shown in the 
address bar is the URL you need to enter in the URL box. You can use "localhost" - or - the 
configured IP address for the WhatsU

6 On the Schedule dialog, select the date and time o
7 Click Next. 

you are sending the r

 E-mail address. Enter an email address for where you would like the report sent.

 Outgoing mail (SMTP) server. Enter the SMTP server for your network. 

 Port. Enter the port number for the mail server. 

 From. Enter an email address for whom is sendi
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  258 

1 From the From the WhatsUp Gold console, select Configure > Recurring Reports. 
Recurring Reports dialog, select an existing Recurring Report and click Edit. 

ugh the Recurring Report dialogs as you would for creating a new Recurring 

ts 
 report before the scheduled time and date: 

sole, select Configure > Recurring Reports. 
ring Reports dialog, select a report and click Test. 

t is complete, a pop-up message tells you whether the test was successful. 

To edit an existing Recurring Report: 

2 On the 
3 Follow thro

Report. 
 

Testing Recurring Repor
To test a recurring
1 From the con
2 On the Recur
3 After the tes
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Learning about workspaces 

o the web 
ble Home portal, or workspace. 

Wo
incl
you display. When you 

ng your workspace views, you should consider the types of information you 
d what 

u want to monitor through a particular workspace view. You should also take 
 

ng and matching summary, group, 

ace view only affect your user account. If you decide to 
your account, your user account will be 

es are limited to display only Device-level workspace reports. Only 
le device can be placed on a device workspace. When you 

change the device-in-context, the reports displayed show data corresponding to the newly 

CHAPTER 20 

rkspaces 

Learning about workspaces .........................................................................

About types of workspaces....................

aging Workspace Views ........................................................................264 

ating workspace views........................................................................268 

ut workspace content.............................................................................268 

g workspace reports to a workspace view ..................................268

The WhatsUp Gold Home workspace is the first screen you see after logging in t
interface. This is your personal, customiza

rkspaces in WhatsUp Gold are designed to be user-specific, and are configurable to 
ude workspace reports specific to users' needs. Workspaces contain multiple views that let 
organize various workspace reports by the type of information they 

begin customizi
need to view most often, the devices in which you need to pay closest attention, an
level of detail yo
into consideration the type of workspace, and the types of workspace reports you can add to
a particular workspace type.  

Home and Device Status workspaces  
Home workspaces can display both Home- and Device-level workspace reports. You can 
place any workspace report on a Home workspace; mixi
and device-specific data.  

Changes that you make to a worksp
completely change all of the workspace views under 
the only account affected by these changes. For more information, see Managing workspace 
views (on page 264). 

D vice Status workspace
workspace reports specific to a sing
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selected device. For more information, see Adding workspace reports to a workspace view (on 

About types of workspaces 

 Top 10 (on page 263) 

Each of the workspace types supports multiple user-defined views and up to 15 small reports 
known as workspace reports can be displayed within each view. These workspace reports 
show content ranging from Current Interface and CPU utilization to Syslog messages. It’s up 
to you to decide which content is most important. 

Ab

eb 
twork 

page 268). 

Top 10 workspaces display Top 10 full reports for your network devices.  
 

The WhatsUp web interface has three types of workspaces: 

 Home (on page 260) 

 Device Status 

 

out the Home Workspace 

Home Workspace 
The WhatsUp Gold Home Workspace is the first screen that you see after you log in to the w
interface. Referred to as "Home," this universal workspace is designed to house the ne
information that you need most visible. 
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The Home Workspace can display both Home- and Device-level workspace reports. You can 
orkspace report on a Home workspace; mixing and matching summary, group, 
specific data.  

at you make to a workspace 
tain the information about 

 important to you. This Workspace comes with some stock content 
 Active Monitors and Top 10 Devices by Ping Response Time, although 

ed by the reports that are most relevant to your job.  

o includes three starter views: 

 General 

you can decide to keep, 
ews. For more 
 page 268). 

rough the Manage 
 (on page 264) dialog. 

 

he Device Status 
kspace reports 

place any w
and device-

The content of this Workspace varies for each user. Changes th
view only affect your user account. This Workspace should con
your network that is most
such as Devices with Down
these reports can and should be replac

The Home Workspace als

 Problem Areas 1 

 Problem Areas 2 

Each workspace view includes several default workspace reports that 
alter, or remove. You can also add other workspace reports to these vi
information, see Adding workspace reports to your Home Workspace (on

You can create your own workspace views for the Home workspace th
Workspace Views

About the Device Status workspace 

Device Status workspace 

workspace is limited to display only Device-level workspace reports. Only wor
The Device Status Workspace is very similar to the Home Workspace, but t

specific to a single device can be placed on a device workspace.  
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The Device Status Workspace is designed to present relevant information about the health 
and performance of a single monitored device. Throughout the Web interface you will see 
links to devices, such as . All of these links point to the Device Status 

monitored device, 
the Device Status is a good place to look for more information on the device status. The 
Device Status Workspace includes several stock workspace views: 

 General 

Workspace for the particular device. If there is a potential problem with a 

 Disk/CPU/Memory 

 Problem Areas 

 Router/Switch/Interface 

 

There are many different types of devices with a variety of features and services that can be 

The Disk/CPU/Memory View is most appropriate for a Windows or UNIX host that supports 
the Host Resources MIB for performance monitoring. The Router/Switch/Interface View is 
most appropriate for a manageable Switch or Router that is capable of reporting Interface or 
Bandwidth utilization. 

monitored. The Workspace Views let you select a view that is most appropriate for the 
individual device. Each time the report is visited, it displays the last view that was selected for 
a device.  
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The device name and icon displays at the top of the Device Status report. You can click the 
device name, for example 192.168.5.151, to change the focus of the report to another device
without leaving the report

 
. 

 

orkspace reports to a Device Status workspace (on page 

Ab

The Top 10 workspace 
The WhatsUp Gold Top 10 workspace displays the Top 10 full reports for your network 
devices. The role of the Top 10 Workspace is to show devices, at a glance, that may be 
potential problems and to provide information on the current health of your network 
devices. It is pre-configured to include workspace reports that display data on the top 
network devices by: 

 Interface Utilization 

 Interface Traffic 

 Ping Response Time 

 Disk Utilization 

 CPU Utilization 

 Memory Utilization 

For more information, see Adding w
268). 
 

out the Top 10 workspace 
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Unlike the Home and Device Status workspaces, the Top 10 workspace is designed with only 
the General workspace view. You can customize the general view in the same way you can 

 

so displays threshold reports. These reports let you set a threshold to 
filter out items that do not match a specified criteria. For example, the Interface Utilization 
Threshold report could have been used (in the example above) instead of the Interface Top 
10 report, to filter out the interfaces that are not above 50% utilization. Using this approach, 
only interfaces with significant usage would be shown. 
 

Managing Workspace Views 

WhatsUp Gold comes with a few pre-configured workspace "views," including one for Default 
Remote Sites. You can create more of your own workspace views to use along with the pre-
configured views. You can create as many as you feel necessary to organize your system for 
efficient reporting. You can also edit, copy, copy to (another user), and delete these views as 
needed. 

other workspace views by removing the default workspace reports and/or adding other Top
10 and Threshold workspace reports. For more information, see Adding workspace reports to 
your Home Workspace (on page 268). 

The Top 10 Workspace al
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From the Workspace View list, select Manage Workspace Views. 

 

rkspace views, and edit, copy, In the Manage Workspace Views dialog, you can create new wo
or delete an existing workspace view. 

 

n of a 

e view, then click Copy to make a copy of that workspace and add it to 

 workspace from here to 
t of workspaces. 

onitor view, t  the list. 

 Click New to configure a new workspace. 

 Select an existing workspace view and click Edit to change the current configuratio
workspace. 

 Double-click an existing workspace to change its configuration. 

 Select a workspac
the list. 

 Select a workspace view, then click 
another user's lis

Copy to to copy an existing

 Select a workspace m hen click Delete to remove it from
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To create a new workspace view: 
1 From the Manage Workspace Views dialog, select New. The New Workspace View dialog 

appears. 

 
2 Enter the appropriate information in the following fields: 

 View name. Enter a name for the workspace view. 

 View type. Choose a type for the workspace view from the drop-down menu. 

 Column count. Enter a value for the number of columns you wish to have in the new 
workspace view. Keep in mind, the more columns you include, the smaller the data 
displayed inside a workspace.  

 Enter a value in pixels for each of the workspace columns. 

3 Click OK to save changes. 

To edit a workspace view: 

ace title as it appears in the Workspace Library. 

1 From the Manage Workspace Views dialog, select Edit. The Edit Workspace View dialog 
appears. 

2 Enter the appropriate information in the following fields: 

 Workspace name. The worksp

 Workspace type. The workspace type as it appears in the Workspace Library (Home 
or Device).  

 Note: Workspace view types cannot be changed after a view is created. For example, a 
Home workspace type cannot be changed later to a Device Status workspace type. 

 Column count. The number of columns in the wor

 Column width. The width of each colum

kspace. 

n in the workspace in pixels. 

3 Click OK to save changes. 
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To copy an existing workspace view: 
1 From the Manage Workspace Views dialog, select Copy. The Edit Workspace View 

dialog appears. 

 
2 Enter the appropriate information in the following fields: 

 columns in the workspace. 

 Column width. The width of each column in the workspace in pixels. 

3 Click OK to save changes. 

r WhatsUp Gold user: 
1 Copy to. The Edit 

 Workspace name. The workspace title as it appears in the Workspace Library. 

 Column count. The number of

To copy a workspace view to anothe
From the From the Manage Workspace Views dialog, select 
Workspace View dialog appears. 

 
2 Enter the appropriate information into the following fields: 

 Copy to user. Select a user account from the drop-down menu in which to copy the 

ry. 

2 Click OK on the dialog that follows. 
 

workspace view. 

 View name. The name of the workspace view as it will appear in the Workspace 
Libra

3 Click OK to save. 

To delete a workspace view: 
1 From the From the Manage Workspace Views dialog, click Delete. 
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Navigating workspace views 

The main way to navigate from one workspace view to another is through the Workspace 
to a workspace, manage your workspace and 
p Gold help system. 

Toolbar. From here you can add content 
workspace views, and access the WhatsU

 

The Workspace Toolbar 
 Add Content. Use this button to add workspace reports to your workspace views. 

 Workspace View. Use this drop-down menu to edit your workspace views and to switch 

or the window you are currently 

Abo

kspace reports are 
 workspace views. For more information, see Understanding 

e 259). 

lbar to bring up the 
log, you can select multiple 

 
s 

 To remove a report, go to the menu for that workspace report and select Close. Keep in 
mind, when you remove a report, any customizations you have made to it are lost.  

 in the 

Adding workspace reports to a workspace view 

You can customize a workspace by adding additional reports to the workspace view. Click 
Add Content to add additional reports to the workspace view.  

 

between workspace views. 

 Help. Use this button to view the WhatsUp Gold Help f
viewing. 

 

ut workspace content 

Workspace reports are smaller versions of the full reports. The wor
displayed within WhatsUp Gold
and using workspaces (on pag

To add, remove, and move workspace reports to a workspace view: 

 To add a report, click Add content on the Workspace Too
Workspace Report Picker. On the Add Content to View dia
workspace reports, from multiple categories. A preview for the workspace report is
displayed at the bottom of the dialog. For more information see, Adding workspace report
to a Device Status workspace (on page 268). 

 To
workspace view. 

 

 move a workspace report, click on a report's title bar and drag it to a new space

  

The reports that are available to add will vary, depending on the current workspace type. 
Home Workspace Views can display any available workspace report, while Device Status 
Workspace Views only present the reports that apply to a single device. There are a large 
number of available reports, so they have been categorized based on their function. The icon 
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to the left of each report indicates the type of of report listed. Report types include tabular, 
review 

To add a report to a workspace: 
1 Open the workspace view to which you want to add content. 
2 o View page appears.  

pie charts, line charts, gauges, and more. When you select a report in the list, a report p
shows in the Preview pane below the list. 

In the Workspace toolbar, click Add Content. The Add Content T

 
3 Click the  button next to a report category folder, then click a report option box for 

each report(s) you want to add to the workspace. A preview image for each workspace 
report is displayed at the bottom of the dialog.  

Response Time category, select For example, click to expand the Ping Availability and 
the Last 4 Hours (Single Device Response Time) option. 
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added to the workspace view. 4 Click OK to save changes. The new report is 
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Using Workspace Reports 

In This Chapter 

Learning about workspace reports............................................................271 

List of workspace reports...............................................................................273 

About the workspace report menu ...........................................................286 

Configuring a workspace report .................................................................286 

Moving workspace reports within a workspace view .........................286 

Device Group Mini Status workspace report..........................................288 

 
 

Learning about workspace reports 

WhatsUp Gold offers a collection of more than 100 configurable workspace reports for 
display in workspace views. These smaller reports show similar information to that found in 

e 

De
Like workspaces, workspace  

 Device workspace reports are displayable in Device workspaces, such as the Device 
Status workspace. 

 Home workspace reports are displayable in Home workspaces, such as the your default 
Home workspace. 

Workspace report categories 
Workspace reports are broken down into categories according to the type of information 
they display: 

 CPU Utilization. These workspace reports display information pertaining to device and 
network CPU levels. 

 Custom Performance Monitors. These workspace reports display information pertaining 
to your custom performance monitors. 

 Disk Utilization. These workspace reports display information pertaining to device and 
network disk levels. 

 General. These workspace reports display information on your WhatsUp Gold settings 
and diagnostics, as well as device-specific and user-configured details.  

TER 21 

the full reports. Because of their smaller size, multiple reports can be placed in a workspac
view, making it possible to view multiple reports simultaneously. 

vice and Home workspace reports 
reports are also typed as either Device or Home:
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 Interface Utilization. These workspace reports display information pertaining to device 
and network interfaces. 

 Inventory. These workspace reports provide a break-down of network devices and their 
settings, including Actions, monitors, and policies. 

 Memory Utilization. These workspace reports display information pertaining to device 
and network memory levels. 

 Performance (Historic and Last Poll). These workspace reports display information 
gathered from WMI and SNMP Performance Monitors regarding your network devices' 
CPU, disk, interface, and memory utilization; and ping latency and availability. 

 Ping Availability and Response Time. These workspace reports display information 
pertaining to device ping availability, response time, and packet loss. 

 Problem Areas. These are trouble-shooting workspace reports that allow you to 
investigate network issues. 

 Remote/Central (included in the WhatsUp Gold Distributed, and MSP Editions). These 
include a variety of workspace reports for the Remote Sites that you are monitoring with 
the WhatsUp Gold Central Site. 

 Split Second Graphs (included in the WhatsUp Gold Premium, Distributed, and MSP 
Editions). These are real-time graphs that display information on SNMP and WMI 
performance counters. These reports allow you to include the real-time information 
available on the Web Performance Monitor network tool and the Web Task Manager 
network tool in any workspace view. 

 Threshold. These workspace reports display information on your network's CPU, disk, 
interface, and memory utilization, and ping function; at or above a specific threshold.  

 Top 10. These workspace reports display the top devices on your network according to 
their CPU, disk, interface, and memory utilization, and ping function. 
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Workspace reports are listed multiple times on the workspace report picker. For example, the 
ion workspace report is listed under the Disk Utilization, Threshold, Top 10, and 
e categories. 

Disk Utilizat
Performanc

 

List of workspace reports 

ports available in WhatsUp Gold.  

workspace reports Type Description 

 

The following is a list of all workspace re

CPU Utilization 

Last Polled Values (single 
device) 

Home Shows the CPU utilization(s) for a specific device at the time of the 
last poll. 

Last Polled Values 
(specific CPU)  

Home Shows the CPU utilization for a specific CPU at the time of the last 
poll. 

Over 80% Utilization* Home Lists all network devices with a CPU utilization greater than 80%. 

Over 90% Utilization Home Lists all network devices with a CPU utilization greater than 90%. 

Top 10 by Utilization* Home Lists the top 10 devices based on their current CPU utilization 
percentage. 
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CPU Utilization 
workspace reports Type Description 

Top 20 by Utilization Home Lists the top 20 devices based on their current CPU utilization 
percentage. 

Last 4 hours (single 
device) 

Device Details all CPU utilization percentages for one device over the last 
h

4 
ours. 

Last 8 hours (single 
device) 

Device Details all CPU utilization percentages for one device over the las
hours. 

t 8 

Last 7 days  (single 
device) 

Device Details all CPU utilization percentages for one device over the last 7 
days. 

Last 30 days (single 
device) 

Device Details all CPU utilization percentages for one device over the last 
30 days. 

Last 4 hours (specific 
CPU) 

Home Details a specific CPU's utilization percentages for one device ove
the last 4 hours. 

r 

Last 8 hours (specific Home Det
CPU)  the last 8 hours. 

ails a specific CPU's utilization percentages for one device over 

Last 7 days (specific CPU) Home Details a specific CPU's utilization percentages for one device ove
the last 7 days. 

r 

Last 30 days (specific 
CPU) 

Home Details a specific CPU's utilization percentages for one device o
last 30 da

f the 
ys. 

 

Custom Performance 
Monitor workspace 
reports Type Description 

Last Polled Values (single 
device) 

Home Details information on a single device's custom performance 
monitor(s) at the time of the last poll. 

Last Polled Value (specific 
monitor) 

Home Details information on a specific custom performance monitor at 
the time of the last poll. 

Top 10 with threshold* Home Lists the top 10 devices by a custom performance monitor 
threshold. 

Top 20 with threshold Home Lists the top 20 devices by a custom performance monitor 
threshold. 

Top 10 by specific 
monitors* 

Home Lists the top 10 devices by a specific custom performance monitor. 

Top 20 by specific 
monitors 

Home Lists the top 20 devices by a specific custom performance monitor. 

Last 4 hours (single 
device) 

Device Details a device's custom performance monitors over the last 4 
hours. 

Last 8 hours (single 
device) 

Device Details a device's custom performance monitors over the last 8 
hours. 

Last 7 days (single 
device) 

Device Details a device's custom performance monitors over the last 7 
days. 
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Custom Performance 
Monitor workspace 
reports Type Description 

Last 30 days (single 
device) 

Device Details a device's custom performance monitors over the last 30 
days. 

Last 4 hours (specific 
monitor) 

Home Details a specific custom performance monitor over the last 4 
hours. 

Last 8 hours (specific 
monitor) 

Home Details a specific custom performance monitor over the last 8 
hours. 

Last 7 days (specific 
monitor) 

Home Details a specific custom performance monitor over the last 7 days. 

Last 30 days (specific 
monitor) 

Home Details a specific custom performance monitor over the last 30 
days. 

 

Disk Utilization 
workspace reports Type Description 

Last Polled Values (single 
device) 

Device Shows the disk utilization for all of a device's disks at the time of 
the last poll. 

Last Polled Values 
(specific disk) 

Home Shows the disk utilization for a specific device disk at the time of 
the last poll. 

All Disks Over 80%* Home Lists all network devices with a disk utilization greater than 80%. 

All Disks Over 90% Home Lists all network devices with a disk utilization greater than 90%. 

Top 10 by Utilization*  Home Lists the top 10 devices based on their current disk utilization 
percentage. 

Top 20 by Utilization Home Lists the top 20 devices based on their current disk utilization 
percentage. 

Top 10 by Free Space* Home Lists the top 10 devices based on their current free disk space. 

Top 20 by Free Space Home Lists the top 20 devices based on their current free disk space. 

Last 4 hours (single 
device) 

Device Details all
hours. 

 disk utilization percentages for one device over the last 4 

Last 8 hours (single Device Details all disk utilization percentages for one device over the last 8 
device) hours. 

Last 7 days (single
device) 

 Device Details all disk utilization percentages for one device over the last 7 
days. 

Last 30 days (single 
device) 

Device Details all disk utilization percentages for one device over the last 
30 days. 

Last 4 hours (specif
utilization) 

ic disk Home Details a specific disk's utilization percentages for one device over 
the last 4 hours. 

Last 8 hours (specific d
utilization) 

isk  Home Details a specific disk's utilization percentages for one device over
the last 8 hours. 

Last 7 days (specific disk 
utilization) 

Home Details a specific disk's utilization percentages for one device over 
the last 7 days. 
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Disk Utilization 
workspace reports Description Type 

Last 30 days (specific disk 
utilization) 

ver 
ys. 

Home Details a specific disk's utilization percentages for one device o
the last 30 da

Last 4 hours (specific disk 
free space) 

Home Details a specific disk's free space for one device over the last 4 
hours. 

Last 8 hours (specific disk 
free space) 

Home Details a specific disk's free space for one device over the last 8 
hours. 

Last 7 days (specific
free spac

 disk 
e) 

Home Details a specific disk's free space for one device over the last 7 
days. 

Last 30 days (specific disk 
free space) 

Home Details a specific disk's free space for one device over the last 30 
days. 

 

General workspace 
reports Type Description 

Device Notes Device Displays a devices's notes configured in Device Properties > 
Notes. 

Device Attributes Device Displays a device's attributes configured in Device Properties > 
Attributes. 

Device SNMP Details Device Displays a device's SNMP details. 

Device Toolbar Device Displays a device's details configured in Device Propterties > 
General. 

Device Custom Links Device Displays any c
Properties > 

ustom links assigned to a device in Device 
Custom Links. 

Device Dependencies Device Shows the state of a device and any devices that are up or down 
dependent on that device. 

Device Active Monitor 
States 

Device Lists all of a device's Active Monitors and their current state. 

Performance Monitor 
Summary 

Device Displays a polling summary for the device-in-context. 

Map View Home Displays a smaller version of a network map. 

Database Size Home Displays a graphical representation of the WhatsUp Gold database 
at the time of the last poll. 

Custom Links Home Displays any custom links that you add to the workspace report. 

Free Form Text/HTML Home Displays any free form text or HTML code that you add to the 
workspace report. 

Web User Activity Log Home s a log of when a user logs on or off the web interface, and Display
the actions taken while logged on. 

Interface Details (specific Home s SNMP information reported by a specific network 
interface) 

Display
interface. 

User Orientation Home ys information regarding the new the new web interface, 
workspaces, and workspace reports. 
Displa
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General workspace 
reports Type Description 

Favorite Reports Home Displays a list and link to any full report on your list of favorites. 

 

Interface Utilization 
workspace reports Type Description 

Last Polled Interface 
(single device) 

time 
st poll. 

Device Shows the interface utilization for all network interfaces at the 
of the la

Last Polled Interface 
(specific interface) the time of the last poll. 

Home Shows the interface utilization for a specific network interface at 

All Interfaces over 80% 
Bandwidth Utilization* 

Home Lists all network interfaces with a utilization greater than 80%. 

All Interfaces over 90% 
tion 

Home Lists all network interfaces with a utilization greater than 90%. 
Bandwidth Utiliza

Top 10 with Traffic 
Threshold* 

Home Lists the top 10 devices based on their current interface traffic. 

Top 10 by Bandwidth Home 0 devices based on their current interface utilization. 
Utilization* 

Lists the top 1

Top 20 by Bandwidth Home 0 devices based on their current interface utilization. 
Utilization 

Lists the top 2

Top 10 by Traffic* Home Lists the top 10 devices based on their current interface traffic. 

Top 20 by Traffic Home Lists the top 20 devices based on their current interface traffic. 

Last 4 hours (single Device erface utilization percentages for one device over the 
device) 

Details all int
last 4 hours. 

Last 8 hours (single Device erface utilization percentages for one device over the 
device) 

Details all int
last 8 hours. 

Last 7 days (single 
device) 

Device Details all interface utilization percentages for one device over th
last 7 days. 

e 

Last 30 days (single 
device) 

Device Details all interface utilization percentages for one device over the 
last 30 days. 

Last 4 hours (specific 
interface utilization) 

Home Details a specific interface's utilization for one device over the last 4 
hours. 

Last 8 hours (specif
interface

ic 
 utilization)  

Home Details a specific interface's utilization for one device over the last 8 
hours.

Last 7 days (specific 
interface utilization) 

 Home Details a specific interface's utilization for one device over the last 7
days. 

Last 30 days (specific 
interface utilization) 

Home Details a specific interface's utilization for one device over the last 
30 days. 

Last 4 hours (specific 
traffic interface) 

Home Details a specific interface's traffic for one device over the last 4 
hours. 

Last 8 hours (specific 
traffic interface) 

Home Details a specific interface's traffic for one device over the last 8 
hours. 
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Interface Utilization 
workspace reports Type Description 

Last 7 days (specific 
traffic interface) 

Home Details a specific interface's traffic for one device over the last 7 
days. 

Last 30 days (specific 
traffic interface) 

 Home Details a specific interface's traffic for one device over the last 30
days. 

 

Inventory workspace 
reports Type Description 

Total Devices by Type Home Lists all monitored network devices by type and number. 

Total Active Monitors by Home l Active Monitors on the network by type and number. Lists al
Type 

Total Passive Monitors by Home Lists all Passive Monitors on the network by type and number. 
Type 

Total Performance 
pe 

mance Monitors on the network by type and number.
Monitors by Ty

Home Lists all Perfor

Total Actions Applied by Home ctions on the network by type and number. 
Type 

Lists all A

Total Devices with Home c attribute. 
Specific Attributes 

Lists all devices with a specifi

Active Discovery Results his Home Once an Active Discovery is performed, the results are listed in t
report. 

 

Memory Utilization 
workspace reports Type Description 

Last Polled Values (sing
device) 

le the Device Shows the memory utilization for all of device's memories at 
time of the last poll. 

Last Polled Value (spec
aspect) 

ific vice at the Home Shows the memory utilization for a specific network de
time of the last poll. 

Over 80% Utilization* ation greater than Home Lists all network devices with a memory utiliz
80%. 

Over 90% Utilization Home Lists all network devices with a memory utilization greater than 
90% 

Top 10 by Utilization* Home Lists the top 10 devices based on their current memory utilization. 

Top 20 by Utilization Home d on their current memory utilization. Lists the top 20 devices base

Last 4 hours (single 
device) 

Device Details all memory utilization percentages for one device over the 
last 4 hours. 

Last 8 hours (single 
device) 

Device Details all memory utilization percentages for one device ov
last 8 hour

er the 
s. 

Last 7 days (single 
device) 

e Device Details all memory utilization percentages for one device over th
last 7 days. 
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Memory Utilization 
workspace reports Type Description 

Last 30 days (single 
device) 

e 
last 30 days. 

Device Details all memory utilization percentages for one device over th

Last 4 hours (specific Home Details a specific memory's utilization for one device over the last 4 
hours. aspect) 

Last 8 hours (specific ific memory's utilization for one device over the last 8 
aspect) 

Home Details a spec
hours. 

Last 7 days (specific Home  memory's utilization for one device over the last 7 
aspect) 

Details a specific
days. 

Last 30 days (specific Home 's utilization for one device over the last Details a specific memory
aspect) 30 days
 

Performance - Historic 
workspace reports Type Description 

Custom Performanc
Monitor Valu

e 
es  

(last 4 hours - single 

last 
4 hours. 

device) 

Device Details a device's custom Performance Monitor values over the 

Interface Utilization Device Details all interface utilization percentages for one device over the 
(last 4 hours - single 
device) 

last 4 hours. 

CPU Utilization 
(last 4 hours - sing
device) 

le 
st 4 Device Details all CPU utilization percentages for one device over the la

hours. 

Memory Utilization 
(last 4 hours - single 
device) 

Device Details all memory utilization percentages for one device over the 
last 4 hours. 

Disk Utilization 
(last 4 hours - single
device) 

 
Device utilization percentages for one device over the last 4 Details all disk 

hours. 

Ping Response Time
(last 4 ho

 
urs - single 

 

device) 

Device Details all ping response times for device's interfaces over the last 4
hours. 

Ping Availability 
(last 4 hours - single 
device) 

Device all ping availability for a device's interfaces over the last 4 Details 
hours. 

Interface Traffic  
(last 4 hours - specific
interface) 

 
Home Details interface traffic for a specific device interface over the last 4 

hours. 

Custom Performance 
Monitor Values  
(last 4 hours - specific 
monitor) 

Home Details a device's specific custom Performance Monitor values over
the last 4

 
 hours. 

  279 



Using WhatsUp Gold v12.3 

Performance - Historic 
workspace reports Type Description 

Interface Utilization 
(last 4 hours - specific 

e 
e last 4 hours. 

interface) 

Home Details a specific interface's utilization percentages for one devic
over th

CPU Utilization 
(last 4 hours - specific 

PU) 

Home  a specific CPU's utilization percentages for one device over 
the last 4 hours. 
Details

C

Memory Utilization 
(last 4 ho
memory) 

urs - specific 
Home Details a specific memory's utilization percentages for one device 

 hours. over the last 4

Disk Utilization Home Details a specific disk's utilization percentages for one device over 
(last 4 hours - specific 
disk) 

the last 4 hours. 

 

Performance - Last
workspace report

 Poll 
s Type Description 

Custom Performance 
Monitor Values (single 
device) 

ance Monitors 
at the time of the last poll. 

Device Shows the values for all of a device's custom Perform

Interface Utilization 
(single device) 

Device Shows the interface utilization for all of a device's interfaces at the 
time of the last poll. 

CPU Utilization (single 
device) 

Device the CPU utilization for all of device's CPUs at the time of the 
last poll. 
Shows 

Memory Utilization Device Shows the memory utilization for all of a device's memories at the 
time of the last poll. (single device) 

Disk Utilization (single k utilization for all of a device's disks at the time of 
device) 

Device Shows the dis
the last poll. 

Custom Performance Home fic device custom Performance 
Monitor Values (specific 
monitor) 

Shows the values for a speci
Monitor. 

Interface Utilization 
(specific interface) 

Home Shows the utilization of a specific device interface at the time of 
the last poll. 

CPU Utilization (speci
CPU) 

fic ast Home Shows the utilization of a specific device CPU at the time of the l
poll. 

Memory Utilization 
(specific aspect) 

Home Shows the utilization of a specific device memory at the time of the
last poll. 

 

Disk Utilization (specific 
disk) poll. 

Home Shows the utilization of a specific device disk at the time of the last 

Ping Response Time Home ng response time of a specific device interface at the 
(specific interface) 

Shows the pi
time of the last poll. 
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Ping Availability and 
Response Time 
workspace reports Type Description 

Last 4 hours (single Device ng response time for all of a device's interfaces over 
device) 

Shows the pi
the last 4 hours. 

Last 8 hours (single Device the ping response time for all of a device's interfaces over 
device) 

Shows 
the last 8 hours. 

Last 7 days (single device) Device the ping response time for all of a device's interfaces over Shows 
the last 7 days. 

Last 30 days (single Device  the ping response time for all of a device's interfaces over 
device) 

Shows
the last 30 days. 

Last 4 hours (single 
evice) 

Device he ping availability for all of a device's interfaces over the 
last 4 hours. 
Shows t

d

Last 8 hours (single 
device) 

Device Shows the ping availability for all of a device's interfaces over the 
last 8 hours. 

Last 7 days (single device) Device Shows the ping availability for all of a device's interfaces over the 
last 7 days. 

Last 30 days (single 
device) 

Device Shows the ping availability for all of a device's interfaces over the 
last 30 days. 

Last Polled Response
Time (specific interfac

 
e) e last poll. 

Home Shows the last ping response time of a specific device interface at 
the time of th

Top 10 by Ping Response 
Time* 

Home Lists the top 10 devices based on their current ping response time. 

Top 20 b
Time 

y Ping Response Home Lists the top 20 devices based on their current ping response time. 

Top 10 by Ping Packe
Loss* 

t Home Lists the top 10 devices based on their current ping packet loss. 

Top 20 by Ping P
Loss 

acket Home Lists the top 20 devices based on their current ping packet loss. 

Top 10 by Ping Home Lists the top 10 devices based on their current ping availability. 
Availability* 

Top 20 by Ping 
Availability 

Home e top 20 devices based on their current ping availability. Lists th

Devices with Ping
Response Time  
over 100msec

 

 

 Home Lists all devices with a ping response time greater than 100 msec.

Devices with Ping
Response Time  
over 500 m

 

sec 

Home Lists all devices with a ping response time greater than 500 msec. 

Devices with Ping Pack
Loss over 50% 

et Home Lists all devices with a ping packet loss greater than 50%. 

Devices with Ping Packet 
Loss over 75% 

Home Lists all devices with a ping packet loss greater than 75%. 
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Ping Availability and 
Response Time 
workspace reports Type Description 

Devices with Ping 
Availability over 50%* 

Home  ping availability greater than 50%. Lists all devices with a

Devices with Pin
Availability over 75% 

g Device Lists all devices with a ping availability greater than 75%. 

 

Problem Areas 
workspace reports Type Description 

Devices with Down Ac
Monitors 

tive Device Displays a device's down Active Monitors. 

All Down Interfaces Device Displays a device's down interfaces. 

Tail of State Change Log Device Displays the tail of the State Change Log for a specified device. 

Tail of Syslog Device Displays the tail of the Syslog full report for a specified device. 

Tail of Windows Event Device Displays the tail of the Windows Event Log for a specified device. 
Log 

Tail of SNMP Trap Log Device Displays the tail of the SNMP Trap Log for a specified device. 

Tail of Action Activity
Log* 

 Device Displays the tail of the Action Activity Log for a specified device. 

Tail of Passive Monitor 
Error Log 

Device Displays the tail of the Passive Monitor Error Log for a specified 
device. 

Web Alarms Device Displays any web alarms fired for a specified device. 

All Completely Down Home s for a specified device group. 
Devices 

Displays down device

All Down Interfaces Home n interfaces for a specified device group. Displays dow

Devices with Down Activ
Monitors 

e d 
up. 

Home Displays devices with down Active Monitors within a specifie
device gro

Unacknowledged Devices Home Displays unacknowledged devices within a specified device group.

Devices that have fired an Home ces that have fired an action over the selected time 
Action  
in the last X hours 

Displays devi
period. 

Tail of State Change Log Home Displays a tail of the State Change Log for your network. 

Summary Counts* Home  summary of a specified device group. Displays a

Tail of Syslog Home Displays the tail of the Syslog full report for your network. 

Tail of Windows Event Home ndows Event Log for your network. 
Log 

Displays the tail of the Wi

Tail of SNMP Trap Log Home Trap Log for your network. Displays the tail of the SNMP 

Tail of Action Activity 
Log* 

Home Displays the tail of the Action Activity Log for your network. 

  282 



Using WhatsUp Gold v12.3 

Problem Areas 
workspace reports Type Description 

Tail of Passive Monitor  ail of the Passive Monitor Error Log for your network. 
Error Log 

Home Displays the t

Map View Home n of a network map. Displays a smaller versio

Device Group Mini Status Home Lists all devices in a device group and displays their status by color.

Web Alarms Home Shows a snap shot of the most recent web alarms fired on your 
network. 

General Error Log Home Displays the tail of the General Error Log for your network. 

 

Remote/Central 
workspace reports Type Description 

(Only available in 
distributed editions) 

  

Summary Counts Home ummary for a remote site by the total number of its 

rs, up interfaces, down interfaces, actions fired in the 

(Remote) 
Provides a s
monitored devices, up devices, down devices, devices with down 
active monitors, devices in maintenance, active monitors, down 
active monito
last four hours. 

Active Monitor States 
(Remote) 

Home states for a remote site at the time of the Displays Active Monitor 
last refresh. 

Tail of Action Activity Log Home Provides the tail (last 10 records) of the Action Log for a device 
(Remote) group on a remote site. 

Device Status (Remote) Home Displays a status summary for devices on a remote site at the time 
of the last refresh. 

Monitor Status (Remote) Home Displays a status summary for monitors on a remote site at the 
time of the last refresh. 

Remote Site List Home Lists all sites configured for use in WhatsUp Gold Remote and 
Central Site Editions. 

Tail of Remote Site Log Home Provides the tail (last 10 records) of the Remote Site Log. 

Remote Site Overview  
for use in your  

Home Displays an overview of information on a remote site configured

WhatsUp Gold Distribute Solution. 

Group List (Remote) Home Lists all subgroups in a remote site's My Network Group and their 
status at the time of the last refresh. 

 

Split Second Graph 
workspace reports  Type Description 

(not available in Standard   
Edition) 

Performance Monitor Home Displays custom real-time graphs for an SNMP or WMI enabled 
device. 
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Split Second Graph 
workspace reports  Type Description 

Interface Home Displays real-time interface utilization for a SNMP enabled device. 

CPU Home 
Or 
Device

 enabled 
device. 
Displays real-time cpu utilization for all cpu's on an SNMP

CPU gauge Home 
or 

Displays real-time cpu utilization for all cpu's on an SNMP enabled 
device. 

device

Ping Home 
Or 

ll network interfaces on 
device. 

Device

Displays real-time ping response time for a

Ping gauge Home 
or 
device

Displays real-time ping response time for all network interfaces
device.  

 on 

Disk Home 
or 

 
device. 

device

Displays real-time disk utilization for all disks on an SNMP enabled

Memory Home 
or 
Device

 Displays real-time memory utilization for a SNMP enabled device.

Task Manager CPU Line
Graph 

 
or 

. Home 

Device

Displays the CPU usage of a WMI-enabled device as a line graph

Task Manager Memory
Usage Lin

 
e Graph or 

Device

e as a line 
graph. 

Home Displays the memory usage of  a WMI-enabled devic

Task Manager CPU Bar Home 

Device

Displays a bar graph of the CPU usage of a  a WMI-enabled device 
Graph or in real time. 

Task Manager Memory 
Usage Bar Graph 

Home 
or 
Device

Displays a bar graph of the memory usage of a  a WMI-enabled 
device in real time. 

 

Threshold workspace 
reports Type Description 

Ping Response Time* Home Displays the top devices based on their current ping response time 
thresholds. 

Ping Packet Loss Home Displays the top devices based on their current ping packet loss 
thresholds. 

CPU Utilization Home Displays the top devices based on their current CPU utilizatio
percentage thresholds. 

n 
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Threshold work
reports 

space 
Type Description 

Memory Utilization Home Displays the top devices based on their current memory utilization 
percentage thresholds. 

Disk Utilization Home Displays the top devices based on their current disk utilization 
percentage thresholds. 

Disk Free Space* Home Displays the top devices based on their current disk free space 
thresholds. 

Interface Utilization Home Displays the top devices based on their current interface ut
percentage thresholds. 

ilization 

Interface Traffic* Home Displays the top devices based on their current interface traffic 
thresholds. 

Custom WMI/SNMP  Home Displays the top devices based on their current custom WMI/SNMP 
thresholds. 

Ping Availability Home Displays the top devices based on their current ping availability 
thresholds. 

 

Top 10 workspace reports Type Description 

Ping Response Time Ho the top devices based on their current ping me Displays 
response time. 

Ping Packet Loss Ho ys the top devices based on their current ping packet me Displa
loss. 

CPU Utilization Ho evices based on their current CPU me Displays the top d
utilization. 

Memory Utilization Ho  top devices based on their current memory me Displays the
utilization. 

Disk Utilization Ho evices based on their current disk me Displays the top d
utilization. 

Disk Free Space Ho p devices based on their current disk free me Displays the to
space. 

Interface Utilization Home Displays the top devices based on their current interface 
utilization. 

Interface Traffic Ho ed on their current interface me Displays the top devices bas
traffic. 

Custom WMI/SNMP  Ho r current custom 
WMI/SNMP. 

me Displays the top devices based on thei

Ping Availability Home Displays the top devices based on their current ping 
availability.  

*Available as Remote Work

 

space Reports in WhatsUp Gold Remote and Central Site Editions. 
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About the workspace report menu 

Each workspace report has a menu on the right side of its title bar. From the Workspace 
Report Menu, you can access help for a specific workspace report, go to the configuration 
dialog for a report, or close the report. Closing a report removes it from the workspace view. 

 that after y
st. 

Keep in mind
to the workspace report i

ou remo
s lo

ve a workspace report from a workspace, all customization 

 
 

Conf g a wor

space reports are de
workspace report's menu, select 

igurin kspace report 

Work signed to be customized to fit your specific needs. From a 
 Configure to bring up the configuration dialog. On this 

dial

 

og, you can: 

ge the report titl

Select a device or device group for the report 

 wi

ecify the width of c ain report columns 

 Chan e 

 Set the height and

 Sp

dth of t

ert

he report 

 

Moving workspace reports within a workspace view 

 supports ce 
report from one column of a wo r, or position a workspace report 
above or below another workspace report, by selecting it and dragging it to another area of 
the workspace view. These location changes are saved: workspace reports will appear in the 

 

WhatsUp Gold drag-and-drop within the web interface. You can move a workspa
rkspace view to anothe
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location to which you
between

 moved them after logging out from the web interface or after moving 
 workspace views. 

 

To move a workspace report: 
1 Select the title bar of the report you ove, then drag it to the desired location. 

A red box highlights the area that the report will be placed when the mouse button is 

2 Release the mouse button to place the report in the new page location. If you want to 
ove, while th t is

 

 want to m

released. 

cancel the m e repor  selected, press the Esc key on your keyboard. 
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Device Group Mini Status workspace report 

nd 
 

The Device Group Mini Status home workspace report lists all devices in a device group a
displays their status by color, allowing you to quickly see the status of all devices in a group
from across the room. 

 

Displaying multiple mini status workspace reports within a workspace view grants you a 
quick look at more than one group on your network and can help monitor important or 
problem areas more efficiently. You also can display Active Monitors associated with the 
devices in a selected group, which is useful in pinpointing what services on your network are 
down. 

To aid in maximizing your screen real estate, you have the ability to change the size and 

the mini status workspace report also aid in device recognition, as devices remain in the same 

display style of the workspace report. Even if the font size is too small to read at first-glance, 
you can use the mouse-over hover text to find out the identity of a device. The static rows of 

position regardless of their current state. 
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1 On the workspace report menu, select Configure. 
2 Enter the appropriate information in the following fields: 

 Name. Enter a title for the workspace report. 

 Device group. Select a device group by clicking the browse (...) button. To select 
every device on the network, regardless of their subgroup, select Every device. 

 Every device. Select this option to display every device in the system regardless of 
group. However, only devices that you have permissions to view will be displayed. 

 Style. Select the style and size in which you would like the mini status displayed. 

 Normal. Displays device and active monitor status with icons. 

 High Contrast. Displays device and active monitor status with bright colors. 

 Show Active Monitors. Select this option to display the active monitors associated 
with the group's devices. 

 Active Monitors per Row. Select the number of active monitors displayed per row. 

 Active Monitors Cell Width. Enter a cell width in pixels. 

3 Click OK to save changes. 

 
 

To configure the Device Group Mini Status workspace report: 
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SNMP overview 

The Simple Network Management Protocol (SNMP) defines a method by which a remote user 
can view or change management information for a device (a host, gateway, server, etc.). 

A monitoring or management application on the remote user's system uses the protocol to 
communicate with an SNMP agent on the device to access the management data. 

The SNMP agent on each device can provide information about the device's network 
configuration and operations, such as the device's network interfaces, routing tables, IP 
packets sent and received, and IP packets lost. This information, called SNMP objects, is 
stored in a standard format defined in the Management Information Base (MIB). The MIB 
defines the SNMP objects that can be managed and the format for each object. 

The SNMP protocol together with the MIB provide a standard way to view and change 
network management information on devices from different vendors. Any application that 
implements SNMP can access MIB data on a specified device. For a detailed description of 
SNMP, see Request for Comments (RFC) 1157. For a description of the MIB, see RFC 1213. The 
MIB information used by WhatsUp Gold is contained in MIB files in the MIB directory 
(..\Program Files\Ipswitch\WhatsUp\Data\Mibs). 
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Monitoring an SNMP Service 

You can add an SNMP active monitor to check that the SNMP service is running on a device. 
For more information, see Assigning Active Monitors (on page 156). 

To assign an SNMP Active Monitor to a device: 
1 Under the Devices tab, on the Device View or Map View tab, right-click a device, then 

click Properties. The Device Properties dialog appears. 
2 Click Active Monitors. The Device Properties Active Monitor dialog appears. 
3 Click Add. The Select Active Monitor Type dialog appears. 
4 Select the SNMP Active Monitor, then click Next. The Set Polling Properties dialog 

appears. 
5 Click to select Enable polling for this Active Monitor, select the Network interface to 

use for poll from the list, then click Next. 
6 (Optional) Set up an Action for the monitor state changes. 

Click Finish to add the monitor to the device. 7 

 Note: An SNMP-manageable device is identified on the map by a star in the upper-right 
corner of the device. 

 

About the SNMP Agent or Manager 

SNMP agent software must be installed and enabled on any devices for which you want to 
receive SNMP information. Windows NT 4.0, Windows 98, Windows 2000, Windows ME, 
Windows XP, Windows Server 2003, and Windows Vista all provide an SNMP agent in their 
default installations. Network systems manufacturers provide an SNMP agent for their 
routers, hubs, and other network boxes. 

For more information, see About the SNMP operations (on page 296) and Enabling SNMP on 
Windows devices (on page 213). 
 

About the SNMP Management Information Base 
(MIB) 

The MIB contains the essential objects that make up the management information for a 
device. The Internet TCP/IP MIB, commonly referred to as MIB-II, defines the network objects 
to be managed for a TCP/IP network and provides a standard format for each object. 

The MIB is structured as a hierarchical object tree divided into logically related groups of 
objects. For example, MIB-II contains the following groups of objects: 

 System. Contains general information about the device, for example: sysDescr 
(description), sysContact (person responsible), and sysName (device name). 
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 Interfaces. Contains information about network interfaces, such as Ethernet adapters, or 
-point links; for example: ifDescr (name), ifOperStatus (status), ifPhysAddress 
l address), ifInOctets, and ifOutOctets (number of octets received and sent by the 

ssing, such as routing table information: 
tHop (the next hop of the route entry). 

ormation about the operation of a specific protocol, for 
P, ICMP, SNMP, and EGP. 

extensions to the 

 object named 
ject has the following 

ded an instance sub-
scr. 

tree (so all these objects 
1.3.6.1.2.1

d description of the MIB, see RFC 1213. 
 

he 
network object named SysDescr with object identifier 1.3.6.1.2.1.1.1 contains a 

An object can have one or more instances, depending on the configuration of the monitored 
 be two 

. In 
h as 

Usin

h a file. 

point-to
(physica
interface). 

 IP. Contains information about IP packet proce
ipRouteDest (the destination), and ipRouteNex

 Other groups provide inf
example, TCP, UD

 The enterprise group contains vendor-provided objects that are 
MIB. 

Each object of the MIB is identified by a numeric object identifier (OID) and each OID can be 
referred to by its text label. For example, the system group contains an
sysDescr, which provides a description of the device. The sysDescr ob
object identifier: 

iso.org.dod.Internet.mgmt.mib.system.sysDescr 

1.3.6.1.2.1.1.1  

This object identifier would be 1.3.6.1.2.1.1.1 to which is appen
identifier of 0. That is, 1.3.6.1.2.1.1.1.0 identifies the one and only instance of sysDe

All of the MIB-II objects (for TCP/IP networks) are under the "mib" sub 
will have an identifier that starts with ). 

For a detaile

About SNMP Object Names and Identifiers 

Each SNMP object has a name and numeric identifier. For example, in the system group, t

description of the device. 

device. For example, a device can have two network adapters, in which case there will
instances of the ifPhysAddress object, which has object identifier 1.3.6.1.2.1.2.2.1.6
this case, you need to specify an instance number at the end of the object identifier (suc
1.3.6.1.2.1.2.2.1.6.1). If you do not specify an instance, it defaults to zero. 
 

g the SNMP MIB Manager 

The SNMP MIB Manager provides a list of all of the MIB files installed in the WhatsUp Gold MIB 
directory. Using this tool, you can import new MIB files to the MIB Manager. SNMP MIB 
Manager validates imported MIB files and flags errors if there is a problem wit
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To use the SNMP MIB Manager: 
1 Go to the SNMP MIB Manager. 

 From the web interface, click GO. The GO menu appears. 

 If the WhatsUp section is not visible, click WhatsUp.  The WhatsUp section of the GO 
menu appears. 

he SNMP MIB Manager dialog opens. 

 the code. 

 Follow the dialogs to 

 Select Configure > SNMP MIB Manager. T

2 Use the following options in the SNMP MIB Manager: 

 View. Select a MIB file in the list, then click View to open the MIB and view

 Add. Click Add to import a MIB file to the MIB Manager.
complete the process. 

 Note: If you need to add a large number of MIB files, you can manually copy them to the 
\Program Files\Ipswitch\WhatsUp\Data\Mibs\ directory, then click Reload in the 
SNMP MIB Manager dialog to update and validate their status. 

 Reload. When you import a new MIB file or are troubleshooting code in a MIB file, 

 

Using the SNMP MIB Manager to troubleshoot MIB 

e 

click Reload to refresh the MIB Module list and the Status list. 

files 

The SNMP MIB Manager validates all MIB files that are imported into or already exists in 
WhatsUp Gold. If an error is identified in a MIB file, the Status column displays the number of 
errors and warnings in the file. If the MIB file syntax is correct and all MIB file dependencies 
are fulfilled, then a check mark is displayed next to the MIB file name and a Success messag
displays in the Status column. 
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Identifying MIB file problems and errors 
If an error exists in a MIB file, you can use the MIB manager to identify where code problems 
exist, then open the MIB file in a text editor (for example, Notepad) and correct the code. 

 

e SNMP MIB Manager list: 

There are a variety of issues that may exist in the code; for example, there may be a simple 
syntax error in the MIB file or there could be a MIB file that has a dependency on another MIB
file. Use the error messages when you view a MIB file to find and correct the problem. 

There are two types of errors that may display in th

  (Warning). This indicates a minor issue with the MIB file (for example, a small syntax 
problem). A MIB file that contains a warning may continue to work, but it is best to 
identify and correct the issue in the MIB file. 

  (Error). This indicates there is a problem in the MIB file that prevents it from wor
MIB file that contains an error must have the error corrected in order for the MIB file to 
function. 

king. A 

 Tip: The most common MIB errors are caused by a MIB dependency on another MIB file that 
is not included in the MIB library. Often, when this issue is corrected, many of the MIB issues 
are resolved. 
Example: If a MIB is missing, the MIB Manager indicates the issue in an error as shown in this 
example excerpt from a MIB status report: 
22      ipMRouteGroup, ipMRouteSource, 
23      ipMRouteSourceMask, ipMRouteNextHopGroup, 
24      ipMRouteNextHopSource, ipMRouteNextHopSourceMask, 
25      ipMRouteNextHopIfIndex, 
26      ipMRouteNextHopAddress           FROM IPMROUTE-STD-MIB 
Error: Cannot find module (IANA-RTPROTO-MIB): At line 26 in 
C:\PROGRA~1\Ipswitch\WhatsUp\Data\Mibs/IPMROUTE-STD-MIB.my 
The important information in this report is: 
Cannot find module (IANA-RTPROTO-MIB). 
This information indicates that the IANA-RTPROTO-MIB is missing from the MIB library in 
C:\Program Files\Ipswitch\WhatsUp\Data\Mibs 
If you determine that a MIB file is missing, you can manually copy the file to the \Program 
Files\Ipswitch\WhatsUp\Data\Mibs\ directory or use the SNMP MIB Manager dialog to 
add (import) a new MIB file. 
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To identify and correct MIB file code: 
rror message in the Status column, then click View. The 

e that identifies the 
 summary 

1 Select the MIB file that has an e
viewer opens with summary information at the top of the pag
number of errors or warnings. In the Lines with errors or warnings
information, you can click the line number to jump directly to a line of code with the 
error. 

 
2 Now that the Viewer has helped you identify the problems in the code, open a text 

editor and correct the code. The MIB files are located in ..\Program 
Files\Ipswitch\WhatsUp\Data\Mibs. 

3 After you have made code changes, save the MIB file, then click Reload in the SNMP MIB 

e code issues. 
 

About the SNMP operations 

An SNMP application can read values for the SNMP objects (for monitoring of devices) and 
some applications can also change the variables (to provide remote management of devices). 
Basic SNMP operations include: 

 Get. Gets a specified SNMP object for a device. 

 Get next. Gets the next object in a table or list. 

 Set. Sets the value of an SNMP object on a device. 

 Trap. Sends a message about an event (that occurs on the device) to the management 
application. 

The SNMP agent software on a device listens on port 161 for requests from an SNMP 
application. The SNMP agent and application communicate using User Datagram Protocol 
(UDP). Trap messages, which are unsolicited messages from a device, are sent to port 162. 

Manager dialog. 
4 Look for the MIB file, that you made changes to, in the list to determine of all the errors 

have been corrected. If all the errors have been corrected, click Close. If the SNMP MIB 
Manager dialog (validator) displays errors, continue repeating steps 1 through 3 until 
you have corrected all of th
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 Note: If an SNMP application makes a request for information about a device but an SNMP 
agent is not enabled on the device, the UDP packets are discarded. 

 

Using a custom name for SNMP device interfaces 

 
e 

ames. Often, the device interface names are 

n 
other applicable workspace reports and split second graphs. 

 

Config
In ord
acces rename each interface according to your naming 
conve

After itors and active 
moni erface in various workspace reports and split 
secon /or active 
moni gly. 

Use t hange a Cisco router interface name. If 
you h ange 
interf

To co

 Open the Cisco Command Line Interface (CLI) and enter the following commands: 

Cisco1812# configure 

Cisco1812(config)# interface FastEthernet 9 

Cisco1812(config-if)# description CUSTOM NAME 

Cisco1812(config-if)# ^Z 

Cisco1812# 

To add a Performance Monitor for a newly renamed device interface: 
1 On the Devices tab, in Device View or Map View, right-click a device, then click 

Properties. The Device Properties dialog appears. 
2 Click Performance Monitors. The Performance Monitors dialog appears. 
3 In the Enable global performance monitors section, click to select the Interface 

Utilization option, then click Configure. The Configure Interface Data Collection dialog 
appears. 

This feature lets you rename SNMP device interfaces to help you manage network interfaces
more efficiently and intuitively. Without this feature you must reference device interfac
names, on a router for example, by their default n
not intuitive and it is difficult to determine the specific interface you are selecting when 
setting up an interface utilization monitor for performance monitors and active monitors. 
This feature also helps you easily select the interface you want to view in interface utilizatio
performance reports and 

uring a custom name (ifAlias) for an SNMP device interface 
er to configure a custom name (IfAlias) for a device's SNMP interface, you need to 
s the device configuration console and 
ntion preference.  

 the interface(s) are renamed, you can add them as performance mon
tors. You can also select the custom int
d graphs. If the device interface(s) already have performance monitors and

tors set up, the new interface name displays in WhatsUp Gold accordin

he following example instructions for how to c
ave other devices, refer to the device documentation for instructions on how to ch
ace names.  

nfigure a device custom name for an SNMP interface on a Cisco router: 
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4 In the Collect data for list, select Specific Interfaces. In this example, CUSTOM NAME is 
the interface name created for the Cisco router. Click to select CUSTOM NAME, then 
click OK. 

 
5 Click OK, then click Close to close the Device Properties dialog. 

es dialog appears. 
Click Active Monitors. The Active Monitors dialog appears. 

To add an Active Monitor for a newly renamed device interface: 
1 In the console application, on the Device View or Map View tab, right-click a device, 

then click Properties. The Device Properti
2 

 Important: If a device has active monitors set up prior to renaming the device's interface(s), 
then after renaming the device's interface(s), remove the old interface(s) from the Active 
Monitor dialog, then click Discover to refresh the device interface list. Use the console 
application for the discover process.  
If a device has performance monitors set up prior to renaming the device's interface(s), the 
device interface names are automatically updated. 

3 (Optional) If a device has active monitors set up for
device's interface(s), select the interface(s) that y

 a device prior to renaming the 
ou renamed from the list of interfaces, 

then click Remove. 
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4 (Optional) Click Discover. The interface list refreshes and populates with the new 
interface names in the Comment list. 

 
5 Click OK, then click Close to close the Device Properties dialog. 

To select a newly renamed device interface for the Interface Utilization report: 
1 From the web interface, click GO. The GO menu appears. 
2 If the WhatsUp section is not visible, click WhatsUp. The WhatsUp section of the GO 

menu appears. 
3 Select Reports > Performance. The Performance Reports list appears. 
4 Under the Device category, click Interface Utilization. An Interface Utilization report 

appears. 

 
ew. 5 Click the device name/IP address (shown above) to select the device you want to vi

The Select a Device dialog appears. 
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6 Expand the network tree list to view the SNMPScan devices, then select the device for 
which you want to view the Interface Utilization report. The Interface Utilization repor
appears. 

t 

7 In the Select Interface list, select the newly named device interface. In this example, the 
interface is named CUSTOM NAME. View the interface utilization report. 

 
 

About SNMP Security 

In WhatsUp Gold, credentials are used like passwords to limit access to a device's SNMP data. 
The credentials system supports SNMP v1, v2, and v3.  

n the web interface 
places throughout the 
Credentials or through 

ased Active Monitors will 
work.  
 

Using th

The T P Trap definitions into the Passive 
Monitor Library. The list in this dialog is populated by the MIBs typically in your WhatsUp Gold 

Credentials are configured and stored in Credentials Library (found o
menu at Go > Configure > Credentials Library) and used in several 
application. They can be assigned to devices in Device Properties > 
the Credentials Bulk Field Change option. 

Devices need SNMP credentials assigned to them before SNMP-b

e Trap Definition Import Tool 

rap Definition Import tool is used to import SNM

MIB folder (\Program Files\Ipswitch\WhatsUp\Data\Mibs). 
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The SNMP Trap monitors that are listed are based on one of three things: 

  301 

 Passive monitors already in the database. By default, the passive monitor database 
comes with a few of the most Common SNMP traps already in it. 

 Passive monitors automatically created by WhatsUp Gold Trap Definition Import 
Tool. Use the Trap Definition Import Tool to create SNMP Traps from MIB files stored in 
the \Program Files\Ipswitch\WhatsUp\Data\Mibs folder. 

 Passive monitors that you define yourself. This can be done either by copying and 
pasting actual trap information directly from your existing logs, or by browsing the MIB 
for OID values that you are interested in, and adding the Generic type (Major) and 
Specific type (Minor) information if required. 

To import SNMP trap definitions into the Passive Monitor Library: 
1 In the WhatsUp Gold console, click Tools > Trap Definition Import Tool. The Trap 

Definition Import Tool dialog appears. 

2  
3 Click to select the traps you want to import, then click Import to passive monitor 

library. The Trap Import Results dialog appears and provides a message about the 
import results. Traps that already exist in the database are not imported again. 
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About Network Tools 

 take 

The following tools help you check the connectivity of networked devices: 

 Ping Tool (on page 304) 

 Trace Route Tool (on page 305) 

 Lookup Tool (on page 306) 

 Telnet Tool (on page 307) 

The following tools help you identify information about MIB objects that network devices 
support: 

 SNMP MIB Walker Tool 

 SNMP MIB File Explorer Tool (on page 310) 

R 23 

Using Network Tools 

In This Chapter 

About Network Tools ......................................................................................303 

Using the Ping tool ..............................................................

Using the Traceroute tool..............................................................................305 

Using the Lookup tool ....................................................................................306 

WhatsUp Gold includes several network tools. These troubleshooting tools allow you to
a closer look at the status of your network devices.   
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The following tools help you identify problems with network devices so you can take 
corrective action to resolve issues: 

 MAC Address Tool (on page 311) 

 Diagnostic Tool (on page 313) 

 Web Performance Monitor (on page 313) 

 Web Task Manager (on page 316) 

 Note: The Web Performance Monitor and Web Task Manager tools are not available in 
WhatsUp Gold Standard Edition. 

Accessing Network Tools 
There are multiple ways to access the network tools. 

 Web interface GO menu. To access the GO menu: 

1 From the web interface, select GO. The GO menu appears.  

2 On the WhatsUp section, select Tools. A list of all available tools appears. 

 Device List and Map View. From either the Device List or Map View, right-click on a 
device and select Tools. 

 

 Device Toolbar Workspace Report. To access network tools using the Device Toolbar 
workspace report: 

1 From either the Device List or Map View, double-click on a device. The device's 
Device Status workspace view appears. 

2 Locate the Device Toolbar workspace report for the selected device. On the right 
side of report, small icons are linked to some of the network tools. 

3 Click an icon to launch the network tool in the context of the selected device. 

 
 

Using the Ping tool 

This tool sends out an ICMP (Internet Control Message Protocol) echo request to the 
networked device identified in Address/Hostname.  
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Tool results 
f this request appear in the bottom of the page after the request has been made. 

kes for the ping request to be returned from 

 Destination. The address specified in Address/Hostname. 

ilure. If failure, a reason is stated for the failure. For example, "Failure: 

 

r the host name or IP 

The results o

 RTT. Round trip time; the amount of time it ta
the remote device. 

 Status. Success or fa
Request timed out." 

To use the Ping Tool: 
1 Enter or select the appropriate information in the following fields.

 Address/Hostname. The target of the Ping echo request. Ente
address of the device you want to check.  

 Note: The Ping tool supports IPv6 addresses. 

 Timeout. Enter the amount of time (in milliseconds) for the tool to wait on a response 
from the device. The Ping fails if this time limit is exceeded. 

 Count. Enter the number of data packets sent by the Ping tool. 

 Ping tool to send. 32 

ool 

Tool results 
 the bottom of the page after the tool has run: 

his is the result of each hop in the Trace Route process. 

 out three ping requests to each hop in the route to the device. 
These columns show the round trip time for each of the requests. 

 Host name. The host name of each device encountered on the path. 

Packet size. Enter the size (in bytes) of the packets you want the 
bytes is the default. 

2 Click Ping to run the tool.  
 

Using the Traceroute t

This tool sends out echo requests to a specific device, then traces the path it takes to get to 
that IP address or host name. This is useful in finding out where on your network an 
interruption occurs. 

The results of this request appear in

 Result. Success or Failure. T

 Ping 1/2/3. The tool sends

 Address. The IP address of each device encountered on the path. 
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To use the Traceroute Tool: 
1 Enter or select the appropriate information in the following fields. 

e host name or IP address of the device you want to  Address/Host name. Enter th
trace the route to. 

 Note: The Trace Route tool supports IPv6 addresses. 

Timeout. Enter the amount of time (in milliseconds) for the tool to wait on a r
from the device. The Trace Ro

 esponse 
ute fails if this time limit is exceeded. 

 Max hops. Enter the maximum number of hops you want to limit the route to. It is 
generally felt that 32 hops should be enough to find any device on the internet. 

t. 

S) server 
pens 

ppropriate information in the following fields. 

o 

 All. Display all available information about the host. 

 CNAME. Display alias names for the host. 

 HINFO. Display the CPU type and operating system type of the host. 

 MX. Display the hostname of the mail exchanger for the domain. 

 NS. Display the hostnames of name servers for the named zone. 

 PTR. Look up the hostname from the Internet address. 

omain's Start of Authority information, which indicates the 
er for the domain and additional administrative information. 

 SRV. Look up any SRV record configured on this DNS server. SRV records specify 

 the DNS server may have for this 
domain name or host. 

2 Click Traceroute to run the tes
 

Using the Lookup tool 

This is a debugging tool that lets you query your Internet domain name system (DN
for information about a domain and its registered hosts. Lookup can show you what hap
when an application on your network uses your DNS server to find the address of a remote 
host. 

To use the Lookup Tool: 
1 Enter or select the a

 Address/Host name. Enter the host name or IP address of the device you want t
trace the route to. 

 Lookup Type. Select the lookup type from the drop-down list: 

 A. Look up the host's Internet address from the hostname. 

 AAAA. Look up for the host IPv6 address from a hostname. 

 SOA. Display the d
primary name serv

the location of services on the network. 

 TXT. Look up any arbitrary text information
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 ZONE. Display the zone listing for the domain. The zone listing describes the 
domains for which the name server is the primary name server) and lists all 

stack look up routines. 

 Custom. Query a custom DNS server. You must then enter the hostname or IP 
e domain name server you want to use. 

l to wait on a response 

 

Using the Telnet tool 

port 23. If no telnet 

registered hosts in the domain. 

 DNS. Select the method of the look up: 

 Stack. Use the OS TCP/IP 

 Default. Use the default DNS server configured on the computer WhatsUp Gold is 
running on. 

address of th

 Timeout.  Enter the amount of time (in milliseconds) for the too
from the device. The Trace Route fails if this time limit is exceeded. 

2 Click Lookup to run the tool. 

Telnet is a simple service monitor that checks for a Telnet server on 
service responds on this port, then the service is considered down. 

To begin the service check, click the Telnet button. Refer to the Telnet application Help for 
more information.  

 Important: The Telnet protocol handler is disabled by default in Microsoft Internet Explorer 
7. To re-enable it, see Re-enabling the Telnet protocol handler (on page 331). 

 

Usin

l lets you discover, or explore in detail, the SNMP objects that a device 
t can be monitored with WhatsUp Gold. The SNMP MIB Walker actively polls 

t ID 

n from the MIB Walker, 
 SNMP object and to 
sor over a node to 

g the SNMP MIB Walker 

This network too
supports and tha
for objects. It does not require MIB files for the polled objects to be loaded. 

An SNMP walk is a succession of SNMP getnext reads starting with the configured Objec
(the root of the subtree walked) until there are no next objects in the MIB subtree or until the 
specified number of lines in the MIB have been walked. As results retur
you can click an object (node) for more detailed information about the
walk further down the list of objects. You can also hover the mouse cur
display SNMP object details. 
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To use the SNMP MIB Walker: 

 the appropriate credentials for the device from the list. For more 
information, see Using Credentials (on page 100). 

  object for which you want 
information. A default OID is displayed in the box. 

1 Enter or select the appropriate information in the following fields. 

 Address or hostname. Enter an IP address hostname for the device. 

 Credentials. Select

Object ID. Enter the numeric or label ID for the

 Filter. (Optional) Enter a filter to narrow down the search by returning only OIDs 
whose values match the filter criteria.  

 Tip r expression, non-case-sensitive filter. For more information, see Regula: This is a regula r 
Expression Syntax. 

 Click the Advanced button 
output types (tree, list-nume

to change the value for the search timeout and retries, 
ric OIDs, list-labels), and the maximum number of lines 

displayed. 

2 After you have entered all of the information, click Walk to perform the search. The 
SNMP MIB Walker returns a list of SNMP objects that are available on the selected 
device. 

 

 
previous w
To cease the walk, click Stop. If you are performing multiple walks, click Back to view the

alk. 
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After the SNMP Walker returns a list of the supported SNMP objects, you can use this 
formation to create custom performance monitors and active script performance mon

s. For more information, see Addin
in itors 
for device g Custom Performance Monitors to Devices (on 

use over the object for which 

page 213). 

To view detailed information about a specific MIB object, mo
you need more information. The information displays in a popup bubble. 

   

You can change the format for the way MIB objects are displayed in the Advanced 

About MIB Output Types 

Parameters dialog. Whether the OID information is output as numeric OIDs or descriptive 
labels, each node may have additional sub-nodes that can be drilled down (walked) for more 
information. Each time you click a node, if there are child nodes, the node you clicked 
becomes the root node for the drill-down. The child nodes are expanded and attributes are 
displayed.  
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MIB objects can be listed in one of three format options: 

ost useful in showing 

s the raw OID information that you can use in Custom Performance 

s you click OID digits, the digits 
ick 

e information expands for the respective digit 
and therefore more granular sub-node information. 

 
 

expand the sub-nodes and view more information. 

 Tree. Lists the MIB object in a tree structure format. This format is m
the OID hierarchy. 

 List - Numeric OIDs. Lists the objects in a tabular format showing OIDs in a row numeric 
format. This format is especially helpful if you do not have the MIB file for the device 
objects. It provide
Monitors and Active Script Peformance Monitors. Also, you can click the individual OID 
digits to display more or less MIB object information. A
further to the left expand the sub-node information of the respective digits. As you cl
OID digits further to the right, the sub-nod

List - Labels. Lists the objects in a tabular format with user friendly labels. If the MIB for 
the object is not loaded, labels will default to numeric OIDs. Click an OID label name to

 Note: You can switch to the WhatsUp Gold MIB Explorer by clicking on the MIB Explorer link 
on the upper-right side of this dialog. 

 

Using the SNMP MIB Explorer 

This network tool lets you search for, or explore through, SNMP objects defined in MIB files. 
The MIB File Explorer has three search/explore options. 

As results return from the MIB File Explorer you can click an object (node) for more detailed 
information about the SNMP object. You can also hover the mouse cursor over a node to 
display SNMP object details. 

To search by object ID: 

 Enter an object label or object ID in the Object ID field, then click Detail. 

To search by MIB module: 

 Select a module from the MIB Module list, then click Display. 

To search objects by type or description: 

 First select Type or Description from the Search Object list. Then proceed appropriately: 

 To search by object Type: 

 Select a type from the list, then click Find. 

 To search by object Description: 

  310 



Using WhatsUp Gold v12.3 

 Enter a regular expression in the Description field. This is a regular express
non-case-sensitive filter. For more information, see Regular Expression Syntax (on 
page 

ion, 

166). After entering the description in the field, click Find. 

 

After the MIB File Explorer returns a list of the supported MIB objects, you can use this 
information to create custom performance monitors and active script performance monitors 
for devices. For more information, see Adding custom performance monitors to devices (on 

213). page 

 Note: You can switch to the WhatsUp Gold MIB Walker by clicking on the MIB Walker link on 
the upper-right side of this dialog. 

 

g the MAC Address Tool 

The MAC Address tool enables you to discover what MAC addresses are present on your 
network and gives you the opportunity to ob

Usin

tain physical connectivity information for 
devices on your network. This tool is useful to solve IP address conflicts within your network 
by providing you with specific switch information. 

Tool results 
After running the tool, the results of the test are displayed at the bottom of the page.  

  311 



Using WhatsUp Gold v12.3 

If Get connectivity information using SNMP is not selec
include the following columns: 

ted when the tool is run, the results 

 Index. The unique value assigned to each interface. This number typically corresponds 

 IP Address. The IP addresses of devices on your network. 

 MAC Address. The MAC addresses of devices on your network. 

 Hostname. The hostnames of devices on your network. 

If Get connectivity information using SNMP is selected when the tool is run, the results 
include the following columns: 

 IP Address. The IP addresses of devices on your network. 

 MAC Address. The MAC addresses of devices on your network. 

 Hostname. The hostnames of devices on your network. 

 Port. The port numbers of the switch ports that are connected to the devices that own 
the listed MAC addresses. 

with the interface port number. 

 Note: If Port and Index report values of -1, WhatsUp Gold did not understand the response 
from the switch or the request timed out. Verify that credentials are correct and that you can 
view other SNMP information from the switch, and then run the MAC Address tool again. 

 Description. The interface description of the interface to which a device is connected. 

To use the MAC Address Tool: 

e subnet on which you would like to find MAC addresses. 

ng SNMP. If you would like switch-specific 
mation for a device in the network, select this option. If this option is 

e following 
options are disabled. 

dential that you use to poll this device. If 
sted, you can add it using the Credential 

ter the amount of time for the tool to wait on a response 
y fails if this time limit is exceeded. 

umber of retries when polling the switch using 

2 Click Discover to discover the MAC addresses present on your network. 
 

Listed as a letter and a numeral, such as "B4".  The interface description allows you to 
identify the physical connector on the switch. 

1 Enter or select the appropriate information in the following fields. 

 Local subnet. Enter th

 Get connectivity information usi
connectivity infor
selected, the following options are enabled. If this option is cleared, th

 Switch IP address. Enter the switch IP address. 

 SNMP credential. Select the SNMP cre
the credential you want to use is not li
Library. 

 Timeout (seconds). En
from the switch. The MAC address discover

 Retries. Enter the maximum n
SNMP. 
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Usin

This tool diagnoses problems within your database by running a diagnostic scan. 

To use the Diagnostic Tool: 
1 To begin the scan, click the Diagnostic button. 
2 After you have looked over and noted any problems, click Close. 
3 To print the report, click the printer icon in the upper right corner of the window. If the 

tool finds any problems, instructions on how to resolve the problems appear onscreen. 
 

Using the Web Performance Monitor 

The Web Performance Monitor extends the functionality of the Microsoft Windows 

g the Diagnostic Tool 

Performance Monitor to the Web. It is a data collecting and graphing utility designed 
specifically for the WhatsUp Gold Web interface that graphs and displays real-time 
information on user-specified SNMP and WMI performance counters. It can be used for a 
quick inspection of a specific network device.  

 

o the database and displayed on workspace views using the Split 
nitor 

The graphs can be saved t
Second Graph - Performance Monitor workspace report or on the Web Performance Mo
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tool. Multiple SNMP and WMI counters can be displayed on a single graph, and the color and 
scale of each graphed item can be individually configured.  

count basis, 
 and saved them. 

and SNMP for network devices such as switches, 

rkspace report. You can 

e Monitor. 

 If the WhatsUp section is not visible, click WhatsUp.  The WhatsUp section of the GO 
menu appears. 

 . 

2 Cl

- or - 

3 Enter the appropriate information into the dialog fields. 

O 

b Performance Monitor appears. 

of the dialog (see the Toolbar buttons table 

4 e changes. 

Graphs created with the Web Performance Monitor are saved on a per-user ac
meaning, graphs are only accessible by the user account that created

The Web Performance Monitor has two purposes: 

 To provide a Web enabled WMI and SNMP performance counter poller and grapher. It 
supports WMI for Windows servers, 
routers, and UNIX devices. 

 To build and edit graphs for use by the Performance Monitor wo
use this workspace report to display any saved graph. 

To add a WMI performance counter to the Web Performance Monitor: 
1 Open the Web Performanc

 From the web interface, click GO. The GO menu appears. 

Select Tools > Web Performance Monitor. The Web Performance Monitor appears

ick Graph > Add WMI Performance Monitor. 

Click the WMI button in the top-right side of the dialog (see the Toolbar buttons table 
below). The Add WMI Performance Counter dialog appears. 

4 Click OK to save changes. 

To dd a SNMP performance counter to the Web Performance Monitor:  a
1 Open the Web Performance Monitor. 

 From the web interface, click GO. The GO menu appears. 

 If the WhatsUp section is not visible, click WhatsUp.  The WhatsUp section of the G
menu appears. 

 Select Tools > Web Performance Monitor. The We

2 Select Graph > Add SNMP Performance Monitor.  

- or - 

Click the SNMP button in the top-right side 
below).  

The Add SNMP Performance Counter dialog appears. 

3 Enter the appropriate information into the dialog fields. 
Click OK to sav 
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Web Performance Monitor menu items 
The Web Performance Monitor menu is located at the top left corner of the window. 

ph back to a blank graph. 

e of the selected graph. 

h 

 File > Save Graph. This saves the current graph to the database. If no filename is 
filename to be specified. All 

 File > Save Graph As. This opens the Save Graph dialog which prompts you for a 

is 
Monitor. 

 Graph > Add WMI Performance Counter. This launches the Add WMI Performance 
Counter dialog.  

 Graph > Add SNMP Performance Counter. This launches the Add SNMP Performance 
Counter dialog. 

 Graph > Edit Selected Counter. This launches the appropriate dialog for editing the 
selected WMI or SNMP performance counter.  

 Graph > Remove Selected Counter. This removes the selected counter from the list and 
graph. No changes are saved to disk until the OK button is clicked or the graph is 
manually saved (File > Save Graph - or - Save Graph As). 

Help menu 

 Help > Help. This launches help for the Web Performance Monitor. 

Web Performance Monitor Toolbar buttons 
The Web Performance Monitor Toolbar is located at the top right corner of the window. 

Button Function 

File menu  

 File > New Graph. This menu item resets the gra

 File > Edit Graph Name. This menu item lets you change the nam

 File > Load Graph. This opens the Load Graph dialog, which displays a list of saved grap
files on the Web server. 

specified, it launches the Save Graph dialog, which allows a 
files are saved to the WhatsUp database. 

filename, and then saves the current graph to disk. 

 Windows Properties. This opens the Configure Window Properties dialog. Use th
dialog to configure the graph and window properties for the Web Performance 

Graph menu 

 

Opens the Add WMI Performance Counter dialog. 

 

Opens the Add SNMP Performance Counter dialog. 

 

Opens the appropriate dialog for editing the selected WMI or SNMP performance 
counter.  

 

Removes the selected graph item from the list and graph. 
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Opens the help topic for the Web Performance Monitor 

For troubleshooting information, see Troubleshooting SNMP and WMI connections (on page 
330). 
 

anager graphs and displays real-

vice issues and take corrective action on a 

Using the Web Task Manager 

The Web Task Manager extends the functionality of the Microsoft Windows Task Manager to 
provide network device overview information about processes occurring on a device, device 
performance, and device interface activity. The Web Task M
time information using SNMP or WMI device connections.  

You can use the Web Task Manager to identify de
device. 

 

There are three tabs that provide device information: 

 s. Provides key indicator process information for a selected device that WhatsUp 
s that are running and the 

n for a selected device that 
g. For example, you can view details about the CPU and 

memory usage.  

 Interfaces. Provides information about a selected device's interfaces that WhatsUp Gold 
is monitoring. For example, you can view a list of interfaces that the device uses learn 
about how much data is transmitted and received via each interface.  

Processe
Gold is monitoring. For example, you can view a list of .exe file
amount of CPU and memory used by each program. 

 Performance. Provides dynamic performance informatio
WhatsUp Gold is monitorin
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 Note: When viewing information for devices running Microsoft Windows, information 
gathered via WMI is displayed in real time. Information gathered by SNMP, however, may 
reflect a delay of one minute or more. This delay is caused by a limitation in how often 
Microsoft Windows updates SNMP values. 

To use the Web Task Manager: 
1 Open the Web Task Manager. 

 From the web interface, click GO. The GO menu appears. 

e GO 

e Web Task Manager appears. 

 (...). Click to open the Web Task Manager Credentials dialog and set a WMI 
 

Updates device information every one second. 

P) used to monitor and 
ge the device. The credentials stored in the Credentials Library are used to 

 If the WhatsUp section is not visible, click WhatsUp.  The WhatsUp section of th
menu appears. 

 Select Tools > Web Task Manager. Th

2 Enter or select the appropriate information for the following fields: 

 Address or hostname. Enter a device IP address to select a device for which you want 
to view process information. Click Reconnect to connect with a device that has 
disconnected from the Web Task Manager. 

 Browse
user name and password or an SNMP read community. The credential options are
provided from the credentials stored in the Credentials Library. 

 Speed. Select the speed at which you want to monitor the device performance. 

 Normal. 

 Medium. Updates device information every five seconds. 

 Slow. Updates device information every ten seconds. 

 Paused. Stops updating device information. 

 Connect using. Select the device protocol (WMI or SNM
mana
connect and read information on the selected device. 

 Note: When viewing information for devices running Microsoft Windows, information 
gathered by SNMP may reflect a delay of one minute or more. This delay is caused by a 
limitation in how often Microsoft Windows updates SNMP values. For this reason, we 
recommend using a Speed of Medium or Slow when using SNMP to view interface 
informa a device running Microsoft Windows. tion about 

3 At the bottom of the Task Manager page, select the tab that you want to use 
(Processe

4 For troubleshooting information, see Troubleshooting SNMP and WMI connections (on 
page 330)

 

s, Performance, or Interfaces). 

. 
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Using the Web Task Manager - Process tab 

Up Gold is monitoring. This information helps you learn about device processes and 
identify trends and issues that occur on a particular network device. You can use the Web 

anager to view the processes running on WMI- or SNMP-enabled network devices. 

The Processes tab provides key indicator process information for a selected device that 
Whats

Task M

 Note: Microsoft Windows Server 2003 reports the VM Size column information in Kilobytes 
instead of Bytes. This is a known issue to be corrected in a future WhatsUp Gold release. 

 

After you have identified a process that is causing device performance issues, such as an 
ation executable like Outlook.exe running multiple instances of the program, you 

can correct the problem to bring the device performance back to normal. 
applic

 Note: Unlike the Windows Task Manager, you cannot terminate processes using the Web 
Task Manager. To terminate a task, you must log in to the computer where the task is running 
and use the Windows Task Manager to end the process. 

 Note: Some differences exist in column names between the Web Task Manager and 
Windows Task Manager in Windows Vista and Windows 2008. The Mem Usage column in 
Web Task Manager is named Working Set (Memory) in Windows Task Manager on 
Windows Vista and Windows 2008. The VM Size column in Web Task Manager has no 
corresponding column in Windows Task Manager on Windows Vista and Windows 2008. 
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Using the Web Task Manager - Performance tab 
The P hat 
What nce and 
ident cur on a particular network device. You can use 
the Web Task Manager to view device performance for devices that are WMI or SNMP 

erformance tab provides dynamic performance information for a selected device t
sUp Gold is monitoring. This information helps you learn about device performa
ify trends, spikes, or other issues that oc

enabled network devices. 

 

you have identified a performance issue that is causing device performance is
 Page File Usage indicating that the system memory 

Afte
as th

r sues, such 
e is nearly at full capacity, you can 

correct the problem to bring the device performance back to normal. 

 Note: When viewing information for devices running Microsoft Windows, information 
gathered via WMI is displayed in real time. Information gathered by SNMP, however, may 
reflect a delay of one minute or more. This delay is caused by a limitation in how often 
Microsoft Windows updates SNMP values. 

The following are examples of information that is provided when you connect to and view a 
WMI enabled device. Note, this information varies by operating system: 
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 CPU Usage. This graph indicates the percentage of time the processor is operating. Use 
ng. 

 

 Page File Usage History. This graph indicates how much the page file memory is used 
age 

 Totals. This provides the total number of Handles, Threads, and Processes occurring on 
the selected device. 

 Commit Charge (K). Provides information about the memory (Total, Limit, and Peak) 
allocated to the operating system and applications running on the device. 

 Physical Memory (K). Provides information about the amount of physical memory (Total, 
Available, and System Cache) installed on the device.  

 Kernel Memory (K). Provides information about how much memory (Total, Paged, and 
Nonpaged) the operating system kernel and device drivers are using. 

this graph to view how much the processor is operati

 CPU Usage History. This graph indicates how much the processor has operated over 
time. You can change the Speed option (High, Normal, Slow, Paused). The Speed option
determines how often updates occur to the CPU Usage History. 

 PF Usage. This graph indicates how much page file memory is used.   

over time. If page file memory usage is high, you may want to increase the available p
file memory. 

 Note: Values reported for Peak and System Cache will differ from values reported by the 
Windows Task Manager on the actual device. In the Web Task Manager, Peak reflects the 
peak value for the time that the Web Task Manager has been open only, and System Cache 
does not include the size of the free page list. 

The following information are examples of the information that is provided when you 
connect to and view a SNMP enabled device. Note, this information varies by operating 
system: 

 In (PKTS). Provides detailed information about the network packets that this device 
receives. 

 Out (PKTS). Provides detailed information about the network packets that this device 
sends. 

 System. Provides general system information about CPU performance, the number of 
interfaces that are running on the device, the total amount of time the device has been 

For troubleshooting information, see Troubleshooting SNMP and WMI connections (on page 
330). 
 

operating in the up mode, and the version number of Cisco software running on the 
device (if applicable). 
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Using the Web Task Manager - Interfaces tab 
The Interfaces tab provides information about the interfaces available on a selected device 
that WhatsUp Gold is monitoring. This information helps you determine how much data is 
transmitted and received via each interface, and therefore may help you locate an interface 
that using an unexpected amount of bandwidth. 

 

After you have identified the interface that is causing bandwidth performance issues, such as 

 

The Web Task Manager includes the following columns: 

 D e 
d

 Index ntifier of the interface as defined on the 
device. 

a file sharing application exposing shared files on a computer for others on the Internet to 
access and download, you can correct the problem to bring the device performance back to
normal. 

escription. This column is the text description of the interface as configured on th
evice. 

. This column is the unique numerical inde

 Transmit %. This column indicates what percentage of the interface's capacity is 
currently being used to transmit data. 
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transmitted by the device 

 Receive %. This column indicates what percentage of the interface's capacity is currently
being used to receive data. 

 In Bandwidth (kbps). This column shows the amount of data received by the device in
kilobits per second. 

 Out Bandwidth (kbps). This column shows the amount of data 
in kilobits per second. 
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Using WhatsUp Gold Distributed and 
MSP Editions 

In This Chapter 

About WhatsUp Gold Distributed and MSP Edition ............................323 

 
 

About WhatsUp Gold Distributed and MSP Edition 

WhatsUp Gold Distributed and MSP Editions extends the capabilities of WhatsUp Gold to 
multiple remote networks. The distributed solution includes a WhatsUp Gold Central 
installation and a WhatsUp Gold Remote installation. The WhatsUp Gold Central Site 
installation coordinates data feeds from multiple Remote Site installations. The network data 
collected from the Remote sites can be viewed in reports on the Central Site. Together, the 
Central and Remote installations provide high visibility to multiple networks from one central 
location.  

For more information, see WhatsUp Gold MSP Deployment Guide 
(http://www.whatsupgold.com/wug123mspdg) or the WhatsUp Gold Distributed Deployment 
Guide (http://www.whatsupgold.com/wug123dsdg).

TER 24 
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Troubleshooting your network 

WhatsUp Gold is a tool used to monitor your network. It is up to you to fix the items that 

The following are questions you should think about while troubleshooting problems 

 Is the entire subnet affected, or a single device? 

 If it is the entire subnet that appears to be down, you should check your hub, router, or 

 Check wireless network cards and signal strength. 

 Check the Health Detail Report to see whether a single monitor or the entire device is 
down. If the device is down, all of the monitors will appear to be down. 

 Using the Ping monitor, verify that the connection between the device and the network is 
up. 

 If a monitor appears to be down, try restarting the service that the monitor is watching. 
To restart a service, you must access the device directly; this cannot be done through 
WhatsUp Gold. 

 

Maintaining the Database 

You can use the WhatsUp database utilities to back up and restore the database and to 
perform database maintenance and troubleshooting. If you have a WhatsUp Gold NetFlow 
Monitor license, you can also back up and restore the NetFlow Monitor databases via the 
WhatsUp database utilities. 

To access the database utilities, open the WhatsUp Gold console, then select Tools > 
Database Utilities from the main menu. 
 

APPENDIX A 

Troubleshooting and Maintenance 

WhatsUp Gold brings to light. 

detected through WhatsUp Gold. 

 Is the entire device affected, or a service monitor on the device? 

 What type of device is down? 

Actions to take 
After you have determined the scope of the network problems, one of the following may 
help you fix the problem. 

switch. 

 Begin with checking the physical connections of the device to the network and to the 
power supply. Check the network cables and power cables. 
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Using the database backup and restore backup utility 
Through this feature, you can back up your complete WhatsUp Gold SQL Server database to 
any mapped directory you have on your network. The file is saved as a .dat file and can be 
restored at any time. Using Backup, your data is saved to a .dat file. Restore reverses this 
process, overwriting your current database with the data in a .dat file. 

 Important: You can use this feature with any local instance of SQL Server whose database is 
named WHATSUP. This feature does not work with remote databases.  

If you want to back up the SQL database to a mapped drive, you may need to change the 
Logon settings for the SQL Server (WHATSUP) service (or your customized SQL service). The 
account must have write access to the mapped drive for the backup to be successful.  

To change the SQL database logon settings: 
1 Click Start > Control Panel > Administrative Tools > Services, then double click SQL 

Server (WHATSUP). The SQL Service Properties dialog appears. 
Click the Log On tab on the Properties dialog. 
Change the account logon settings as required. 

2 
3 

 Important: This is a complete backup and restore, so any change that you make after the 
backup will be overwritten if a restore process is done. 

To access the Database Utilities Backup and Restore features: 

From the main menu in the WhatsUp Gold console, select Tools > Database Utilities > Back 
Up SQL Database. 

- or -  

Tools > Database Utilities > Restore SQL Database. 
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About the database tools 

1 se Utilities > 

The database tools let you manage index fragmentation and purge expired data. 

To access the tools:  
From the main menu in the WhatsUp Gold console, select Tools > Databa
Tools. The Database Tools dialog appears. 

 
2 Select one of the tools: 

 Performance 

 Table Maintenance 
 

Database Performance Tool 
The Database Performance Tool is used to monitor the size of your database, and to manage 
the index fragmentation percentage of the individual tables. Fragmented indexes can cause 

rably, in much the same way that disk 
n slower. 

e 

r 
tation, along with the total number of data rows in that table. 

ice. The 
 dialog, next to this button. 

database operations to slow down conside
fragmentation causes your computer to ru

Click Check for fragmented tables to begin. This may take a considerable amount of tim
(up to a few minutes), depending on how many records are in your database. 

 Select fragmented tables to optimize. This list shows all database tables with greate
than 10% index fragmen

 Optimize selected tables. Select the tables in the list above to defragment those 
database tables. WhatsUp Gold automatically stops and restarts the WhatsUp Serv
status of the operation appears on the
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 The current database size is. This section of the dialog shows the tot
used by the database. If you are using SQL Server 2005 Express as the W

al amount of space 
hatsUp Gold 

te 
se. WhatsUp Gold 

automatically stops the WhatsUp Service and restarts it once the operation is complete.   

D k the integrity of all 
constraints in the database, check for consistency in and between system tables in the 

E, 
which shrinks the size of the data files in the database. Note that no compression is used; 

ing empty space.  

 
?url=/library/en-

Web site.. 

Database Tools Table Maintenance 
This ul 
when is process is lost and cannot be 
restored. 

rpose they serve (active 
monitors, report data collection, and other). Select the tables you want to purge from the 

rows in this table that currently holds data. This 
ludes live and expired rows. 

 Expired Rows. The total number of expired data rows in this table. Expired data is data 
d by the application or has not been 

reused. These are rows that are marked for deletion, or have been kept longer than 
needed, according to your data roll-up settings. 

Click Purge Expired Rows to remove those records from the database. 
 

Recovering from a "Version Mismatch" error 

When starting the WhatsUp Gold application, you may get a "Version Mismatch" error if the 
program version does not match the database version. The WhatsUp Gold application can 
only use a database that is compatible with the version of the software currently installed. 

If the install encounters an error during upgrade and you abort the database upgrade portion 
of the install, or you choose the Ignore option and allow the upgrade process to continue the 
install, the database may not not be upgraded properly. To attempt to resolve this issue, 
reboot your machine and run the same install again. During the install, select the Repair 
option. 

database, this section also displays the percentage of the 4 GB file size limit currently in 
use. 

 Validate and compact database. Click this button to execute commands that valida
the database, index, and database links, and to compact the databa

The validation phase executes the SQL Server commands DBCC CHECKCONSTRAINT, 
BCC CHECKCATALOG, and DBCC CHECKDB.  These commands chec

database, and check the allocation and structural integrity of all the objects in the 
database. 

The compacting phase executes the SQL Server command DBCC SHRINKDATABAS

the database is simply compacted by remov

For more information on validating or compacting the database, see Getting Started with
SQL Server (http://www.msdn.microsoft.com/library/default.asp
us/startsql/getstart_4fht.asp) on the Microsoft 

 

 feature lets you purge expired data from data tables in your database. Be very caref
 using this dialog, as data that is purged through th

 Select tables to purge. The data tables are grouped by the pu

three lists. 

 Total Rows. The total number of data 
inc

that has been rolled up, and has not yet been purge
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 Important: If running the repair does not correct the database issue, review your log file to 
help identify the issue (located in the ..\Program 
Files\Ipswitch\WhatsUp\RemoteDBConfig.txt, search the Ipswitch Knowledge Base 
(http://www.whatsupgold.com/wugTechSupport) for technical support resources, or contact 
Ipswitch Technical Support (http://www.whatsupgold.com/wugTechSupport) for 
troubleshooting help. 

You may also get a "Version Mismatch" error if you restore a WhatsUp Gold database from an 
earlier version of the application. To attempt to resolve this issue, reboot your machine and 
run the same install again. During the install, select the Repair option. 

 Important: The WhatsUp Gold polling engine will not run, nor can the WhatsUp Gold 
application or web interface be used until this database version mismatch error is corrected. 

 

Task Tray Application fails on Windows Vista 

After installing WhatsUp Gold on Microsoft Vista, the WhatsUp Gold Task Tray Application 
does not connect to the database if you log in to Windows using any account other than the 
account used to install the application. To correct this issue, execute this script from the 
command line in the  C:\Program Files\Ipswitch\WhatsUp\DB Scripts\ folder: 

sqlcmd -E -S (local)\WHATSUP -d WHATSUP -i 
grant_all_users_read_access.sql 

 Important: If you run the above script, all database users (admin and others) are granted 
read access to the WhatsUp Gold database. 

 

Connecting to a Remote Desktop 

he Remote Desktop/Terminal Services client that 

 for that 

 the 

WhatsUp Gold provides a quick link to t
allows you to connect to your devices remotely. If the client is installed on your WhatsUp 
Gold computer, and the Remote Desktop/Terminal Services is installed and activated on the 
device you want to connect to, you are prompted for the user name and password
device.  

This application allows you to troubleshoot problems with your devices and monitors 
identified by WhatsUp Gold. 

To connect to a remote desktop: 
1 Right-click the device you want to connect to. 
2 From the right-click menu, select Remote Desktop. If the connection is successful,

log in dialog appears. If the connection fails, an error message appears.   
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 Note: For more information about the Remote Desktop feature, see the online help for the 
Remote Desktop client itself. 

 

hW

This
Gol

To restart the WhatsUp Gold engine: 
1 
2 
3 
 

Troubl nections 

atsUp Gold engine message 

 message means that WhatsUp Gold is not operating properly, because the WhatsUp 
d Engine service has stopped. 

Open the Windows Control Panel. 
Select Administrative Tools > Services. The Services window appears. 
Select Ipswitch WhatsUp Engine, then click Start. 

eshooting SNMP and WMI con

If you experience connection problems when connecting to a device via the Web Task 
Manager, Web Performance Monitor, or any other WhatsUp Gold feature that uses WMI or 
SNMP, please consult the lists below to troubleshoot the problem. 

Troubleshooting a WMI connection 

 Important: You must have administrative credentials to establish WMI connections. For 
more information, see Using Credentials (on page 100). Also, see Microsoft article 875605 
(http://support.microsoft.com/default.aspx?scid=kb;en-us;875605).  

 Establishing a WMI connection can be very slow.  

This slow connection time can worsen when attempting to connect with devices run
Microsoft Vista. 

ning 

evice's firewall and 
the firewall for device to which you are attempting to connect. Also be sure to open this 

 Connected devices that are running different versions of Microsoft software (i.e. - 

 
o 

10 seconds. 

We recommend that you open RPC port 135 on both the WhatsUp d

port on any firewall between the connecting devices. Refer to the operating system Help 
for more information. 

Microsoft XP and Vista) may experience delayed or slow communication. 

 WMI over VPN connections can take up to 120 seconds (possibly longer) to establish an
initial connection. After the initial connection is made, subsequent connections take 8 t

 Again, we recommend that you open RPC port 135 on each device's firewall, and any 
firewall between the connecting devices. 
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 A WMI memory leak exists in Windows 2003 and XP. Microsoft has developed hotfix 
, 

an

For m  
(http
(http://msdn2.microsoft.com/en-us/library/aa389286.aspx), and the section entitled "I can't 
connect to a remote computer" in the Microsoft Script Center article, "WMI Isn't Working!" 
(http://www.microsoft.com/technet/scriptcenter/topics/help/wmi.mspx#E2C).  

911262 (http://support.microsoft.com/kb/911262/en-us) that minimizes the leak in XP
d completely fixes the leak in Windows 2003.  

ore information regarding WMI and connection problems, see Microsoft articles 389290
://msdn2.microsoft.com/en-us/library/aa389290.aspx), 389286 

Troubleshooting an SNMP connection 

 Important: The SNMP Trap Listener must be enabled to collect data for the SNMP Trap Log. 
To enable the WhatsUp Gold SNMP Trap Listener, the Microsoft SNMP Trap Listener must be 
disabled. Also, be sure to open SNMP port 162 for incoming SNMP traps. 

 If you receive invalid values when attempting to monitor the IfOperStatus OID from a 

 If you experience connection problems with a specific device, ensure that the device has 

s is 

interval could help compensate for the lengthy Microsoft polling interval. 

 Sim  spikes in your graphs, try 
incr

 

Re-enabling the Telnet protocol handler 

The Telnet protocol handler is disabled by default in Microsoft Internet Explorer 7. In order to 
ble the Telnet protocol. 

To re-enable the Telnet protocol: 

_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet 
Explorer\Main\FeatureControl 

eControl, create a new key named 
FEATURE_DISABLE_TELNET_PROTOCOL. 

lore.exe and set the value to 0 (decimal). 
protocol is 

device running Vista, download Microsoft's hotfix 935876 
(http://support.microsoft.com/kb/935876) to solve the problem. 

SNMP enabled. Also ensure that SNMP port 161 is open on the device you are attempting 
to monitor. 

 If you get what looks like a "stair-step" in your CPU and Process Utilization graphs, thi
caused by Microsoft's 60-second polling interval. Increasing WhatsUp Gold's polling 

ilarly, if you experience delays and/or unexpected, weird
easing the polling interval. 

use the Telnet tool in WhatsUp Gold, you need to re-ena

1 Click Start > Run. The Run dialog box opens. 
2 In the Open box, enter: Regedit, then click OK. The Registry Editor opens. 
3 Go to the following key: 

HKEY

4 Under the HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet 
Explorer\Main\Featur

5 Add a DWORD value named iexp
6 Close the Registry Editor and restart Microsoft Internet Explorer 7. The Telnet 

enabled. 
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Passive Monitor payload limitation 

Passive monitors have a payload limitation of 3 KB for WMI, SNMP, and Syslog Passive 
Monitors. Users should no longer get blank emails or nothing logged to the database. 
 

Restarting the WhatsUp Gold services from the 
comm

d polling engine and the Ipswitch Web Server using 
 line utility. This utility can be called directly from the 

ated processes. 

and line 

You can quickly restart the WhatsUp Gol
the NmServiceRestart.exe command
command line or from batch scripts or scheduled tasks as part of your autom

Usage 
NmServiceRestart.exe [/s] [/p] [/w] 

Parameter Description 

/s Run in silent mode. When this option is included, the utility does not report
feedback. 

 any 

/p Restart the WhatsUp Gold polling engine only. 

/w Restart the Ipswitch Web Server only. 
 

 Note: If both /p and /w are specified, the utility restarts both services. If only one is specified, 
the utility restarts only the service that is specified. 

 

Recommended SMS modems and troubleshooting 
tips 

Ipsw
SMS

dem.  

 Falcom Samba 75 (http://www.falcomusa.com) 

itch has tested the following SMS modems for use with the SMS Direct Action (not the 
 Action): 

 Motorola® RAZR V3 (http://www.motorola.com) (Recommended) 

This cell phone was connected to the WhatsUp device acting as a GSM mo

 Siemens TC65 Terminal (http://www.usa.siemens.com) 

Unlike the other modems that have their own drivers to install, this modem did not have 
specific drivers to install. The Windows Standard 56000 bps modem driver was used with 
the maximum port speed set to 115200.  
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To consider 
 GSM networks operate in the 850/900/1800/1900 Mhz bands. 

 GSM modems are typically either dual or quad band. 

 Note: You must acquire a dual modem that operates at the correct frequency, or purchase a 
quad band modem. 

 European markets typically use 900/1800 Mhz capable devices. 

evices. 

Tro
If an S rt) 
to wh by the modem. 

ge returns to correct SMS modem issues 
Some SMS Direct enabled phones do not work correctly with SMS Direct Actions because 

 corrected by adding 

ination of a carriage return (\r) and/or line feed (\n) 
: 

 
 

Uninstalling Ipswitch WhatsUp Gold v12 

rt > Settings > Control Panel, then select Add or Remove Programs. 
2 Select Ipswitch WhatsUp Gold v12. 

 The U.S. and Canada use 850/1900 Mhz capable d

ubleshooting SMS Modems 
MS modem is not working as expected, verify that the communications port (COM po
ich the modem is attached is configured to use settings supported 

1 In the Windows Control Panel, double-click Device Manager. The Device Manager 
appears. 

2 Expand Ports. 
3 Double-click the communications port used by the SMS modem. The Communications 

Port Properties dialog appears. 
4 Select the Port Settings tab. 
5 Using the documentation provided by the modem manufacturer, verify that the port 

settings listed are supported by the modem. If the listed settings are not supported, 
make any necessary changes. 

6 Click OK to save changes.  

Using line feeds and carria

new line characters are not always handled properly. This issue may be
the following new registry key entry: 

HKEY_LOCAL_MACHINE\SOFTWARE\Ipswitch\Network Monitor\Whatsup plug-
ins\Actions\ActSmsDirect\NewLine  

In the Value data box, enter a comb
command. For example enter one of the following

 newline \r\n (recommended) 

 newline \r 

newline \n 

To uninstall Ipswitch WhatsUp Gold v12: 
1 Select Sta
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3 Select Remove. 
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You can also run the Ipswitch WhatsUp Gold v12 installation program, then select Remove. 

 Remove the WhatsUp Gold application, but leave network data I have collected 
intact. This uninstalls the WhatsUp Gold program but keeps all your WhatsUp 

he WhatsUp Gold application, and all network data I have collected. 
moves all of your WhatsUp configuration and 

monitoring data. 

Select one of the following dialog options: 

configuration data as well as the monitoring data you have collected. SQL Server 2005 
Express will not be uninstalled. 

 Remove both t
This uninstalls the WhatsUp program and re

 Also, remove the "WhatsUp" copy of SQL Server Express Edition. This also removes 
the "WhatsUp" SQL Server 2005 Express Edition instance that was created during the 
installation. Select this option to remove ALL WhatsUp components from the system.  

 Note: When this option is selected, WhatsUp Gold leaves SOME data behind, such as the 
\HTML directory and the \Data directory for situations where there may be user-modified or 
user-created fi rectories. les in those di

 



 
 

APPENDIX B 

  335 

About the Dashboard Screen 
Mana

iew....................................335 

Installing the Dashboard Screen Manager..............................................336 

Screen Manager playlist .............................338 

Ipswitch Dashboard Screen Manager overview 

f 

ork monitoring application, WhatsUp Gold, and as an aid to 
he Dashboard application is included in the WhatsUp Gold 

imes, cycling and changing on its own without the 
provides the capability to view multiple networks that 

Though the Dashboard Screen Manager was created to work along-side WhatsUp Gold, it can 
all 

hboard and sees that the connectivity to 
t the same 

 to see that the extreme temperatures of the day have 
ems for the cable transmitters. 

ger 

In This Chapter 

Ipswitch Dashboard Screen Manager overv

How does the Dashboard Screen Manager work? ...............................336 

Configuring a Dashboard 
 
 

The Dashboard Screen Manager is a stand-alone application designed to display a series o
Web pages, or a "playlist," on one or multiple monitors. The Dashboard was created as a 

mplement to the Ipswitch netwco
keeping your network visible. T
Central and Remote Site installations. 

The Dashboard can run on a display console and cycle through various pages from the 
WhatsUp Gold web interface. Network administrators then have important and pertinent 
network information on display at all t
need of constant configuration. It also 
you are monitoring simultaneously. 

display virtually any Web page. For example, an Internet business providing service to a sm
town in the desert glances at one screen on the Das
the town is down. By displaying the weather for this town on another screen a
time, the network administrator is able
likely caused probl

 Note: If you want to display a password protected page for another Web application, you 
must supply a valid username and password for the page. For more information, see the 
Dashboard application Help. 

For more information about the Dashboard 
g

playlists, see Configuring a Dashboard Playlist (on 
pa e 338). 
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For more information about configuring a multi-monitor network display, see Setting up a 

it needs: 

What 
On th
a single monitor. A playlist or multiple Web pages. When a playlist is 
configured with a single Web page, this single page is refreshed on a user-specified refresh 
interval. When a playlist is configured with multiple Web pages, the playlist cycles through 
the pages also on a user-specified interval. 
 

Installing the Dashboard Screen Manager 

On the device you wish to install the Ipswitch Dashboard Screen Manager: 

1 Log on to an Administrator account. 
2 Start the installation program: 

If you downloaded the Dashboard from the Ipswitch Web site, run the downloaded 
installation application. 

3 Read the Welcome screen. Click Next to continue. 
4 Read the license agreement. Select the appropriate option, then click Next. 
5 Select the install directory for the Dashboard. The default is:  

C:\Program Files\Ipswitch\Dashboard 

To browse and select an install directory different than that of the default location, click 
Change. 

Click Next to continue. 

6 Click Install to install the Ipswitch Dashboard. 

WhatsUp Multi-Monitor Network Display, located on the WhatsUp Gold Web site 
(http://www.whatsupgold.com/). 
 

How does the Dashboard Screen Manager work? 

In order for the Dashboard to work, 

1 A monitor, or several monitors 
2 A playlist for each monitor 

The Dashboard displays a single playlist on every monitor you configure for use with the 
Dashboard. You can configure as many monitors as you would like for use with the 
Dashboard. 

is a Dashboard playlist? 
e Dashboard Screen Manager, a playlist is a list of Web pages the Dashboard displays on 

 can consist of one single, 

 Note: To terminate the installation once it has began, click Cancel. 

7 Make your selection, then click Finish. 
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Disable script debugging in Internet Explorer 
ve installed the Dashboard Screen Manager, it is important that you make sure 

-up and could crash 
nsure or know that 

t debugging in Internet Explorer: 
t Explorer and go to Tools > Internet Options. The Internet Options 

dialog appears. 
 tab.  

3 Scroll down and check the Disable Script Debugging (Internet Explorer) and the 

Opening the Dash
After successfully installing the Dashboard, you can access the application from your 
Windows Start Menu by selecting Ipswitch Dashboard > Dashboard. 

After you ha
script debugging is disabled. Otherwise, a debugging program will pop
the Dashboard. By default, script debugging is disabled, but if you are u
you have it enabled, you can check this setting in Internet Explorer. 

To disable scrip
1 Open Interne

2 Select the Advanced

Disable Script Debugging (Other) options. 
4 Click OK to save changes. 
 

board Screen Manager 

 Note: This changes if after the initial setup of the Dashboard, you choose to run the 
Dashboard at Startup (on the Dashboard Settings dialog). If you choose to do so, the 
Dashboard Screen Manager will automatically take you to the blank screen discussed below. 

When the dashboard first opens, a blank screen is displayed. The blank page's title bar read
"Ipswitch Dashboard [Configure the 'Pl

s, 
aylist' for the Dashboard by clicking a mouse button] - 

aboutblank." 

y 

Operations dialog. From here, you can 

If you have multiple displays, you will see a Dashboard application instance for each displa
in the taskbar. For example, if you have three display devices, DISPLAY1, DISPLAY2, or 
DISPLAY3 shows in the taskbar. Select the display you want to configure first, then click a 
button on your mouse to open the Dashboard 
configure Dashboard playlists (on page 338). 
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Conf

Keep in mind that you need to set up a playlist for each physical monitor on which you want 
to display Web pages through the Dashboard Screen Manager.  

Screen Manager upon Startup, click Start > 
Programs > Ipswitch Dashboard > Dashboard. The Dashboard Operations dialog appears. 

u 
alog 

. The Pane 

iguring a Dashboard Screen Manager playlist 

To configure a single Web page playlist: 

If you have chosen not to run the Dashboard 

- or - 

If you have chosen to run the Dashboard Screen Manager upon Startup, on the display yo
want to configure a playlist for, click on the screen and the Dashboard Operations di
appears.  

1 On the Dashboard Operations dialog, 
Properties dialog appears. 

select Playlist for this Monitor

 
2 
3 fields: 

he URL for the Web page you want to display in the following 

http://www.websitename.com/webpagename 

 econds) for how often 

lect a user from the drop-down list, or click the 
browse (...) button to choose a user from the WhatsUp Gold Web Login Library. This 

Select Display single Web page. 
Enter the appropriate information in the following 

 Title bar text. Enter the title bar name for the Dashboard display. 

 URL. Enter or paste t
format: 

Refresh interval (in seconds). Enter an amount of time (in s
you would like the Web page to refresh. 

 WhatsUp Gold Web login. Either se
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user account is used for the Dashboard application to log-in to a password protected 
site. Without a proper user account, the application is not able to display a password-
protected Web page. If you are using a non-WhatsUp Gold Web page, set the Web 
login to None. 

 Note: Other applications requiring a username and password to display Web pages can be 
used in the Dashboard Screen Manager. You can specify these other application username 
and passwords in the URL field, appended to the Web page URL. 

4 Click OK to save changes. 

 Important: The Web Login drop-down list is empty until you populate the Web Login Library 
with users. You can do this via the Web Login Library dialog. 

To configure a multiple Web page playlist: 

If you have chosen not to run the Dashboard Screen Manager upon Startup, click Star
Programs > Ipswitch Dashboard > Dashboard. The Dashboard Opera

t > 
tions dialog appears. 

- or - 

If you  
want
appears.  

play you want to configure a playlist for, select Playlist for this Monitor. The 
Pane Properties dialog appears. 

following fields: 

 Title bar text. Enter the title bar name for the Dashboard display. 

 URL. Enter or paste the URL for the Web page you want to display in the following 
format: 

http://www.websitename.com/webpagename 

 Refresh interval (in seconds). Enter an amount of time (in seconds) for how long you 
would like the Web page to be on the screen. 

 WhatsUp Gold Web login. Either select a user from the drop-down list, or click the 
browse (...) button to choose a user from the WhatsUp Gold Web Login Library. This 
user account is used for the Dashboard application to log-in to a WhatsUp Gold Web 
page. Without a proper user account, the application is not able to display a 
password-protected Web page. If you are Gold Web page, set 
the Web login to None. 

 have chosen to run the Dashboard Screen Manager upon Startup, on the display you
 to configure a playlist for, click on the screen and the Dashboard Operations dialog 

1 On the Dashboard Operations dialog, select Playlist for this Monitor. The Pane 
Properties dialog appears. 

2 On the dis

3 Select Cycle through multiple Web pages. 
4 Click the Add button to add Web pages to the list. The Add URL to Playlist dialog 

appears. 
5 Enter the appropriate information in the 

 using a non-WhatsUp 
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 Note: Other applications requiring a username and password to display Web pages can be 
used in the Dashboard Screen Manager. You can specify these other application username 
and passwords in the URL field, appended to the Web page URL. 

6 Click OK to add the new Web page to the playlist. 
g a Web page from the list and then clicking the 7 Edit and Remove Web pages by selectin

Edit or Remove button. 
8 Click OK to save changes. 
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APPEN

Using the SNMP API 
The W ur 
scripted monitors and actions. With the addition of GetMultiple, you have the ability to get 

NMP request. GetNext issues the SNMP GetNext command to 
ows a specified object. Finally, the addition of the 

SetFunction allows you to send SNMP set commands to your SNMP manageable devices. 

The S

 CoreAsp.SnmpRqst. The main SNMP object used to send SNMP requests (Get, GetNext, 

 to 

 CoreAsp.ComResponse. A response object returned by certain methods of the 
mpRqst object that contain the status (either error or success) of an SNMP request and 

the value of the polled object(s). 

DIX C 

hatsUp Gold SNMP COM API has been enhanced to improve the performance of yo

multiple OIDs within a single S
retrieve the value of the object that foll

NMP API includes the following objects: 

Set) to a remote device. 

 CoreAsp.ComResult. An object returned by certain methods of the SnmpRqst object
indicate success or failure. 

Sn

 Note: There are several things to keep in mind when attempting to use the SNMP API. If you 
are experiencing errors, please see Troubleshooting the SNMP API (on page 348). 

 
 

CoreAsp.SnmpRqst 

This object is used to send SNMP requests to a remote device. 

Rqst uses a three step process: 

1 Call bject against a particular device. 

le or Set operations against a 

Initialize or Initialize2 must be called prior to any other members. 

CoreAsp.Snmp

s Initialize or Initialize2 to initialize the o
2 Sets optional parameters such as timeout value, port, etc. 
3 Performs any number of Get, GetNext, GetMultip

device. Those operations return an ComSnmpResponse object that contains the status 
of the operation and the value either directly (use Failed/GetValue/GetOid) or as a 
list of SNMP variable binding returned as XML data (use GetPayload). 
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Method Description Returns 

Initial
   nD
) 

 is 
not configured with a valid SNMP credential, the 

responding to the device ID of a device 
igured in WhatsUp Gold. 

Tip: In Active Script Monitor and Script 
Performance Monitors, the device ID of the 
device to which the monitor is assigned can be 
obtained from the Context object: 
Context.GetProperty("DeviceID")  

ize(  
eviceID  

Initializes the SnmpRqst object for the device with 
the device ID specified in nDeviceID. If a device

ComResult object  

operation will fail.  

 nDeviceID. A positive integer 
cor
conf

Initialize2( 
   sDeviceAddress, 
   nCredentialID  
) 

Initializes the SnmpRqst object by creating a 
connection to a device using the IP address of a 
device and a credential stored in WhatsUp Gold. This 
method can be used to initialize SnmpRqst for a 
device that is not configured in WhatsUp Gold as 
long as the credentials for the device are configured 
in the credential library. 

 sDeviceAddress. The address or hostname 
of the device to be queried. 

 nCredentialID. A positive integer 
corresponding to the credential ID of a 
credential configured in WhatsUp Gold. 

ComResult object  

SetTimeoutMs( 
   
nTimeoutInMilliSec 
) 

Sets the timeout value in milliseconds. If not 
specified, the timeout defaults to 2000 milliseconds. 

 nTimeoutInMilliSec. A positive integer 
representing the number of milliseconds 
after which unresolved requests should be 
terminated. 

ComResult object  

SetNumRetries( 
   nNumberRetries 
) 

Sets the number of times to retry a request that has 
timed out. If not specified, failed requests are retried 
one time.  

 nNumberRetries. A positive integer 
representing the number of times to retry 
timed out requests. 

Tip: To send only one SNMP packet per request, 
set nNumberRetries to 0 (zero). 

ComResult object  

SetPort( 
   nPort 
) 

Sets the TCP/IP port to be used by SnmpRqst. If not 
specified, port 161 is used. 

 nPort. A positive integer between 1 and 
65535 corresponding to the port to be used. 

ComResult object  
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Method Description Returns 

Get( 
   sOid 
) 

of the specified object. 

 sOid. A string contai

Issues an SNMP Get command to retrieve the value 

ning a valid OID. 

ComSnmpResponse 
object 

GetNext( Issues an SNMP GetNext command to retrieve the ComSnmpResponse 
   sOid 
) 

value of the object that follows the specified object 
in lexicographic order. 

 sOid. A string containing a valid OID. 

object 

GetMultiple( 
   sListOfOids 

Issues an SNMP Get command for each of the objects 
specified. GetMultiple sends all commands in a 

ComSnmpRespons
object 

) single SNMP protocol data unit, so it is more efficient 
ommands independently. 

e 

than issuing multiple Get c

 sListOfOids. A comma-separated list of 
valid OIDs. 

Set( 
   sOid, 
   sType, 

Issues an SNMP Set command to set an OID value on 
a device. 

ComSnmpResponse 
object 

   sValue 
) 

 sOid. A string containing a valid OID for the 
object for which you want to set the value. 

 sType. A single character corresponding to 
the type of value to set. 

u

s = string 

x = hexadecimal string 

d = decimal string 

n = NULL object 

o = object ID 

i = integer 

 = unsigned integer 

t = timeticks 

a = IPv4 address 

b = bits 

 sValue. A string containing the value to set. 

 Note: The Set function will not work unless the MIB object and the community string for the 
device have the Read Write access right. 
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Core omRe

This object is returned e SnmpRqst object or other objects to indicate the 
status of an o

Asp.C sult 

 by members of th
peration. 

Member Description 

Failed Returns true if this object contains a failure and false if the object contains a 
success. 

GetErrorMsg If Fa  message. iled is true, this member returns the associated error

 Note: All the mem hey have no arguments and bers of the ComResult object are methods. T
should be called without parenthesis.  

 

CoreAsp.ComSn

This object contains a res SnmpRqst member 
functions: Get Get

mpResponse 

ponse from an SNMP request. It is returned by 
, Next, GetMultiple and Set. 

Member Description 

GetOid ot be used with operations 
ple. 

Note Rqst.GetNext. It can 

Returns the OID of the polled object. This member cann
that poll multiple objects, such as SnmpRqst.GetMulti

: This member is only useful when used with Snmp
be used with SnmpRqst.Get and SnmpRqst.Set, but it returns the same 
OID that you specified when calling those functions. 

GetValue ly be used with functions 
SnmpRqst.Get, SnmpRqst.GetNext and SnmpRqst.Set) 

Returns the value of the polled object. This member can on
that poll a single object (

Failed If the r ,

Note ling multiple objects, Failed returns true if even one error 

equest succeeded, returns false. If the request failed

: When pol

 returns true. 

exists in the results returned by GetPayload. 

GetErrorMsg If Failed returns true, this member returns the associated error message. 
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ad Returns XML data describing SNMP variable bindings (each c  OID, Type 
and Value).  

This X h 
n p

   <S
sOid=
   <S r="false" sError="" 

 

ou c
rm

ontaining

ML data consists of a single VarBindList node whic
Bind nodes.  

contains one or many 
S m Var

<VarBindList> 
nmpVarBind bHasError="false" sError="" 
"1.3.6.1.2.1.1.1.0" sValue="HELLO" /> 
nmpVarBind bHasErro

sOid="1.3.6.1.2.1.1.1.1" sValue="WORLD" />
</VarBindList> 

Y
info

an use the Microsoft XML DOM object to access this info
ation, see the Read multiple objects in one request example. 

rmation. For more 

GetPaylo

 Note: All the  They have no members of the ComSnmpResponse object are methods.
arguments and should be called without using parenthesis. 

 

ple scExam r

These example scripts de n use. All of these examples are written in 
JScript. 

Initialize an SNMP object with vice ID 

The SnmpRqst.Initialize method returns a ComResult object that tells if the initialization 
succeeded or failed. 

This script uses the Failed me ror and logs an error message using 
GetErrorMsg if the initializatio

var oSnmpRqst = new ActiveXObject("CoreAsp.SnmpRqst"); 

var nDeviceID = 150; 

var oComResult = oSnmpRqst.Initialize(nDeviceID); 

if (oComResult.Failed) 

{ 

 Context.LogMessage(oComResult.GetErrorMsg); 

} 

Alternatively, initialization using a device address and an SNMP credential ID: 

var oSnmpRqst = new ActiveXObject("CoreAsp.SnmpRqst"); 

var sAddress = "192.168.3.1"; 

var oComResult = oSnmpRqst.Initialize2(sAddress, nCredentialID); 

if (oComResult.Failed) 

{ 

 Context.LogMessage(oComResult.GetErrorMsg); 

} 

ipts using the SNMP API 

monstrate the SNMP API i

 error check from a de

thod to detect an er
n failed: 

var nCredentialID = 1; 
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Send a standard Get and log the polled value 

ect("CoreAsp.SnmpRqst"); 

var oComResult = oSnmpRqst.Initialize(nDeviceID); 

 Context.LogMessage(oComResult.GetErrorMsg); 

mpRespons

{ 

t.L

} 

else 

{ 

 led " + oSnmpResponse.GetOid + ", got " +  

 oSnmpResponse.GetValue); 

} 

 

var oSnmpRqst = new ActiveXObject("CoreAsp.SnmpRqst"); 

; 

if (oComResult.Failed) 

oComResult = oS

oComResult = oS

var oSnmpRespon

if (oSnmpRespon

{ 

ntext.

} 

else 

 Context.

 oSnmpRes

} 

Walk the MIB using GetNext 

var oSnmpRqst = new ActiveXObject("CoreAsp.SnmpRqst");  

var nDeviceID = 150; 

var oComResult = oSnmpRqst.Initialize(nDeviceID); 

if (oComResult.Failed) 

{ 

 Context.LogMessage(oComResult.GetErrorMsg); 

} 

var sOid = "1.3.6.1.2"; 

//get the next 10 objects 

for (i=0; i<10; i++) 

var oSnmpRqst = new ActiveXObj

var nDeviceID = 150; 

if (oComResult.Failed) 

{ 

} 

var oSn

if (oSnmpResponse.Failed) 

e = oSnmpRqst.Get("1.3.6.1.2.1.2.1.0"); 

 Contex ogMessage("Failure. Error=" + oSnmpResponse.GetErrorMsg); 

Context.LogMessage("Success. Pol

Send a Get using non-standard port and timeout

var nDeviceID = 150; 

var oComResult = oSnmpRqst.Initialize(nDeviceID)

{ 

 Context.LogMessage(oComResult.GetErrorMsg); 

} 

nmpRqst.SetPort(1234); 

nmpRqst.SetTimeoutMs(5000); // 5 second timeout 

se = oSnmpRqst.Get("1.3.6.1.2.1.2.1.0"); 

se.Failed) 

 Co LogMessage("Failure. Error=" + oSnmpResponse.GetErrorMsg); 

{ 

LogMessage("Success. Polled " + oSnmpResponse.GetOid + ", got " +  

ponse.GetValue); 
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{ 

 var oSnmpResponse = oSnmpRqst.GetNext(sOid); 

 if (oSnmpResponse.Failed) 

 { 

  

  

 } 

 else 

 { 

  

  

 } 

} 

Read multiple objects in one request 

var o

var nDeviceID = Context.GetProperty("DeviceID"); 

if (oComResult.Failed) 

} 

pResponse = 

0,1.3.6.1.2.1.1.3.0"); 

ssage("Failure. Error=" + oSnmpResponse.GetErrorMsg); 

 { 

var nDeviceID = 150; 

Context.LogMessage("Failure. Error=" + oSnmpResponse.GetErrorMsg); 

break; 

sOid = oSnmpResponse.GetOid; 

Context.LogMessage(sOid + "=" + oSnmpResponse.GetValue); 

SnmpRqst = new ActiveXObject("CoreAsp.SnmpRqst"); 

var oComResult = oSnmpRqst.Initialize(nDeviceID); 

{ 

 Context.LogMessage(oComResult.GetErrorMsg); 

 

// Get three objects in one packet: 

var oSnm

oSnmpRqst.GetMultiple("1.3.6.1.2.1.1.1.0,1.3.6.1.2.1.1.2.

 

if (oSnmpResponse.Failed) 

{ 

 Context.LogMe

} 

else 

{ 

 var sXML = oSnmpResponse.GetPayload; 

 

 var objXMLDocument = new ActiveXObject("Microsoft.XMLDOM"); 

 objXMLDocument.async = false; 

 objXMLDocument.loadXML(sXML); 

 

 var oVarBinds = objXMLDocument.getElementsByTagName("SnmpVarBind"); 

 

 // For each variable binding, log OID=VALUE 

 for (var i=0; i<oVarBinds.length; i++) 

  Context.LogMessage(oVarBinds(i).getAttribute("sOid") + "=" +  

  oVarBinds(i).getAttribute("sValue")); 

 } 

} 

Reboot a Cisco device using Set 

var oSnmpRqst = new ActiveXObject("CoreAsp.SnmpRqst"); 

  347 



Using WhatsUp Gold v12.3 

var oComResult = oSnmpRqst.Initialize(nDeviceID); 

if (oComResult.Failed) 

sage(oComResult.GetErrorMsg); 

pRqst.Set("1.3.6.1.4.1.9.2.9.9.0", 'i', 2); /* reload */ 

(oSnmpResponse.Failed) 

Context.LogMessage("Failure. Error=" + oSnmpResponse.GetErrorMsg); 

t " + 

mpResponse.GetValue); 

Troubleshooting the SNMP API 

empt to use the SNMP API. 

for different versions 
orks on all SNMP capable devices, the results returned depend on 

 SNMP version. For example, SNMPv1 and v2 return different results for the GetMultiple 
MPv1 returns only an error, 

ile SNMPv2 returns results for the correct OIDs and an error for the incorrect OID. 

ws with IPv6 
k on the following versions of Windows when using IPv6: 

Windows 20

Windows XP 

indows Vista 

uters and switches have a default packet size limitation of 1500 bytes. The GetMultiple 
will return an error if the parameter size exceeds the limit.  

{ 

 Context.LogMes

} 

var oSnmpResponse = oSnm

if 

{ 

 

} 

else 

{ 

 Context.LogMessage("Success. Polled " + oSnmpResponse.GetOid + ", go

oSn

} 

 

There are several things to keep in mind as you att

Different results 
Although the SNMP API w
the
function. If one of the OIDs used in the fuction is incorrect, SN
wh

The inability to work on certain versions of Windo
The SNMP API does not wor

 03 

 
 W

Maximum packet size on routers and switches 
Ro
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