
Using WhatsUp Gold 
WhatsConnected 
Layer 2 and 3 Discovery 
and Mapping
About, configuring, and using the 
Layer 2 and 3 discovery and mapping 
features in WhatsUp Gold



Contents 

CHAPTER 1  Welcome to WhatsConnected

Finding more information and updates............................................................................................................... 2 
Sending feedback......................................................................................................................................................... 3 

CHAPTER 2  Installing and Configuring WhatsConnected

System requirements .................................................................................................................................................. 5 
Installation overview ................................................................................................................................................... 5 
Activating WhatsConnected licenses.................................................................................................................... 5 

CHAPTER 3  Discovering Networks

Getting started with WhatsConnected................................................................................................................. 7 
About Layer 2 Network Discovery .......................................................................................................................... 8 
Configuring Layer 2 Network Discovery............................................................................................................... 8 

About Layer 2 Network Discovery scan types........................................................................................ 9 
About Layer 2 discovery settings ............................................................................................................... 9 
Configuring network protocols and credentials.................................................................................12 

Running a Layer 2 Network Discovery ................................................................................................................16 
Adding a device manually...........................................................................................................................17 
Refreshing network connectivity .............................................................................................................18 

CHAPTER 4  Using the WhatsConnected console

About the console ......................................................................................................................................................19 
About Layer 2 Network Discovery Files ..............................................................................................................19 
Managing Layer 2 Network Discovery Files ......................................................................................................19 

Creating a new discovery file .....................................................................................................................20 
Opening a discovery file ..............................................................................................................................20 
Opening a recently used discovery file ..................................................................................................20 
Using Replace Devices..................................................................................................................................20 
Using Merge Devices ....................................................................................................................................21 
Using Replace Maps ......................................................................................................................................21 
Using Merge Maps .........................................................................................................................................21 
Using Save.........................................................................................................................................................21 
Using Save As...................................................................................................................................................22 

CHAPTER 5  Viewing Network Data

About network data views ......................................................................................................................................23 
About data grid views ..................................................................................................................................23 

  i 



  ii 

About Device Categories View ..............................................................................................................................27 
About Device Details tab view ..................................................................................................................28 

About Device List View.............................................................................................................................................30 
About Device List columns .........................................................................................................................31 
Using Device List filters ................................................................................................................................31 
Viewing Device List details .........................................................................................................................32 

About the Topology Maps View............................................................................................................................34 
About Topology Tree View .........................................................................................................................35 
Managing and customizing topology groups and maps ................................................................35 
About Topology layout modes .................................................................................................................43 

About the Subnets view...........................................................................................................................................47 
Viewing Subnet device details ..................................................................................................................47 

About the Links view.................................................................................................................................................48 

CHAPTER 6  Using WhatsConnected Tools

About WhatsConnected Tools ...............................................................................................................................49 
Using Layer 2 Trace ....................................................................................................................................................50 
Using IP/MAC Finder..................................................................................................................................................53 

About the Select button ..............................................................................................................................55 
About the Refresh Connectivity button.................................................................................................56 

Rebuild Connectivity .................................................................................................................................................56 
Classify Devices............................................................................................................................................................56 
Using the Device Viewer ..........................................................................................................................................57 

CHAPTER 7  Configuring WhatsConnected

About WhatsConnected configuration settings .............................................................................................59 
Configuring Applications Settings .......................................................................................................................59 
Configuring Discovery Settings.............................................................................................................................60 
Configuring Protocol Settings ...............................................................................................................................62 
Configuring Device Types .......................................................................................................................................63 

  



 
 

  1 

 

CHAPTER 1 

Welcome to WhatsConnected 

In This Chapter 

Finding more information and updates........................................................2 
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WhatsConnected is a layer 2 and layer 3 network discovery and visualization plug-in for 
WhatsUp Gold that equips network managers with a comprehensive tool set to accurately 
depict and visualize their device connectivity, including VLAN overlays, down to the 
individual port. Layer 2 discovery and mapping accesses the physical infrastructure 
information embedded in devices to provide significantly more detailed topology 
information than layer 3 discovery mechanisms. In addition to widely used IP discovery 
protocols, such as ICMP, ARP, and SNMP, layer 2 discovery leverages a number of other 
mechanisms to discover devices including industry standard Link Layer Discovery Protocol or 
LLDP, as well as equipment manufacturer proprietary discovery protocols. 

With layer 2 information available about how devices in your network are connected, their 
interdependencies, and their locations, you can locate problems and resolve them more 
easily. WhatsConnected helps you understand your network from top to bottom and focus 
on keeping it running securely and at peak performance. 

WhatsConnected provides the key functions network professionals need to be able to 
discover, map, search, and document their networks. 

Discovery 
The WhatsConnected discovery process uses industry-standard protocols, such as ICMP and 
SNMP, to find devices on your network. Information about discovered devices is available as a 
simple device list view, a device category view, and a detailed topology view. 

Mapping 
After WhatsConnected knows about the devices on your network, it can generate a map that 
shows the physical connections between all of the devices. Standard and custom maps 
provide an easy way to browse the network infrastructure. With the connectivity data readily 
available, managing the day-to-day complexities of a network is simplified. 

Any topology map in WhatsConnected can be exported to WhatsUp Gold, automating 
custom map views and active monitor creation for the interfaces on the map's devices. 
WhatsConnected integrates with WhatsUp Gold to identify and create powerful monitoring 
strategies for your network. 
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Searching 
The WhatsConnected detailed device views allow for simple browsing of connectivity for any 
device on the network. You can use the Layer 2 Trace and IP/MAC Finder tools to easily 
discover the location of any device on the network. 

Documenting 
WhatsConnected makes it easy to share network details. You can export your topology maps 
to Microsoft Visio and generate reports that contain detailed information about the devices 
on your network. 
 
 

Finding more information and updates 

The following are information resources for WhatsConnected. This information may be 
periodically updated and available on the WhatsUp Gold Web site 
(http://www.whatsupgold.com/support/index.asp). 

 Release Notes. The release notes provide an overview of changes, known issues, and bug 
fixes for the current release. The notes also contain instructions for installing and 
configuring WhatsConnected. The release notes are available on the WhatsUp Gold web 
site http://www.whatsupgold.com/wugWC1231relnotes. 

 Application Help for the console. The console help contains dialog assistance, general 
configuration information, and how-to's that explain how to use the features. The Table of 
Contents is organized by functional area, and can be accessed from the main menu or by 
clicking Help. 

 WhatsUp Gold optional plug-ins. You can extend the core features of WhatsUp Gold by 
installing plug-ins. For information on available plug-ins and to see release notes for each 
plug-in, see WhatsUp Gold plug-ins documentation 
(http://www.whatsupgold.com/wugplugins). 

 Licensing Information. Licensing and support information is available on the MyIpswitch 
licensing portal (http://www.myipswitch.com/). The web portal provides enhanced web-
based capabilities to view and manage Ipswitch product licenses. 

 Knowledge Base. Search the Ipswitch Knowledge Base of technical support and 
customer service information. The knowledge base is available on the WhatsUp Gold web 
site (http://www.whatsupgold.com/wugTechSupport). 

 User Forum. Use the online user group forums to interact with other WhatsUp Gold users 
to share helpful information about the application. The User Forums are available on the 
WhatsUp Gold web site (http://forums.ipswitch.com/). 
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Sending feedback 

We value your opinions on our products and welcome your feedback. 

To provide feedback on existing features, suggest new features or enhancements, or suggest 
ways to make our products easier to use, please fill out our product feedback form 
(http://www.ipswitch.com/company/prodfeedback.asp). 

 
 

http://www.ipswitch.com/company/prodfeedback.asp
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Installing and Configuring WhatsConnected 

In This Chapter 

System requirements ...........................................................................................5 

Installation overview ............................................................................................5 

Activating WhatsConnected licenses.............................................................5
 
 

System requirements 

The minimum software and hardware requirements are based on the WhatsUp Gold v12.3 
requirements. For more information, see the WhatsUp Gold v12.3 Release Notes 
(http://www.whatsupgold.com/wug1231relnotes). 
 

Installation overview 

The files for WhatsConnected are installed automatically with WhatsUp Gold v12.3. Your 
license file determines whether you can access WhatsConnected. Before installing, we 
recommend that you read the Release Notes for possible application update details and 
review the System requirements (on page 5) information to ensure that the system, on which 
you are attempting to install, meets the base-level requirements.  

To update your license to purchase WhatsConnected, visit the MyIpswitch portal 
(http://www.myipswitch.com). For more information, see Activating WhatsConnected licenses 
(on page 5). 
 

Activating WhatsConnected licenses 

If WhatsConnected is installed using the installation application downloaded from the Web 
link provided in the purchase confirmation email, the program is fully functional immediately 
after installation. 

If the WhatsConnected license is not automatically activated during installation, you can 
manually activate WhatsConnected using the activation program in the WhatsUp Gold group 
on the Windows Start menu. 

http://www.whatsupgold.com/wug1231relnotes
http://www.myipswitch.com/
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To activate WhatsConnected manually: 

 Note: Before you begin the manual activation process, make sure that you have your product 
serial number available to use in the activation program. 

1 Click Start > Programs > Ipswitch WhatsUp Gold > Manage WhatsUp Gold License. 
The activation program appears. 

2 Follow the onscreen instructions to complete the product activation. 

 Note: When activation completes, a confirmation page indicates that the license has been 
activated. If activation does not complete successfully, you may be behind a proxy or firewall 
that is blocking the activation request. In this case, click Offline and follow the onscreen 
instructions. 

For more help and information about licensing, go to the Mypswitch licensing portal 
(http://www.myipswitch.com/). 
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Getting started with WhatsConnected 

To start WhatsConnected: 

 From the WhatsUp Gold console, click Tools > WhatsConnected. WhatsConnected 
starts. 

When you start the WhatsConnected application, the WhatsConnected Startup dialog helps 
you begin using the WhatsConnected application. 
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There are two Getting Started options to help you begin gathering and viewing Layer 2 
network information: 

 Start a new network scan to discover devices connected on the network. Click Wizard to 
start the Wizard discovery process. 

 If you have saved WhatsConnected discovery files previously, you can select an existing 
discovery file in the Recent files list, then click Open. 

Click Do not show this at startup to prevent this dialog from appearing each time you start 
WhatsConnected. 

For more information about other methods to do network discovery, see About Layer 2 
Network Discovery (on page 8). 
 

About Layer 2 Network Discovery 

WhatsConnected discovers the devices on your network and displays a topological map of 
the network's physical structure. WhatsConnected also captures detailed information about 
each device, including IP and MAC addresses for all interfaces on the device, information 
about software installed on the device, and more. 

There are three ways to add devices with the Layer 2 Network Discovery: 

 Through the Layer 2 Network Discovery option in the WhatsConnected console Discover 
> Network menu. For more information, see Run Discovery. 

 Through the single device discovery option in the WhatsConnected console Discover > 
Device menu. For more information, see Add New Device in the WhatsConnected Help. 

 Through the Getting Started with WhatsConnected Wizard that appears when you start 
WhatsConnected. For more information, see Getting started with WhatsConnected (on 
page 7). 

 

Configuring Layer 2 Network Discovery 

Layer 2 Network Discovery can run with a minimal amount of configuration. The discovery 
settings can be specific and point to a certain part of your network, or more general and 
pertain to the entire network. In both cases, network settings are key to successful network 
scans.  

There are two main elements to configure for each network scan.  

 A base discovery configuration that includes a discovery scan type and IP scope. For more 
information, see About Layer 2 Network Discovery scan types (on page 9). 

 The network protocols and credentials used during the network scan. For more 
information, see the Configuring network protocols and credentials (on page 12) section. 

Layer 2 Network Discovery setup is accomplished by using the Discovery Setup wizard or 
manually through several WhatsConnected dialogs. This section describes how you can 
manage both the discovery settings and protocol settings manually. 
 

  8 
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About Layer 2 Network Discovery scan types 
An important part of Layer 2 Network Discovery is understanding the different methods by 
which a network can be discovered. There are two Layer 2 Network Discovery methods.  

ARP Cache Discovery 
Address Resolution Protocol (ARP) Cache discovery locates network devices by reading SNMP 
information on your network. This scan type uses SNMP enabled devices (usually routers) to 
identify devices that are active on your network. In addition to using the ARP cache on each 
network device, ARP Cache discovery also uses many proprietary discovery protocols to find 
additional devices connected to the network.  

The Discovery Setup wizard prompts you to enter a Seed IP Scope (IP addresses, IP address 
ranges – including IP subnets) that indicates where you would like the discovery to start. 
These devices are used as the seed of the network discovery.  

 Important: We recommend that you use ARP Cache discovery as your primary discovery 
method. 

Ping Sweep discovery 
Ping Sweep discovery scans a range of IP addresses and finds the devices that respond to the 
ICMP or SNMP protocol.  

The Network Discovery Setup wizard prompts you to enter a Seed IP Scope (IP addresses, IP 
address ranges including subnets) that indicates where you would like to focus your network 
scan.   

 Note: The Ping Sweep discovery method is used for very specific discovery scans. If you are 
unsure of your network configuration, including any of its subnetworks, ARP Cache discovery 
is a more appropriate method for discovering your network. 

For more information about how Seed IP Scopes work in each Layer 2 discovery method, see 
About Seed IP Scope (on page 11). 
 

About Layer 2 discovery settings 
Each network scan requires several base-level settings that guide the discovery scan of your 
network. Discovery settings are grouped by a general name that describes the area of the 
network that the settings scan. 
 

Configuring discovery settings 
To add discovery settings: 
1 From the main menu of the WhatsConnected console, select Configure > Discovery 

Settings. The Discovery Settings dialog appears. 

  9 
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2 The dialog displays all previously defined discovery settings. To create a new collection 
of discovery settings, right-click in the left list, a right-click menu appears.  

3 Click New. The New Discovery Settings dialog appears. 
4 Enter a Name that gives context to the discovery settings you are creating (i.e. TestLab, 

Production Network). This name is stored so that it can be reused for later network 
scans. 

5 Click OK. 
6 On the Discovery Settings dialog, a new entry appears in the left pane list for the new 

collection of discovery settings. Select the new collection name from the list. 
7 Select the discovery method for the network scan from Method. For more information 

about the discovery types, see About Layer 2 Network Discovery scan types (on page 9). 
8 Enter the number of Max Threads to use while running the discovery scan. This 

indicates the number of separate threads to run in the background as WhatsConnected 
attempts to communicate with the devices on the network.  

 Note: If you are concerned about the load discovery could place on the network, you can 
reduce the Max Threads to cut back on the concurrent network communication. 

9 Select whether the discovery engine should try to Ping Devices First before attempting 
any other protocol. 

10 Select whether the discovery engine should attempt to Ping Discovered Subnets to 
provide a more complete scan during an ARP Cache type of discovery.  

 Note: This option tells the engine to take each discovered subnet and run a ping sweep 
through it to ensure all devices are discovered in the defined subnet.  

11 Select whether to Enable Collector Log. This is a trace flag for support purposes; enable 
this option only by direction from technical support 

12 Enter the Seed IP Scope. For more details in regards to the Seed IP Scope, see About 
Seed IP Scope (on page 11). 

13 Enter the Include IP Scope. For more details in regards to the Seed IP Scope, see About 
Include IP Scope (on page 11). 

14 Enter the Exclude IP Scope. For more details in regards to the Seed IP Scope, see About 
Exclude IP Scope (on page 11). 

15 Click OK to save all changes made in the Discovery Settings dialog. 

To rename discovery settings: 
1 From the main menu of the WhatsConnected console, select Configure > Discovery 

Settings. The Discovery Settings dialog appears. 
2 The dialog displays all previously defined discovery settings. To rename a collection of 

discovery settings, right-click the collection that you would like to rename, then click 
Rename. The Rename Discovery Settings dialog appears. 

3 Enter a new Name for the collection of discovery settings. 
4 Click OK.  
5 Click OK to save all changes made in the Discovery Settings dialog. 
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To delete discovery settings: 
1 From the main menu of the WhatsConnected console, select Configure > Discovery 

Settings. The Discovery Settings dialog appears. 
2 The dialog displays all previously defined discovery settings. To delete a collection of 

discovery settings, right-click the collection that you would like to delete, then click 
Delete. The selected collection of discovery settings is deleted. 

3 Click OK. 
4 Click OK to save all changes made in the Discovery Settings dialog. 
 

About discovery IP scopes 
Discovery IP scopes are a means by which discovery is configured to understand the area(s) of 
the network that it scans, or excludes from a scan.  

IP scopes can be: 

 A single IP address (i.e. 10.0.0.1) 

 A range of IP addresses (i.e. 10.0.0.1-10.0.0.100) 

 A subnet range of IP addresses (i.e. 10.0.0.1/24 or 10.0.0.1/255.255.255.0) 

The following is a description of how these IP scopes are used in WhatsConnected discovery 
settings. 
 

About Seed IP Scope 

Seed IP Scope defines the range of IP addresses where network discovery starts a scan. 

 For Ping Sweep discovery, these addresses are contacted with an initial ICMP request. 

 For ARP Cache discovery, these addresses are queried for additional data. The discovery 
engine reads SNMP data from these devices and continues to scan the network for 
additional devices based on the SNMP responses from the seed devices. 

 

About Include IP Scope 

Include IP Scope defines the range of IP addresses in which to include in the network scan. 

 For Ping Sweep Discovery, Include IP Scope is the same as the Seed IP Scope.  

 For ARP Cache Discovery, Include IP Scope indicates an IP address range that the network 
scan should restrict itself to during discovery. 

Example 
 A single IP address (i.e. 10.0.0.1) 

 A range of IP addresses (i.e. 10.0.0.1-10.0.0.100) 

 A subnet range of IP addresses (i.e. 10.0.0.1/24 or 10.0.0.1/255.255.255.0) 
 

About Exclude IP Scope 

Exclude IP Scope defines the range of IP addresses to exclude from in the network scan.  

 For Ping Sweep Discovery, Exclude IP Scope might be an IP range of servers or 
workstations that are a subnet of the Seed IP Scope.  

 For the ARP Cache Discovery, Exclude IP Scope indicates an IP address range that network 
scan should not attempt to discover. 
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Configuring network protocols and credentials 
Several industry-standard protocols are used in Layer 2 Network Discovery. The two main 
protocols used in this type of discovery are ICMP and SNMP; the SSH protocol can also be 
used to enhance discovery of Linux and UNIX devices.  

The following section describes how to manage each protocol and its settings. 
 

The ICMP protocol 
The ICMP protocol allows the discovery engine to test whether a particular IP address is active 
and responding on the network. Depending on network latency, this protocol can be 
adjusted to meet the configuration on your network. 

To change the ICMP settings for the discovery engine: 
1 From the main menu of the WhatsConnected console, select Configure > Protocol 

Settings. The Protocol Settings dialog appears. 
2 The left pane of the dialog displays all registered protocols; ICMP is a default protocol. 

Select the root ICMP node to expand the tree node. 
3 Select ICMP 1. The protocol settings appear in the right pane.  

 Important: You must have at least one ICMP protocol setting for discovery to operate 
properly.  

4 Increase or decrease the Timeout settings. The default timeout is 500 milliseconds.  

 Note: If you are discovering across a WAN link, increase the timeout. 

5 Increase or decrease the number of ICMP Retries. The default number of one retry is 
recommended for most networks.  

 Note: If you are discovering across a WAN link, increase the number of retries. 

6 Click OK to save the protocol changes. 
 

The SNMP protocol and credentials 
The SNMP protocol allows the discovery engine to query detailed device information from 
each SNMP-enabled device. The correct SNMP Read community names, along with the 
appropriate timeout and number of retries are required for successful network queries.  

This section describes how to add and maintain the appropriate SNMP protocol settings for 
successful network discovery.  

To add a SNMP protocol setting: 
1 From the main menu of the WhatsConnected console, select Configure > Protocol 

Settings. The Protocol Settings dialog appears. 
2 The left pane of the dialog displays all registered protocols; SNMP is a default protocol. 

Select the root SNMP node, the tree node expands. 
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3 Browse the default SNMP settings by clicking on the SNMP entries in the tree.  

If your SNMP settings are not visible, you can add a new SNMP setting by right-clicking on 
the SNMP root and selecting New. A new SNMP entry is placed in the tree. In the right 
pane, a default Read/Write community name appears. 

4 Select the SNMP Version (v1 or v2) that your network devices are configured to 
support. 

5 Enter the new SNMP Read Community name. 
6 Optionally, enter a new SNMP Write Community name. 
7 Increase or decrease the SNMP Timeout. This setting is dependent on the latency and 

load on your network devices. Longer timeouts can cause discovery to slow down. 
However, if the network is experiencing a lot of network traffic, a longer timeout is 
recommended. A default of 1000 milliseconds is recommended for small to medium size 
networks.  

 Note: If you are discovering across a WAN link, allow for a longer timeout. 

8 Increase or decrease the number of SNMP Retries. This setting is dependent on the 
latency and load on your network devices. More retries allow for SNMP failures or heavy 
network loads. However, more retries slow down the discovery process. One or two 
retries is recommended for small to medium size networks.  

 Note: If you are discovering across a WAN link, increase the number of retries. 

9 Click OK, to save the protocol changes. 

 Note: As Layer 2 Network Discovery runs, each SNMP protocol setting is used until a 
successful community name is found. Consider keeping the number of SNMP community 
names to a minimum to increase the efficiency of the network scan. Also, the discovery scan 
uses the SNMP settings in the order that they are listed in the protocol list. Use the Move Up 
and Move Down options on the right-click menu to move the most likely SNMP community 
names to the top of the list. 

To edit a SNMP protocol setting: 
1 From the main menu of the WhatsConnected console, select Configure > Protocol 

Settings. The Protocol Settings dialog appears. 
2 The left pane of the dialog displays all registered protocols; SNMP is a default protocol. 

Select the root SNMP node, the tree node expands. 
3 Browse the default SNMP settings by clicking on the SNMP entries in the tree. Select the 

SNMP entry you would like to modify. 
4 Modify the existing settings. 

 Select the SNMP Version (v1 or v2) that your network devices are configured to 
support. 

 Edit the SNMP Read Community name. 

 Optionally, edit the SNMP Write Community name. 
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 Increase or decrease the SNMP Timeout. This setting is dependent on the latency and 
load on your network devices. Longer timeouts can cause discovery to slow down. 
However, if the network is experiencing a lot of network traffic, a longer timeout is 
recommended. A default of 1000 milliseconds is recommended for small to medium 
size networks.  

 Note: If you are discovering across a WAN link, increase the number of retries. 

 Increase or decrease the number of SNMP Retries. This setting is dependent on the 
latency and load on your network devices. More retries allow for SNMP failures or 
heavy network loads. However, more retries slow down the discovery process. One or 
two retries is recommended for small to medium size networks.  

 Note: If you are discovering across a WAN link, allow for a longer timeout. 

5 Click OK to save the protocol changes. 

To delete a SNMP protocol setting: 
1 From the main menu of the WhatsConnected console, select Configure > Protocol 

Settings. The Protocol Settings dialog appears. 
2 The left pane of the dialog displays all registered protocols; SNMP is a default protocol. 

Select the root SNMP node, the tree node expands. 
3 Browse the default SNMP settings by clicking on the SNMP entries in the tree. Select the 

SNMP entry you would like to delete. 
4 Right-click the SNMP node, then click Delete. The SNMP entry is removed. 
5 Click OK to save the protocol changes. 
 

The SSH Protocol 
The SSH protocol allows the discovery engine to query detailed device information from 
Linux and UNIX devices. The correct SSH user name and password are required to query 
information from your Linux/UNIX devices. This protocol is not required; it is needed only if 
you wish to discovery of Linux/UNIX systems. Leave empty if you do not want to use this 
protocol. 

To add an SSH protocol setting: 
1 From the main menu of the WhatsConnected console, select Configure > Protocol 

Settings. The Protocol Settings dialog appears. 
2 The left pane of the dialog displays all registered protocols; SSH is a NOT a default 

protocol and displays as an empty root in the left tree view. Select the root SSH node, if 
pre-defined SSH settings exist, they display in the expanded tree. 

3 Browse the existing SSH settings by clicking on the SSH entries in the tree.  

If your SSH settings are not visible, you can add a new SSH setting by right-clicking on 
SSH root and selecting New. A new SSH entry is placed in the tree. In the right pane, 
protocol fields appears. 

4 Enter a new SSH User Name. 
5 Enter a new SSH Password. 
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 Note: SSH user names and passwords are encrypted. 

6 Enter a defined SSH port. The default port number is 22. 
7 Click OK, to save the protocol changes. 

To edit a SHH protocol setting: 
1 From the main menu of the WhatsConnected console, select Configure > Protocol 

Settings. The Protocol Settings dialog appears. 
2 The left pane of the dialog displays all registered protocols. Select the root SSH node 

and the tree node expands. 
3 Browse the existing SSH settings by clicking on the SSH entries in the tree. Select the 

SSH entry you would like to modify. 
4 Modify the existing settings. 

 Enter a new SSH User Name. 

 Enter a new SSH Password. 

 Note: SSH user names and passwords are encrypted. 

 Enter the defined SSH port. The default port number is 22. 

5 Click OK, to save the protocol changes. 

To delete a SSH protocol setting: 
1 From the main menu of the WhatsConnected console, select Configure > Protocol 

Settings. The Protocol Settings dialog appears. 
2 The left pane of the dialog displays all registered protocols. Select the root SSH node 

and the tree node expands. 
3 Browse the existing SSH settings by clicking on the SSH entries in the tree. Select the 

SSH entry you would like to modify. 
4 Right-click the SSH, then click Delete. The SSH entry is removed. 
5 Click OK to save the protocol changes. 
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Running a Layer 2 Network Discovery 

Layer 2 Network Discovery scans your network for devices, using the protocol(s) and settings 
you selected. After devices are found, you may view the new discovery results in the 
WhatsConnected console. 

 

To run a Layer 2 Network Discovery: 
1 From the console click Discover > Network. The Run Discovery dialog appears. 
2 From the Discovery Settings list, select the discovery configuration that you want to 

run. To learn more about discovery configurations, see Configuring Layer 2 Network 
Discovery (on page 8). 

3 Click New. The Network Discovery Setup wizard appears.  
- or - 
Select an existing profile in the Discovery Settings list, then click Edit. The Network 
Discovery Setup wizard appears. 
- or - 
Select an existing profile in the Discovery Settings list, then click Start. The Network 
Discovery for the selected profile runs. Go to step 11. 

4 In the Name box, enter a discovery configuration name that identifies the network (or 
part of the network) you want to discover. If you are editing an existing profile, the name 
is entered by default. 

5 Select a method for discovering the network. Either ARP Cache or Ping Sweep 
discovery, then click Next. For more information about discovery types, see About Layer 
2 Network Discovery scan types (on page 9). 

  16 



Ipswitch WhatsConnected for WhatsUp Gold v12.3.1 

6 Enter an IP Seed Scope to define the starting point of either the ARP Cache discovery, 
or the IP ranges to use in the Ping Sweep discovery.  

 Click Add Default Gateway to add your default network gateway to the IP Seed 
Scope.  

 Click Advanced to further define the IP scope configuration of the discovery process.  

To learn more about Advanced IP scope settings, see Discovery Advanced IP Scoping in 
the WhatsConnected Help. 

7 Click Next. The Discovery Protocol Settings dialog appears. 
8 Define the SNMP and ICMP settings required to discover your network. Enter the SNMP 

read communities as well as any Timeout and Retry information for the SNMP or ICMP 
requests. 

9 Click Finish. The wizard closes and the new discovery configuration is automatically 
added to the Discovery Settings list in the Run Discovery dialog. 

10 Click Start to run the discovery process. 
11 When the discovery progress is complete, click OK. The Device Categories dialog 

appears. You can view network device information in this dialog or use the View menu 
for other network viewing options. For more information, see Viewing Network Data (on 
page 23). 

For more information, see Example: Using the Discovery Setup Wizard. 
 

Adding a device manually 
There are two ways to add a single device: 

 From the main menu of the WhatsConnected console, select Discover > Device. 

 On the WhatsConnected console toolbar, click  Plus. 

To manually add a device to the network data: 
1 From the WhatsConnected console, select Discover > Device (or select the Plus image 

from the console toolbar). The Add Device dialog appears. 
2 Enter the IP Address/Hostname for the device into the appropriate field. 
3 Click OK. The Run Discovery dialog appears. 
4 Click Start Discovery. 
5 After the discovery process is complete, click OK to add the device to the network data. 

The Device Categories View appears and the newly added device is automatically 
selected. 
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Refreshing network connectivity 
After a network is discovered, you can update connectivity data with a single discovery 
process. 

To refresh the connectivity of a network: 
1 From the main menu of the WhatsConnected console, select Discovery > Refresh 

Connectivity. The Run Discovery dialog appears and the discovery process begins to 
examine all networking devices to update their sighting and connectivity information. 
The progress indicators display the status of the discovery process. 

2 Click OK. The updated information is automatically be added to the current network 
data.  

 



 
 

  19 

 

CHAPTER 4 

Using the WhatsConnected console 

In This Chapter 

About the console.............................................................................................. 19 

About Layer 2 Network Discovery Files...................................................... 19 

Managing Layer 2 Network Discovery Files .............................................. 19
 
 

About the console 

The WhatsConnected console is a Windows application used for discovering, visualizing, and 
exporting network data. The console has the following components: 

 Layer 2 Network Discovery (on page 8) 

 Network Device (on page 56) and Topology Maps View (on page 34) 

 Exporting Topology Maps to WhatsUp Gold (on page 40) 

 Exporting Topology Maps to Microsoft Visio™ (on page 40) 
 

About Layer 2 Network Discovery Files 

WhatsConnected saves the information from a network discovery in a discovery file (.dis file 
extension). This flat file format makes it easy to share and move network data between 
computers with WhatsConnected installed. The size of these files is dependent on the 
number of devices saved in each discovery run and can be managed as part of the general file 
system. 
 

Managing Layer 2 Network Discovery Files 

At the end of a network discovery scan, the network data is loaded into the WhatsConnected 
console. At this point, there a several features available for you to manage the discovery (.dis) 
files. You can: 

 Create a new discovery file. 

 Open an existing discovery file. 

 Replace devices in a current discovery file with devices from another discovery file. 

 Merge devices in a current discovery file with devices from another discovery file. 

 Replace topology maps in a current discovery file with maps from another discovery file. 
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 Merge maps in a current discovery file with maps from another discovery file. 

 Save a discovery file. 

 Save an existing discovery file to another discovery file. 
 

Creating a new discovery file 
At the end of a network discovery run, the network data is updated in the WhatsConnected 
console. At this point, you can save this network data to a discovery file. This file can be later 
used when the WhatsConnected console is opened. 

To create a new discovery file: 

 From the console, click File > New. This clears any existing network data so that you can 
perform a new network discovery. 

For an example of using network discovery, see Running a Layer 2 Network Discovery (on 
page 16). 

 

Opening a discovery file 
After starting the WhatsConnected console, you may want to open an existing discovery file. 

To open an existing discovery file: 
1 From the console, click File > Open. The File Open dialog appears. 
2 Browse to a network discovery file, then click Open. The network data is loaded into the 

WhatsConnected console. 
 

Opening a recently used discovery file 
The WhatsConnected console keeps track of any recently opened/saved discovery files. You 
may open these files at any time from the console File menu. 

To open a recently used discovery file: 

 From the console, click File. At the bottom of the menu, any recently opened/saved files 
are listed. Select the network discovery file that you want to open. 

 

Using Replace Devices 
The WhatsConnected console provides the capability to replace the set of devices in the 
current network data model with those from another discovery file. 

To replace the current set of devices: 
1 From the console, click File > Replace Devices. The Open Discovery File dialog appears. 
2 Browse to locate the discovery file that you want to open, then click Open. 

The current device set will be replaced with the devices from the selected file. The topology 
maps will not be modified. 
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Using Merge Devices 
The WhatsConnected console provides the capability to merge the current set of devices with 
the devices from another discovery file. 

To merge the current set of devices: 
1 From the console, click File > Merge Devices. The Open Discovery File dialog appears. 
2 Browse to locate the discovery file that you want to open, then Click Open. 

The device set from the selected file will be merged with the current set of devices. The 
topology maps will not be modified. 
 

Using Replace Maps 
The WhatsConnected console provides the capability to replace the topology maps with the 
current discovery file with those of another discovery file. 

To replace the current topology maps with those from an external data file: 
1 From the console, click File > Replace Maps. The Open Discovery File dialog appears. 
2 Browse to locate the discovery file that you want to open, then Click Open. 

The topology maps from the external file will replace those maps of the current discovery file. 
 

Using Merge Maps 
The WhatsConnected console provides the capability to merge the topology maps in the 
current discovery file the with those of another discovery file. 

To merge topology maps from an external data file with the current set of maps: 
1 From the console, click File > Merge Maps. The File Open dialog appears. 
2 Browse to locate the discovery file that you would like to open. Click Open. 

The topology maps from the external discovery file will be merged with those of the current 
discovery file. 
 

Using Save 
The WhatsConnected console provides the capability to save the current network data model 
to a discovery file (.dis). Any modifications made to a network data model, such as added 
devices through discovery or added/modified topology maps, need to be saved much like a 
standard document after it has been modified. 

 Note: A discovery file can only be saved after it has received an initial discovery file name. 
Therefore, use File > Save As to assign a file name to the network model the first time. 

To save network data to a discovery file: 

 From the console, click File > Save. The file is saved. 
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Using Save As 
The WhatsConnected console provides the capability to save the current network data model 
to a discovery file. After an initial discovery, or if you want to save the network model to a 
different discovery file name, you can use the Save As feature. 

To save network data to a discovery file: 
1 From the console, click File > Save As. The Save Discovery File dialog appears. 
2 Give the discovery file a name, then click Save. 

The network data will be saved to the file. 
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About network data views 

The WhatsConnected console provides the capability of browsing network discovery results 
using a number of different views. The views that WhatsConnected provides: 

 The Device Categories view (on page 27) 

 The Device List view (on page 30) 

 The Topology Map view (on page 34) 

 The Subnets view (on page 46) 

 The Links view (on page 48) 

The following section describes how each view is used to visualize your network data. 
 

About data grid views 
An important feature of the WhatsConnected console is its capability to show network data in 
a data grid, or spreadsheet-like form. These data grid views provide a number of user 
functions that are beneficial to creating multiple views of your network data. The following 
section describes the base-level functions of the data grid view: 

 Column filtering (on page 24) 

 Edit Device Category (on page 24) 

 Show in Device Categories (on page 24) 

 Remove selected devices (on page 25) 

 Print and Print Preview (on page 25) 

 Save CSV (comma-separated value file) (on page 26) 

 Copying to clipboard (on page 26) 
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Column filtering 
Each data grid view allows you to show and hide its columns. This feature provides a 
powerful filtering capability so that you may structure your views in a way that brings the 
data into a form that you find most useful as a network administrator. 

To show and hide columns in a data grid view: 
1 Right-click a column heading in the data grid view. A list displaying all the columns that 

are displayed in that data grid appears; only columns with checks are displayed in the 
data grid.  

2 To show a column, click the name of the column that you want to display in the grid. 
The data grid updates automatically. 

3 To hide a column, clear the check from column that you would like to remove from the 
grid. The data grid updates automatically. 

4 To close the column list options, click anywhere outside of the list box.  

 Note: Show and hide selections are not persistent between different sessions of 
WhatsConnected. When you close the current session of WhatsConnected, data grid views 
return to their default display settings. 

 

Edit Device Category 
Use the Device Types dialog to create or modify a custom device type mapping. To do this, 
you enter an SNMP OID (sysObjectID) and select a device category for which to map a device. 
For more information about SNMP OIDs, refer to your device documentation or the Internet 
Assigned Numbers Authority (IANA) web site (http://www.iana.org/assignments/enterprise-
numbers). 

 sysObject ID (OID). Enter the SNMP OID (sysObjectID) for which you want to map a 
device. For more information about SNMP OIDs, refer to your device documentation or 
the Internet Assigned Numbers Authority (IANA) web site 
(http://www.iana.org/assignments/enterprise-numbers). 

 Include Subtree.  

 Category. Select a device type category for which to map the device.  

 Vendor/Manufacturer. Enter the vendor or manufacturer name. 

 Model. Enter the vendor or manufacturer model. 

 Description. Enter the vendor or manufacturer description. 
 

Show in Device Categories 
The Device Categories View is an explorer-type view with a Device Category tree view on the 
left, and a Device Details tab view on the right. The Device Categories view automatically 
categorizes and groups network devices so they can be viewed by their functional 
characteristics. The following is a list of all the categories that are supported by the 
WhatsConnected console. 

 Routers 

 Switches 

 Hubs 
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 Wireless Access Points 

 Printers 

 Macintosh 

 Windows 

 Windows Servers 

 Linux 

 Unix 

 IP Phone Managers 

 IP Phones 

 Power/UPS 

 Unknown 

 Note: Any device that is either not categorized or does not support SNMP will be placed in 
the Unknown category. 

To view a Device Category: 
1 From the main menu of the WhatsConnected console, select View > Device 

Categories. The Device Categories view appears. 
2 Click a category to expand it and view more information and the devices belonging to 

the category.  
3 Click a device to display device details on the right side of the page. 
 

Remove selected devices 
WhatsConnected allows you to customize device lists by removing devices from a data grid 
device list. This feature lets you select devices that you want to manage with 
WhatsConnected. 

To remove selected devices from a data grid view: 
1 In a data grid view, select the devices you want to remove from the device list. 

 Press CTRL then select multiple non-contiguous devices in the list. 

 Press SHIFT to select multiple contiguous devices in the list. 

2 Right-click in the data grid view. The right-click menu appears. 
3 Click Remove selected devices. A confirmation dialog appears and asks if you are sure 

you want to delete the selected devices. 
4 Click Yes to delete the selected devices or No to cancel the device deletion. If you 

clicked Yes, the selected devices are removed from the device list. 
 

Print and Print Preview 
Each data grid can produce printable reports of the items in the data grid view. 

 Note: The print capability is disabled in the trial version of WhatsConnected. 
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To print items in a data grid view: 
1 Right-click any item in the data grid view. A right-click menu appears. 
2 Select Print. The standard Print dialog appears. 
3 Select the print options, then click OK. 

To print preview items in a data grid view: 
1 Right-click any item in the data grid view. A right-click menu appears. 
2 Select Print Preview. The standard Print Preview view appears. You may use this view 

to preview how the report will look when printed.  

 Tip: You can print the document by clicking the Printer icon in the Print Preview toolbar. 

 

Save to a comma-separated value (CSV) file 
Each data grid can be saved to a comma-separated text file. This allows data to be extracted 
from the WhatsConnected data files and imported into other applications, such as Microsoft 
Excel. 

 Note: This capability is disabled in the trial version of WhatsConnected. 

To save to a comma-separated value (CSV) file: 
1 Right-click any item in the data grid view. A right-click menu appears. 
2 Click Save to CSV. The Save to CSV file dialog appears. 
3 Browse to the location where you want to save the CSV file, then enter a File name for 

the data grid view. 
4 Click Save. 
 

Copying to clipboard 
Each data grid can be copied to the windows clipboard and then pasted into another 
application. 

 Note: This capability is disabled in the trial version of WhatsConnected. 

To copy data items to the clipboard: 
1 Click any item in the data grid view to ensure the correct view is selected. 
2 Press Control + C. The data grid view items copy to the clipboard. 
3 Open any application to which you can paste the clipboard data; for example Microsoft 

Excel™. 
4 Press Control + V. The contents of the clipboard copy into the application. 
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About Device Categories View 

Device Categories View automatically categorizes and groups network devices so they can be 
viewed by their functional characteristics. Categories include networking groups such as 
Routers, Switches, Hubs, and Wireless Access Points. This view also helps distinguish between 
desktop and server operating systems such as Macintosh, Windows, Windows Servers, Linux, 
and UNIX. Additional device categories, such as Printers and IP Phones, help organize your 
network data. Any device that is either not categorized, nor supports SNMP, is placed in the 
Unknown category. 

 

The Device Categories view also provides a tabular view of the inventory and configuration 
data that is gathered from each network device. For more information, see About Device 
Details tab view (on page 28). 

Data displayed in this view can be removed, printed, print previewed, or saved to a comma-
separated-value (CSV) file for use in Microsoft Excel or other reporting applications. For more 
information, see About data grid views (on page 23). 
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To view Device Categories: 
1 From the main menu of the WhatsConnected console, select View > Device 

Categories. The Device Categories view appears. 

 Tip: You can also view device categories from the WhatsConnected console shortcut menu. 

Click  (Device Categories shortcut icon). The Device Categories dialog appears. 

2 Click a category to expand it and view more information about the devices in the 
category.  

3 Click a device to display device details on the right side of the page. 
 

About Device Details tab view 
Associated with the Device Categories view, the Device Details tab provides a tabular view 
that displays detailed network device information. When a device is selected in the Device 
Categories view, the details of the device are shown in the Device Details tab view.  

 

Tabs are only shown if a device has data that can be displayed. Possible tab views that may be 
associated with each device are: 

 System. Provides IP Address/MAC Address, MIB II information, product vendor, and 
other system information. 

 IP Addresses. Provides IP Address configuration information. 
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 Interfaces. Provides name entries (IF information) for each device interface and other 
interface information. 

 Bridge Ports. Provides Bridge Port and VLAN name and index information. 

 VLANs. Provides Virtual LAN configuration information. 

 LAG Trunks. Provides Link Aggregation Group information. 

 Assets. Provides inventory information about the device components.  

 Links. Provides physical connectivity information from this device to other network 
devices. 

 IP Routes. Provides IP route configuration data information. 

 Spanning Tree (STP). Provides spanning tree configuration and status information. 

 ARP Cache. Provides Address Resolution Protocol (ARP) table information. 

 Forwarding. Provides Layer 2 forwarding information. 

 Protocol Profile. Provides information about successful protocol matches for this 
device. 

 HSRP. Provides information about the Hot Standby Router Protocol (HSRP) on the 
device. The information relates to the standby nature of routers. 

 IP Phone. Provides information about the selected (individual) IP phone. 

 IP Phone Manager. Provides information about the IP phones that are registered or 
are communicating with a call manager. 

 IP Routes. Provides information about the IP routes configured for this device.  

 VRRP. Provides information about the Virtual Router Redundancy Protocol (VRRP) on 
the device. The information relates to the standby nature of routers. 

 STP. Provides information about Spanning Tree Protocol entries discovered on this 
device.  

 Software. Provides information about installed software discovered on this device. 

Each of the Device Details tabs is built with the data grid views that were described 
previously. For more information about the data grid views, see About data grid views (on 
page 23). These views allow you to browse, sort, and export (print) the data that is shown for 
each device. 
 

  29 



Ipswitch WhatsConnected for WhatsUp Gold v12.3.1 

About Device List View 

Device List View is a spreadsheet-like view that helps you organize, filter, and find network 
devices and data.  

 

You can filter data displayed in the view by using the Device Filter and Advanced features.  

Data displayed in this view can be filtered, edited by device category, shown in device 
categories, removed, printed, print previewed, or saved to a comma-separated-value (CSV) 
file for use in Microsoft Excel or other reporting applications. For more information, see About 
data grid views (on page 23). 

 Tip: You can double-click any device in the Device List view. The Device Details tab view 
opens with more details about the device. 

To view Device List: 
1 From the main menu of the WhatsConnected console, select View > Device List. The 

Device List view appears. 

 Tip: You can also view device list from the WhatsConnected console shortcut menu. Click 

 (Device List shortcut icon). The Device List dialog appears. 

To view Device Details: 

 With the device list open, double-click a device in the list. The Device Details appear. For 
more information, see About Device Details tab view (on page 28). 
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About Device List columns 
The device list shows all matching devices in the data grid view. There are number of 
columns that display the respective data for each device.  

The columns of the grid view are: 

 Hostname. The DNS hostname for the device. 

 IP Address. The IP address that the device was discovered by. 

 MAC Address. The MAC address associated with the main IP address. 

 NetBios Name. The windows NetBios name (if supported and known). 

 NetBios Domain. The windows NetBios domain (if supported and known). 

 System Name. The MIB II system name. 

 System Description. The MIB II system description. 

 System OID. The MIB II system object ID. 

 Vendor. The network device manufacturer. 

 Model. The network device model number. 
 

Using Device List filters 
You can use Device List filters to locate specific network devices and subnets. These filtering 
tools let you to find devices that match your specified search criteria.  

To filter the device list by device type in the list view grid: 
1 From the main menu of the WhatsConnected console, select View > Device List. The 

Device List view appears. 

 Tip: You can also view device list from the WhatsConnected console shortcut menu. Click 

 (Device List shortcut icon). The Device List dialog appears. 

2 Click the Device Filter list, then select the device type you want to view in the device 
list. The filtered devices appear in the device list. 

To filter the device list by search criteria: 
1 From the main menu of the WhatsConnected console, select View > Device List. The 

Device List view appears. 

 Tip: You can also view device list from the WhatsConnected console shortcut menu. Click 

 (Device List shortcut icon). The Device List dialog appears. 
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2 Click Advanced. The Advanced Device Filter dialog appears. 

 
3 Enter the desired search criteria in the provided fields. Use a wild card in any text box. 

For example, Hostname: device1*. 
4 After the device filter search criteria are entered, click OK. The list displays only the 

devices that match the search criteria. 
5 Click Advanced to further refine the search criteria, then click OK. Only the current list 

of devices is compared against the current set of search criteria to show a refined set of 
devices. 

6 Click Clear, then click OK to clear all search criteria and return to the complete device 
list. 

 

Viewing Device List details 
Associated with the Device List view, the Device Details tab provides a tabular view that 
displays detailed network device information. When a device is selected in the Device List 
view, the details of the device are shown in the Device Details tab view. 

To view the device list details: 
1 From the main menu of the WhatsConnected console, select View > Device List. The 

Device List view appears. 

 Tip: You can also view device list from the WhatsConnected console shortcut menu. Click 

 (Device List shortcut icon). The Device List dialog appears. 
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2 In the device list, select a device for which to view more details, then click Details. The 
Device Details list appears.  

 

Tabs are only shown if a device has data that can be displayed. Possible tab views that may be 
associated with each device are: 

 System. Provides IP Address/MAC Address, MIB II information, product vendor, and 
other system information. 

 IP Addresses. Provides IP Address configuration information. 

 Interfaces. Provides name entries (IF information) for each device interface and other 
interface information. 

 Bridge Ports. Provides Bridge Port and VLAN name and index information. 

 VLANs. Provides Virtual LAN configuration information. 

 LAG Trunks. Provides Link Aggregation Group information. 

 Assets. Provides inventory information about the device components.  

 Links. Provides physical connectivity information from this device to other network 
devices. 

 IP Routes. Provides IP route configuration data information. 

 Spanning Tree (STP). Provides spanning tree configuration and status information. 

 ARP Cache. Provides Address Resolution Protocol (ARP) table information. 

 Forwarding. Provides Layer 2 forwarding information. 

 Protocol Profile. Provides information about successful protocol matches for this 
device. 

 HSRP. Provides information about the Hot Standby Router Protocol (HSRP) on the 
device. The information relates to the standby nature of routers. 
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 IP Phone. Provides information about the selected (individual) IP phone. 

 IP Phone Manager. Provides information about the IP phones that are registered or 
are communicating with a call manager. 

 IP Routes. Provides information about the IP routes configured for this device.  

 VRRP. Provides information about the Virtual Router Redundancy Protocol (VRRP) on 
the device. The information relates to the standby nature of routers. 

 STP. Provides information about Spanning Tree Protocol entries discovered on this 
device.  

 Software. Provides information about installed software discovered on this device. 

Each of the Device Details tabs is built with the data grid views that were described 
previously. For more information about the data grid views, see About data grid views (on 
page 23). These views allow you to browse, sort, and export (print) the data that is shown for 
each device. 
 

About the Topology Maps View 

The Topology Maps view displays the layer 2, or physical topology, of your networking 
devices. Topology maps can be organized by groups or individually. By default, 
WhatsConnected builds a Network Devices view that displays the topology of your core 
network device infrastructure. 
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With the topology data, you can build custom topology views that display important 
elements of your network infrastructure. These topology views can be exported to Visio for 
sharing or WhatsUp Gold as new devices. 
 

About Topology Tree View 
Topology Maps View is an explorer-type view that allows you to organize and view network 
data in a graphical format. The topology viewer provides the capability to visually represent 
the relationships between each network device based on either its physical network 
connectivity or on your preferences. The left tree view allows you to organize topology 
groups and maps while the right view displays a graphical topology view of the network 
devices. To learn more about topology maps and using the topology maps view, see 
Managing and customizing topology groups and maps (on page 35). 
 

Managing and customizing topology groups and maps 
The topology tree view allows you to manage your topology maps through the right-click 
menu. WhatsConnected allows you to create your own custom topology maps. Using the 
layer 2 connectivity data, you can interactively place devices on a topology map and then use 
the right-click menu for that device to add/remove connected devices. 

To add a new topology map: 
1 Right-click on any topology group in the topology tree view. The right-click menu 

appears. 
2 Select Add Map. The Add Map dialog appears. 
3 Enter a name for the new topology map in Name.  

 Note: Topology map names must be unique. 

4 Click OK. The topology map is added to the selected group. 

To add a new topology group: 
1 Right-click on topology group in the topology tree view. The right-click menu appears.  
2 Select Add Group. The Add Group dialog appears. 
3 Enter the name of the new topology group in Name.  

 Note: Topology group names must be unique. 

4 Click OK. The topology group is added as a subfolder under the selected group. 

To rename a topology group or map: 
1 Right-click on topology group or map in the topology tree view. The right-click menu 

appears. 
2 Select Rename. The Rename Group/Map dialog appears. 
3 Enter the new name of the topology group or map in Name. 
4 Click OK. The topology group or map is updated to reflect the new name. 
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To delete a topology group or map: 
1 Right-click on a topology group or map in the topology tree view. The right-click menu 

appears. 
2 Click Delete. The group/map will be removed from the topology tree view.  

To cut and paste a topology group or map: 
1 Right-click on topology group or map in the topology tree view. The right-click menu 

appears. 
2 Select Cut. The group or map is removed from the topology tree view. 
3 Right-click on the topology group that you would like to place the topology item under 

in the tree view. The right-click menu appears. 
4 Select Paste. The group or map is placed under the selected topology group. 
 

About adding individual or connected devices to a topology map 
WhatsConnected allows you to customize topology maps by adding devices to the topology 
map.  

There are two methods by which to add devices to a topology map: 

 Adding an individual device to a topology map. 

 Adding a connected device to a topology map. 

The following steps describe how to accomplish both methods. 

To add device(s) to a topology map: 
1 From the main menu of the WhatsConnected console, select View > Topology Maps. 

The Topology Maps view appears. 

 Tip: You can also view topology maps from the WhatsConnected console shortcut menu. 

Click  (Topology maps shortcut icon). The Topology Maps dialog appears. 

2 Select a topology map you want to modify in the topology tree view. 
3 Right-click in the topology map area. The right-click menu appears. 
4 Select Add Devices. The Select Devices dialog appears. 
5 Select the devices from the list that you would like to add to the topology map. You can: 

 Double-click a device to select it and return to the previous dialog. 

 Press Ctrl and click to select multiple non-contiguous devices in the list. 

 Press Shift and click to select multiple contiguous devices in the list. 

6 Click OK. The selected devices are placed on the topology map. The layout settings (for 
example, radial or hierarchy) determine how the new devices are displayed in the 
topology map. To learn more about topology layout modes, please see About Topology 
layout modes (on page 43). 

 Note: The topology map shows the relationships between devices on the map based on 
their Layer 2 connectivity—if two devices are physically connected, the topology view 
illustrates their connection. 
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To add connected devices to a topology map: 
1 From the main menu of the WhatsConnected console, select View > Topology Maps. 

The Topology Maps view appears. 

 Tip: You can also view topology maps from the WhatsConnected console shortcut menu. 

Click  (Topology maps shortcut icon). The Topology Maps dialog appears. 

2 Right-click on a device in a topology map. The right-click menu appears. 
3 Select Add Connected. The following options are displayed. 

 Network Devices[x/y]. Add all connected network devices to the topology map. 

 Servers[x/y]. Add all connected servers to the topology map. 

 Workstations[x/y]. Add all connected workstations to the topology map. 

 Printers[x/y]. Add all connected printers to the topology map. 

 All Devices[x/y]. Add all connected devices to the topology map. 

 Note: [x/y] represents the following: 
y = the number of devices of that type connected to the device you have selected. 
x = the number of connected devices that are already on the topology map. 

 Select. Use the Select Devices dialog to individually select which connected devices 
are added to the topology map. 

4 By clicking on any of the displayed options, the topology map is updated with the 
selected devices. 

 

About removing devices from a topology map 
WhatsConnected allows you to customize topology maps by removing devices from a 
topology map.  

There are four methods to remove devices from a topology map: 

 Remove all devices from a topology map. 

 Remove a single device from a topology map. 

 Remove select devices from a topology map. 

 Remove connected devices from a topology map. 

The following steps describe the methods to remove devices. 

To remove all devices from a topology map: 

1 Select the topology map in the topology tree view. 

2 Right-click in the topology map area. The right-click menu appears. 

3 Select Remove All. All devices are removed from the topology map. 
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To remove a single device from a topology map: 

1 Select the topology map in the topology tree view. 

2 Right-click on a device on the topology map. The right-click menu appears. 

3 Select Remove Device. The device is removed from the topology map. 
- or - 
Select a device on the topology map. 

4 Press DELETE. The device is removed from the topology map. 

To remove selected devices from a topology map: 

1 Select the topology map in the topology tree view. 

2 Right-click in the topology map area. The right-click menu appears. 

3 Click Remove Devices. The Select Devices dialog appears. 

4 Use the Select Devices dialog to select the devices that you would like removed 
from the topology map. 

 Press CTRL to select multiple non-contiguous devices in the list. 

 Press SHIFT to select multiple contiguous devices in the list. 

5 Click OK. The selected devices are removed from the topology map. 

To remove connected devices from a topology map: 

1 Select the topology map in the topology tree view. 

2 Right-click on a device on a topology map. The right-click menu appears. 

3 Select Remove Connected. The following options are displayed. 

 Network Devices [x/y]. Remove all the connected network devices from the 
topology map. 

 Servers [x/y]. Remove all the connected servers from the topology map. 

 Workstations [x/y]. Remove all the connected workstations from the topology 
map. 

 Printers [x/y].  Remove all the connected printers from the topology map. 

 All Devices [x/y]. Remove all connected devices from the topology map. 

 Note: [x/y] represents the following: 
y = number of devices of this type connected to the device you have selected. 
x = number of connected devices that are already on the topology map. 
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 Select. Click to use the Select Devices dialog to individually select the connected 
devices to remove from the topology map. 

4 The selected devices are removed from the topology map. 
 

Viewing device properties from a topology map 
From the Topology Map, you can use the right-click menu to view device properties for each 
device on the map. 

To view device properties on the topology map: 
1 From the main menu of the WhatsConnected console, select View > Topology Maps. 

The Topology Maps view appears. 

 Tip: You can also view topology maps from the WhatsConnected console shortcut menu. 

Click  (Topology maps shortcut icon). The Topology Maps dialog appears. 

2 Select a topology map you want to modify in the topology tree view. 
3 Right-click a device with connected devices, then select Device Properties. The Device 

Viewer appears. 
4 Click the tab for the device information you want to view. 
 

Viewing device properties from the topology map 
From the Topology Map, you can use the right-click menu to view link properties for each link 
on the map. 

To view link properties on the topology map: 
1 From the main menu of the WhatsConnected console, select View > Topology Maps. 

The Topology Maps view appears. 

 Tip: You can also view topology maps from the WhatsConnected console shortcut menu. 

Click  (Topology maps shortcut icon). The Topology Maps dialog appears. 

2 Select a topology map you want to modify in the topology tree view. 
3 Right-click a link line between connected devices, then select Link Properties. The Link 

Properties dialog appears. 
4 View the information about the two linked devices. If viewing a Multi-Link properties 

dialog, you can scroll or click the page bar to select the device connection point you 
want to view.  
- or - 
Click Remove Link to remove the link between the devices on the topology map. 

 

Exporting network data 
With your network data and topology maps in place, you are ready to start monitoring and 
exporting your Layer 2 network devices. One of the key features of the WhatsConnected 
solution is the capability to export network data into platforms outside of the 
WhatsConnected console. Sharing the details of your network through Microsoft Visio™ 
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documents or creating topology maps in WhatsUp Gold provide flexible tools to document 
and monitor your network. 
 

Exporting topology maps to Visio 

You can export the WhatsConnected network data to Microsoft Visio 2003 or 2007 where you 
can further view and edit the network map. The following information describes the steps to 
export your topology maps to Visio from WhatsConnected or WhatsUp Gold. 

To export a topology map to Microsoft Visio from WhatsConnected: 
1 From the main menu of the WhatsConnected console, click View > Topology Maps. 

The Topology Maps tree appears. 
2 Select the topology map, in the topology tree view, that you want to export. 
3 Right-click in the topology map area. The right-click menu appears. 
4 Click Export To. The right-click menu appears. 
5 Click Visio. The Visio Export dialog appears. 

 Tip: You can also select the topology map you want to export, then from the shortcut menu 

of the WhatsConnected console, click  (Export topology to Microsoft Visio icon). The Visio 
Export dialog appears. 

6 Enter the appropriate information in the following fields: 

 Document Dimensions 

 Sheet(s) across. Defines the width of the document. 

 Sheet(s) down. Defines the height of the document. 

 Include in export 

 Custom Properties. Each shape on the Visio document can be populated with 
custom properties. Select this option to indicate that you want custom properties 
placed on the Visio shape.  

 Note: Custom properties include: IP address, MAC address, Host name, NetBIOS name, 
NetBIOS domain, System name, System description, System OID, System contact, System up-
time, Vendor, Model, Serial Number, Hardware revision, Firmware revision, and Software 
revision. 

 Link Labels. Select this option to indicate that labels should be placed on the 
Visio links that attach devices to one another. In most cases, this represents the 
interface names that connect the devices. 

 Multi-Link Labels. Select this option to indicate that a multi-link label should be 
displayed in the Visio document. Multi-link labels are used when multiple 
ports/interfaces connect two devices (i.e. LAG ports). 

 Note: The shapes that are used in the Visio document are based on the shapes that are 
shown in the topology view. You may change these shapes in the Application Settings 
dialog. 
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7 Click OK. The topology map is exported to a Visio document. 

To export a topology map to Microsoft Visio from WhatsUp Gold: 
1 From the WhatsUp Gold console, right-click a device in a Map View tab that you want to 

export to Visio. The right-click menu appears.  
2 Click Export Topology To Visio. The Export Topology to Visio dialog appears. 
3 Select a Device Group/Map View that you want to export to Visio, then click Export. 
4 Enter the appropriate information: 

 Export Shapes. Select the type of shapes to use in the Topology Maps. You can select 
from these choices: 

 WhatsUp. The topology maps use the basic functional shapes from WhatsUp Gold 
to draw a device on the topology maps. 

 Cisco. The topology maps use the standard Cisco icons/images for each functional 
collection (Router, Switch, etc) to represent a device. 

 Visio. The topology maps use the standard Visio icons/images for each functional 
collection (Router, Switch, etc) to represent a device. 

 Document Dimensions 

 Sheet(s) across. Defines the width of the document. 

 Sheet(s) down. Defines the height of the document. 

 Include in export 

 Custom Properties. Each shape on the Visio document can be populated with 
custom properties. Select this option to indicate that you want custom properties 
placed on the Visio shape.  

 Note: Custom properties include: IP address, MAC address, Host name, NetBIOS name, 
NetBIOS domain, System name, System description, System OID, System contact, System up-
time, Vendor, Model, Serial Number, Hardware revision, Firmware revision, and Software 
revision. 

 Link Labels. Select this option to indicate that labels should be placed on the 
Visio links that attach devices to one another. In most cases, this represents the 
interface names that connect the devices. 

 Multi-Link Labels. Select this option to indicate that a multi-link label should be 
displayed in the Visio document. Multi-link labels are used when multiple 
ports/interfaces connect two devices (i.e. LAG ports). 

 Note: The shapes that are used in the Visio document are based on the shapes that are 
shown in the topology view. You may change these shapes in the Application Settings 
dialog. 

5 Click OK. The topology map is exported to a Visio document. 
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Exporting topology maps to WhatsUp Gold 

You can use the right-click menu to export the WhatsConnected topology map details to 
WhatsUp Gold v12.3 or later. When the topology map is exported, the devices discovered 
with WhatsConnected are automatically created as new devices (or merged with existing 
devices) in the WhatsUp database.  

The following are created by the WhatsConnected export: 

 The device collection and Map View are created to represent the WhatsConnected 
topology map.  

 Active and statistical monitors are created for topology connections on each Map View. 

 Device Inventory attributes are created in the WhatsUp database. Device attributes, such 
as Name, Description, Contact, Location, Serial Number, Model, and VLAN, are created on 
each exported device. 

 Note: WhatsConnected tools are enabled in the WhatsUp console. For more information 
about WhatsConnected tools, see Using WhatsConnected Tools (on page 49). 

During the export, WhatsConnected compares devices in the WhatsUp Gold database with 
those in the WhatsConnected network data. Matches are made based on device attributes to 
avoid duplicate devices exporting to WhatsUp Gold. 

To export a topology map to Ipswitch WhatsUp Gold: 
1 From the main menu of the WhatsConnected console, select View > Topology Maps. 

The Topology Maps view appears. 
2 Select the topology map, in the topology tree view, that you want to export. 
3 Right-click in the topology map area. The right-click menu appears. 
4 Click Export To. The right-click menu appears. 
5 Click WhatsUp Gold. The WhatsUp Gold Export dialog appears. 

 Tip: You can also select the topology map you want to export, then from the shortcut menu 

of the WhatsConnected console, click  (Export topology to WhatsUp Gold icon). The 
WhatsUp Gold Export dialog appears. 

6 Enter the appropriate information:  

 WhatsUp Gold Settings 

 Server. This information is auto-filled. It indicates the WhatsUp Gold server to 
which WhatsConnected will export the topology map. 

 Node License Count. This indicates the current WhatsUp Gold device count 
available for the WhatsUp Gold license. 

 Currently in use. This indicates the current number of devices used out of the 
overall available device count in the license. 
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 Node export count. This indicates the number of devices to be created during 
the selected map export. 

 Important: WhatsConnected does not allow you to export devices to the WhatsUp database 
that exceed the available device count in the license. If prompted, you must reduce the 
number of devices that you are attempting to export. Remove the devices from the 
WhatsConnected topology map. 

 Layer 2 / Topology Export Settings. Use the following options to describe the 
information and types of monitors to create during the export. 

 Enable Exported Ping/SNMP Interface Active Monitors. Select this option to 
enable Ping and SNMP Interface Active Monitors. This mode activates the polling 
engine to immediately begin polling the new monitors upon their creation. 

 Create Ping Latency and Availability Performance Monitors. Select this option 
to create Ping Latency and Availability Monitors for the exported devices. 

 Create Interface Utilization Performance Monitors. Select this option to create 
Interface Utilization Performance Monitors for the interfaces that connect the 
exported devices on the topology map. 

 Note: Only the interfaces that connect devices are exported. 

 Enable Exported Performance Monitors. Select this option to enable 
Performance Monitors for the exported devices. This mode activates the polling 
engine to immediately begin polling the new monitors upon their creation. 

7 Click Export. The Status field and progress bar displays the progress of the export. 

To view the export results, open WhatsUp Gold console and find the device collection with 
the same name as the WhatsConnected topology map. The default topology map is named 
Network Devices. 
 

About Topology layout modes 
To understand the layout modes, you must first be familiar with the layout strategy used by 
the WhatsConnected topology engine. For each map, the topology viewer selects a root 
device which becomes the starting point of the diagrams. The root device is selected based 
on finding the device on the diagram with the most network connections. You can also 
change the root device. 

To change the Root Device: 
1 Select any device on the topology map, then right-click. The right click menu appears. 
2 Click Select As Root Device. This overrides the automatic root calculation and all 

parent/child relationships are built based on the newly selected device as the root 
device. 

Using the connectivity model, the topology viewer sets the root as the parent and then 
assigns all connected devices as children. This process continues until all devices on the 
topology map are given a parent/child relationship. 
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With the parent/child relationships calculated, the WhatsConnected topology viewer 
provides three layout modes for any topology map. These modes describe the manner in 
which each child node (or device) is given its position on the topology map. The layout 
modes are described as follows: 

 Radial. In this mode, each child node is connected to its parent in a radial (or circular) 
pattern. For more information, see About Radial layout settings (on page 44). 

 Hierarchy. In this mode, each child node is given a position in a hierarchical or tree-
like view with the root being either on the left, top, right or bottom. For more 
information, see About Hierarchy Layout settings (on page 44). 

 Manual. In this mode, you can use the drag-and-drop features of the topology view to 
position the device on the topology map where you want to locate it. For more 
information, see About Manual Layout setting (on page 45). 

To change a topology map layout settings: 
1 From the main menu of the WhatsConnected console, select View > Topology Maps. 

The Topology Maps view appears. 

 Tip: You can also view topology maps from the WhatsConnected console shortcut menu. 

Click  (Topology maps shortcut icon). The Topology Maps dialog appears. 

2 Select a topology map you want to modify in the topology tree view. 
3 Right-click the topology map, then select Layout Settings. The Layout Settings dialog 

appears. 
4 Use the Layout Settings dialog to adjust the layout options. For more information about 

auto-layout settings, see Layout Settings in the WhatsConnected Help. 
5 Click OK. The selected devices will be repositioned on the topology map. 
 

About Radial Layout settings 
In the radial layout mode, connected child devices are given positions in a radial (or circular) 
pattern around their parent device. You can modify the layout results by changing the 
following layout attributes: 

 Level Spacing. This setting dictates the amount of space between the parent and child 
device. Increase this value to provide more spacing between the parent and children 
devices. 

 Node Angle. This setting dictates the amount of space between each child (or sibling) 
devices. Increase this value to fan out the children. 

 Note: When increasing the node angle, if a large number of devices are shown connected to 
one parent, the radial layout may overlap (make a full circle). In this case you may need to 
decrease the node angle and increase the level spacing. 
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About Hierarchy Layout settings 
In the hierarchy layout mode, connected child devices are given positions in a hierarchical (or 
tree like) pattern in relationship to their parent. You can modify the layout results by 
changing the following layout attributes: 

Direction. This setting indicates the placement of the root device and the direction the 
children will be placed from the root device. 

 Down. The root device is placed at the top of the topology map, and children are 
placed respectively below the root device. 

 Up. The root device is placed at the bottom of the topology map, and children are 
placed respectively above the root. 

 Left. The root device is placed at the right of the topology map, and children are 
placed respectively to the left of the root. 

 Right. The root device is placed at the left of the topology map, and children are 
placed respectively to the right of the root. 

Alignment. This setting indicates the placement of the root (or parent) device in relationship 
to its children. 

 Center. The root/parent device is centered (either vertically/horizontally) with respect 
to its children. 

 Left. The root/parent device is located to the far left (either vertically/horizontally) 
with respect to its children. 

 Right. The root/parent device is located to the far right (either vertically/horizontally) 
with respect to its children. 

Level Spacing. This setting dictates the amount of space between the parent and child 
devices. Increase this value to provide more spacing between the parent and children 
devices. 

Node Spacing. This setting dictates the amount of space between each child (or sibling) 
devices. Increase this value to create more space between sibling devices. 

Straight Links. A flag that indicates whether the lines from the parent device to the children 
devices should be straight lines or routed (angled) lines. 
 

About Manual Layout settings 
In manual layout mode, the automatic layout methods are turned off and you are given 
complete control over device placement on the topology map. The topology maps provide a 
drag-and-drop capability to simplify creating and arranging a custom topology map. The 
following is a list of drag-and-drop operations in manual layout mode. 

 Left Mouse Click. Selects a device on the topology map. 

 Shift + Left Mouse Click. Multi-selects devices on a topology map. 

 Left Mouse Click + Mouse Move. Selects and drags a device to a new position on the 
topology map. 
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 Alt + Left Mouse Click + Mouse Move. Selects and drags a device PLUS all of its 
children to a new position on the topology map. 

You can use the manual layout mode to add new devices to the topology map. The method 
to add a device is the same as adding a device in radial or hierarchical layout mode. After the 
devices are placed on the topology map, you can manually move devices on the map or 
select the radial (on page 44) or hierarchy (on page 44) layout settings to readjust the map. 
 

Layout Children 
While in the manual layout mode, the WhatsConnected topology maps provide the capability 
to use the auto-layout algorithms to reposition child devices on a topology map.  

To reposition child devices on a topology map: 

 Note: Make sure that the layout settings are set to Manual layout to change layout children 
settings. For more information see, Layout Children in the WhatsConnected Help. 

1 From the main menu of the WhatsConnected console, select View > Topology Maps. 
The Topology Maps view appears. 

 Tip: You can also view topology maps from the WhatsConnected console shortcut menu. 

Click  (Topology maps shortcut icon). The Topology Maps dialog appears. 

2 Select a topology map you want to modify in the topology tree view. 
3 Right-click a device with connected devices, then select Layout Children. The Layout 

Children dialog appears. 
4 Use the Layout Settings dialog to adjust the layout options. For more information about 

auto-layout settings, see Layout Children in the WhatsConnected Help. 
5 Click OK. The selected devices will be repositioned on the topology map. 
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About the Subnets view 

The Subnets view is an explorer-type view that shows the grouping of network devices based 
on their respective subnets (or IP addressing information). 

The device list on the right side of the pane is a data grid view and therefore supports all 
sorting, exporting, and column filtering options. For more information about data grid views, 
see About data grid views (on page 23). 

 
 

Viewing Subnet device details 
Associated with the Subnets view, the Device Details tab provides a tabular view that displays 
detailed subnet device information. When a device is selected in the Subnet view, the details 
of the device are shown in the Device Details tab view. 

To view subnet device details: 

 From the main menu of the WhatsConnected console, select View > Subnets. The 
Subnets view appears. 

 Tip: You can also view subnets from the WhatsConnected console shortcut menu. Click  
(Subnets icon). The Subnets dialog appears. 
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About the Links view 

The Links view is a spreadsheet-like view that displays all known topology links in the 
network discovery file. This view provides a concise list of all of your network connections. 

 

Data displayed in this view can be printed, print previewed, or saved to a comma-separated-
value (CSV) file for use in Microsoft Excel or other reporting applications. For more 
information, see About data grid views (on page 23). 

To view the Links view: 
1 From the main menu of the WhatsConnected console, select View > Links. The Links 

view appears. 

 Tip: You can also view links from the WhatsConnected console shortcut menu. Click  
(Links shortcut icon). The Links dialog appears. 

2 View the following information about the links: 

 Local Link. Shows the local side of a connection. This connection is the Display Name 
of the device, and if available, the interface information. 

 Remote Link. Shows the remote side of a connection. The connection is the Display 
Name of the remote device, and any available interface information. 

3 Click Close to close the Links dialog. 
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Using WhatsConnected Tools 
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About WhatsConnected Tools 

WhatsConnected includes network tools that are available in both the WhatsConnected and 
WhatsUp Gold consoles. 

 Layer 2 Trace tool 

 IP/MAC Finder tool 

 Export Topology to Visio (on page 40) tool 

 Device Viewer (on page 56) tool 
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Using Layer 2 Trace 

In troubleshooting situations, it is often critical to understand the path that network data 
takes to access another network device. The Layer 2 Trace tool provides a method to trace the 
physical network path from one device to another.  

 

Using previously discovered network connectivity data, the Layer 2 Trace tool finds the path 
between the two devices and then displays each network interface that is used to build the 
path. The trace tool also allows for a quick check of the status and availability of each step 
along the layer 2 path. 

The Layer 2 trace tool is accessible from the WhatsConnected and WhatsUp Gold console.  

To run the Layer 2 Trace tool from WhatsConnected console: 

From WhatsConnected: 
1 From the main menu of the WhatsConnected console, select Tools > Layer 2 Trace. The 

Layer 2 Trace dialog appears. 

 Tip: You can also view Layer 2 Trace tool from the WhatsConnected console shortcut menu. 

Click  (Layer 2 Trace shortcut icon). The Layer 2 Trace dialog appears. 
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From WhatsUp Gold: 
1 From the WhatsUp Gold console, select a device group map view.  
2 Right-click on any device in the map view. The right-click menu appears. 

 Click Layer 2 Trace. The WhatsConnected - Layer 2 Trace dialog appears. 

3 Click Source. The Select Source Device dialog appears. 
4 Select a starting device for the layer 2 trace, then click OK. The IP address selection 

appears in the Source Device box. 

 Tip: You can use the Device Filter list to view specific device types. 

5 Click Destination. The Select Destination Device dialog appears. 
6 Select a destination device for the layer 2 trace, then click OK. The IP address selection 

appears in the Destination Device box. 

 Tip: You can use the Device Filter list to view specific device types. 

7 Click Trace. The step-by-step layer 2 path from the source device to the destination 
device displays in a list format. The results of the search are displayed in the Layer2 Trace 
tool list columns. 

 Device. Lists the devices that the network path traverses. 

 IP Address. Lists the IP address of each device on the network path. 

 Interface Name. Lists the interfaces that the network path traverses. 

 Status. Lists the device status information. 

 Note: After a trace is completed, you can click Ping to view the current status of the Layer 2 
path. This tool pings each device identified in the trace and uses SNMP to query the interface 
for its status. 

8 Click Clear to remove the information from the Layer 2 Trace table and start a new trace. 
- or - 
Click Close to close the dialog. 

To run the Layer 2 Trace tool from WhatsUp Gold console: 
1 From the WhatsUp Gold console, right-click a device in a Device View or Map View tab. 

The right-click menu appears.  
2 Click Layer 2 Trace. The Layer 2 Trace dialog appears. 
3 Click Source. The Select Source Device dialog appears. 
4 Select a starting device for the layer 2 trace, then click OK. The IP address selection 

appears in the Source Device box. 

 Tip: You can use the Device Filter list to view specific device types. 
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5 Click Destination. The Select Destination Device dialog appears. 
6 Select a destination device for the layer 2 trace, then click OK. The IP address selection 

appears in the Destination Device box. 

 Tip: You can use the Device Filter list to view specific device types. 

7 Click Trace. The step-by-step layer 2 path from the source device to the destination 
device displays in a list format. The results of the search are displayed in the Layer2 Trace 
tool list columns. 

 Device. Lists the devices that the network path traverses. 

 IP Address. Lists the IP address of each device on the network path. 

 Interface Name. Lists the interfaces that the network path traverses. 

 Status. Lists the device status information. 

 Note: After a trace is completed, you can click Ping to view the current status of the Layer 2 
path. This tool pings each device identified in the trace and uses SNMP to query the interface 
for its status. 

8 Click Clear to remove the information from the Layer 2 Trace table and start a new trace. 
- or - 
Click Close to close the dialog. 
- or - 
Click Save to open the Save Up Dependency dialog. This dialog provides a list of Layer 2 
paths, found in the Layer 2 trace, that can use up dependencies in WhatsUp Gold polling 
dependency rules. For more information, see Dependencies overview in the WhatsUp 
Gold Help. 
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Using IP/MAC Finder 

The IP/MAC Finder tool provides an easy way to locate an IP or MAC address on the network. 
Using the previously discovered network devices, IP/MAC Finder will find and display network 
interfaces that have sighting information for the supplied IP or MAC address. To get the most 
up-to-date sighting information, you can use the Refresh button which sends SNMP requests 
to each network device to quickly update the sighting information.  

 

When enough network data is available, IP/MAC Finder indicates to which network interface 
the IP or MAC address is physically connected. 

 Note: The IP/MAC Finder is accessible from both the WhatsConnected console and the 
WhatsUp Gold console. 

The IP/MAC Finder tool can search for either an IP or a MAC address on the network. The 
results of the search are displayed in the IP/MAC Finder list columns. 

To use the IP/MAC Finder tool on the WhatsConnected console: 

From WhatsConnected: 
1 From the main menu of the WhatsConnected console, select Tools > IP/MAC Finder. 

The IP/MAC Finder dialog appears. 

 Tip: You can also view IP/MAC finder tool from the WhatsConnected console shortcut menu. 
Click  (IP/MAC Finder shortcut icon). The IP/MAC Finder dialog appears. 
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From WhatsUp Gold: 
1 From the WhatsUp Gold console, select a device group map view.  
2 Right-click on any device in the map view. The right-click menu appears. 
3 Click IP/MAC Finder. The WhatsConnected - IP/MAC Finder dialog appears. 

  

4 Enter the appropriate information in the following fields. 

 IP Address. Enter the IP address of a device for which you want to find sightings on 
the network. Leave this option blank if you are only scanning for a MAC address.  
- or - 
Click Select to select a device, in the Select Devices dialog, for which you want to 
identify a MAC address. For more information, see About the Select button (on page 
55). 

 Note: The IP/MAC Finder tool does not support IPv6 addresses. 

 MAC Address. Enter The MAC address for which you are scanning the network. Leave 
this option blank if you are only scanning for an IP address. 

5 Select Use Network Devices Only to display the IP/MAC sightings found only on 
network device types.  
- or - 
Deselect Use Network Devices Only to display all IP/MAC sightings found on all device 
types. 

6 Click Find to search the network to locate where the IP or MAC device is on the network. 
The results of the search are displayed in the Sighting Information list: 

 Device. Lists the name of the network device that has sighting information for the IP 
or MAC address. 

 IP Address. Lists the IP address of the sighting device. 

 Interface Name. Lists the network interface that is routing or forwarding traffic to the 
IP or MAC address. 

 Is Linked To. Lists the network devices to which the device is linked. 

7 Click Clear to remove the information from the IP/MAC Finder table and start a new 
device sighting. 
- or - 
Click Close to close the dialog. 

To use the IP/MAC Finder tool within WhatsUp console: 
1 From the WhatsUp Gold console, right-click a source device in a Device View or Map 

View tab. The right-click menu appears. 
2 Click IP/MAC Finder. The IP/MAC Finder dialog appears.   
3 Enter the appropriate information in the following fields. 

 IP Address. Enter the IP address of a device for which you want to find sightings on 
the network. Leave this option blank if you are only scanning for a MAC address.  
- or - 
Click Select to select a device, in the Select Devices dialog, for which you want to 
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identify a MAC address. For more information, see About the Select button (on page 
55). 

 Note: The IP/MAC Finder tool does not support IPv6 addresses. 

 MAC Address. Enter The MAC address for which you are scanning the network. Leave 
this option blank if you are only scanning for an IP address. 

4 Select Use Network Devices Only to display the IP/MAC sightings found only on 
network device types.  
- or - 
Deselect Use Network Devices Only to display all IP/MAC sightings found on all device 
types. 

5 Click Find to search the network to locate where the IP or MAC device is on the network. 
The results of the search are displayed in the Sighting Information list: 

 Device. Lists the name of the network device that has sighting information for the IP 
or MAC address. 

 IP Address. Lists the IP address of the sighting device. 

 Interface Name. Lists the network interface that is routing or forwarding traffic to the 
IP or MAC address. 

 Is Linked To. Lists the network devices to which the device is linked. 

6 Click Clear to remove the information from the IP/MAC Finder table and start a new 
device sighting. 
- or - 
Click Close to close the dialog. 

 

About the Select button 
The IP/MAC Finder tool's Select feature uses previously discovered network information to 
help you find a device, then select the device for which to search the network for sightings of 
its IP or MAC address. 

To use the Lookup button: 
1 Open the IP/MAC Finder tool from either the WhatsConnected or WhatsUp Gold 

console (see Using the IP/MAC Finder (on page 53)). 
2 Click Select. The Select Devices dialog appears. This dialog allows you to pick a device 

from your existing network discovery. 
3 In the Device Filter list, select the device type you want to display in the Device List. All 

device devices are listed by default. The device list displays those devices that match the 
device filter criteria. 

4 Select a device in the list, then click OK. The IP address and MAC address automatically 
fills the IP Address and MAC Address fields. 
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About the Refresh Connectivity button 
The IP/MAC Finder tool's Refresh Connectivity feature refreshes the connectivity model by 
sending SNMP requests to each network device to update the network data. 

To use the Refresh Connectivity button: 
1 Open the IP/MAC Finder tool from either the WhatsConnected or WhatsUp Gold 

console (see Using the IP/MAC Finder (on page 53)). 
2 Click Refresh. The Run Discovery dialog appears. 
3 Wait for the progress information to indicate that the discovery is complete. 
4 Click OK. The network model updates with the latest connectivity information based on 

this discovery run. 
 

Rebuild Connectivity 

The Rebuild Connectivity feature reruns the connectivity engine to rebuild all the links inside 
the network model. Rebuild connectivity generally happens automatically after a new 
discovery, but you can run Rebuild Connectivity at any time if you have merged more devices 
into the network using the file menu. 

To run the Rebuild Connectivity: 

 From the main menu of the WhatsConnected console, select Tools > Rebuild 
Connectivity. The Rebuild Connectivity tool runs. 

 

Classify Devices 

The Classify Devices feature reruns the device classifier after the device type configuration 
has been changed. With this feature, you can enter mappings into the Device Type 
Configuration and run Classify Devices to update all device categories. 

To run the Rebuild Connectivity: 

 From the main menu of the WhatsConnected console, select Tools >Classify Devices. 
The Classify Devices tool runs. 
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Using the Device Viewer 

The Device Viewer allows you to view device configuration and inventory details from the 
WhatsUp Gold console. The information displayed in the Device Viewer is accessed from the 
WhatsUp database. 

To run the Device Viewer tool: 
1 Start the WhatsUp Gold console. 
2 Locate a device that has been exported from WhatsConnected to the WhatsUp 

database. 
3 Right-click the device in the WhatsUp console. The right-click menu appears. 
4 Select Device Viewer. The WhatsConnected Device Viewer appears displaying the 

device details. Tabs are only shown if a device has data that can be displayed. Possible 
tab views that may be associated with each device are: 

 System. Provides IP Address/MAC Address, MIB II information, product vendor, and 
other system information. 

 IP Addresses. Provides IP Address configuration information. 

 Interfaces. Provides name entries (IF information) for each device interface and other 
interface information. 

 Bridge Ports. Provides Bridge Port and VLAN name and index information. 

 VLANs. Provides Virtual LAN configuration information. 

 LAG Trunks. Provides Link Aggregation Group information. 

 Assets. Provides inventory information about the device components.  

 Links. Provides physical connectivity information from this device to other network 
devices. 

 IP Routes. Provides IP route configuration data information. 

 Spanning Tree (STP). Provides spanning tree configuration and status information. 

 ARP Cache. Provides Address Resolution Protocol (ARP) table information. 

 Forwarding. Provides Layer 2 forwarding information. 

 Protocol Profile. Provides information about successful protocol matches for this 
device. 

 HSRP. Provides information about the Hot Standby Router Protocol (HSRP) on the 
device. The information relates to the standby nature of routers. 

 IP Phone. Provides information about the selected (individual) IP phone. 

 IP Phone Manager. Provides information about the IP phones that are registered or 
are communicating with a call manager. 

 IP Routes. Provides information about the IP routes configured for this device.  

 VRRP. Provides information about the Virtual Router Redundancy Protocol (VRRP) on 
the device. The information relates to the standby nature of routers. 
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 STP. Provides information about Spanning Tree Protocol entries discovered on this 
device.  

 Software. Provides information about installed software discovered on this device. 

 Note: The device details are the same as those displayed in the Device Details Viewer in the 
WhatsConnected console. For more information, see About Device Details tab view (on page 
28). 

 Note: You can click Select to open the Select Device dialog and select another device. For 
more information, see Select Devices in the WhatsConnected Help. 
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About WhatsConnected configuration settings 

WhatsConnected provides a variety of configuration setting options to help you optimize 
WhatsConnected Layer 2 discovery for your network. 

 Application Settings (on page 59) 

 Discovery Settings (on page 60) 

 Protocol Settings (on page 62) 

 Device Types (on page 63) 
 

Configuring Applications Settings 

You can use the Applications Settings to select the type of shapes to use in the Topology 
Maps. The topology map shape options are: 

 WhatsUp 

 Cisco 

 Visio 

To configure Application Settings: 
1 From the main menu of the WhatsConnected console, select Configure > Application 

Settings. The Application Settings dialog appears. 
2 Select the shapes you want to use in your topology maps: 

 WhatsUp. The topology maps use the basic functional shapes from WhatsUp Gold to 
draw a device on the topology maps. 

 Cisco. The topology maps use the standard Cisco icons/images for each functional 
collection (Router, Switch, etc) to represent a device. 
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 Visio. The topology maps use the standard Visio icons/images for each functional 
collection (Router, Switch, etc) to represent a device. 

 Note: You can only select the Visio topology maps option if a supported version of Visio 
(Microsoft Visio 2003 and 2007) is installed. This option is not available if Visio is not installed. 

3 Click OK to save settings. 
 

Configuring Discovery Settings 

A network discovery requires a general collection of settings to define a network discovery 
scope. Use the Discovery Settings to edit discovery collection settings, select a discovery 
configuration from the list of network discovery collections, or enter information for a new 
discovery collection. 

 

Creating, renaming, or deleting discovery collections 
To create a new discovery collection: 
1 In the left pane, right-click the discovery collection name you want to change, then click 

New. The New Discovery Settings dialog appears. 
2 Enter a discovery collection name, then click OK. The new discovery collection appears 

in the list. 

To rename a discovery collection: 
1 In the left pane, right-click the discovery collection name you want to change, then click 

Rename. The Rename Discovery Settings dialog appears. 
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2 Enter the new discovery collection name, then click OK. The new name appears in 
discovery collection list. 

To delete a collection: 

In the left pane, right-click the discovery collection name you want to delete, then click 
Delete. The discovery collection list is deleted. 

To configure the Discovery Settings: 
1 From the main menu of the WhatsConnected console, select Configure > Discovery 

Settings. The Discovery Settings dialog appears. 
2 Enter the discovery options in the following fields: 

 Method. Select the discovery type to use (ARP Cache or Ping Sweep) for the scan. For 
more information about the discovery types, see Running a Layer 2 Network Discovery 
(on page 16). 

 Max Threads. Enter a number for the max number of threads to use while running 
the discovery scan. This indicates the number of separate threads to run in the 
background as WhatsConnected attempts to communicate with the devices on the 
network. 

 Note: If you are concerned about the load discovery could place on the network, you can 
reduce the number of Max Threads to cut back on the concurrent network communication. 

 Ping Devices First. Select this option to indicate whether a successful ICMP ping is 
required before trying any other type of communication with the device. 

 Ping Discovered Subnets. Select this option to indicate that you would like to run a 
Ping Sweep through each discovered subnet when running an ARP Cache discovery. 
This option does not apply for a Ping Sweep discovery. 

 Seed IP Scope. Enter the IP address that defines where the network discovery will 
start. Seed IP Scope defines the range of IP addresses where network discovery starts 
a scan. In a Ping Sweep discovery, these addresses are contacted with an initial ICMP 
request. In an ARP Cache discovery, these addresses are queried for SNMP data. The 
discovery engine reads SNMP data from these devices and continues to scan the 
network for additional devices based on the SNMP responses from the seed devices. 
Example IP scopes: 

 A single IP address - 10.0.0.1 

 A range of IP addresses - 10.0.0.1-10.0.0.100 

 A subnet range of IP addresses - 10.0.0.1/24 or 10.0.0.1/255.255.255.0 

 Include IP Scope. Enter the IP range that defines the addresses in which to include in 
the network scan. Leave this option blank if you do not want to limit the network 
scan. 

 For the Ping Sweep Discovery option, Include IP Scope is the same as the Seed IP 
Scope.  

 For the ARP Cache Discovery option, Include IP Scope indicates an IP address 
range that the network scan should attempt to discover. 
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Example 

 A single IP address (i.e. 10.0.0.1) 

 A range of IP addresses (i.e. 10.0.0.1-10.0.0.100) 

 A subnet range of IP addresses (i.e. 10.0.0.1/24 or 10.0.0.1/255.255.255.0) 

 Exclude IP Scope. Enter the IP range that defines the range of IP addresses to exclude 
from the network scan. Leave this box blank if you want to include all IP addresses in 
the network scan.  

 For the Ping Sweep Discovery option, Exclude IP Scope might be an IP range of 
servers or workstations that are a subnet of the Seed IP Scope.  

 For the ARP Cache Discovery option, Exclude IP Scope indicates an IP address range 
that the network scan should not attempt to discover. 

Click OK to save changes. 
 

Configuring Protocol Settings 

Use the Protocol Settings dialog to configure the protocol settings (for ICMP, SNMP, or SSH) 
that you want to use for network discovery. 

 SNMP discovery requires the SNMP read community information, timeout settings, and 
retry counts. 

 ICMP discovery requires the timeout settings and retry counts. 

 SSH discovery requires the User Name, Password, and Port used to attempt an SSH 
connection. 

To configure Protocol Settings: 

 From the main menu of the WhatsConnected console,select Configure > Protocol 
Settings. The Protocol Settings dialog appears.  

To create a new protocol setting: 
1 Right-click a supported protocol, then click New. The protocol editor dialog appears in 

the right pane. 
2 Enter the protocol settings in the protocol editor. 

To edit protocol settings: 
1 Use the protocol explorer tree to locate the protocol and specific settings you want to 

edit.  
2 In the protocol list, select with the protocol setting. The protocol editor dialog appears 

in the right pane. 
3 Enter the settings you want to modify in the protocol editor. 
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To delete a protocol setting: 

Right-click a protocol setting in the tree view, then click Delete. The protocol setting is 
deleted from the list. 

Click OK to save changes. 
 

Configuring Device Types 

Use the Device Types dialog to create or modify a custom device type mapping. To do this, 
you enter an SNMP OID (sysObjectID) and select a device category for which to map a device. 
For more information about SNMP OIDs, refer to your device documentation or the Internet 
Assigned Numbers Authority (IANA) web site (http://www.iana.org/assignments/enterprise-
numbers). 

To configure Device Types: 
1 From the main menu of the WhatsConnected console, select Configure > Device 

Types. The SNMP OID to Device Type Configuration dialog appears. 
2 Use the following options to create and edit device types:  

 New. Click to create a new device type configuration (mapping). 

 sysObject ID (OID). Enter the SNMP OID (sysObjectID) for which you want to map 
a device. For more information about SNMP OIDs, refer to your device 
documentation or the Internet Assigned Numbers Authority (IANA) web site 
(http://www.iana.org/assignments/enterprise-numbers). 

 Include Subtree. Select to include the device OID subtree entries in the device 
type configuration. 

 Category. Select a device type category for which to map the device.  

 Vendor/Manufacturer. Enter the vendor or manufacturer name. 

 Model. Enter the vendor or manufacturer model. 

 Description. Enter the vendor or manufacturer description. 

 Edit. Select a device in the OID Maps list to modify the current settings. 

 Copy. Select a device in the OID Maps list to copy an existing OID Map and modify it 
to create a new OID Map. 

 Delete. Select a device in the OID Maps list to delete an existing OID Map. 

3 Click OK to make changes. 
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