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CHAPTER 1 

Introduction 

In This Chapter 

Ways to Automate Regular File Transfers .....................................................5
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Building a List of Files for Transfer...................................................................6

Transfer Files as a Compressed Archive ........................................................7

Transfer and Append to a Remote File ..........................................................7

How to Speed Up Transfer of Large Files......................................................7

Integrating WS_FTP with a Browser or E-Mail.............................................8

Search an FTP Site for a File or Folder ............................................................9

Using the Upload Wizard....................................................................................9

This guide introduces tools that can help you automate regular file transfer tasks, 
troubleshoot problems, verify transfers, and customize the way you work with Ipswitch 
WS_FTP 12. 

This chapter shows some of the situations where the tools can help you. The following 
chapters present more detailed information about the tools. 
 
 

Ways to Automate Regular File Transfers 

If you do regular file transfers, such as updating a web site nightly, or sending an accounting 
report to the home office weekly, you may find it easier to automate the transfer. Several 
WS_FTP tools let you automate transfers: 

 

If you want to: Use this tool:

Have a regular transfer, such as a file upload, 
occur at a specified time interval, such as every 
Thursday at 5:00 pm. 

Scheduler Utility. See the Scheduler Utility (on page 15) 
chapter. 

Mirror a set of files on your PC with a set of files 
on an FTP server. 

Synchronize Utility. See Synchronizing Files and Folders
(on page 27). 



If you want to: Use this tool:

Automate a regular process that includes not 
only a file transfer, but actions such as changing 
directories, deleting files, or checking for the 
success or failure of a command. 

Script Utility. See the Script Utility (on page 41) 
chapter. 

 

You can open any of these tools from the Tools menu. 
 

Check Transfer Status and Logs 

Use the Information Window at the bottom of the WS_FTP main window to verify transfers, 
pause or cancel a transfer, and troubleshoot both transfer and connection problems. 

You can interact with “transfer jobs” shown in the Transfer Manager and Transfer History. For 
example, you can use Batch Mode with the Transfer Manager to build a list of files for transfer. 

The Connection Log shows the commands sent back and forth (the “conversation”) between 
WS_FTP and the FTP server. 

For more information, see Using the Information Window (on page 11). 
 

Building a List of Files for Transfer 

When transferring multiple files, you may find it easier to first build a list of files for transfer, 
then process the transfer. When Batch Mode is active, you can browse folders and add files 
to the batch list. You can review the list, make any changes, and then upload or download the 
entire list. 

To use Batch Mode: 

1 In the toolbar, click Connect to open the Site Manager. 
2 Select a site and click Connect. 
3 Select Tools > Batch Mode. At the bottom of the remote site's file list, you'll see the 

Batch Mode icon. 
4 Select a file or files and click the transfer arrow. The file will be placed in the Transfer 

Manager. 

Within the Transfer Manager, you can select a file to remove it from the list, view the 
transfer properties, transfer or schedule for later transfer. For more information, see Using 
the Information Window (on page 11). 

5 After you have added all of the files to the batch, select Tools > Batch Mode again to 
take WS_FTP out of batch mode. 
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6 In the Transfer Manager, select the requests you want to execute. Hold down the Ctrl 
key to select multiple requests. 

7 After you take the client out of batch mode, it will execute the transfers. 
 

Transfer Files as a Compressed Archive 

When you select files or folders and upload them while Compression Mode is enabled, the 
files are transferred as a single ZIP archive. Compression Mode can only be used when 
transferring files from your local computer to a remote server.   

To use Compression Mode: 

1 In the toolbar, click Connect to open the Site Manager. 
2 Select a site and click Connect. 
3 From the Tools menu, select Compression Mode. At the bottom of the remote site's file 

list, you should see the Compression Mode icon. 
4 Select the files or folders to transfer. 
5 Click the Upload arrow. 
 

Transfer and Append to a Remote File 

When WS_FTP is in Append Mode, you transfer a source file and append it to a destination 
file. You can append files in either direction, upload or download. Append Mode saves you 
the extra step of concatenating two files after transfer. 

To use Append Mode: 
1 In the toolbar, click Connect to open the Site Manager. 
2 Select a site and click Connect. 
3 From the Tools menu, select Append Mode. At the bottom of the remote site's file list, 

you should see the Append Mode icon. 
4 Select the file or files to transfer. You are prompted for the destination file name. 
5 Enter the file name of the destination file (the file to which the transferred files are 

appended). 

The selected files are transferred and appended to the destination file. If you open the desti-
nation file, you will see the appended files. 
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How to Speed Up Transfer of Large Files 

Large files, such as an architect's blueprint or a software executable, can take longer to 
transfer. If you regularly transfer large files, you can use Multipart mode to speed up the 
transfer. 

When in Multipart Mode, WS_FTP splits large files into smaller segments, and downloads all 
segments via different, yet concurrent, connections. This decreases the total download time 
for large individual files. 

 Multipart works with download files only. It does not work with SSL connections.  

To use Multipart Mode: 
1 In the toolbar, click Connect to open the Site Manager. 
2 Select a site and click Edit. 
3 Select the Transfer options and make sure that Maximum transfer connections is set 

to more than one. 

The number of connections made is determined by the number of additional 
connections specified here and the number of connections allowed by the server. 

4 Click OK to close the Site Options, and then click Connect. 
5 Select Tools > Multipart Mode. At the bottom of the FTP site's file list, you'll see the 

Multipart Mode icon. 

When you transfer files to this site, WS_FTP will use multiple data connections. 

The Transfer Manager displays the file, the number of segments that the file has been 
divided into, and the status of the transfer of each of the segments. When each of the 
segments are complete, the Transfer Manager shows the status of re-combining the 
segments into one file, if that process takes longer than 2 seconds. 

If there are no segments listed under the file being downloaded, then the file is not large 
enough to be divided.   

6 To turn off MultiPart Mode, select Tools > Multipart Mode again. 
 

Integrating WS_FTP with a Browser or E-Mail 

FTP sites have an Internet address, similar to a web address, that looks like: 

ftp://ftp.ipswitch.com, sftp://ftp.ipswitch.com, or ftps://ftp.ipswitch.com

You can set an option in WS_FTP so that when you click on an FTP, FTPS, or SFTP address in 
your browser or e-mail client, so that WS_FTP will open and connect to the FTP server. 

The type of FTP address affects how this works:    
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If the address includes: WS_FTP does:

the name of an FTP server  
Ex. ftp.ipswitch.com 

Opens and connects to the server 

the path and name of a file 
Ex: ftp.ipswitch.com/French/ftp803.txt 

Downloads the file to your PC and prompts whether 
to save or open the file. 

the path and name of a folder 
Ex: ftp.ipswitch.com/French 

Opens, connects to the server, and navigates to the 
folder. 

To turn on Browser Integration: 
1 In the toolbar, click Options. 
2 From the Program Options dialog, select Browser Integration. 
3 If you use Netscape Navigator and want WS_FTP to handle FTP URLs, select the first 

check box. 
4 If you use Microsoft Internet Explorer and want WS_FTP to handle FTP URLs, select the 

second check box. 
5 If you want to be prompted each time you click an FTP URL so you can choose whether 

or not to use WS_FTP, select Ask before using WS_FTP. 
 

Search an FTP Site for a File or Folder 

If you are searching a large, complex site for a file, you can use the Find Utility to quickly 
locate the file and then initiate a transfer. For more information, see Search Utilities (local and 
remote) (on page 45). 
 

Using the Upload Wizard 

The Upload Wizard is a utility that allows you to transfer files from your local system to a 
remote site without using the WS_FTP interface. There are two ways to access the Upload 
Wizard: 

 In Windows Explorer, select the files or folders you want to upload, then right-mouse 
click on the list. In that list you will see 'Upload using WS_FTP Upload Wizard.' After 
selecting that option, the Upload Wizard appears with the files already added to the 
upload list. 

 From the Start menu, select Programs > Ipswitch WS_FTP 12 > Utilities > WS_FTP 
Upload Wizard. The Wizard opens and is ready for you to add the files you want to 
upload. 
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CHAPTER 2 

Using the Information Window 

In This Chapter 

The Transfer Manager ....................................................................................... 11
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How to Schedule a Transfer............................................................................ 14

Connection Log................................................................................................... 14

Use the Information Window at the bottom of the WS_FTP main window to verify transfers, 
pause or cancel a transfer, and troubleshoot both transfer and connection problems. 

You can interact with transfer jobs shown in the Transfer Manager and Transfer History. For 
example, you can use Batch Mode with the Transfer Manager to build a list of files for transfer. 

The Connection Log shows the commands sent back and forth (the “conversation”) between 
WS_FTP and the remote server. 

By default, the Information Window is viewable, but you toggle it on or off using the View 
menu. 
 
 

The Transfer Manager 

The Transfer Manager is the module of Ipswitch WS_FTP  
Professional that performs transfers. It can also be used to view the progress of transfers, 
schedule the transfer of multiple files, and view logs for individual transfers. 

The Transfer Manager displays a list of all pending, paused, and failed transfers. 

 

 Source. The path and name of the file or folder that is to be transferred. 

 Status. The current status of the listed item. The icon shows the type of event. 
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 Progress. How complete the event indicated in Status is. Click the button next to 
Progress to either start or pause the transfer. 

 Transferred. The number of bytes transferred. 

 Rate (KB/S). The number of kilobytes being transferred per second. 

 Time Left. The estimated time left until the transfer is complete. 
 

How to Use the Batch Mode 
You can use Batch Mode to add requests to the Transfer Manager. 

1 Connect to a server. 
2 Select Tools > Batch Mode or click Batch Mode in the toolbar. 
3 Select a file or files and click the transfer arrow. The file will be placed in the Transfer 

Manager. 
4 After you have added all of the files to the batch, select Tools > Batch Mode again to 

take WS_FTP out of batch mode. 
5 In the Transfer Manager, select the requests you want to execute. Hold down the Ctrl 

key to select multiple requests. 
6 After you take the client out of batch mode, it will execute the transfers. 
 

How to Pause a Transfer 
To pause an active transfer from the Transfer Manager, select the entry, then right-click and 
select Pause from the menu. 

You can also click the Pause button next to the progress column. 
 

How to Remove an Item 
To remove an item from the Transfer Manager, select the transfer item, then right-click and 
select Delete from the menu. 
 

Request Properties 
You can double-click any item on the Transfer Manager to view the Properties dialog for that 
item. 
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The following information appears on the File Properties dialog. 

 Elapsed Time. The amount of time that has passed since the transfer began. 

 Contains. Number of files and folders contained in the request. (Only displayed when a 
folder is selected.) 

 Transferred Bytes. The number of bytes transferred. 

 Transfer Rate. The number of Kilobytes being transferred per second. 

 Transfer Mode. Whether the file was transferred in binary or ASCII mode. (Not displayed 
when a folder is selected.) 

 Attempts. Number of times the application tried to make the transfer. 

 Operation. The type of transfer being performed. Either Upload or Download. 

 Status. The current status code of the listed item. 

 Source. The path name of the source of the transfer. 

 Destination. The path name of the destination of the transfer. 
 

Transfer History 

The Transfer History tab displays a list of successful transfers. This list can be sorted by clicking 
on the column headers. 

 

 Transfer Arrow. The arrow on the far left side of the item identifies what type of transfer 
was performed. An up arrow means upload, a down for download, and a left-right arrow 
is for site-to-site transfers. 

 Date. This is the date and time the transfer was completed. 

 Source. This is the site profile that was used to connect to the source. 

 Source Path. The path on the source directory from the root to the transferred item. 

 Source File Name. The name of the source file that was transferred. 

 Destination. The site profile and folder that was used to connect to the destination. 

 Destination Path. The path on the destination directory from the root to where the 
transferred item was placed. 

 Destination File Name. The name of the file after it has been transferred. 

 Size. The number of bytes transferred. 
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Executing a file 
After a file is successfully transferred, you can select it and choose Execute from the right-
click menu. If it is a download, the destination file will be opened in its associated application. 
If it is an upload, the source file will be opened. 
 

Clearing the History 
You can remove items from the history list by selecting them and choosing Delete from the 
right-click menu. 

You can remove all items by selecting Clear All from the right-click menu. 
 

How to Schedule a Transfer 

To schedule a transfer from the Transfer Manager or Transfer History tabs: 

1 Select a request, file, or folder. 
2 From the right-click menu, select Schedule. 
3 In the Schedule Item Properties dialog, enter the date, time, and frequency of the 

transfer. 
4 Click OK to add the item to Scheduler. 
 

Operation After Transfers 
The Operations After Transfers submenu can be found on the Tools menu. This submenu 
allows you to select the following operations: 

 Exit Application. After the application finishes all active or scheduled transfer requests, 
WS_FTP will close itself. 

 Shutdown Computer. After the application finishes all active or scheduled transfer 
requests, WS_FTP will attempt to shut the computer down. 

 

Connection Log 

The Connection log shows all commands sent from WS_FTP to the server and shows the 
replies from the server. This log can help you troubleshoot a connection error. 

The log window will contain all actions that have been initiated for the selected transfer 
request, including pause and resume. 

For descriptions of error messages that may appear in the log, see Textual Error Messages (on 
page 69). 
 

  14 



 
 

CHAPTER 3 

Scheduler Utility 

In This Chapter 
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Examples................................................................................................................ 16

The WS_FTP Pro Scheduler Utility lets you create FTP tasks or “jobs” for transfers that you 
need to perform repeatedly or manually at a particular time. Each task can consist of any 
number of uploads and downloads of files and folders. 

This chapter provides an overview of the Scheduler and some examples of how you might 
use it. For detailed instructions on using the Scheduler, start the Scheduler and use its online 
Help. 
 
 

Using the Scheduler 

To access the Scheduler window, do one of the following: 

 In the Tools menu, select Scheduler Utility. 

 From the Start menu, select Programs > Ipswitch WS_FTP 12 > Utilities > WS_FTP 
Scheduler. 

 

Once you are in the Scheduler window, you are ready to set up a file transfer task. You can: 

 Add a pre-existing script to run at a particular time. (For more information on creating 
scripts, see Script Utility (on page 41).) 

 Drag and drop a file from the WS_FTP interface to the Scheduler window to create an 
upload task. 

 Create a new transfer/custom task. 

 Modify or delete tasks. 
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 The WS_FTP Scheduler will run the task at the time you schedule it to run, or you can 
make the task run on demand by using the Run Now option. 

 

Examples 

The following are examples of how you might use the WS_FTP Scheduler. 
 

Adding a Script to the Scheduler 
To add a script to the scheduler: 

1 From the WS_FTP Scheduler dialog, click File > New > Custom. The Schedule Item 
Properties dialog appears. 

2 In the Start Date and End Date boxes, set the dates for when you want this recurring 
task to begin and when you want it to end. 

 

3  In the Start Time box, enter the time of day you want the task to run. 
4 In the Executable box, enter the full path to the ftpscript.exe application. 
5 In the Command box, enter -f followed by the full path to the script you want WS_FTP 

Scheduler to run. If the path contains spaces, put quotation marks around the path. 
6 If you are on a Windows 2000 or Windows XP, you must enter your user login and pass-

word in the boxes provided. 

 If you are on a domain, include the domain name in the Username box. Example: 
IPSWITCH_D\userid 
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7 Select the frequency of the recurring transfer in the Schedule Frequency area. 
8 Click OK to add this task to the scheduler. 
 

Updating a Web Site on a Nightly Basis 
If you have a Web site you would like to update every night, without having to manually 
upload all of the files you have recently changed, you can set up a scheduled task to have it 
run as frequently as you like. 

To schedule items: 

1 In WS_FTP, select the file you want transfer from the local or a remote site, then click 
File > Send to Scheduler. 

You can select multiple files or folders by holding the Ctrl key and clicking the file or 
folder name. The Schedule Item Properties dialog appears. 

2 In the Start Date and End Date boxes, set the dates for when you want this recurring 
task to begin and end. 

3 In the Start Time box, enter the time of day you want the task run. 
4 The Executable, Command, and Task Name boxes are filled in for you. A .tmp file 

name is automatically entered in the Command box. This file identifies the files to 
download and the locations to transfer them to and from. 

5 If you are using Microsoft Windows 2000 or Microsoft Windows XP workstation, enter 
your Username and Password in the boxes provided. 

6 In the Schedule Frequency, select the recurring transfer frequency. 
7 Click OK to add this task to the scheduler. 
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CHAPTER 4 

Backing Up Files 

In This Chapter 

Using the Backup Job Wizard (WS_FTP Professional) ........................... 19
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The WS_FTP Professional Backup Wizard lets you select files or folders that you want to back 
up, schedule a backup time, or run the backup immediately. Unlike the Synchronize utility, 
rather than comparing and transferring files in multiple directions (for example, 
synchronizing files between a local and remote site), Backup transfers selected files or folders 
from one location to another (in one direction). 

This chapter provides an overview of the Backup Wizard, Managing Backup Jobs, and some 
examples of how you might use the Backup features. 
 
 

Using the Backup Job Wizard (WS_FTP Professional) 

To start the Backup Job Wizard: 

 Click Tools > Backup Files > Add a new backup job.... 



 Complete the Backup Wizard settings to create a new Backup Job. 

 

 After the settings are complete, the Manage Backup Jobs dialog opens. The new Backup 
Job displays in the list. The job will run at the next scheduled time, or you can click Run 
Now to run the job immediately. 

 If you schedule a backup job to run Daily (in Backup Wizard settings), the job will start 
running on the day following the start date.   

To manage backup jobs: 

1 Click Tools > Backup Files > Manage backup jobs. The Manage Backup Jobs dialog 
opens. 

2 Click to highlight a Backup Job that you want to Change, Remove, or Run: 

 Change. Click to edit the selected Backup Job. 

 Remove. Click to remove the selected Backup Job. 

 Run Now. Click to run the selected Backup Job immediately, without waiting for the 
scheduled time. 

3 To add a new Backup Job, click Add and complete the new Backup Job settings. 
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Examples 

The following are examples of how you might use the Backup Job Wizard and Manage 
Backup Jobs. 
 

Adding a Backup Job with the Backup Job Wizard 
If you need to save critical report files that you receive each day and currently store on your 
local drive. You can back up the files to another drive (for example, a mapped network drive) 
at a selected time each day. 

To add a backup job to the scheduler: 

1 Click Tools > Backup Files > Add a new backup job The Backup Wizard opens. 
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2 Browse to select the Files to backup location. When the Browse for Folder dialog 
opens, make sure that you select the appropriate tab (Local or Remote) for the files you 
want to back up. Click OK. 

 

3 Browse to select the Backup files to location. Again, when the Browse for Folder dialog 
opens, make sure that you select the appropriate tab (Local or Remote) for the files you 
want to back up, then click OK. 

4 If you want to have the backup files compressed to a .zip file, click ZIP file before 
backing up. 
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5 Click Next. The Backup Schedule wizard page displays. 

 

6 Select the Backup Frequency, Start Time, Perform this task options to schedule the 
backup, then click Next. The Backup Login wizard page displays. 

7 Enter your Windows Username, Password, and Password Confirmation for your user 
account. 

 Important:Make sure that you enter your Username, Password, and Password 
Confirmation. This provides the appropriate login information when the Backup Wizard 
starts to run a scheduled backup. 
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8 Click Next. The Manage Backup Jobs dialog opens and the new Backup Job displays in 
the list. The job will run at the next scheduled time, or you can click Run Now to run the 
task immediately. 

 

 
 

Changing a Backup Job with Manage Backup Jobs Dialog 
If you need to change settings for a currently scheduled backup job or add a new backup job, 
you can use Manage Backup Jobs options. 

To change, add, remove, or run a backup job: 
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1 Click Tools > Backup Files > Manage backup jobs The Manage Backup Jobs dialog 
opens. 

 

2 Click to highlight a Backup Job that you want to Change, Remove, or Run: 

 Change. Click to edit the selected Backup Job. 

 Remove. Click to remove the selected Backup Job. 

 Run Now. Click to run the selected Backup Job immediately, without waiting for the 
scheduled time. 

3 To add a new Backup Job, click Add and complete the new Backup Job settings. 
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CHAPTER 5 

Synchronizing Files and Folders 

In This Chapter 
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Exclusions (WS_FTP Professional)................................................................. 35

Inclusions (WS_FTP Professional) ................................................................. 37

Using the Synchronize Utility from the  Command Line...................... 39

The WS_FTP Synchronize Utility lets you synchronize (or “mirror”) files and file directories 
between local files, remote sites, network drives, and USB drives with minimal intervention. 

It lets you keep remote sites up-to-date by automatically uploading files which have changed 
while deleting files that have been removed from the master directory. This is especially 
useful for quickly and efficiently updating Web sites. 

This chapter provides an overview of the Synchronize Wizard, the Synchronize Utility and 
some examples of how you might use it. For detailed instructions on using the Synchronize 
Utility, start the Synchronize Utility and use the online Help. 
 
 

Using the Synchronize Wizard 

To start the Synchronize Wizard: 



1 Click Tools > Synchronize Files > Add a new synchronize task. The Synchronize 
Wizard opens. 
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2 Complete the Synchronize Wizard settings to create a new Synchronize project (control 
file). After you have completed the Synchronize Wizard, the synchronize settings display 
in the Synchronize Utility dialog. 

 

3 Click: 

 Execute to run the sync job immediately. 

 Schedule to open the Schedule utility and set times to run the sync job. 

 Save to save the sync job control file (.ctl) to store configuration options and settings 
for your synchronize jobs. This saves you from setting up a job each time you want to 
run it. 

 

Using the Synchronize Utility 

To start the Synchronize Utility: 
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 From the Tools menu, click Synchronize Files > Manage synchronize tasks. The 
Synchronize Utility opens. 
 
- OR - 
 

 From the Start menu, select Programs > Ipswitch WS_FTP 12 > Utilities > WS_FTP 
Synchronize Utility. 

The Synchronize dialog opens. 
 

Synchronize Dialog 
This is the main dialog of the WS_FTP Synchronize utility. When you use this dialog, you are 
creating a control file (.ctl) that will be used to perform the synchronization between the 
locations you identify. 

 Important: You cannot use OpenPGP mode when transferring files using the Synchronize 
Utility. You can transfer files that have already been OpenPGP-encrypted. 

The following are the dialog features: 

Toolbar buttons - The buttons control the various functions of the utility. 

 New - Click this button to start a new control file. 

 Open - Click this button to open a control file. 

 Save - Click this button to save your current settings as a control file.   

 Execute - Click this button to execute the synchronize job. If the Visual compare only 
(no action performed) option is selected, the Compare dialog shows the actions that will 
occur, but no transfers are made. 

 Schedule - Click this button to schedule the synchronize job through WS_FTP Scheduler. 

 Location1 and Location2 - The locations section is where you identify the directories 
that you want to synchronize. Click the Browse button to choose the directory for 
Location 1 and Location 2. Locations can be either a local or a remote site. 

 Modes - Select the mode you want Synchronize to operate in. 

 Synchronize Location 1 --> Location 2 - This mode updates Location 2 so that it 
includes all the files and subfolders of Location 1. 

 Synchronize Location 1 <-- Location 2 - This mode updates Location 1 so that it 
includes all the files and subfolders of Location 2. 

 Synchronize both Location 1 <--> Location 2 - This mode makes each location 
match the other by copying the newest version of Location 1 files to the Location 2 
and by copying the newest version of Location 2 files to Location 1. 

 Customized - Lets you set the actions you want the utility to perform when files are 
found with a specific status. 

 Status and Actions - Use these options when you have chosen Customized mode. The 
Status is the current state of the comparison, and the Action is what WS_FTP 
Synchronize will do when it finds an item with that status. 
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 Only on Loc1 - The file is only found in Location 1. 

 Newer on Loc1 - The file found in Location 1 is newer than the file found in Location 
2. 

 Same on both - The file found is the same in both locations. 

 Newer on Loc2 - The file found is newer on Location 2. 

 Only on Loc2 - The file is only found in Location 2. 

 Options. Select the options you want Sync to use. 

 Top level only. Select this option to have the locations synchronized on the top level 
only. All subdirectories will be ignored. 

 Show files/folders that won't be transferred. Select this option to have Sync display 
files with the No Action action code in the Compare dialog. 

 Visual compare only (no transfer). Select this option to have Sync populate the 
Compare dialog without executing the synchronize job. Once you are on the Com-
pare dialog, you can make changes to what tasks the job will perform. 

 Show FTP conversation in log. Select this option to show the FTP conversation in the 
generated log file, as well as the log pane on the Compare dialog. 

 Perform case-insensitive comparisons. Select this option to have Synchronize 
ignore differences in upper and lower case filenames. 

 Skip unmodified files. Select this option to have Synchronize compare files between 
the sites. The content is compared using the user selected File Integrity algorithm 
settings, click Help for more information. If the files are the same, no transfer occurs. If 
the files are not the same, they are updated to the target site(s).  

 Note:This option compares files before transferring them and therefore may reduce the 
transfer speed. 

 If ASCII Transfer Mode, OpenPGP, Compression Mode, or Append Mode transfer options are 
used, then the Skip unmodified files option is ignored. 

 Post Transfer Actions. See Post Transfer Actions (on page 34). 

 Exclusions. See Exclusions (on page 35). 

 Inclusions. See Inclusion Examples (on page 37). 
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Example 
The following is an example of how you might use the Synchronize Utility. 

 

When you click the Execute button, the control file named untitled.ctl (the name is displayed 
in the title bar for the dialogue) is executed according to the parameters set on the WS_FTP 
Synchronize Utility screen: 

 Synchronize makes a connection with the FTP site defined  
in the Location 2 box and logs on with the information stored on the site profile. 

 After the connection is made, the program navigates to the  
'/ipswitch' directory on the FTP site and the 'C:\WS_FTP Pro' directory on your local system 
as defined in the Location 1 box. 

 According to the options selected, Location 1 is to be updated with all files found in 
Location 2. 

 If you want to schedule this task to run on a regular basis, or at a certain time of day, click 
the Schedule button. The Schedule Item Properties dialog appears. Use this dialog to 
set the time, date, and frequency of the synchronize job. For more information on using 
the WS_FTP Scheduler, see “Using the Scheduler” on page 13. 
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 Since the Visual compare only option is selected, the transfers will not be executed, but 
the Compare dialog will appear comparing the two locations, and displaying potential 
actions to be taken by the utility. You can change the actions to be performed on this 
dialog, then click Execute to start the process. 

 

 

 
 

Using a Control File 

The Synchronize Utility uses control files (.ctl) to store configuration options and settings for 
your synchronize jobs. This saves you from having to set up a job each time you want to run 
it. 
 

To create a control file: 
To create a control file: 

1 Choose a directory for both Location 1 and Location 2. You can type in a local directory 
in either box, or click the Browse button to choose a remote site from a site profile, or a 
local folder. Click the Local tab on the Folder Selection dialog to choose a local folder.  
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 Note: You cannot use OpenPGP mode with the Synchronize Utility. If you use a OpenPGP-
enabled site with Synchronize, be aware that the files will not be encrypted. You can, 
however, transfer files that have already been OpenPGP encrypted. 

2 Select the options you want to use. 
3 Select the mode you want to execute. 
4 Review the Status and Actions that will perform and make any adjustments you need to 

make. If you make an adjustment, your status will be changed to Customized. 
5 Set up any post transfer actions (on page 34) you want to use. 
6 Identify any Inclusions (on page 37) or Exclusions (on page 35) you may have. 
7 Click Save to save the control file. 

You will now be able to use that control file anytime you use Synchronize. You can open and 
edit the control file when you want to change the Synchronize option. 
 

Executing Control Files Using HotSync (WS_FTP Professional) 
You can save a control file (.ctl) as an icon on your desktop and use the HotSync functionality 
to quickly synchronize files and folders. 

To set up a control file as a HotSync shortcut: 

1 Go through the process of creating a control file. 
2 Save the control file as a shortcut icon on your desktop. 
3 To initiate the Synchronize job, double-click the shortcut icon. The Synchronize Utility is 

displayed to show the progress of the synchronization. 

The files and folders are automatically synchronized with the location defined in the control 
file. 
 

Post Transfer Actions (WS_FTP Professional) 

Post transfer actions let you further process a source file after the transfer has been 
completed. If you are doing an upload, then the source file is in a local folder, and the post 
transfer action will be processed on the local machine. If you are doing a download, then the 
source file is in a remote folder, and the post transfer action will be processed on the remote 
server, if the server allows it.  

You can choose from the following actions: 

 None. No action taken on completion of file transfer. 

 Delete Source File(s). After the file transfer is completed, delete the source file(s) from 
the folder. 

 Rename Source File(s). After the file transfer is completed, rename the source file(s) in 
the folder. 

 Move Source File(s). After the file transfer is completed, move the source files to a 
specified folder. 
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 Rename and Move Source File(s). After the transfer has completed, renames the source 
file(s) using the Rename Mask (described above), then moves the files to the specified 
directory on the source machine. 

To delete a file after the transfer completes: 
1 For the Action option, select Delete Source File(s). 
2 For any files transferred in the specified Synchronization job, the source files will be 

deleted. 

To move files after the transfer completes: 
1 For the Action option, select Move Source File(s). The Folder box appears. 
2 Browse and select a folder to which the source files will be moved. 

When the transfer is completed, for any files transferred as part of the Synchronization 
job, the source file will be moved to the specified folder. 

To rename files after the transfer completes: 
1 For the Action option, select Rename Source File(s). The File Rename Mask appears. 
2 In the File Rename Mask, enter the characters and any macros to use in renaming the 

file. For information about what can be entered here, see Post Transfer Macros. 

When the transfer is completed, for any files transferred as part of the Synchronization 
job, the source file will be renamed using the file mask. 

To rename and move files after the transfer completes: 
1 For the Action option, select Rename Source File(s). The File Rename Mask and the the 

Folder box appear. 
2 In the File Rename Mask, enter the characters and any macros to use in renaming the 

file. For information about what can be entered here, see Post Transfer Macros. 
3 In the Folder box, browse and select a folder to which the source files will be moved. 

When the transfer is completed, for any files transferred as part of the Synchronization 
job, the source file will be renamed using the file mask and then moved to the specified 
folder. 

 

Exclusions (WS_FTP Professional) 

With the Exclusion system, you can enter a file name, file extension, or search string to have 
WS_FTP Synchronize ignore any files or folders that match the string. Wildcards (* and ?) can 
be used for unknown file names or several files of a similar name or type. 

 Note:  Exclusion settings are processed after Inclusion settings. 

To add an exclusion: 

1 In the Exclusions section of the dialog, click Add. The Exclusion dialog appears. 
2 Enter what you want to exclude in the Rules box. If you are using the Absolute location 

type, you can click the Browse button to select the file or folder. 
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Click here for examples of exclusion rules.  

3 In the Type box, select what type of item you want to apply the exclusion to. 

 Apply to files. Select to apply the exclusion to files only. 

 Apply to folders. Select to apply the exclusion to folders only. 

 Apply to both. Select to apply the exclusion to both files and folders. 

 Absolute location. Select to apply the exclusion to a specific file or folder in a specific 
location. 

4 Click OK to add the exclusion to the list. 
 

Exclusion Examples 
Here are a few examples of exclusions, followed by an explanation of each. 

Absolute file exclusions 

Exclusion rule: /mydir/*.exe 
Type: Absolute location 

This will exclude all .exe files in the mydir remote directory, but the path is taken from the 
root of the remote system. 

Exclusion rule: c:\mydir\*.exe 
Type: Absolute location 

This will exclude all .exe files in the c:\mydir local directory. 

Exclusion rule: /mydir/nextdir/myfil?.* 
Type: Absolute location 

This will exclude any file beginning with myfil with one arbitrary character and any extension 
in the directory /mydir/nextdir. 

Absolute directory exclusion 

Exclusion rule: /m?dir 
Type: Absolute location 

This will exclude all directories that match the mask m?dir, but the path is taken from the root 
of the file system. The ? is a substitute for any single character. 

Exclusion rule: c:\m?dir 
Type: Absolute location 

This will exclude all directories on the c: drive that match the mask m?dir. The ? is a substitute 
for any single character. 

Relative directory exclusions 

Exclusion rule: mydir 
Type: Apply to folders 
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This will exclude any directory named mydir anywhere in the file system. 

Exclusion rule: m*ir 
Type: Apply to folders 

This will exclude any directory that matches the mask m*ir from anywhere in the file system. 
The * means that the name can have any number and value of character in between the "m" 
and the "ir." 

Relative file exclusion 

Exclusion rule: mydir\*.exe 
Type: Apply to files 

This will exclude any .exe files in any directory named mydir anywhere in the file system. 

Relative file/folder exclusion 

Exclusion rule: ~* 
Type: Apply to both 

This will exclude any file or folder starting with the ~ character, anywhere in the file system. 
 

Inclusions (WS_FTP Professional) 

With the Inclusion system, you can enter a file name, file extension, or search string to have 
WS_FTP Synchronize include any files or folders that match the string. Wildcards (* and ?) can 
be used for unknown file names or several files of a similar name or type. 

 Note: Inclusion settings are processed before Exclusion settings. 

To add an inclusion: 

1 In the Inclusions section of the dialog, click Add. The Inclusion dialog appears. 
2 Enter what you want to include in the Rules box. If you use the Absolute location type, 

click Browse to select the file or folder. 

Click for examples of inclusion rules.  

3 In the Type box, select what type of item you want to apply the inclusion to: 

 Apply to files. Select to apply the inclusion to files only. 

 Apply to folders. Select to apply the inclusion to folders only. 

 Apply to both. Select to apply the inclusion to both files and folders. 

 Absolute location. Select to apply the inclusion to a specific file or folder in a specific 
location. 

4 Click OK to add the inclusion to the list. 
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Inclusion Examples 
Here are a few examples of inclusions, followed by an explanation of each. 

Absolute file inclusions 

Inclusion rule: /mydir/*.exe 

Type: Absolute location 

This will include all .exe files in the mydir remote directory, but the path is taken from the root 
of the remote system. 

Inclusion rule:c:\mydir\*.exe 

Type: Absolute location 

This will include all .exe files in the c:\mydir local directory. 

Inclusion rule: /mydir/nextdir/myfil?.* 

Type: Absolute location 

This will include any file beginning with myfil with one arbitrary character and any extension 
in the directory /mydir/nextdir. 

 

Absolute directory inclusion 

Inclusion rule: /m?dir 

Type: Absolute location 

This will include all directories that match the mask m?dir, but the path is taken from the root 
of the file system. The ? is a substitute for any single character. 

Inclusion rule: c:\m?dir 

Type: Absolute location 

This will include all directories on the c: drive that match the mask m?dir. The ? is a substitute 
for any single character. 

 

Relative directory inclusions 

Inclusion rule: mydir 

Type: Apply to folders 

This will include any directory named mydir anywhere in the file system. 
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Inclusion rule: m*ir 

Type: Apply to folders 

This will include any directory that matches the mask m*ir from anywhere in the file system. 
The * means that the name can have any number and value of character in between the "m" 
and the "ir." 

 

Relative file inclusion 

Inclusion rule: mydir\*.exe 

Type: Apply to files 

This will include any .exe files in any directory named mydir anywhere in the file system. 

 

Relative file/folder inclusion 

Inclusion rule: ~* 

Type: Apply to both 

This will include any file or folder starting with the ~ character, anywhere in the file system. 
 

Using the Synchronize Utility from the  Command 
Line 

The Synchronize Utility has been designed to be a command line utility that can be sched-
uled and run unattended. To do this, you must first use the user interface to set up and test a 
control file for the synchronization task. 

After this has been done, you can run the Synchronize Utility directly from the command line 
by using the following syntax: 

You can also add this command to a batch file and schedule it using WS_FTP Scheduler. For 
more information on using command line batch files, see Using a Batch File (on page 64). For 
more information on using the WS_FTP Scheduler, see Using the Scheduler (on page 15). 

 
 

  39 





 
 

  41 

CHAPTER 6 

Script Utility 

In This Chapter 
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Running a Script from the Script Utility...................................................... 43
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The WS_FTP Script Utility lets you group any number of file transfer tasks into a script that can 
be executed with one action. This can be especially useful for file transfers that you do 
repeatedly. 

This chapter provides an overview of the Script Utility and some examples of how you might 
use it. For detailed instructions on using the Script Utility, start the Script Utility and use its 
online Help. 

Using scripts, you can: 

 Connect to FTP sites 

 Upload or download files 

 Set the transfer mode 

 Make, delete, and rename folders 

 Delete and rename files 

 After the transfer has completed: delete, rename, move source files 

 Execute a DOS command 

Scripts can also have some limited flow control. They can: 

 Check for the success or failure of the previous command 

 Jump to another point in the script if either success or  
failure is detected 

Suppose you post weekly reports on your company's server for your co-workers in other cities 
to download. Let's assume you place the current week's reports in a folder named Current. 
You could create a script that: 

 Changes the name of last week's Current folder to Prior. 

 Creates a new folder named Current. 

 Uploads your current weekly reports to the Current folder. 

You can also create scripts for downloads that you do repeatedly. 
 
 



Starting the Script Utility (WS_FTP Professional) 

You can start the WS_FTP Script Utility in the following ways: 

 Select Start > Programs > Ipswitch WS_FTP 12 > Utilities > WS_FTP Script Utility. 

 With WS_FTP open, select Tools > Script Utility. 
 

Writing and Debugging Scripts 

To write and/or debug a script, start the Script Utility. 

The Script Editor/Debugger window appears. 

 

For a complete list of scripting commands, see “Script Command Reference” in the online 
help. 
 

Executing Scripts 

You can execute scripts from either the Command Prompt or from the Script Utility itself. 
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Executing a Script from the Command Prompt 
Go to the Command Prompt and type ftpscrpt followed by the appropriate command line 
parameters. 

For example: 

There are other parameters you can use with the ftpscrpt command. For detailed information, 
go to the Script Utility online Help and see “Executing Scripts.” 

To be able to run a script from any location on your hard disk, we recommend that you place 
the Script Utility folder in the Path statement in your Autoexec.bat file - if you are running 
Microsoft Windows XP. If you're using Windows 2003, add the WS_FTP Professional folder to 
the path variable in the System Environment. 
 

Running a Script from the Script Utility 

To run a script from the Script Utility, start the utility, open the script, then click Run. 
 

Example 

In the following example, the script executes the following sequence of commands: 

1 Turns on the Trace command to send detailed information to  
the transfertrace.txt file. 

2 Logs onto the server with the user name wsansbury. 
3 Logs onto the server with the password yomhashoah. 
4 Connects to the FTP server ftp.mywebprovider.com. 
5 Changes the remote directory to /user/wsansbury/images. 
6 Changes the local directory to C:\My Documents\My Pictures 
7 If the MGET is successful, the script executes the FILEDELETE label. 
8 If the MGET fails, the script executes the DISCONNECT label. 
9 All files ending in .jpg are copied from the remote directory to the local directory. 
10 This line identifies the FILEDELETE label. 
11 All files ending in .jpg are deleted from the /user/wsansbury/images remote folder. 
12 This line identifies the DISCONNECT label. 
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13 CLOSE disconnects from the FTP server 
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CHAPTER 7 

Search Utilities (local and remote) 

In This Chapter 
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Using Remote Search........................................................................................ 50

Examples................................................................................................................ 52

WS_FTP lets you search local files or a remote site for files that match your search criteria. 
After the files are found, you can transfer the files to the appropriate local or remote location. 

Remote search is especially useful if you are looking for files on a large, complex FTP site. 

Local search helps you find files or file content on your computer. The Local search provides 
two types of search capabilities: 

 File content. Use the Google™ Desktop or Copernic Desktop Search™ to search for 
content within files on your computer. 

 File name. Use the Windows® Desktop Search to search for files by file name on your 
computer. 

This chapter provides an overview of the local and remote search utilities and some examples 
of how you can use them. For more information, see the online Help. 
 
 



Using Local Search 

Use the Local Files Search to search for files by file name or search for file content on your 
computer. 

 

To find files on your computer (searching for file names): 
1 Make sure that the Local Desktop Search is enabled in the Program Options, under 

Tools > Options > General, in the Desktop Search Technology box click Local 
Desktop Search, then click OK. 
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2 From the Tools menu, click Search > Local Files. The Search tab opens in the local 
connection window. 

 

3 In the Search box, enter the file name or part of the file name you want to find. You can 
use wildcard characters such as * and ?.  
For additional search options, click Options. The Search Options dialog box opens. Click 
Help for more information about the Search Options dialog. 

 

4 Click OK. The search results are displayed in the search results list. 
5 Select the file that you want to upload from the search results. Upload the files to the 

FTP server you select. For more information about search result transfer options, see the 
following section Using the Local Search Results (on page 49). 

 Only a single file at a time can be selected and transferred from the search results. 

You can also search for content within files on your computer with the Google™ Desktop 
Search or Copernic Desktop Search™ options. 

 Copernic or Google Desktop Search utility must be installed to search for file content using 
their integrated search engine from the Ipswitch WS_FTP client. If the desktop search utility 
is installed on your computer, it will appear in the Program Options > General > Desktop 
Search Technology list. 
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 To find file content in files on your computer: 
1 Make sure the Local Desktop Search is enabled in the Program Options, under Tools > 

Options > General, in the Desktop Search Technology box click your preferred 
desktop search engine, Google Desktop Search or Copernic Desktop Search, then 
click OK. 

 

 If the Google Desktop Search or the Copernic Desktop Search utility is installed on your 
computer, it appears in the Desktop Search Technology list. 

2 From the Tools menu, click Search > Local Files. The Search tab opens in the local 
connection window. 

 

3 In the Search box, enter the file content search criteria for the text you want to find. 

 The Google Desktop Search or the Copernic Desktop Search parameters are determined 
by each search utility. Refer to the Help information to learn about using each utility's unique 
search parameter requirements. 

 The search Options button is disabled when the Google Desktop Search or the Copernic 
Desktop Search utility is installed and enabled. If the desktop search utility is installed on 
your computer, it appears in the Tools > Options > General > Desktop Search Technology 
list. 

4 Click OK. The search results are displayed in the search results list below. 
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5 Select the file that you want to upload from the search results. Upload the files to the 
FTP server you select. For more information about search result transfer options, see the 
following section Using the Local Search Results (on page 49). 

 Only a single file at a time can be selected and transferred from the search results. 

 

Using the Local Search Results 
After you locate a file on a local site, you can right-click, then click: 

 Upload using the WS_FTP Upload Wizard. 

 Send to [favorites site name] (HotDrop file) to transfer the file to the HotDrop's 
associated remote site. 

 WS_FTP Transfer > Compress and Transfer as [filename.zip] to transfer the file to the 
active remote site. 

 WS_FTP Transfer > Encrypt and Transfer to use an encryption key to encrypt a file 
before transfer. 

 WS_FTP Transfer > Sign and Transfer to add your digital signature to a file. By adding 
your digital signature, you provide a higher degree of confidence in the file integrity for 
those downloading your files. 

 WS_FTP Transfer > Encrypt, Sign and Transfer to first encrypt a file, then to add your 
digital signature. 

 Send to Scheduler to open the Schedule Properties dialog and schedule a file transfer. 
 

To transfer a file: 
1 In the search results dialog box, select the file you want to transfer, then select one of 

the short cut (right-click) menu options described above. 
2 Select the site or folder to upload the file to. 
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Using Remote Search 

Use the Remote Files search to find files by file name on a remote site. 

 

To find files on an FTP site: 
1 Start the Find Utility by doing one of the following: 

 From the Tools menu, click Search > Remote Sites. The WS_FTP Find Utility dialog 
opens. 
 
- OR - 

 From the Start menu, select Programs > Ipswitch WS_FTP 12 >  
Utilities > WS_FTP Find Utility. 

 

2 Use the Look in list box to select a site previously searched or click the Browse button 
to specify the site to which you will connect and search. You can also type in a host 
name or FTP URL. 
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3 Enter your search criteria. You can search by name, date modified, size, or any 
combination of the three. 

4 Click Find Now. The Find Utility connects to the FTP site and searches according to your 
criteria. 

For example, if you search the Ipswitch FTP site for a file named wsftp80.pdf, the following 
results are displayed. 

 

 
 

Using the Remote Search Results 
After you locate a file on a remote site, you can: 

 Transfer it. 

 Schedule it for transfer at a later time, by selecting Send to Scheduler from the right-
mouse menu. 

 

To transfer a file: 
1 In the dialog box above, select the file you want to transfer, and select Transfer from 

the right-mouse menu. A browse window appears. 
2 Select the folder to which you want to download the file. 
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Examples 

The following are examples of different types of searches. 
 

Finding a File When You Are Not Sure of Its Name 
The example below shows how to search for a file when you are not sure of the correct full 
name. In this case, the name begins with ws_f, but the rest of the name is unknown. The * at 
the end is a “wildcard” that takes the place of the missing characters. When this search is run, 
the Find Utility locates every file on the site that begins with ws_f. 
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The results of the search are shown below. 

 

You can also use wildcard characters (* and ?) at the beginning of  
a name if you are unsure about the beginning characters. For example, searching for *.exe 
returns all files ending with the .exe file extension. 
 

Finding a File Modified During a Specific Time Period 
To search for a file modified during a specific time period, click the Date Modified tab and set 
the options you need. In the example below, the WS_FTP Find Utility will search for all files 
modified between October 26, 2003 and February 08, 2005. 
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Finding a File in a Particular Folder 
If you know the name of the folder in which the file you are looking for is stored, you can 
narrow your search by having the Find Utility look only in that folder. 

 

To locate a particular folder: 
1 Click the Browse button next to the Look In field to connect to the selected site and 

display a list of the available folders. 

 

2 Select the folder that you want to search. 
3 Click OK. The Look In box is filled in with the path of the selected folder. 
4 Click Find Now to search through the files in that folder. 
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Finding a File Smaller Than a Certain Size 
If you want to limit the size of the files found in a given search, enter the FTP site and file 
name on the Name & Location tab, then click the Advanced tab. 

 

In the Size is box, you can select At least or At Most, then enter the file size in kilobytes in the 
KB box. 
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You can use the command line from the command prompt to run the WS_FTP interface. 

When you use the command line, you are actually running a subset of the functionality of the 
WS_FTP interface. Using the command line, you can: 

 Upload and download files 

 Specify ASCII or binary transfer mode 

 Convert file names to lowercase when uploading 

 Set up pre-scheduled transfers 

 Create batch files that will handle multiple commands 

 Use post transfer actions to delete, rename, or move source files after the transfer has 
completed 

 Note:Though some command lines in this chapter may wrap across multiple lines, all 
command lines should be entered on one line. 

 
 

Basic Command Line Syntax 

The following illustrates the correct command line syntax, broken down by argument type. 

wsftppro -s <source> -d <destination>

For example, a command using this format would look like this: 
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wsftppro -s local:c:\tartan.bmp -d robert!border:/pub/tartan.bmp

The section below shows the breakdown of that command into the parts illustrated above. 
The command name wsftppro must always be placed in the beginning of the command. 

 Note:So you can use the command line from any location on your hard disk, we recommend 
that you place the WS_FTP folder in the Path statement in your Autoexec.bat file, if you are 
running Windows 2000, Windows 2003, or Windows XP. Otherwise, change to your WS_FTP 
folder when you use the commands. 

  
 

Site Information 
wsftppro -s local:c:\tartan.bmp -d robert!border:/pub/tartan.bmp

If you use a configured site from the command line, WS_FTP uses the User ID, Password, and 
Account Name you saved in the site configuration. To use a configured site, enter the site 
name in front of the remote directory (which can be either the source or the destination). If 
the configured site is stored in a folder, you must also enter the folder name. Separate the 
folder name from the site name by using the ! symbol (sitefolder!sitename). In the example 
above, we use the border site configuration stored in the robert folder. 

If you have saved a password with the site, WS_FTP logs you on using the saved password. If 
you have not saved a password with the site, you can enter it in the command line by using 
the -w argument. 

For example: 

wsftppro -u username -w password -s robert!border:/pub/tartan.bmp -d 
local:c:\armstrong\

If you have saved an account name in the site configuration, the command line logs you on 
using the saved account name. If you have not saved an account name, you can use the -c 
argument to specify the account name when you enter the command line. For example: 

wsftppro -c account -s robert!border:/pub/tartan.bmp -d 
local:c:\armstrong\

If you do not use a configured site profile, you must put the IP address, URL, or host name in 
the source or destination argument to connect to that site. See the Transfer Source and 
Transfer Destination sections for examples of command line commands that use this. 
 

Transfer Source 
wsftppro  -s local:c:\tartan.bmp -d robert!border:/pub/tartan.bmp 

The transfer source argument begins with the -s argument, followed by the label for the 
source, and the path to the item or items being transferred. If the source of the transfer is 
your local system, the source label is local. If you are doing a download, the source label is 
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either the site folder!site name or the IP address, FTP URL, or Host name of the remote site. 
For example: 

wsftppro -s robert!border:/pub/tartan.bmp -d local:c:\tartan.bmp 

or 

wsftppro -s ftp://username:password@border.ipswitch.com/pub/tartan.bmp -d  
local:c:\armstrong\ 

or 

wsftppro -u username -p password -s 156.21.50.78:/pub/tartan.bmp -d local:c:\ 
 

Transfer Destination 
wsftppro -s local:c:\tartan.bmp -d robert!border:/pub/tartan.bmp

The transfer destination argument begins with the -d argument, followed by the label for the 
destination, and the path to where files are being transferred to. If the destination is your 
local system, the destination label is local. If you are doing an upload, the destination label is 
either the site folder!site name (as in the example above) or the IP address, FTP URL, or Host 
name of the FTP site. For example: 

wsftppro -s local:c:\tartan.bmp -d 
ftp://username:password@border.ipswitch.com/pub/tartan.bmp 

or 

wsftppro -s local:c:\tartan.bmp -u username -w password -d 
156.21.50.78:/pub/tartan.bmp
 

File Transfer Options 

Uploading Files 
To upload a file, use the basic command syntax with the file or files you want to upload 
identified in the source argument. For example; if you want to copy the file tartan.bmp from 
the armstrong folder on your C: drive and place it in the /pub/ folder on the site identified in 
the border site profile use: 

wsftppro -s local:c:\armstrong\tartan.bmp -d 
robert!border:/pub/tartan.bmp

or 

wsftppro -s local:c:\armstrong\tartan.bmp -d robert!border:/pub/ 
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Notice that the second option omits the file name from the destination location. You can do 
this when you want the transferred file to have the same name as it does in the source loca-
tion. However, note that you must enter the trailing slash after the destination folder in order 
for this to work. 
 

Downloading Files 
Use the same command syntax as described above for downloading files, except that, the 
source of the transfer is the remote system instead of your local system. 

wsftppro -s robert!border:/pub/tartan.bmp -d 
local:c:\armstrong\tartan.bmp

In the example above, you are connecting to the remote system using the border site profile 
and downloading the tartan.bmp file to the armstrong folder on your C: drive. 
 

Renaming Files 
To rename a file during the upload, enter a new file name after the destination folder. For 
example, to upload the Tag.doc file and rename it NewTag.doc on the FTP site, type: 

wsftppro -s local:c:\sports\Tag.doc -d 
robert!border:/pub/drop/NewTag.doc
 

Adding Current Date and Time Information to File Names 
To automatically add the current date and time information during the upload, enter the 
%date attribute after the file name in the destination folder. For example, to include the date 
and time on the Tag.doc file on the FTP site, type: 

wsftppro -s local:c:\sports\Tag.doc -d 
robert!border:/pub/drop/Tag%date.doc 

The date and time will be added in the following format: 

YYYYMMDD.HH:MM:SS 

For example, the file in the example (Tag.doc), if transferred on Feb 4, 2009 at 11:00 AM, 
would be renamed as:  

Tag20090211:00:00.doc 
 

Compressing Files 
To compress a file to a .zip file during the upload, enter the -compress argument, type: 

wsftppro -compress -s local:c:\sports\Tag.doc -d 
robert!border:/pub/drop/Tag.doc
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Transferring multiple files from the same location 
If all the files you want to transfer are in the same folder, you can use the wildcard characters, 
* and ?, in the file name. For example, if you want to upload all of the files in C:\Sports\ use: 

wsftppro -s local:c:\sports\*.* -d robert!border:/pub/drop/ 

Or, to transfer all .doc files in the same folder, enter: 

wsftppro -s local:c:\sports\*.doc -d robert!border:/pub/drop/ 

To transfer multiple files not in the same folder, see Multiple Folders or Commands (on page 
65). 
 

Converting File Names to Lower Case 
When uploading files, you can have WS_FTP convert file names to lower case by adding the -
lower argument at the end of the command line. For example, if the file you want to transfer 
is named Tag.doc, WS_FTP can upload it as tag.doc by using: 

wsftppro -s local:c:\sports\Tag.doc -d robert!border:/pub/drop/ -lower
 

Post Transfer Actions 
Post transfer actions let you further process a source file after the transfer has been 
completed. If you are doing an upload, then the source file is in a local folder, and the post 
transfer action will be processed on the local machine. If you are doing a download, then the 
source file is in a remote folder, and the post transfer action will be processed on the remote 
server, if the server allows it.  

The following post transfer actions are available from the command line: 

 -delete  

After the file transfer is completed, delete the source file(s) from the folder. 

 -rename [Rename Mask] 

where Rename Mask includes the characters and any macros (on page 62) to use in 
renaming the file. 

After the file transfer is completed, rename the source file(s) in the folder. 

 -move [directory] 

After the transfer has completed, moves the source file(s) to the specified directory on the 
source machine. 

 

Deleting source files after transfer 

wsftppro -s local:c:\sports\*.doc -d robert!border:/pub/drop/ -delete 

When the transfer is complete, the source files (c:\sports\*.doc) will be deleted. 
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Renaming source files after transfer has completed: 

wsftppro -s local:c:\sports\*.doc -d robert!border:/pub/drop/ -rename 
[dd][mm][yy][hh][OnlyName].[OnlyExt] 

When the transfer is complete, the source files (c:\sports\*.doc) will be renamed, which if 
transferred on Jan 15, 2009 at 11:00 am, will be renamed with the date and time prefixed to 
the original file name and extension; for example: c:\sports\tartan.doc would be renamed 
c:\sports\01150911tartan.doc 

Moving source files after transfer has completed: 

wsftppro -s local:c:\sports\*.doc -d robert!border:/pub/drop/ -move 
c:\sports\archive\

When the transfer is complete, the source files (c:\sports\*.doc) will be moved to the 
directory: c:\sports\archive\ 

Renaming and moving source files after the transfer has completed: 

wsftppro -s local:c:\sports\*.doc -d robert!border:/pub/drop/ -rename 
[dd][mm][yy][hh][OnlyName].[OnlyExt] -move c:\sports\archive\ 

When the transfer is complete, the source files (c:\sports\*.doc) will be renamed, which if 
transferred on Jan 15, 2009 at 11:00 am, will be renamed with the date and time prefixed to 
the original file name and extension; for example: c:\sports\tartan.doc would be renamed 
c:\sports\01150911tartan.doc. The source files are then moved to the directory: 
c:\sports\archive\ 

 
 

Post Transfer Rename Macros 
The Rename Mask lets you create a mask, or rule, that WS_FTP will use to rename a file, after 
the file transfer completes. The file name of the original file is compared to the mask, and the 
new file name is generated. In this mask, you can enter any data you want to include in the 
file name, such as a store number, or some other identifier. 

You can also use macros, which are variables that you can use to add data to the file name, for 
example the date and time the file was transferred file. You can select from the following 
macros to create the File Rename Mask.  

 [OnlyName] - The original file name minus the extension and the period (between name 
and extension). To retain the original file name, you must use this macro. 

 [OnlyExt] - The original file name extension. To retain the original file name extension, 
you must use this macro. 

 If you want to retain the original file name and extension, you would enter 
[OnlyName].[OnlyExt]. Whether or not you retain the original name or extension, you need 
to include the period between the file name and extension. 
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 [H] - HOUR; minimal representation, 24-hour clock. Example: "7" 

 [HH]- HOUR; two-digit representation, 24-hour clock. Example: "07" 

 [TT] - MINUTE; two-digit representation. Example: "07" 

 [SS] - SECOND; two-digit representation. Example: "07" 

 [MM] - MONTH; two-digit numeric representation. Example: "07" 

 [DD] - DAY-OF-MONTH; two-digit representation. Example: "07"  

 [YY] - YEAR; two-digit representation. Example: "02"  

 [YYYY] - YEAR; four-digit representation. Example: "2002"  

For example, if you want to upload a file named inventory.pgp, then rename the file in the 
destination directory with the upload date and time, you could use macros to create the 
following File Rename Mask:  

[mm][dd][yy][hh][OnlyName].[OnlyExt] 

which, if transferred on January 15, 2009 at 7:00 AM, would rename the file to: 
01150907inventory.pgp 

 You do have to enter the period that separates the file name from the extension.  

 

 
 

File Transfer Modes 
You can transfer files in binary mode or in ASCII mode. We recommend using binary mode to 
transfer all files unless you know the file contains only text, then you are able to use ASCII 
mode. 

To specify the transfer mode, you use the -binary or -ascii argument at the end of the 
command string. 

When you do not specify the transfer mode in the command line, WS_FTP transfers the file in 
whatever file transfer mode is the default in the WS_FTP interface. Therefore, if you plan on 
using the command line more than just occasionally, set the Startup Transfer Mode to Auto 
Detect. 
 

Transferring Files and Folders with Spaces in the 
Name 

If you are transferring a file whose name has spaces  in it, you have two options. You can 
enclose that portion of the command line in quotes, or use the short name of the file (as 
shown in the Dir listing you get from the command prompt.) 
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Enclosing the Command Line in Quotes 
If the file you want to transfer is named my tartan.bmp, use: 

wsftppro -s "local:c:\armstrong\my tartan.bmp" -d "robert!border:/pub/my 
tartan.bmp"
 

Using the Short Name 
If the file you want to transfer is named my tartan.bmp in Windows, but appears as 
my~1.bmp when you use the Dir command at the command prompt, you can use the short 
file name to transfer the file (as shown in the Dir listing you get from the command prompt). 
To do this (using the first example in this chapter), enter: 

wsftppro -s local:c:\armstrong\my~1.bmp -d robert!border:/pub/my~1.bmp
 

Using a Batch File 

 Note:You cannot run two batch files at the same time. 

Instead of typing the command at the command prompt, you may find it more expedient to 
enter the command line into a batch file (a text file with the file extension .bat). This makes it 
easier to correct mistakes and to run the same command again. 

You run the command by invoking the .bat file at the command prompt, double-clicking the 
icon for the .bat file from within Windows, or running the .bat file from another application 
(such as WS_FTP Scheduler). 

Here is a batch file (for the example at the beginning of this chapter) as viewed from a 
Windows text editor: 

  

When you run the batch file named tartan.bat, WS_FTP uploads the tartan.bmp file to the 
border FTP site. 

Note that using a batch file involves placing the command name wsftppro at the beginning 
of each line in the file. Since each instance of the command name starts the WS_FTP 
application (and connects to the remote site), you would only use a batch file to work with 
one command at a time. If, on the other hand, you want to issue a group of commands, follow 
the procedure in Multiple Folders or Commands (on page 65). 

Remember that if a file name has a space in it, you must enclose that entire argument in 
quotes. 
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Multiple Folders or Commands 

To transfer files to or from multiple source or destination folders, or to issue multiple com-
mands, use the -m argument followed by the name of a text file that contains the commands. 
To transfer files from several locations on the hard disk described in the first example in this 
chapter, enter (at the command prompt or in a batch file) something like: 

wsftppro -m xferall.txt 

where the content of xferall.txt (as viewed in Windows Notepad) is: 

 

Note that: 

 The command name wsftppro must not appear in the text file 

 Each line of text must contain only one command line. 

 Each command line can contain any of the arguments described in  
this chapter. 

 If a file or folder name has a space in it, you must enclose that entire argument in quotes. 
 

Pre-scheduled Transfers ("Automated Transfers") 

You can use the command line to schedule transfers that you want to run automatically. To 
do this, you create a batch file as described above, and then run the batch file using WS_FTP 
Scheduler. For more information, see Scheduler Utility (on page 15). 

When you use the command line to perform a pre-scheduled transfer, you may use the -
quiet parameter to prevent WS_FTP from displaying a message box if an error occurs. This is 
particularly useful for avoiding a situation in which WS_FTP might otherwise prompt for user 
input, such as clicking the OK button in an error message. This way, you can pre-schedule 
transfers to run automatically when you're not at your computer. (When you return to the 
computer, you can always check the log file to see if there were any problems.) 

To use the examples shown previously, you could do a pre-scheduled transfer by creating the 
following batch file: 
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as well as the following text file: 

 

Then, you could have the Scheduler run the auto10.bat file at 10:00 PM each night. 

Remember that if a file name has a space in it, you must enclose that entire argument in 
quotes. 
 

Extras 

Here are a few more arguments and uses of the command line that some users have found 
helpful. These are listed below. 

To have WS_FTP display a dialog box that prompts you for the command line, type: wsftppro 
-ask 

To launch the WS_FTP interface and default to the border site inside a folder named robert: 
wsftppro -p robert!border 

To prevent WS_FTP from displaying error messages, use the -quiet argument. This is useful if 
you want to do automated transfers when no one is around to respond to a message. An 
example: 

wsftppro -s local:c:\armstrong\tartan.bmp -d 
robert!border:/pub/tartan.bmp -quiet
 

Summary of Arguments 

Here is a list of all arguments you can use in the command line. 

Arguments (alphabetical) When to use Important restrictions 

-ascii Use -ascii when transferring 
text files. 

 

-binary Use -binary when transferring 
non-text files such as 
executable programs, word 
processing documents, and so 
on. 
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-c account Use -c to work with sites that 
require an account for the user 
to log in, or to access partitions. 
account is the name of your 
account on the remote site. 

If provided, overrides the account 
in the site configuration. 

-compress Use -compress to turn files into 
a .zip compressed file. 

The -compress option overrides 
post transfer actions. Post transfer 
actions will not be run if the 
compress option is also specified.

 

-d path_and_filename Use -d to indicate the 
destination path and desired 
file name of the file you want to 
upload or download. 

You must specify one of the 
following: 

-d local: 

-d folder!profile 

-d ip address: 

-d ftp://address 

-%date Use -%date to add a date and 
time stamp as part of the file 
name. 

 

-delete Use -delete when you want to 
delete the source files, after the 
transfer has been completed. 

If the transfer is a download, you 
can delete files on the remote 
server only if the server allows it. 

-lower Use -lower to have WS_FTP 
convert file names to lower 
case letters when you transfer 
from your PC to a remote site. 

If you use the  
-lower argument, it must be at 
the very end of the command. 

-m text_file Use -m to do transfers that 
involve multiple source 
locations, multiple destinations, 
or multiple commands. text_file
is the name of the file that 
contains the commands. 

 

-move directory path Use -move when you want to 
move the source files to 
another directory, after the 
transfer has completed. 

If the transfer is a download, you 
can move files on the remote 
server only if the server allows it. 

-quiet Use -quiet to suppress pop-up 
dialogs. The primary use is to 
suppress a logon request for 
silent installs. Error messages 
are logged to the log file. They 
are never sent to the screen. 

 

-rename [Rename Mask] Use -rename when you want to 
rename the source files, after 
the transfer has completed. 
See Rename mask macros (on 
page 62) for more information.

If the transfer is a download, you 
can rename files on the remote 
server only if the server allows it. 
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-s path_and_filename Use -s to indicate the source 
path and file name of the file 
you want to upload or 
download. 

 

-u userID Specifies a user ID. Use -u to use 
sign on using the userID. 

If provided, overrides the user ID 
in the site configuration. 

-w password Use -w to identify password as 
the password to use to connect 
to the ftp site. 

If provided, overrides the 
password in the site con-
figuration. 

 
 

Return Codes 

Messages returned in response to a wsftppro command can include the following codes: 

 

Return Code Description 

0 Success 

1 Failed to load site 

2 Source parsing error 

3 Destination parsing error 

4 Source and destination ae local 

5 Failed to connect with source 

6 Failed to connect with destination 

7 Failed to get source folder 

8 Failed to get destination folder 

9 No source filename 

10 Destination filename specified with wild cards in the source 

11 Wildcards in the destination 

12 Source file not found 

13 Transfer failed 

14 No command line specified (starts the application user interface) 

15 No command file - failed to open reference file 

16 Failed to initialize 
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APPENDIX A 

Textual Error Messages 
This Appendix lists common textual error messages. Each error message is followed by an 
explanation of the error, and some possible workarounds or solutions, if any exist. 

Some of these error messages are returned by the FTP protocol and will appear in the 
Connection Log, preceded by a three-digit reply code. 

Others of these textual error messages may appear in dialog boxes generated by WS_FTP or 
your operating system. 

For more information, see the KnowledgeBase on the Ipswitch web site at:  
http://www.ipswitchft.com/support/index.asp. 
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"Blocking call canceled" 

There are several possible causes for this problem. Try these tests in the order shown: 

1 Disconnect from the FTP site if you are currently connected to it. Then turn on passive 
mode. To do this: 

 Select Tools > Site Manager. 

 Select the site, then click Edit. 

In the Site Options, select Advanced, then select Use passive mode for data 
connections. 

After you have done this, try reconnecting to the site. 

2 If you still receive this error message, set the network timeout for the site to 120 in the 
interface: 

 Select Tools > Site Manager. 

 Select the site, then click Edit. 

 In the Site Options, select Advanced, then enter 120 or higher for the Network 
Timeout. 

3 If you still receive this error after making the above changes, try the command line FTP 
(not the WS_FTP Command Line) and see if you can connect and how long it takes. After 
you know how long it takes to connect, enter this time into the Network Timeout 
setting on the Advanced dialog of the site options as described above. 

4 If you still cannot connect please contact the FTP server administrator for assistance. 
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"Connection refused" or "Connection closed by 
remote" 

Either the host is not running an FTP server program, or the FTP site is accepting connections 
only from certain clients, or there is a conflict within your network. See page 59 and follow 
steps 3 and 4. 
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"Disk quota exceeded" 

The disk quota is not determined by WS_FTP; it exists on the FTP site. You can either delete 
some files on the site to make room for your upload (if you have permission) or get more 
space from the site administrator. 
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"File too large to download" 

This message is coming from the FTP site that you are connected to.  
This site has a limit on how large a file you can download. 
 

"Logon failure; Quitting." 

The FTP site is not recognizing or accepting your user ID and/or password. Contact the FTP 
site administrator to verify that you are using the correct User ID and password. 
 

"MDTM" 

The current FTP site does not support Month-Day-Time-Marking; this means that after the file 
was uploaded, WS_FTP attempted to preserve the date and time, but the FTP site does not 
support this feature. However, the files will transfer correctly. Note that this is not a fatal error, 
even though it displays in red. 

You can disable this option by selecting Preserve file time on upload (MDTM support 
required) on Site Properties > Session. 
 

"User access denied" 

The error “530 user access denied” indicates that you are not properly logged on to the 
server. Make sure the information on the Host Info dialog of site options is correct. Common 
problems are spaces, case sensitive entries, or incorrect user name or password. If you are 
unsure whether or not you are using the correct user name and password, contact the FTP  
site administrator. 

Most FTP sites support anonymous logins where you do not have to have an actual account 
on the FTP site in order to download files; the user ID is the word Anonymous and the pass-
word is your e-mail address. To test this, try connecting to the Ipswitch FTP site 
(ftp.ipswitch.com) using the user ID “Anonymous.” 

If you do have to have an actual account on the FTP server, for example, a server where you 
place your web pages, then you will need to obtain a user ID and password from the server 
administrator and enter them in the host information tab. 
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